Le forum a été mis à jour! (lire la suite...)

TkGlitch

Membre
  • Content count

    98
  • Joined

  • Last visited

  1. @@BlackLeader787 Pour une simple clé USB ça devrait fonctionner sans alimentation externe sur le N4 je pense.
  2. @ Est-ce que le toolkit met à jour le bootloader ou il ne fait qu'un unlock ? Si vous avez le dernier bootloader N4 en flash standalone de dispo ça peut peut-être le faire (sinon, si motivation il y a, fais comme moi et passe par fastboot). Je connais assez mal les spécificités et soucis du N4 vu que je n'étudie en profondeur que les appareils sur lesquels je bosse, mais le problème que tu rencontres n'est pas normal si bootloader, recovery et rom sont à jour et fonctionnent comme ils le devraient. TWRP 2.8.x.x était sensé régler divers problèmes de compatibilité avec KitKat qui étaient déjà réglés sur CWM depuis un petit moment, donc à moins que la source de votre TWRP ne soit pas complètement merge avec l'upstream (la source globale), CWM devrait rencontrer le même soucis. Le mieux c'est d'essayer effectivement ! :) En espérant que tu arriveras à tes fins.
  3. @ Du coup j'ai demandé à quelques contacts s'ils avaient d'autres idées pour ton problème, et ça semble se confirmer.. Le bootloader et/ou le recovery serai(en)t en cause. Si une mise à jour du bootloader ne suffisait pas, ils te recommandent de faire un reflash d'usine (avec wipe sd interne) sur une 4.4.x et de chopper la toute dernière version de ton recovery préféré. De plus, ça devrait t'éviter d'autres problèmes de ce genre à l'avenir, notamment avec certaines roms (ce qui semble le plus fréquent). Bonne chance à toi quoi qu'il en soit.
  4. @ J'ai upload une dernière version de test (test4). Si ça ne marche toujours pas, le problème vient d'ailleurs (bootloader, recovery ?). Toujours http://d-h.st/users/Tk-Glitch/?fld_id=39775#files
  5. @ Aucun problème ! Etrange. J'ai testé sur ma N7 du coup, et avant, même erreur que toi, et après, plus d'erreur. Je vais vérifier si j'ai bien upload le bon.. Est-ce que c'est toujours "Error executing updater binary" ou il n'y a plus que le set_perm ?
  6. Héhé c'est gentil :) Je n'ai pas de N4 malheureusement. Je travaille sur la N7 2013 depuis sa sortie (et très vaguement sur le Galaxy S4 int), et je me prépare à peut-être passer sur la N9 à sa sortie si elle me plaît autant que les rumeurs qui courent sur elle. Pour le N4, sauf si j'en découvre un dans ma boîte aux lettres un matin il y a peu de chance que je m'y intéresse sérieusement. Barome semble en bonne voie pour faire un super kernel de toute façon ! :P
  7. Aaah, c'est un peu différent alors. Bon, je fais passer tout ça sur le billard et je vous tiens au jus :P Au fait.. Merci de ton aide Kaptain K. On va y arriver ! EDIT : Je crois que j'ai réussi à régler le problème. J'upload le test 3. EDIT2 : Test3 up http://d-h.st/users/Tk-Glitch/?fld_id=39775#files
  8. Ok. Oui j'ai changé le binaire par celui d'Aroma pour voir si ça ne venait pas de lui. Visiblement pas. Et juste avant cette erreur là, toujours le même "set_perm" qui foire ?
  9. @ TWRP donc.. ça veut peut-être dire que le script va plus loin et démonte /data, ce qui empêche par la même occasion l'écriture des screens. Au pire si tu peux poster l'erreur sous forme textuelle ça me va aussi, même si c'est un peu plus chiant pour toi :P
  10. @ Très intéressé par la nouvelle erreur. Par contre pour les screenshots tu fais ça via adb ? A moins que tu parles des screenshots effectués sous Android directement ?
  11. Je vais être obligé de faire une fake install pour voir ce que c'est du coup :D Merci :) Edit : J'ai une autre idée. Je réupload un test et si ça ne marche toujours pas je fais subir le tout à ma N7. Edit 2 : Ce sont les builds "test2" ici : http://d-h.st/users/Tk-Glitch/?fld_id=39775#files
  12. Ahah, faudrait que je check exactement ce qu'il se passe, mais c'est une erreur quoi qu'il en soit (je veux dire niveau syntaxe). J'ai upload un petit test en espérant que Barome ne m'en tiendra pas rigueur. Au moins on sera fixés. Pour les aventureux : Problème non réglé, merci à Kaptain K.
  13. Hey Barome, j'ai regardé rapidement ton updater-script après avoir vu les problèmes de certains de tes utilisateurs. Et je suis tombé sur ça : run_program("/tmp/busybox", "data", "/data"); Le problème c'est que ça ne va pas monter /data, et donc tous ceux qui ont leur partition data unmount par défaut dans le recovery vont avoir l'erreur. Essaye avec ça à la place (comme tu l'avais fait pour /system) : run_program("/tmp/busybox", "mount", "/data"); Le problème devrait être réglé :)
  14. C'est toujours un plaisir Barome. Mais tu me flattes.. Je me fais vieux. T'as vu le temps qu'il m'a fallu pour pondre mes rebases sur la N7 ? :D A propos de la source, en effet, les règles du forum ne le réclament pas, mais la license GPL, tout ça.. Fin je fais vraiment mon chieur, le code est accessible facilement. La sénilité me rend extrémiste ! :P
  15. Hey Barome ! Tu sembles avoir bien avancé depuis nos derniers échanges B) Donc bravo à toi ! Juste une chose pour faire mon chieur, je ne vois pas de lien vers ton code source en première page :P Continue comme ça, on a besoin de sang neuf.. ^_^