Sign in to follow this  
Followers 0
johnoflyon

Runstatic pro - Perte signal GPS

16 posts in this topic

Bonjour à tous,

 

J'ai acquis un galaxy s7 il y a deux mois environ.

J'ai installé l'application Runstatic Pro que j'utilisais sur mon précédent téléphone depuis 2 ans sans aucun problème.

 

Mais depuis que je l'utilise avec mon S7 l'application plante.

Je m'explique.

Je démarre le GPS en extérieur.

Puis démarrage de l'appli. Uns fois que le logo GPS est vert et que je suis bien localisé sur le plan je démarre la sesson de runing.

Au bout de quelques minutes je reçois un message: "perte du signal GPS".

or, je suis toujours localisé sur le plan, le logo GPS est toujours vert.

Mais je n'ai plus aucune stat. et bien sûr plus de coach vocal.

 

A la fin de mon parcours de 1h par exemple l'appli me dis que j'ai parcouru 0.43km ou quelque chose dans ce genre.

çà me la fait une dizaine de fois. çà n'a jamais marché correctement.

 

J'ai tenté de désinstaller l'appli puis de la remettre: rien

J'ai paramétré le GPS avec satellite et wifi: rien

 

Quelqu'un a-t-il déjà eu un problème de ce genre?

Merci d'avance pour vos retours.

Share this post


Link to post
Share on other sites

Bonjour, je ne suis pas un spécialiste du truc, mais comment se comporte ton GPS quand tu utilises un logiciel de navigation ? (disons, celui fourni en standard par Google, MAPS)

Peux-tu tester de refaire un parcours, mais avec MAPS au lieu de Runstatic ?

Ceci pour vérifier que ce n'est tout bonnement pas le GPS qui "décroche" (soit matériellement, soit logiciellement...)

Share this post


Link to post
Share on other sites

Salut à toi!

Je n'ai pas de problèmes avec le GPS via maps. Je l'utilises quelques fois en voitures sans aucun problème. ...

Share this post


Link to post
Share on other sites

Salut,

 

J'ai le même souci depuis ce week-end. Deux courses où il m'a paumé une partie de mon parcours ou il me sort des trucs bizarres : samedi, sans coupure, il me donne 6 kms pour un parcours qui en fait 9. Je vais tester autre chose (Nike+) pour voir ce que ça donne.

Share this post


Link to post
Share on other sites

Je vais tester une autre application d'ici là fin de semaine. On se tiens au courant si ça beug aussi ou pas....

Mais ça soule! Runstatic j'ai payer la version pro! J'ai toutes mes stats depuis 2 ans, marathon. ...

Share this post


Link to post
Share on other sites

Alors, une chose à faire : Tu as payé pour un service... Contacte Runstatic pour leur faire part du problème ! ;)

Share this post


Link to post
Share on other sites

Je l'ai fait. Aparement ce problème est arrivé à plusieurs personnes. Et à chaque fois runstatic répond que le problème ne vient pas de l'application mais du téléphone. Il renvoie donc au SAV du constructeur téléphone.

On tourne en rond...

Share this post


Link to post
Share on other sites

Et avec l'autre appli que tu devais tester, ca fait quoi ?

 

Parce que si le tracking est bien effectif, c'est que c'est FORCÉMENT l'appli qui est fautive ! ;) (Méthode de la dichotomie...)

Share this post


Link to post
Share on other sites

Je n'ai pas pu encore tester. Temps de chiotte ces derniers jours qui m'on fait passé l'envie de courir^^ lol

Ce week-end je teste et je vous tiens au courant des résultats!

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai enfin testé avec une autre application: runkepper.

Même problème qu'avec runstatic.

Je perd le signal gps en cours de session. Du coup stats faussés et perte du coach vocal.

 

J'en déduis donc que ce problème vient du téléphone...

Share this post


Link to post
Share on other sites

100% d'accord avec ton analyse, le problème n'est pas lié à Runstatic...

 

Donc, ton GPS "perd" le signal... Essaie de voir si en installant un logiciel pour les GPS, ca ne répare pas le truc...

J'ai un GPS plus que cyclothymique, et pour lui mettre des "coups de pieds au Q", j'utilise GPS Status (la version FREE est déjà bien efficace...)

https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2

 

Ca va en fait monitorer ton GPS, et cela devrait l'empêcher de perdre le fix (sauf, comme pour tous les GPS, quand tu passes dans des endroits où le signal ne passe pas, hein...)

 

Si cela ne résout pas le problème, il faut envisager un "factory reset" (remise à l'état sortie de boîte, avec la possibilité éventuelle de récupérer les données sauvegardées liées à ton compte Google)

Share this post


Link to post
Share on other sites

Salut!

Alors j'ai réussis à voir la cause du problème. Pas le solutionner mais au moins trouver la cause^^

Au passage j'ai utilisé l'application que tu m'as donné pour le GPS et j'ai le même problème.

Donc le probleme:

J'ai fait des test ce matin en voiture. Lorsque j'utilise l'application sans mettre en veille le téléphone j'ai pas de soucis. Le GPS est bon ainsi que le coach vocal tous les km.

Par contre si je met le téléphone en veille (pour par exemple le mettre dans la pochette du survêtement quand je cours) alors la au bout de quelques secondes le signal gps se perd et le coach vocal s'arrête.

Puis lorsque je rallume le tel le GPS de refix et le coach vocal reprend.

Donc le problème vient lors de la mise en veille du tel. Ya til un moyen de régler cette mise en veille pour ne pas désactiver le GPS,

Share this post


Link to post
Share on other sites

Aîe !

J'ai eu le même problème avec mon "vieux tromblon" lorsque j'ai voulu installer un podomètre (moins de fonctionnalités que RunStatic, mais utilise aussi l'accéléromètre...)

Dès que la mise en veille avec code (ou schéma) se faisait, l'accéléromètre ne donnait plus d'infos... ACER m'a dit que c'était pour économiser la batterie !

 

Bref...

La première solution que je vois est de désactiver, soit automatiquement au lancement de runstatic (via un gestionnaire de profil comme Llama ou DroidAutomation), soit manuellement au moment où tu vas courir( et puis, ne pas oublier de le remettre en rentrant... )

 

Sinon, il faudrait que tu regarde sur la gestion de ton "lock screen" (écran de verrouillage) s'il n'y a pas une option pour l'empêcher de rentrer en veille quand il y a Runstatic de lancé... Je ne peux pas plus t'aider à ce stade, car j'ai un Android ICS 4.0.3 et le lock screen est basique de chez basique... Au pire, voir s'il n'existe pas sur le market un lock screen alternatif qui serait capable de le faire !

 

Autant sur mon vieux tromblon, je peux tolérer ce genre de limitation, autant sur un S7 tout neuf, ca fait un peut ch...

 

A voir aussi, maintenant qu'on sait ce qui se passe, si Runstatic n'aurait pas un paramètre pour maintenir le téléphone allumé (donc pas d'entrée en veille...)

Share this post


Link to post
Share on other sites

Salut à toi!

Je m'excuse pour le délai de réponse un peu long^^.

J'ai finalement résolu le problème en faisant le test à plusieurs reprises.

J'ai juste désactiver le mode économie d'énergie du téléphone.

J'avais l'habitude de tjrs avoir le tel en mode éco pour la batterie.

Avec mon ancien s4 je le mettais tjrs en eco aussi et ça ne gênait pas runstatic.

Sur le s7 ça empêche runstatic de fonctionner donc il suffit juste de le désactiver.

Un peu bête cette régression. Mais bon au moins ça marche maintenant ^^

Share this post


Link to post
Share on other sites

C'est l'essentiel !

 

Tu pourras toujours dire que ton téléphone t'a bien fait... courir ! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0