Faman

Lenovo Tab 2 X103 Bloquée

Recommended Posts

Bonjour à tous,

 

J'ai eu peur que ma tablette soit briquée mais j'ai été rassuré de voir sur le forum qu'un appareil qui s'allume encore n'est généralement pas briqué. Pour autant j'espère trouver une solution sans trop tarder 😉.

 

J'ai essayé d'installer TWRP sur une tablette Lenovo Tab 2 X103F, à l'aide de Minimal ADB and Fastboot, mais je n'ai jamais réussi à accéder au mode recovery, ni avec le bootloader de base ni avec TWRP.

 

Lorsque j'allume la tablette, après le démarrage du système elle n'affiche que le message "Unfortunately, Setup Wizard has stopped", à répétition, sur écran noir et je ne peux rien faire de plus à part l'éteindre. Je n'ai toujours pas accès au mode recovery et je n'arrive plus à détecter la tablette avec Minimal ADB and Fastboot. Par contre lorsqu'elle est allumée elle s'affiche dans l'explorateur windows comme n'importe quel périphérique de stockage.

 

Auriez-vous des pistes à explorer ?

 

Merci !

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu es sûr de la référence "Lenovo Tab 2 X103" ?

On ne trouve pas grand'chose avec cela dans Google, plus des liens vers des modèles ayant des noms qui sont plus familiers pour des Lenovo, genre Tab 2 A10-70 etc.

Il faudrait trouver son firmware d'origine (stock) mais avec ce nom je n'arrive à rien.

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement c'est la Tab 2 X30F pardon, ou encore Tab 2 A10-30

Modifié par Faman

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah, ben c'est la même que j'ai alors ^_^

Elle est/était en quelle version d'Android ?

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

La ROM est téléchargeable ici à priori : https://www.leakite.com/2017/02/lenovo-tab2-a10-30-firmware.html ou là http://www.fars-gsm.com/thread75531.html...

Mais je n'ai pas modifié la ROM mis à part la personnalisation du système lorsqu'il était normalement démarrer avant de chercher à installer TWRP...

D'autre part comment charger à nouveau le firmware d'origine dans les conditions actuelles ?

 

Je l'ai reçue ce matin en android 5 je crois et j'ai fait la maj système, "dans les règles", en android 6 (sans problème à ce point).

Modifié par Faman

Partager ce message


Lien à poster
Partager sur d’autres sites

L'installation de TWRP peut faire beaucoup de dégâts...

D'autre part il a fallu que tu la rootes pour cela, non ? comment as-tu fait ? il faut peut-être chercher de ce coté-là aussi la source de tes ennuis ^_^

J'ai des firmwares pour ce modèle au format QFIL/QPST, l'outil de flashage depuis un PC branché en USB. Cherche un tuto, exemple (en anglais) : https://androidmtk.com/use-qualcomm-flash-image-loader-qfil

Si tu as fait l'upgrade Marshmallow, il te faut cette version, je crois qu'on ne peut pas revenir en arrière.

La source que tu cites est douteuse.

J'ai un fichier TB2-X30F_S018_160715_ROW_qpst,7z (venant de XDA je pense) qui semble correspondre.

 

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Super ! merci de tes réponses. J'ai installé ça http://www.shuame.com/root/# pour le root, puis Kingroot. J'ai redémarré plusieurs fois après avoir rooté et sans problème.

Je voulais changer la ROM d'où l'install de TWRP. Mais je ne suis même pas convaincu qu'il ait été installé en réalité puisque je n'ai jamais pu démarrer en mode recovery.

Partager ce message


Lien à poster
Partager sur d’autres sites

On ne m'otera pas de l'idée que ces cochonneries chinoises vérolent les firmwares de certains appareils, le plus souvent curieusement des tablettes. J'ai eu des exemples de tablettes rendues totalement inutilisables (reset usine à chaque redémarrage) par Kingo.

Comment as-tu installé TWRP après le root ? quel tuto as-tu suivi ?

Pour le matériel Lenovo, les meilleures sources sont souvent russes (Google Translate ou mieux Yandex Translate sera ton ami) : 

https://4pda.ru/forum/index.php?showtopic=717232

http://lenovo-forums.ru/files/category/106-proshivki-lenovo-tab-2-a10-30/

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

D'autre part tu as gardé la ROM officielle ? Sinon qu'as-tu installé ? Moi j'aurais bien installé celle-là https://forum.xda-developers.com/android/development/rom-lineageos-14-x-lenovo-tb-x103f-t3607253, c'est faisable sans tout casser mais j'ai pas réussi 😌. Pour installer une autre ROM est-il nécessaire de repasser d'abord par la ROM oficielle ?

 

En gros pour TWRP j'ai fait ça https://forum.xda-developers.com/showpost.php?p=73877849&postcount=88 (ma mise à l'écrit était confuse, je ne suis pas sur d'avoir réussi à tout bien reconstituer dans l'ordre).

Je me suis appuyé sur https://forum.xda-developers.com/showpost.php?p=71099378&postcount=188 et https://forum.xda-developers.com/showpost.php?p=72307502&postcount=2

 

Clairement je trouve bien sales aussi ces trucs chinois mais à défaut de trouver mieux..... Après j'avoue qu'avec une expérience comme celle que tu partages, mieux vaut s'abstenir 🤔

Partager ce message


Lien à poster
Partager sur d’autres sites

Ma A10-30 est en firmware d'origine, je ne l'ai même pas passée en Marshmallow parce que ce que j'ai lu sur cette upgrade m'a refroidi.

Elle fonctionne très bien comme cela, vois vraiment pas pourquoi je changerais.

Je suis d'un naturel très prudent, je ne commence jamais à bidouiller un smartphone/tablette avant au moins 1 an 1/2 à 2 ans après son achat. En gros quand je l'ai remplacé et que je peux me permettre de le casser ! Je n'ai cette tablette que depuis un peu moins d'un an.

Je suis allé voir tes liens. Si tu as fait un "fastboot boot TWRP-3.0.2_TB-X103F-beta.img" c'est une énorme erreur. EDIT : j'avais mal lu. Non, pas forcément. Mais bon... cf ligne suivante.

Enfin bref, pas envie de creuser. Le fait est là, tu l'as vérolée.

 

Si j'étais toi, je resterais en firmware stock... mais c'est ta tablette.

Et oui, quoi qu'il en soit indispensable de la remettre au propre d'abord.

 

Modifié par Ultrix
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

En tous cas merci pour toutes ces infos !

J'ai de quoi avancer, je te tiens au courant..

Partager ce message


Lien à poster
Partager sur d’autres sites

J'essaye QFIL depuis un moment, il reconnait bien mon image "TB2-X30F_S000113_160816_ROW_qpst\TB2-X30F_S000113_160816_ROW_qpst\Images\prog_emmc_firehose_8909_ddr.mbn" et sélectionne les fichiers "rawprogram0.xml" et "patch0.xml" du même dossier mais il ne détecte pas la tablette.

Ouverture de QFIL, appui de VOL+ et connexion de la tablette, chargement des fichiers dans QFIL, mais le bouton "Download" n'est pas appuyable et QFIL affiche toujours "No Port Available", la tablette est reconnue par l'ordinateur puisque accessible comme espace de stockage..

J'ai pourtant bien désinstallé tous les pilotes de la tablette et réinstallé uniquement le Driver USB Qualcomm auparavant.. Ca serait peut-être utile de savoir à quel port correspond la tablette..

Modifié par Faman

Partager ce message


Lien à poster
Partager sur d’autres sites

Si la tablette est vue en MTP c'est qu'elle est démarrée normalement, sous Android, et pas dans le mode EDL nécessaire au flashage.

Dans ce mode, son écran est éteint.

Es-tu bien parti d'une tablette complètement éteinte ?

 

Apparemment un seul bouton de volume ne suffit pas : https://forum.xda-developers.com/showpost.php?p=67342567&postcount=12

 

EDIT : je viens de faire le test sur ma A10-30 et je confirme.

- tablette complètement éteinte

- appui maintenu sur volume+ et volume-

- brancher le câble USB

59c49b22453ba_2017-09-2207_06_10-.jpg.da0b1d15479bf7d8214c3439c98a235d.jpg

Le numéro de port (ici 28) changera sur ton PC.

Modifié par Ultrix
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors ça avance, le problème venait bien de la nécessité d'appuyer les deux boutons de volume. Cette fois la tablette est reconnue et le chargement démarre.

J'ai essayé avec TB2-X30L_S024_151118_ROW_PC et TB2-X30F_S000113_160816_ROW_qpst. Dans les deux cas Download Fail:Sahara Fail:QSaharaServer Fail:Process fail

Modifié par Faman

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah 🤔 ça se complique.

Comme je ne vais pas flasher ma tablette pour le plaisir, je ne vais pas pouvoir t'aider plus que d'éliminer les causes fréquentes d'erreurs avec tous les programmes de flashage depuis un PC :

- QFIL lancé en tant qu'administrateur ?

- version de QPST/QFIL ? des drivers Qualcomm ?

- version de Windows ? (essayer plutôt sur W7)

- port USB 2.0 ? (de préférence à 3.0)

- autre câble/port/PC ?

 

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai réessayé sur un autre poste, W7 pro SP1. QFIL (1.0.0.3 ou 2.0.0.5) lancés en tant qu'admin, Qualcomm HS-USB QDLoader v. 2.0.9.6 (21/10/2014), USB 2.0... pas plus avancé

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens d'arriver à redémarrer la tablette.

 

Après avoir installé QPST 2.7.460 sur PC Win7 pro,

j'ai désarchivé TB2-X30F_S000113_160816_ROW_qpst.7z dans le répertoire C:\Program Files (x86)\Qualcomm\QPST\bin\Firmware\

La tablette étant connectée et reconnue comme périphérique Qualcomm sur le port 3, j'ai ouvert QPST Configuration et joué dans les options, notamment Server/Start QPST Server, puis Server/Stop QPST Server... C'est peut-être ça qui a réinitialisé la connexion avec la tablette.

Après ça j'ai ouvert QFIL (2.0.1.1, celui installé avec QPST) en tant qu'administrateur et chargé le firmware précédemment désarchivé.

Joie ! Ca a fonctionné.

 

Un grand merci à Ultrix pour ton suivi et tes éléments d'avancement !

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Parce qu'avant tu essayais directement de flasher le .7z sans le désarchiver ??? :blink: oups.

Effectivement c'est une étape que je n'avais pas précisée...

Sinon bien ouéj, pour le start/stop, je garde ça dans un coin !

 

Et de rien, content d'avoir pu donner un coup de main. Le forum est fait pour ça.

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 6 minutes, Ultrix a dit :

Parce qu'avant tu essayais directement de flasher le .7z sans le désarchiver ???

Non non quand-même pas :P. Mais je désarchivais simplement ça dans mes téléchargements, là je l'ai placé dans le répertoire d'installation de QPST. J'ai vu certains dire sur internet que le chemin d'accès avait son importance..

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah OK... c'est vrai que certains outils de flashage s’accommodent mal de chemins un peu longs/tordus (espace, caractères spéciaux)

J'ai eu ce genre de problème avec SP Flash Tool.

Depuis je mets toujours ça dans des dossiers simples, du genre D:\ANDROID\<nom-du-modèle-sans-espace>

 

Donc te voilà revenu en Marshmallow stock ?

Je suis allé traîner plus sur le sujet que tu avais cité sur LineageOS 14 (merci pour le tuyau au passage). Les retours sont bons. Ca me prendra peut-être un jour. Mais pour l'instant, vu l'usage que j'en fait (essentiellement du MyCanal/Molotov/Youtube/Dailymotion/SFR TV au lit) elle me va très, très bien comme ça. J'ai quand même peur de perdre en qualité du son (un des reproches faits dans le fil en question)

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui je suis à nouveau en stock. J'ai pas l'impression qu'il y ait d'autre ROM assez aboutie, ce n'est pas le cas de celles de tokar77 en tous cas. Et pour celle de GartimusPrime sur xda qui a l'air assez stable et qui apparemment sera retravaillée par rapport au son et autres, la page en question sur xda est dédiée aux tablettes x103f et non x30f (d'où mon erreur sur le premier post). Sur sa page de téléchargement https://www.androidfilehost.com/?w=files&flid=182425 GartimusPrime présente sa ROM comme étant pour les tablettes Lenovo 10", sans plus de précisions... Je suis pas sur que la ROM soit compatible X30F au final...

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant