xazuretsu

[TUTO] Installation de ADB

95 posts in this topic

Bonjour,

je viens d'installer le SDK dans sa dernière version, quand je veux lancer une machine virtuelle d'ICS depuis ADV: j'ai une fenêtre de commande AVD Manager.exe et une fenêtre verticale (l'écran de la machine virtuelle j'imagine) qui reste totalement noire mais aucun message d'erreur!

où est mon erreur?

je précise que si je lance une commande ADB dans le dossier tool ça fonctionne bien.

erreurf.png

Uploaded with ImageShack.us

erreur2pi.png

Uploaded with ImageShack.us

Share this post


Link to post
Share on other sites

Pour ceux que ça intéresse, j'ai trouvé une vidéo qui montre comment installer sous linux le SDK et Linux:

Notamment pour ceux qui comme moi ont bloqué à cause du message d'erreurs:

Cannot complete the install because one or more required items could not be found.Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found

Comme, on peut le voir sur la vidéo, Il faut installer "Linux tools".

Edited by serrum

Share this post


Link to post
Share on other sites

Bonjour !! j'ai suivis plusieurs tuto qui reviennent souvent au même évidement.

Sous windows j'ai pas eu de problème ça fait un moment que ça tourne ok.

Néanmoins j'ai repris Linux et notamment Ubuntu ( enfin pour base car j'ai pris un Fork tout pres sous Gnome 3 [ubuntu Gnome Shell Remixe] ) bref mes commandes ADB fonctionnent sans soucis c'est bon elle sont bien étégré au PATH j'ai ajouté sur Eclipse le plugin Android téléchargé et installer. Mais je n'ai aucune options lié au SDK Android dans mon IDE. ... du coup même dans les préférences je ne peux pas renseigner l'emplacement de mon SDK

Share this post


Link to post
Share on other sites

il faut installer le plugin dans eclipse

Dans Help>Install new software ajoute l'adresse https://dl-ssl.google.com/android/eclipse/

Share this post


Link to post
Share on other sites

Oui oui c'est fait bien évidement :)

Share this post


Link to post
Share on other sites

bonsoir a tous j'orai besoin de votre aide pr plus de precision car je suis bloqué? dans le tuto il est mentionné :

" Normalement, si vous entrez dans l'invit de commande et vous lancez une commande adb, l'invit vas vous marquer un truc du genre: "adb non reconnu"."

Quel commande??

Par la suite le asb :

"Dans votre dossier androidSDK, allez dans "tools" et lancez la commande android.

Sélectionnez ensuite "availible packages" , cochez tout ( c'est mieux) et télécharg"

Mais quel commande???

Share this post


Link to post
Share on other sites

Salut

Moi aussi j´ai des problèmes mais la je peux t´aider:

" " Normalement, si vous entrez dans l'invit de commande et vous lancez une commande adb, l'invit vas vous marquer un truc du genre: "adb non reconnu"."

Quel commande?? "

La commande: adb :P ce n´est pas "une" mais la commande...

Ensuite:

"Dans votre dossier androidSDK, allez dans "tools" et lancez la commande android.

Sélectionnez ensuite "availible packages" , cochez tout ( c'est mieux) et télécharg"

Mais quel commande???

La commande android, tu click dessus et une fenêtre apparait

Edited by Tuga

Share this post


Link to post
Share on other sites

Juste pour signaler, concernant Linux, que pour certaines distributions, il existe des dépôts dans lesquels nous retrouvons les outils adb, fastboot, etc...

Donc, plus besoin d'installer SDK, et consorts...

 

Ainsi, pour les *Buntu (fonctionnent aussi pour Linux Mint), depuis la version 13.04 - qui arrivent à fin de vie - nous retrouvons les binaires de manière officielle, voire mise-à-jour grâce au PPA ( https://launchpad.net/~phablet-team/+archive/tools ).

 

Cela facilite l'installation - concernant l'usage de ces binaires, celui-ci ne change.

 

Juste au cas où, voici un tuto que j'ai écrit pour la reconnaissance de tablette sous Linux. (excusez le fait que ce soit sur une autre communauté ...)

Share this post


Link to post
Share on other sites

Besoin d'aide rapidement, pourquoi lorsque je clique sur sdk Manager je vois rapidement une fenetre noir s'ouvrir et tres rapidement disparaitre et rien du tout de ne fait!!!!ÉÉÉ

Share this post


Link to post
Share on other sites

Bonsoir,

 

j'essaie d'installer adb mais je reste bloquer sur l'étape :

 

Dans votre dossier androidSDK, allez dans "Tools" et lancer la commande android sélectionner ensuite availible packages cochez tout et télécharger. 

 

<< je vais dans le dossier androidSDK je trouve android.bat que je lance, une boite de dialogue s'affiche je clique sur exécuter et la une boite noir apparait et disparait (on dirait l'invit de commande) et rien d'autre ne se passe. <<  :(

j'en ai ma claque de cette tablette elle a pas de marque et tous les tutos que j'ai pu voir pour la réinitialiser ne fonctionne pas ( je n'arrive meme pas a entrer dans le menu de réinitialisation par le biais des combinaisons de touche "home power + et/ou - du volume" "power + et/ou - du volume") je l'ai eu d'ocaz donc pas de garantie, mon fils l'a bloquée et aucune recup possible par Google puisque pas de connexion. (de toute façon je ne pense pas avoir eu le temps d'enregistrer mon compte Google m'en rappel plus)

 

Voila, alors svp dites moi si je dois la mettre a la poubelle ou si il y a un moyen de réinitialiser cette chose horrible qui s'appelle tablette. :angry:

 

Merci d'avoir pris la peine de me lire   :mad:

 

 

 

Share this post


Link to post
Share on other sites

Bonsoir,

 

Si j'ai bien compris, tu cherches a faire tout cela pour passer outre un schéma de verrouillage mis sur la tablette, c'est bien ça ?

Si oui, je crains d'avoir de mauvaises nouvelles pour toi, mais j'attends la réponse avant.

Share this post


Link to post
Share on other sites

oui c'est bien cela car mon fils l'a bloquée, j'ai un compte Google mais je n'arrive pas a me connecter dessus avec la tablette je ne sais pas si c'est parce que l'a tablette n'a pas de connexion ou si c'est parce que je ne 'lai pas enregistrer  il m'étais impossible d'aller sur Google Play mais j'ai du mal a me souvenir car elle a fonctionner environs une semaine et cela fait déjà a peut près six mois quelle est bloquée je poste donc avant de la mettre a la poubelle ! j'ai eu le même soucis avec mon tel a l'époque le galaxie spica qui a fini aux ordures

Share this post


Link to post
Share on other sites

C'est donc bien ce que je pensais.

Malheureusement, dans ce cas, les règles du forum ne nous autorisent pas à donner une autre solution que celle-ci : http://forum.frandroid.com/topic/166422-by-pass-du-sch%C3%A9ma-de-mani%C3%A8re-s%C3%A9curis%C3%A9/ qui n'a aucune chance de fonctionner ici si la tablette n'a pas une connexion internet active ou si tu n'as pas le compte+mot de passe enregistré dans la tablette.

C'est donc SAV uniquement... ou poubelle si pas de SAV possible. En tous cas nous, ici, nous ne pouvons rien proposer d'autre.

Share this post


Link to post
Share on other sites

bah j'ai le logo du wifi mais lorsque je m'identifie sur Google rien ne se passe elle me remet toujours

le même message vous avez taper un mauvais shéma  ......

veuillez vous connecter avec Google ...  

 

je me doutais qu'elle finirait a la poubelle, 

merci tout de même

Share this post


Link to post
Share on other sites

Un grand MERCI pour ton tuto. J'ai installé ADB sous Windows 7, mais à chaque fois que je veux lancer une invite de commande... Scrogneugneu! à chaque fois il me dit: 

 

15012605414217502512907696.jpg

 

Je désinstalle tout et réinstalle selon ta méthode

 

Merci 

Edited by Barbatrac

Share this post


Link to post
Share on other sites

@@SAWNWICHE meme probleme pour moi sous windows 8 lorsque je clique sur sdk Manager je vois rapidement une fenetre noir s'ouvrir et tres rapidement disparaitre et rien du tout


jai trouvé, tu vas dans tools et tu 2clickes sur android.bat

Share this post


Link to post
Share on other sites

Bonjour

Après avoir téléchargé succsessivement

javasetup_u131.exe

adbdriverinstaller.exe

android-studio-bundle_162.3871768-windows.exe

Après avoir lancé android.bat suivi de sdkmanager.bat comme recommandé. Le résultat obtenu est celui du fichier joint. où je butte sur la vatiable d'environnement repo_os_override. dont la valeur n'est peut-être pas celle attendue. mais avec ou sans guillemets, "windows" n,a pas l'air de plaire. un petit coup de main à un Papy de 82 balais qui nage un peu, serait le bienvenu. Merci d'avance

 

invite de commandes.txt

Share this post


Link to post
Share on other sites

j,ai oublié de préciser être averti de la réponse au message que je viens de poster; si il n'est pas trop tard merci de le prendre en compte.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now