Le forum a été mis à jour! (lire la suite...)
wolfen13fr

Android System Recovery sur tablette chinoise ...

21 posts in this topic

Bonjour !

J'ai acheté il y a peu une tablette 9,7", écran capacitif, processeur A8, webcam, sous Android 2.2 ( http://cgi.ebay.fr/ws/eBayISAPI.dll?ViewItem&item=220754738565 )... Un joli joujou qui fonctionne pas mal mais ... je suis un insatiable bidouilleur et j'ai fait une belle boulette. Devant l'incapacité à installer certaines applications pourtant normalement compatibles, j'ai cherché à comprendre un peu le système Android (je touche ma bille sous Mac OS X et sous Linux). Et bêtement, j'ai tapoté l'écran sur un truc que je n'aurai pas dû je pense : dans /system/framework, j'ai appuyé sur framework...apk (je ne sais plus exactement le nom) et ça m'a marqué que ça allait remplacer le programme déjà installé ... et j'ai validé sans lire plus attentivement. L'installation a échoué et la tablette a bien fonctionné pendant un moment.

Ce soir, j'ai voulu démonter ma carte micro SD et là, la tablette n'a plus répondu. J'ai donc fait un reset. Depuis, elle démarre avec le petit Android et le curseur qui clignotte puis le gros Android gris apparaît et ... Rien. La vague blanche qui traverse le logo commence puis le logo disparaît et réapparaît quelques fois et écran vide ...

J'ai réussi à trouver la combinaison de touche pour rentrer en Android system recovery (3e) en pensant faire un factory reset. Mais là, je reste bloqué : j'ai bien les quatres propositions à l'écran (reboot system now, apply sdcard:update.zip, wipe data/factory reset et wipe cache partition) mais impossible de me déplacer dans ce menu pour sélectionner le factory reset.

Tout ce que je peux faire, c'est actionné le bouton de menu / volume bas pour valider le reboot system (la première option en fait) mais impossible de choisir une autre option.

Est-ce que quelqu'un a une idée ? Ou bien va-t-il falloir que je la renvoie en maintenance en Chine (ce qui ne m'enchante pas du tout !) ?

Merci d'avance pour votre réponse ...

Share this post


Link to post
Share on other sites

Hum... C'est malencontreux... Comme je n'y connais absolument rien en Android je ne peux pas t'aider par contre y a t'il moyen de lancer l'installation à partir de la MicroSD?

PS : Ta tablette m'interesse, à t'elle des Rom custom?

Share this post


Link to post
Share on other sites

Je la découvre et je ne saurais te répondre. Toutefois, mon problème a évolué : j'ai pu ré-installé un firmware via USB. Mais ce n'est pas le firmware exact de ma tablette et le wifi et la webcam ne fonctionnent pas. Par contre, le système est plus fluide (toujours du Froyo).

Il faut donc maintenant que je trouve le firmware exact de la tablette ou un moyen de refaire fonctionner le wifi et la webcam.

Je cherche donc un firmware de gPad M97 (je crois ...). Là, elle tourne avec celui d'une gPad Gforce.

Share this post


Link to post
Share on other sites

Bon, j'ai encore avancé : j'ai esssayé un autre firmware et le wifi fonctionne (je reponds actuellement avec la tablette !) mais pas la webcam ... moindre mal pour le moment. Mais je vais aller faire un tour du côté de ton lien, Mneo2.

Share this post


Link to post
Share on other sites

Bon t'avance deja c'est bien :)

Sinon pas beaucoup de gens pour cette tablette dommage :( car elle a de bonnes spécs

Le firmwar que je t mis a dispo date de mi mars :) tu me diras ce que t'en pens

Bon courage

Share this post


Link to post
Share on other sites

C'est surtout ça qui m'a contraint à partir sur une Nook Color, la communauté est beaucoup plus grande au US donc il y aura sans doute Honeycomb (qui est déjà en Bêta) et plus si infinité... . Par contre les tablettes NoName malgré le potentiel materiel etc... Il y en a trop sur le marché (et souvent de la m**** qui rame, ecran resistif, bu en tous genre ...) et pas assez de bidouilleur :/ ... . Mais je pense acheter cette tablette plus tard quand les prix auront baissé :)

Tiens nous au courant!

Share this post


Link to post
Share on other sites

Bon, j'ai testé le firmware de Mneo2 et c'est la même chose : Wifi OK - Webcam KO ... Mais comme je le disais, c'est moindre mal pour le moment (Skype a refusé de s'installer sur ma gPad lorsque j'avais le firmware d'origine). La fonctionnalité d'appareil photo est moyennement intéressante si on considère que la webcam est en façade. Donc, la plus grosse utilité restera de la vidéo-conférence ... Je me penche sur le problème actuellement.

Je commence à comprendre un peu les rouages d'Android ... Donc, je vous tiens au courant ...

@Etane : personnellement, j'ai négocié ma tablette sur ebay et comme on était deux à en vouloir, nous l'avons eu pour 210 euros environ chacun, frais de port compris - 1 seul frais de port divisé en deux du coup. J'ai profité de la fonctionnalité "Faire une offre" d'eBay et après quelques échanges avec le vendeur, nous l'avons passée de $280 à $265, avec négociation sur les frais de port.

Les premiers retours, pour ma part, sont très positifs : l'écran tactile est confortable, la fluidité est bonne malgré quelques latences de temps en temps mais rien qui me fasse regretter mon achat pour le moment. Mon copain est aussi très content de son achat.

Share this post


Link to post
Share on other sites

Yep,

Bon je suis en train de mettre a jour!

J'ai recu la tablette avec un launcher assez moche avec un cube...Enfin bon!La ca flash

On verra pour la Cam :)

Apres le flash le root puis bidouillage

Ps : Flashage Ok,Camera Ok :(

Edited by Mneo2

Share this post


Link to post
Share on other sites

Tu as la webcam ok avec le firmware en lien au dessus ? As-tu eu une opération réussie à 100% ou bien as-tu été obligé de débrancher la tablette après un moment parce que l'application de faisait plus rien (MfgTool) ?

Share this post


Link to post
Share on other sites

J'ai la webcam avec le lien que je t donné :)

Sinon aucune autres manip

Au bout de 5Min30 a gauche dans l'application de flashage tu verras operation complete Ok mais le bouton reste rouge pas grave

Tu débranche la tablette,tu prends un truc pour faire un reset dans le petit trou de la tablette

Voila en gro

Share this post


Link to post
Share on other sites

Personnellement, au bout de quelques minutes, je vois à gauche un message du type unrecognize device et le compteur tourne, sans rajouter d'erreur sur le bas. Donc je finis par resetter la tablette et voilà. Il va falloir que je regarde ça de plus près.

Autre question : as-tu des soucis pour installer certaines applications type Skype, Twitter (client officiel) ou Maps ?

Share this post


Link to post
Share on other sites

Salut,

Bizzar ton histoire :( moi ca fait send uimage etc puis write....et celui qui prend le plus de temps c'est systeme.img (normal il fait 120Mo)

Pour l'instal des applications au debut oui j'avais pas toutes les applications style maps par exemple j'ai trouvé une bidouille sur pandawill dans build.prop mais il faut etre root (Z4root) pour pouvroir modifié (si c'est le fichier se trouve dans /systeme)

Faut que je retrouve la manip :)

Sinon j'ai installé la nouvelle version du player de google 3.03....pas mal (en gros celui de HoneyComb)

Pour l'instan je me bat pour mettre la nouvelle version du Market 2.3.11 si je me trompe pas (elle a demaré mais a cause de la bidouille que j'ai faite dans le build.prop ben ca me fait un ForceClose) Bref je cherche encore :)

Franchement cette tablette sera 100% bidouille lol (Car j'ai un HTC Desire HD avec Rom Miui 1.4.8 si ya moyen de porté ca sur la tablette ca sera un Kiff)....

Allé courage

Ps : Voila le lien pour le fix du market : http://www.pandawillforum.com/viewthread.php?tid=3469&from=indexheats

Edited by Mneo2

Share this post


Link to post
Share on other sites

Je suis super intéressé par ta bidouille sur le /system/build.prop ... J'ai déjà rooté avec Z4root.

En fait, lorsque je vais sur http://market.android.com depuis un navigateur, pas mal d'appli sont signalées comme incompatible avec mon appareil ... Il faut que je comprenne le mécanisme de test de la compatibilité.

Lorsque tu flashes avec mfgtool.exe, est-ce que tu coches la deuxième opération (51 RFL MMC Linux ...) dans Options / Configurations ? C'est cette opération qui ne fonctionne pas chez moi je pense. Je ne comprends pas encore trop bien ce qu'elle fait ...

Le player actuel me va pour le moment. Il ne me manque que la webcam pour être pleinement satisfait ...

Share this post


Link to post
Share on other sites

Salut l'ami :)

Ben ecoute j'ai mis le lien pour la bidouille :)

Sinon non j'ai rien coché en plus j'ai juste choisi le bon port de ma tablette Elvis dans mon gestionnaire de périph (mais si je me rappel dans le log de flashage ben il la voit comme imx515 elvis ou un truc dans le genre mais je pens que ca tu le sais)

Et j'ai fais start (comme tout flashage que ca soit la reprog de ma voiture le flashage de ma xbox360 ps3 iphone DHD etc je cherche pas a trop je fonce aprés ca passe ou ca casse XD mais pour l'instant je fais pas ca a l'aveugle donc ca finit bien)

Bon j'ai tenté d'adapté un recovery menu : j'ai pris comme exemple celui du Sony Ericsson X10 pourquoi ? car il s'installe dans le systeme en lui méme du au bootloader blocké du sony...j'ai testé mais ca fonctionne pas faut que je trouve!!!!!!!!!a partir de la on pourra peut étre mais vraiment peut étre lol installé des roms custoums

Ps : comment tu as réussi a rentré dans le recovery d'origine?

Edited by Mneo2

Share this post


Link to post
Share on other sites

Bon, j'avance dans ma compréhension du système et de la gPad ... J'ai réussi à bidouiller un firmware qui démarre directement en Français dès le premier allumage, j'ai un market qui fonctionne en partie (quelques applications ne sont pas trouvées encore mais j'y travaille, j'ai inclu la bidouille de la modification du build.prop).

Par contre, toujours pas de webcam fonctionnelle ... Il va falloir que je me trouve quelqu'un qui a une tablette d'origine sur qui je pourrais pomper le répertoire system et récupérer ce qui concerne la webcam. J'y travaille ...

Share this post


Link to post
Share on other sites

Yep,

Idem pour moi je vais me mettre au portage de ginger mais bon a cause du bts qui approche pas trop le temps lol

Sinon ta bidouillé le system.img sous linux?

Share this post


Link to post
Share on other sites

Oui, j'ai monté le system.img sous Linux et j'ai pu faire les modifications nécessaires. Il me reste plus qu'à trouver pourquoi la webcam ne démarre pas mais je ne sais pas encore trop où chercher : pilote ? V4l2 qui ne marche pas bien ? ... Je ne sais pas ... Je cherche ...

Share this post


Link to post
Share on other sites

Un petite derniere question car je maitrise pas linux juste le mini quoi

Comment as tu monté le system.img pour pouvoir modifié (enfin avec quoi ) car j'ai essayé de modifié la rom avec android kitchen mais il me fait un zip a la fin lol

Merci de ton aide

Ps : j'ai supp plein d'appli qui servent a rien dans le system\app : sms,phone,search provider,BT,etc la tablette a gagné en peche mais vraiment :)

Share this post


Link to post
Share on other sites

Pour monter ton system.img sous Linux, tu crées un répertoire de montage :

mkdir montage

et tu montes ensuite l'image par la commande mount :

sudo mount -o loop system.img ./montage

Attention, ici, j'ai évidemment considéré que ton répertoire "montage" et ton fichier "system.img" sont dans le même répertoire.

Quand tu as fini tes modifications, tu démontes :

sudo umount ./montage

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now