axonien

Membre
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by axonien

  1. Bonjour, Je rencontre un petit problème dans l'utilisation de la carte microsd de mon Axon 7. Le UUID (je crois que cela s'appelle comme cela) de la carte semble changer à chaque redémarrage du portable, si bien que le chemin du répertoire pour accéder aux fichiers qui y sont enregistrés change à chaque fois puisqu'il est utilisé pour définir "l'adresse" de la carte, comme on peut le voir avec un gestionnaire de fichiers comme "total commander" : /storage/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx/file.txt Comme j'utilise des raccourcis sur l'écran d'accueil vers certains de ces fichiers, ils ne sont plus reconnus après avoir rallumé le portable, puisque leur adresse change tout le temps. Le portable a l'air de "redécouvrir" la carte à chaque redémarrage, en lui réattribuant à chaque fois un nouvel UUID. Pourtant c'est une carte sandisk neuve que j'ai acheté exprès pour ce portable, formatée en exFat et qui fonctionne très bien quand je l'utilise sur un PC et sur l'Axon 7. Je peux copier et effacer des fichiers sans problème et les applications peuvent l'utiliser pour y mettre des données. Je l'ai reformaté pour vérifier, mais le problème est toujours là. Est-ce un comportement normal et sinon quelqu'un a-t-il une idée de ce qui pourrait expliquer ce comportement ? Merci pour votre aide.
  2. axonien

    Axon 7: Problème UUID de carte microSD

    Merci pour ta réponse très rapide Mylmic. Effectivement mon Axon est sous Android 8 Oreo, j'avais oublié de le préciser. J'ai reformaté la carte en NTFS comme tu le suggères et Android au lieu d'identifier la carte avec un uuid, utilise maintenant le numéro de série du volume de la carte (16bits au lieu de 32 pour l'uuid) qui lui ne semble change pas changer à chaque redémarrage, du coup mon problème est résolu : storage/xxxxxxxxxxxxxxxx/ J'avais lu qu'exFat était plus indiqué pour fonctionner sous android avec des cartes de grandes capacités, mais NTFS ne semble pas poser de problème pour l'instant. J'ai fait des recherches plus précises sur ce sujet, mais n'ai encore rien trouvé. Aurais-tu éventuellement un lien qui explique l'origine de ce problème qui serait spécifique à Oreo ? Merci infiniment pour ton aide en tout cas.