Jump to content

artur

Membre
  • Content Count

    404
  • Joined

  • Last visited

Posts posted by artur


  1. Bonjour,

    Bon je viens de changer de smartphone pour un Note 2 donc j'arrête les bricolages sur le U790. Je répondrais néanmoins aux questions si je passe dans le coin.

     

    Je n'ai pas réussi à installer le compte google sur mon U790. Je me suis procuré les apk suivants :

    GoogleServicesFramework.apk, OneTimeInitializer.apk, Phonesky.apk, GoogleLoginService.apk, GoogleFeedback.apk en m'inspirant de ce tuto :

    https://forum.frandroid.com/topic/153502-tuto-installation-de-google-play-sur-logicom-tab-1052/

     

    Ensuite je n'ai pas utilisé adb car même si mon U790 est rooté, je n'obtient pas uid=0(root) gid=0(root) à la commande adb shell id

    Pourtant j'ai accès à tous les fichiers système et j'ai pu renommer les fichiers son d'alumage et d'extinction du U790 pour le rendre silencieux.

     

    Donc je suis passé par root explorer pour faire les modifs préconisées. J'ai réussi à installer GoogleServicesFramework.apk et du coup l'option créer un compte google apparait. Mais je n'ai jamais réussi à trouver de GoogleLoginService.apk qui marche et du coup je suis resté bloqué à ce niveau.

     

    Avec Rootexplorer j'ai fait un peu de ménage et j'ai viré notamment SogouInput.apk ce qui economise de la place et rend le clavier beaucoup plus agréable sans aucun caractère chinois.

     

    Voila mon retour sur le U790.

     

    En conclusion je dirait que le U790 est un appareil honnète qui fait le job, a un prix défiant toute concurence. L'absence de compte google est assez pénible mais on s'en sort.


  2. Je suis en train de tester des ROM. Pour le moment deux ROM custom = deux plantages au redémarage ....

    J'ai testé celle-ci :

    http://translate.googleusercontent.com/translate_c?depth=1&hl=fr&rurl=translate.google.fr&sl=zh-CN&tl=en&u=http://m-zte-u790.liqucn.com/rj/119158.shtml&usg=ALkJrhi1lbQUfluKCaX5kE7P7J9hpVRwfg#commentbox

     

    et celle-ci :

    http://translate.googleusercontent.com/translate_c?depth=1&hl=fr&rurl=translate.google.fr&sl=zh-CN&tl=en&u=http://m-zte-u790.liqucn.com/rj/119151.shtml&usg=ALkJrhhUthwbgozjfFijmrdiyUZaCEGdfg

     

    Je met ici le lien vers les firmware fournis par ZTE car je vais en avoir besoin apparemment....

     

    http://www.ztedevice.com.cn/support/smart_phone/e65977ef-0504-421b-8ee0-3d62aa9dbdd1.html#type=software

     

    C'est en chinois, le U790 n'étant vendu qu'en Chine et ZTE organisant son site de support par pays.

    Le premier package est apparemment un outil de diagnostic.

    C'est le deuxième (logique vu la taille) qui contient le firmware.

     

    Edit:

    Bon finalement j'ai flashé la ROM fournie par ZTE avec succès. C'est la seule que j'ai trouvé qui fonctionne. On peut la mettre en anglais pour ceux qui se posaient la question....

    Par contre toujours pas de compte google....

     

    Info utile : Après plantage lors du flash d'une ROM on se retrouve avec le recovery d'origine et un U790 presse-papier.

    Il faut reflasher le recovery pour avoir des options avancées. Ça permet de monter l'USB depuis le recovery ce qui permet d'avoir accès à la carte SD depuis son PC. Une fois que vous avez bien galéré à essayer des ROM, vous pouvez copier la ROM ZTE sur votre carte SD, la flasher et retrouver un U790 opérationnel...


  3. Bonjour,

    Ce tuto concerne le ZTE U790 disponible en import sur hongkongeek ou sur Ebay. Le ZTE U790 n'est PAS Identique au ZTE V790 et n'est pas non plus identique au Kis Lite. Je précise car ce sont des erreurs que j'ai commises parmi de nombreux tâtonnements.

     

    Le ZTE U790 est basique : 250 Mo de RAM, 1Ghz de proco (ou 800Mhz on ne sait pas trop), pas de GPS, pas de double Sim, appareil photo 3Mpx sans flash trèèès basique (celui de mon Hero de mes débuts sous android était meilleur...).

    MAIS le ZTE U790 est très bon marché (43 euros qui dit mieux!) et dispose d'un excellent rapport performance/prix et vous dépannera si, par exemple, on vous a volé votre précieux...

     

    Le ZTE U790 acheté sur Hongkongeek arrive avec une version bizarre sans google play et surtout sans la possibilité d'installer un compte google. Avec K9mail et en installant les applis via des market alternatifs ou avec les apk, on s'en sort mais ce n'est pas très pratique.

     

    Je vous fais partager ici les infos et les avancées que j'ai pu faire pour améliorer ça.

     

    Important :

    Comme toujours, si vous ou l'un de vos collaborateurs étiez capturés ou
    tués, le département d'Etat niera avoir eu connaissance de vos agissements.

    Soyez conscient des risques pris en effectuant ces modifications.
    Si vous endommagez votre téléphone, ni le forum ni moi ne pourront être tenu pour responsables.

     

    Le Root :

     

    Je ne suis pas dev donc la solution que j'ai trouvée ici vient de mes recherches sur les sites chinois et en particulier celui-ci : http://220.189.209.76/read/5898/1

    La traduction en anglais est ici :

    http://translate.google.fr/translate?hl=fr&sl=zh-CN&tl=en&u=http%3A%2F%2F220.189.209.76%2Fread%2F5898%2F1&sandbox=1

     

     

    Avant tout il faut se procurer le package U790_Flash.zip, ici :
    http://pan.baidu.com/share/link?shareid=187225&uk=2586250311

    Cela ne marche pas toujours et j’essaierai de le mettre en ligne ailleurs. Après extraction on obtient :

    SP_Flash_Tool (Outil de flashage)
    driver (brush-drive)
    U790_CWM (Recovery)
    U790_Root.zip ( ROOT package)

    On copie U790_Root.zip à la racine de la carte SD comme d'hab et on éteint le téléphone.

    Ensuite on installe le pilote.

    Dans le répertoire driver, on lance install driver et on attend que ça s'installe.

    Ensuite on branche le téléphone éteint ; oui c'est bizarre mais chez sur le U790 il n'y a pas de mode download : on flash téléphone éteint car apparemment la bête ne dort que d'un œil ;-).

    Windows va détecter un nouveau périphérique, il faut refuser l'installation automatique et lui demander d'aller chercher le pilote dans le répertoire Driver/2K_XP_COM/.

    Ensuite on débranche et on rebranche et on renouvelle l'opération. Donc oui il faut que windows détecte deux fois le nouveau périphérique sinon l'install est incomplète et vous aurez un message d'erreur durant le flash du recovery.

     

    Flashage du recovery

    Après avoir débranché le téléphone, on lance l'outil de flashage, un genre de odin-like, en lançant Flash_tool.exe dans le répertoire SP_Flash_Tool.

     

    Dans Options, on active USB Mode.

    36_23374_afeddfd066a9b57.png

     

    Ensuite dans File on choisis open Scatter-loading file et on sélectionne le fichier MT6575_Android_scatter.txt dans le répertoire U790_CWM.

    36_23374_6490f6f62515fa5.png

     

    Puis on clique sur la flèche "download", à coté de "stop".

    On obtient un avertissement mais on continue.

    36_23374_7bc784a1caf6217.png

     

     

    36_23374_8f77695631f2493.png

    A ce stade la barre de progression est à 0%. On branche le câble sur le téléphone (qui est éteint je rappelle).

    Le process commence. 0 la fin on a une petite fenêtre download ok avec un rond vert.

    36_23374_78de323d60488e0.png

     

     

    Le recovery a donc été flashé avec succès. C'était la partie la plus délicate. On peut débrancher le câble.

    Le recovery d’origine ne permet pas de flasher U790_Root.zip et vous aurez un échec si vous tentez ça.

     

     

    Passage en root

    Que dire? Il n'y a plus qu'a redémarrer en mode recovery en appuyant sur vol haut + power. La touche de validation est maintenant la touche de recherche alors qu'avec l'ancien recovery c'était la touche de gauche.

    On choisis "install zip from sdcard" puis "choose zip from sdcard" et selectionne "U790_Root.zip".

    36_23374_155ccb1a90017d2.png

     

    On valide, on patiente quelques secondes, on reboote la bête et on savoure!

     

    Je vais continuer à bricoler et je posterais mes avancées ici.


  4. Bonjour,

    J'ai un gros soucis : quand je flash avec odin ça fonctionne ( All threads completed. (succeed 1 / failed 0))

    mais j'ai un message d'erreur sur le mobile comme quoi /dbdata ne peux pas être monté.

    Can't mount /dbdata

    your storage not prepared yet, please use UI menu for format an reboot actions.

    Ensuite au démarrage j'ai un bootloop.

    J'avais fait un wipe data/factory reset + wipe cache.

    Le truc c'est que le recovery a été changé et que je n'ai que 4 choix : apply update from sdcard, les deux wipe et le reboot alors je vois pas trop ce que je pourrai formater....


  5. Ca tourne enfin! Merci dago pour ta Rom! Par contre on fait comment pour supprimer ton petit message sur le bureau?

    edit : Je fais quelques commentaires à la suite de mes aventures.

    - ça a été dit et redit mais bon...le téléphone ne prend pas la charge en mode download ou recovery car la charge est pilotée de manière logicielle. Donc le GS doit être suffisamment chargé avant tout flashage.

    - si le tel tombe en panne de batterie, avant de vous précipiter au sav, achetez un chargeur universel (un gros clip plastique maintient la batterie en place et deux lamelles pivotantes sont à mettre en contact avec les bornes de la batterie) et enlevez la batterie du GS pour la recharger. Ensuite remettez là en place et retentez votre chance... (si la charge n'a pas marché, vérifiez que vous n'avez pas inversé les bornes)

    -Si vous avez déjà une rom custom, mieux vaut flasher d'abord la JM8 avant de flasher la ROM de Dago.

    -Dans le tuto sur le changement de kernel par ODIN, il faut bien sur décompresser le fichier zip pour avoir un tar

    - Le flashage du GS est quand même plus sportif que sous HTC (je viens du hero). Si vous aviez l'habitude de flasher votre HTC souvent et en tout lieu, de l'overcloker et lui faire subir toutes sortes d'avanies, faites attention! Avec le GS tout est plus compliqué et vérifiez avant tout que vous avez accès au modes download et recovery avec les raccourcis boutons car c'est TRES utile, notamment quand vous avez foiré un flashage et que le GS est en vrac et ne peut plus booter...

    - Quand on flashe avec odin il faut d'abord lancer odin et le paramétrer et ensuite démarer le tel en mode dowload et enfin le brancher au PC. C'est présenté comme ça dans le tuto mais je précise que cet ordre n'est pas facultatif.

    Perso si je branche le GS avant de lancer odin, le gs n'est pas détecté. Donc je débranche le gs et le rebranche mais en général dans ces cas là le flashage plante. Et si vous avez planté un flashage, il faut redémarer en mode download avant tout branchement sinon vous risquez d'avoir la fameuse icone triangulaire jaune et d'être obligé d'enlever de nouveau la batterie.


  6. @Vincesonata : Merci! J'ai flashé le kernel avec succès!

    Mais au redémarrage j'ai un avertissement : "new filesystem detected" avec plusieurs options (oui avec ou sans factory reset et backup, non+enter recovery mode, non+remove new config). Je serais tenté de choisir oui sans factory reset mais si quelqu'un a une suggestion, je le remercie par avance.

    edit : J'ai choisi oui... on verra bien


  7. Bon j'ai fini par m'en sortir : recharge de la batterie au chargeur universel + deux tentatives de flash en JM8 (la première a planté)

    Mais maintenant je vais retenter le coup avec ta ROM Dago mais je m'aperçois que mon recovery a été modifié! J'ai une version light avec simplement aply update.zip sans la possibilité d'aller chercher ta ROM.

    Je vais tenter le coup en renommant ta rom en apdate.zip mais quelqu'un peut il m'expliquer pourquoi j'ai perdu mon recovery "élaboré" avec toutes les options et les lagfix?


  8. Parce que c'est un flash via le logiciel odin donc qui s'effectue sous mode download

    ok. On est obligé de passer par Odin :emo_im_undecided:

    Je suis en train de télécharger la ROM.

    Je n'aime pas flasher avec Odin. Je trouve que ça'est une usine à gaz. Mais si je n'ai pas le choix.....

    Mais si il faut obligatoirement partir de la JM8, il faudrait le préciser dans le tuto....

    Je dis ça, je dis rien....


  9. Je suis bloqué sur l'écran "Galaxy S" "GT-I9000" depuis de longues minutes après mon premier reboot!

    je sais que ça peut être long mais là ça fait déjà un gros quart d'heure.......

    Je tente le reboot? Je vire la batterie?

    Je viens de la Tayutama mais j'avais voulu faire les choses proprement et j'ai fais un wipe avant de flasher. J'ai aussi viré le lagfix que j'avais mis par l'intermédiaire du recovery.


  10. J'ai installé la version 1.0.2 et le lagfix No-RFS Overkill JFS et tout marche sans soucis. Market OK.

    Je précise que j'ai effectué l'install directement à partir d'une ROM SFR après un retour SAV.

    Je trouve cette manière de procéder beaucoup plus simple que de passer par Odin qui fait un peu pilotage de centrale nucléaire... :rolleyes:

    Franchement après m'être tapé les install en deux passes avec Odin, en suant à grosses goutes au moindre ralentissement, les install (et surtout les desinstall) de lagfix qui crashent..... j'apprécie vraiment cette manière de flasher. C'est peut être parce qu'avant j'avais un hero que je flashait dans le métro sans aucun stress :cool:

    Je préfère de beaucoup passer par le recovery. En plus avec la version 1.0.2 on peut démarrer en mode recovery directement avec un appui long sur power : le must!


  11. Bon, j'ai récupéré mon GS opérationnel après un passage éclair au SAV (j'en profite pour saluer le SAV externalisé de meilleur mobile).

    Ettt, comment dire.... j'ai encore fait mon boulet :| C'était juste un problème de charge! Mon GS n'était probablement pas assez chargé avant le flash. Comme la charge est pilotée par le soft, pendant un flash il n'y a pas de charge même si le phone est branché en USB (cela a déjà été dit plein de fois mais bon je le redis quand même).

    J'avais déjà pensé à cette hypothèse et j'avais tenté la charge directe de la batterie sans succès... à cause d'une erreur de polarité! + et - ne sont pas indiqués sur la batterie donc quand vous chargez avec un chargeur universel, il faut penser à vérifier que la charge se fait avec un multimètre.

    Je retrouve mon GS avec une ROM SFR horrible mais bon elle ne va pas survivre très longtemps. Le techos ne m'a pas posé de questions au sujet d'une éventuelle tentative de flashage et je ne me suis pas étendu sur le sujet....


  12. Si tu avais le download et recovery mode avant le flash c'est obligé que ça fonctionne.

    Malheureusement non... Je l'ai déjà flashé une fois en JM8. Ça avait marché nikel mais j'avais oublié de faire un wipe comme un boulet.....

    J'ai voulu reflasher et j'ai désinstallé le lagfix tayutama que j'avais mis. La désinstallation s'est bien déroulée mais après le tel était très instable.

    J'ai lancé la première étape du flash..... et plus rien. Le tel est briqué bon pour le sav.

    Ce we j'ai tenté de recharger la batterie à fond avec un chargeur universel au cas ou une charge insuffisante bloquerait le démarrage mais ça ne change rien.

    Donc je déconseille le tayutama. En tout cas pas de wipe + tayutama = brikage du tel en ce qui me concerne :(

×
×
  • Create New...