HarFanG

Membre
  • Compteur de contenus

    280
  • Inscription

  • Dernière visite

Réputation sur la communauté

23 Neutre

À propos de HarFanG

  • Rang
    Android à poil bleu

Profile Information

  • Marque
    INOSOP 10-4.0.4 SynchroDigital 10"
  • Modèle
    Nokia E72

Visiteurs récents du profil

2 431 visualisations du profil
  1. HarFanG

    Cubot X6 : bloqué au boot.

    Je commence par la fin, pour changer un peu : effectivement, j'aurais du backuper avant de re-bricoler à Noël. Cette fois-ci, il s'agissait d'une bidouille déjà faite par moi-même par le passé, et tout s'était justement très bien passé ; je n'avais par conséquent aucune raison d'avoir des doutes. Et tu as bien raison : la famille on n'en a qu'une, et elle devrait toujours passer devant. Et je te remercie de ton aide. Tu as du mal à me suivre, alors je te récapépète un brin : - factory reset : le phone redémarre comme au premier jour (demande de langue, compte gogole, toussa toussa) - à ce moment-là, si je reloade le backup consécutif à mon plantage = ç'est replanté direct au boot (comme si je n'avais rien fait) - le .backup se décompresse facilement avec 7zip, mais à partir de là, le phone n'en veut plus (checksum error machin) Certes, je ne suis pas un génie linuxien, mais pas une totale quiche non plus : j'ai bidouillé et upgradé des tablettes, et rooté 36000 trucs. Chez moi, j'ai un backup total en .img : le hic, c'est que je ne suis pas chez moi pour encore un sacré moment Ceci dit, j'ai bcp de choses sur mon X6, mais je ne me souviens plus de tout, c'est pour ça que j'aimerais vraiment qu'il reboote tel qu'il était avant que j'aie la mauvaise idée de trifouiller dedans une fois de plus. Après, bah si je n'arrive pas à m'en sortir, je repartirai en reset factory, et j'irai fouiller dans les .apk du backup.
  2. HarFanG

    Cubot X6 : bloqué au boot.

    Suite de mes aventures. Spoiler : mais c'est pas encore la fin. J'ai donc regardé dans le .backup décompressé, j'ai analysé au mieux de mes connaissances, et j'ai supprimé quelques fichiers parlant de "xposed truc" et "hack machin". J'ai changé le nom de ce .backup de manière à le reconnaitre plus facilement, et je l'ai fait bouffer au recovery "load user data". Echec cinglant : checksum error (ou un truc qui veut dire la même chose). Là, j'ai ré-essayé avec le .backup décompressé, mais sans l'avoir modifié : checksum error. On sait comment le calculer, ce fameux checksum ? J'ai compris qu'ils en parlaient sur le thread XDA, mais bon... Autre piste possible : le xposed_disabled_recovery. De ce que j'y comprends, il vérifie s'il existe un fichier spécifique dans "BIN", et si oui, il le renomme. QUESTION : y'a moyen de faire ça manuellement, en accédant aux fichiers du phone en USB ? Car sur ma SD card, il n'y a pas de dossier "bin" => doit être dans le X6... Des idées, histoire que je puisse me reposer un brin ? 😓
  3. HarFanG

    Cubot X6 : bloqué au boot.

    Bon, je poste à ma propre suite, histoire de ne pas faire de post trop long. J'ai trouvé ceci : https://forum.xda-developers.com/showthread.php?t=2528969 En bricolant, j'ai pu décompresser un backup_xx_backup : de 345 Mo, je suis passé à 620 Mo (ce qui est la taille annoncé lors du backup proprement dit). J'obtiens quelques tonnes de dossiers/fichiers. En triant par date, je vois 6 dossiers modifiés le 24 décembre 2018 <=== bingo, c'est là que j'ai planté la bête. En ouvrant l'un de ces dossiers au hasard, je vois qu'il y a deux fichiers datés du 24/12 aussi : les noms sont compliqués, mais comprennent "xposed machin" pour l'un, et pour l'autre, y'a "connectivity hack" dedans. Est-ce qu'avec tout ça, y'aurait moyen de supprimer ou modifier des trucs pour que ça fasse un backup "bootable" ?
  4. HarFanG

    Cubot X6 : bloqué au boot.

    Voici les dernières nouvelles... J'ai fait une copie du xposed_recovery.zip en le renommant en "update.zip". J'ai essayé de lancer les deux : à chaque fois, ça tourne quelques secondes et ça me dit "update aborted". Je me suis finalement résigné à tenter le "factory reset" : ça a bossé quelques instants, puis le phone a redémarré comme au déballage ! Donc jusque là, rien n'est irrémédiablement bousillé, je suis soulagé ! Par contre, lorsque j'essaie de recharger le "user data" sauvé précédemment, le X6 rebloque au boot comme si je n'avais rien fait. J'en conclus donc que : 1- Il est ok côté système Android ; 2- Il faudrait trouver ce qui ne va pas dans le user data sauvé : y'a moyen de l'éditer et de le modifier, ce truc ?
  5. HarFanG

    Cubot X6 : bloqué au boot.

    Oki, j'ai bien fait de farfouiller un peu ^^ Par contre, je n'ai aucune idée de comment faire ce que tu dis Je rentre dans le recovery, et je lui dis que c'est une update en lui présentant le fichier en question ? Je sens qu'on est tout proche de la salvation, et j'aimerais éviter de faire une dernière ânerie ^^
  6. HarFanG

    Cubot X6 : bloqué au boot.

    Bananier 2019. Ca m'a pris un peu de temps pour revenir commenter, mais avec les fêtes de fin d'année...pfou. J'ai enfin pu remettre la main sur un lecteur de cartes SD : à la racine de la µSD du X6, il y a [aussi du bordel evidemment] et deux fichiers ".backup". - userdata_20090101_001336.backup - userdata_20090101_002802.backup Faisant un peu plus de 345 Mo chacun. Ils sont datés du 1/1/2009, une date antérieure à l'achat de mon stupidphone, mais qui doit s'expliquer par le fait qu'il est "planté". J'imagine que c'est ça qu'il faut utiliser dans le recovery après reset d'usine. Cependant, il y a aussi un fichier "Xposed-Disabler-Recovery.zip" d'un peu plus d'1 Ko. Dedans, au fond des dossiers inclus, il y a "META-INF\com\google\android\update-binary". C'est du code texte, j'ai regardé, il y a ceci : Il ne faudrait pas essayer de faire quelque chose avec ? Vu que c'est en (re)installant le Xposed framework que ça a planté au reboot. Une idée ?
  7. HarFanG

    Cubot X6 : bloqué au boot.

    Ah attends un peu... Si je ne m'abuse, j'ai du faire un backup autrefois (ça date). Je crois que j'ai un dossier rempli de fichiers .img, ça doit être ça. En vacances à l'Etranger pour encore un bon moment, ça attendra mon retour en France pour vérifier. Donc, pour tester ma chance : - j'enleve la sim et la SD du phone ; - facultatif : je verifie si le fichier "xxxxx.backup" est sur la SD. Si oui, j'en fais quelques copies okazou. Si non, tant pis, je verrai à mon retour ; - factory reset depuis le recovery ; - je remets la sim et la SD dans le phone ; - puis je tente de loader le "xxxx.backup" de la SD depuis l'option idoine dans le recovery. C'est le bon ordre, la bonne méthode ?
  8. HarFanG

    Cubot X6 : bloqué au boot.

    Pour le fichier "xxxx_xxx.backup" je demandais où le trouver après que le recovery l'aie sauvegardé, pas son contenu ^^ De toute manière, je ne connais pas Linux. Mon hypothèse est la suivante : si je tente le factory reset via le recovery et que le phone repart, le fichier ".backup" peut-il être ré-introduit via l'option correspondante du recovery ? Et ainsi, le X6 se retrouverait avec mes données, sans que je perde quoi que ce soit. En fait, je pense que reflasher le firmware, c'est un peu une mesure extrême ; doit bien y avoir une manoeuvre moins risquée à faire, non ? Au mieux, le factory reset fait tout repartir comme en 40. Au pire, le flash flingue définitivement tout le bordel. D'autant plus que ça fait un bail que j'ai pas utilisé SPflash, je ne suis pas certain de ne pas faire une bêtise... EDIT : d'ailleurs, avec SPflash, y'a pas moyen d'accéder aux fichiers du phone et faire des modifs ? Si ça se trouve, y'a juste une ligne qui s'est rajoutée, et c'est elle qui bloque, sait-on jamais...
  9. HarFanG

    Cubot X6 : bloqué au boot.

    Hello et merci de ta réponse. Il n'est pas aussi "bidouillé" qu'il y parait, rassure-toi. Je l'ai simplement rooté (pré-rooté d'usine celui-là), et rajouté un recovery. Pour le firmware, il faut savoir que j'ai souhaité faire une mise à jour autrefois : n'aimant pas foncer bille en tête, j'avais creusé profondément. Bien m'en a pris, car j'ai pu découvrir qu'il existe deux versions de mon tel : la mienne et la + récente. Il n'existe (n'existait ? ) qu'une version de firmware, et elle ne collait pas avec mon matos : en particulier, l'appareil photo arrière n'était plus reconnu, y'a pas mal de gens qui se sont fait avoir. Par conséquent, je l'avais laissé tel quel, au final il tourne-tournait très bien. C'est pourquoi j'ai un peu peur de tout flasher, d'ici à ce que ce ne soit pas la bonne version = je me sers énormément de la caméra arrière, car je voyage beaucoup. Puis-je te poser une ou deux questions ? 1- la sauvegarde du recovery crée donc un fichier "xxxxxxxxxxxxx_nom_à_coucher_dehors.backup : y'a moyen de le récupérer quelque part, okazou ? Il se fout sur la SD p-e ? 2- y'aurait pas un moyen quelconque d'accéder au phone via PC afin de pouvoir modifier l'un ou l'autre fichier ? 3- question subsidiaire : pour moi, ça date pas mal, as-tu un lien fiable pour pecho SP Flash Tools stp ?
  10. Salut à tous et toutes ! Un petit bout de temps que je ne suis plus passé par ici. J'ai un gros souci, voici un résumé : en vacances outre-Atlantique, j'ai voulu ajouter la map "Québec" dans mon Cubot X6 (Here We go). Trop lent par wifi, j'ai voulu passer par le reverse tetherin, que j'avais déjà testé par le passé, sous Windows XP. Et avec succès, je le précise. Hier, j'ai voulu faire pareil, mais ça n'a pas fonctionné. Vu que c'est pas le même PC que chez moi, j'ai pensé qu'il manquait le "connectivity hack". En principe, sur le X6, de mémoire je l'avais déjà installé : mais ça date de quelques années... Bref, je lance l'install (depuis l'Android Tethering) et à moment, ça me dit qu'il me faut le "Xposed framework". Lui aussi, il doit déjà être installé depuis un bail. Ceci fait, il me dit qu'il faut rebooter. Je le fais...et le X6 reste bloqué sur le logo CUBOT du démarrage. Je me dois de préciser que j'ai acquis ce phone en 2014 ou 2015 neuf, et qu'à l'époque, j'ai déjà bidouillé dessus : root sans souci, et probablement un recovery, mais ma mémoire n'en est pas sûre. Il doit être en 4.3 ou 4.4 je ne sais plus exactement. Concretement, voici ce qu'il y a : - j'ai enlevé la SIM et la SD card ; - le tel bloque sur le logo CUBOT ; - le PC le détecte en USB, voit les 2 unités de stockage, mais ne peut évidemment pas y accéder ; - volume - et power = recovery chinois, j'y comprends rien ; - volume + et power = recovery anglais, j'ai fait "delete cache" mais ça ne change rien ; - j'ai fait "save user data" et ca a enregistré un fichier avec un nom pas possible et l'extension ".backup" . En désespoir de cause, je pourrais tenter le "factory reset" depuis le recovery anglais, mais dans ce cas, je perdrai toutes mes données, et j'en ai accumulé depuis des années. Voilà, c'est un peu long, mais j'ai préféré donner un max d'infos dès le départ. Quelqu'un verrait une solution pour me sortir de ce pétrin ? Et Joyeux Noël EDIT : j'avais posté ceci par erreur dans la section "tablettes".
  11. Désolé, je me suis trompé de section. A effacer svp, merci.