Jump to content
kerti

probleme a l'install du plugin Android Devlpmt Tools dans Eclipse

Recommended Posts

Bonjour,

En provenance du tuto pour install le sdk android:

https://www.frandroid.com/28/installer-android-sdk-sans-prise-de-tete/comment-page-1/#comment-22031

je rencontre un probleme:

aprés avoir lancer eclipse (plusieur version on été testé: easyeclipse et Eclipse for java ee)

clique sur help -> Software Updates -> Find and Install.

puis: Search for new features ton install

et enfin: New remote site

ici on entre un nom et un url:

celui-ci: https://dl-ssl.google.com/android/eclipse/

on clique sur finish.

une fenetre d'update s'ouvre, on selectionne notre "feature to install", et c'est la qu'un méchant message d'erreur nous empéche de cliquer sur next pour valider. Les message d'erreur son diférent selon les version d'eclipse utilisé pour cet manip:

erreur avec easyeclipse:

Android Development Tools (0.9.6.v201002051504-24846) requires plug-in « org.eclipse.wst.sse.core ».

erreur avec eclipse for java ee:

Android Development Tools (0.9.6.v201002051504-24846) requires plug-in « org.eclipse.gef ».

estce que quelqu'un aurait la solution a ce probleme?

comment fair pour Installer android sdk sans prise de téte ^^ ?

Share this post


Link to post
Share on other sites

Les erreurs indiquent qu'il te manque des plug-ins ou features Eclipse (soit la mauvaise version, soit pas là du tout). Le plugin Eclipse pour le SDK d'Android a besoin de ceux ci pour fonctionner. Tu dois donc les installer, pour ça dans Find and Install commence par aller sur le site de ta version d'Eclipse.

Pour EasyEclipse c'est http://easyeclipse.org/update/site.xml (mais je crois qu'il est vide là). Sinon tu peux DL Gallileo (Eclipse 3.5) qui doit déjà être équipé de ces plug-ins.

Tu dois savoir, que le SDK d'Android est séparé, c'est un ensemble d'outils, de samples, de librairies qui servent à dev pour Android, et le plug-in ne fait jamais qu'adapter les outils d'Eclipse pour pouvoir utiliser ce SDK (qui fait par ailleurs plus d'un giga) !

En revanche, si installer 2 plugins est pour toi une prise de tête, tu risques de bang ta tête contre les murs sous peu :D

Share this post


Link to post
Share on other sites

Dison que le plus chiant c'est de pas savoir quoi faire pour résoudre un problem, maintenant que tu m'as éclairé avec ta lanterne, je vais voir si la prise de téte persiste ou pas... je teste sa demain

Share this post


Link to post
Share on other sites

avec eclipse galileo: j'lai installé, j'lai mis a jour, j'ai suivit le tuto (légére diférence dans la procédure mais sa reste identique)

ça marche nikel :)

Share this post


Link to post
Share on other sites

salut,

en fait j'avais oublié ce topic (désolé :s)

je crois me rappelé que pour résoudre ce problem, il fallait mettre le dossier "tool" du sdk android en variable d'environnement (path) et en suite procéder a Software Updates -> Find and Install

je suis vraiment désolé de pas avoir imédiatement posté la solution (plus détaillé) sur le forum. On ne m'y reprendra pas deux fois...

je vous remercie.

ps: comment on fix le sujet en résolu?

Edited by kerti

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...