Jump to content
pcmac

Gps ne me repère pas

Recommended Posts

Bonjour. Je rencontre des problèmes à l'utilisation du GPS. Le fixe ne se fait pas précisément.

J'allume la fonction GPS, puis googlemaps. A ce moment l'icône de GPS (le petit point dans la cible) clignote. J'ai ma position approximative assez vite sur googlemaps. Cependant impossible d'obtenir ma position précise, au bout de 5 vraies minutes. Est ce que vous aussi? Je m'y prends mal ? Ya t'il un réglage particulier ?

Sent from my Z130 using Forum FrAndroid mobile app

Share this post


Link to post
Share on other sites

Je n'ai pas du tout ce genre de problème avec mon Z3, dont la rapidité de fix du GPS est au contraire une bonne surprise pour un low-cost.

Question peut-être idiote : le test a-t-il été bien fait en extérieur avec une vue ciel bien dégagée ? le téléphone a-t-il une connexion de données ? (3G) c'est très utile même si théoriquement pas indispensable pour le fix.

Share this post


Link to post
Share on other sites

Bonjour Lannig (sans fautes lol).

Bien entendu, la data est activée, quant au ciel c.'était légèrement gris. Avec mon defy c'était quasi immédiat dans les mêmes conditions.

Quand tu as le fix, le rond ne clignote plus dans le cercle ? (Je parle de l'icône du GPS).

Sent from my Z130 using Forum FrAndroid mobile app

Share this post


Link to post
Share on other sites

Exact, ça ne clignote plus. J'utilise l'appli GPS Test qui montre clairement combien de satellites vus/utilisés, la précision du fix etc.

Share this post


Link to post
Share on other sites

Re

Essaie ce matin par beau temps: fixe en qqlqs secondes.

Mais le rond continue de clignoter dans Google maps.

Sent from my Z130 using Forum mobile app

Salut

Lannig j'ai téléchargé ton appli GPS test. As tu une procédure de test à me conseiller ?

Sent from my Z130 using Forum mobile app

Share this post


Link to post
Share on other sites

Lannig j'ai téléchargé ton appli GPS test. As tu une procédure de test à me conseiller ?

Non, seulement lancer l'appli... :)

Share this post


Link to post
Share on other sites

Re

Gros problème, je n'ai même plus le rond bleu énorme dans googlemap qui rétrécit au fur et à mesure de la précision du repérage.

Décidément, je comprends pas. Pourrais-tu me donner tes réglages dans les données de localisation ?

 

Voici les miens:

 

Accès à ma position: ON

Satellite GPS: ON

Localisation via wifi et réseau mobile: OFF

 

 

Ensuite dans GPS:

 

Aide GPS EPO: OFF

A-GPS: OFF

 

Ensuite, je ferai des essai avec l'appli gps test en la lancant, je te dirai ce que je vois...

Edited by pcmac

Share this post


Link to post
Share on other sites

Ensuite dans GPS:

 

Aide GPS EPO: OFF

A-GPS: OFF

 

Pourquoi tout ça OFF ? au contraire il faut les mettre sur ON. Les GPS Mediatek ont besoin d'une assistance pour fixer correctement.

Pour cela il faut avoir ces deux paramètres sur ON et une connexion data opérationnelle.

Share this post


Link to post
Share on other sites

Pourquoi tout ça OFF ? au contraire il faut les mettre sur ON. Les GPS Mediatek ont besoin d'une assistance pour fixer correctement.

Pour cela il faut avoir ces deux paramètres sur ON et une connexion data opérationnelle.

je n'ai pas de forfait data, donc je ne souhaite pas utiliser la 3G pour le GPS

est-ce qu'il y a moyen d'utiliser le gps comme un gps autonome sans carte sim ou sans connexion de données? je n'arrive pas à fixer, les options EPO et A-GPS sont activées (mais forcément sans SIM ça ne sert à rien...), donc je suis un peu perdu (sans jeux de mots)

comment faire pour faire fonctionner ce foutu gps, du moins avec google maps?

Share this post


Link to post
Share on other sites

Sans aucune assistance, les GPS Mediatek on vraiment beaucoup de mal à fixer. C'est long, parfois tellement long que ça n'arrive jamais.

Si tu n'as pas de forfait 3G, il faut au moins une fois par mois activer l'EPO quand ton smartphone est connecté à un wifi et forcer une m-a-j des données EPO.

Si possible, le mieux est d'activer EPO+A-GPS alors que tu es connecté en wifi et de tenter un fix près d'une fenêtre, ou de profiter d'un wifi en plein air (genre dans les parcs à Paris, mais la saison ne s'y prête pas :))

Le plus souvent tu feras cette manip, le plus facile et rapide seront les fix quand tu n'auras pas de connexion data.

  • Like 1

Share this post


Link to post
Share on other sites

Sans aucune assistance, les GPS Mediatek on vraiment beaucoup de mal à fixer. C'est long, parfois tellement long que ça n'arrive jamais.

Si tu n'as pas de forfait 3G, il faut au moins une fois par mois activer l'EPO quand ton smartphone est connecté à un wifi et forcer une m-a-j des données EPO.

Si possible, le mieux est d'activer EPO+A-GPS alors que tu es connecté en wifi et de tenter un fix près d'une fenêtre, ou de profiter d'un wifi en plein air (genre dans les parcs à Paris, mais la saison ne s'y prête pas :))

Le plus souvent tu feras cette manip, le plus facile et rapide seront les fix quand tu n'auras pas de connexion data.

j'ai un peu de mal à comprendre le gsm

quand je lance google maps dont le raccourci est dans les applications, le fix ne se fait pas (le petit rond en haut à gauche continue à clignoter)

mais quand je lance firefox, sur la page d'accueil de google, je lance google maps (via le launcher où on a accès à traduction, gmail, etc), ça lance une autre interface de maps et là je suis localisé de suite et je peux faire des itinéraires

dans l'application google maps dont le raccourci est dans les applications, j'ai un petit bouton en bas à droite de la carte qui ne réagit pas à la pression

Edited by daktary

Share this post


Link to post
Share on other sites

Maps dans un navigateur te repère par ton adresse IP, donc par le wifi.

C'est une localisation très approximative... et qui nécessite d'être connecté en wifi.

Share this post


Link to post
Share on other sites

Maps dans un navigateur te repère par ton adresse IP, donc par le wifi.

C'est une localisation très approximative... et qui nécessite d'être connecté en wifi.

localisé par le wifi?????? mais alors vachement précis car via le "maps" de google (le navigateur donc) je suis pile poil à mon adresse...

bizarre, quel est le critère pris en compte (mon IP est localisée chez mon FAI à 20 km de chez moi)?

ça me semble étrange, je pensais que la puce gps des gsm était indépendante de tout réseau, et que le A-GPS était une aide basées ur la géolocalisation via les antennes GSM actives...

Edited by daktary

Share this post


Link to post
Share on other sites

Je remonte un peu ce sujet, car j'ai un souci bizarre de GPS sur mon Z3.

 
 

Sans aucune assistance, les GPS Mediatek on vraiment beaucoup de mal à fixer. C'est long, parfois tellement long que ça n'arrive jamais.

Si tu n'as pas de forfait 3G, il faut au moins une fois par mois activer l'EPO quand ton smartphone est connecté à un wifi et forcer une m-a-j des données EPO.

Si possible, le mieux est d'activer EPO+A-GPS alors que tu es connecté en wifi et de tenter un fix près d'une fenêtre, ou de profiter d'un wifi en plein air (genre dans les parcs à Paris, mais la saison ne s'y prête pas :))

Le plus souvent tu feras cette manip, le plus facile et rapide seront les fix quand tu n'auras pas de connexion data.

 

Effectivement les GPS ont besoin d'une communication data.

Juste pour info (c'est la minute culture) un GPS fonctionne en calculant la distance qui le sépare de plusieurs satellite.

En gros, le GPS reçoit le signal d'un satellite, signal qui contient l'heure à laquelle il a été émis, et donc le GPS peut calculer le temps qu'a mis le signal pour arriver et du coup en déduire la distance qui sépare le récepteur GPS sur satellite qui a envoyé le signal.

Mais ça implique que les horloges du satellite et du récepteur GPS soient synchronisée, ce qui est très compliqué (ton téléphone n'embarque pas une horloge atomique ) donc il faut recevoir le signal d'au moins 4 satellites pour avoir une position précise.

 

Mais ca ne suffit pas, car on sait alors où on est par rapport aux satellites, mais si on ne sait pas ou sont les satellites par rapport à la terre... du coup on ne sait pas où on est sur terre et le GPS ne sert à rien.

Le récepteur GPS doit donc posséder une "carte" des positions des satellites, mais comme si c'était déjà pas assez compliqué, les satellites du système GPS ne sont pas géostationnaires, ils bougent et tournent autour de la terre!

 

Donc c'est pas une carte, mais une éphéméride, qui va contenir la position des satellites dans le temps.

 

C'est ici qu'intervient la communication data.

Ces éphémérides ne sont pas universelles, il n'y a pas une carte de position des satellites jusqu'à la fin des temps.

En fait, elles ont une durée de vie de 4h et sont publiées par les satellites toutes les 2h.

C'est à dire que toutes les 2h, une nouvelle éphéméride est envoyée avec les position des satellites pour les 4h à venir.

 

Donc toutes les 4h, ton GPS doit télécharger la nouvelle éphéméride.

C'est ce qu'on appelle un "fix à froid" ou un "fix à chaud".

Si ton GPS est coupé depuis plus de 4h, il doit télécharger les éphémérides avant de pouvoir de localiser (fix à froid) ce qui prend plus de temps, car les éphémérides sont transmises par les satellites avec le signal qui permet de calculer la position, mais avec un débit assez faible (50 bits par seconde)

Au contraire si ton GPS est coupé depuis moins de 4h, il a déjà en mémoire une éphéméride valide et peut donc realiser le fix plus rapidement.

 

Pour accélérer ce téléchargement, on a inventé le A-GPS (Assisted GPS), ou les éphémérides ne sont plus téléchargées depuis un satellite, mais depuis "internet" via une communication data GSM (mais j'imagine qu'un téléphone avec une connexion Wifi doit aussi pouvoir utiliser celle ci).

 

Donc si tu n'as pas un abonnement data ou que tu n'as pas activé l'A-GPS, c'est normal que le fix soit un peu long.

 

 

Lannig, merci pour l'info sur les puces Mediatek qui ont du mal sans assistance, ça explique certainement être mon problème.

En effet j'utilise Waze pour mon trajet maison/travail.

D'habitude je lance l'appli quand le monte dans la voiture, téléphone sur le support fixé au pare brise, et j'ai le fix GPS (même à froid) assez rapidement.

 

Disons qu'au boulot, où j'ai un parking très dégagé, le fix se fait en une minute, deux à tout casser.

A la maison c'est un peu compliqué, vu que c'est en ville, dans des petites rues avec des immeubles de 3ou 4 étages, l'effet canyon ralenti un peu le fix, mais bon, ca va quand même assez vite.

A noter que dans les 2 cas, j'ai un réseau wifi à disposition.

 

Mais depuis 2 jours, c'est vraiment la misère.

Ca met facilement plus de 5 minutes... surtout quand je quitte le boulot (plus de couverture wifi des que je sors du parking)

 

J'imagine que la couverture data de free doit merdouiller (j'ai un forfait 2€, je n'utilises la data que pour Waze, le reste du temps je passe par le wifi, donc je n'ai aucune idée de la qualité du reseau free)

En l'absence de wifi et de data 3G, ca expliquerai pourquoi mon Z3 rame à faire le fix.

 

Mais chose étrange, ce topic m'a donné l'idée d'aller regarder les parametres GPS (que je n'avais jamais touché) et j'ai découvert que les options A-GPS et EPO

J'ignorais ce qu'était l'EPO (pour mois, c'etait juste Eau Pastis Olives, un dopant autorisé sur le tour de France) et j'ai découvert que c'était un truc spécifique à Mediatek, avec des éphémérides valable un mois (c'est ecrit dans les parametres du Z3, quand on fait Parametres/Données de Localisation/Satellites GPS/Réglages EPO/A propos de EPO.

D'ailleurs le menu Réglages EPO permet de bloquer le téléchargement automatique (utile quand on a pas un (gros) forfait data) et de lancer le téléchargement manuellement.

Dommage qu'on ne puisse par lui dire "téléchargement automatique, mais que en Wifi"

Edited by Julien34
  • Like 1

Share this post


Link to post
Share on other sites

Hello,

j'ai hérité d'un Z3 mais avec ce dernier impossible de fixer les Gps je pense avoir tout tester mise à jour manuelle du fichier Epo, test mise à jour EPO avec MT GPS, la manipe mobileuncle tools et toujours aucun fixe ! A priori il n'a jamais fixé!

 

J'ai démonté le tel mais je ne vois pas ou est la puce et antenne.

 

Si vous avez des infos ou idée pour le faire fonctionner ou le démonter ?

 

Merci

Edited by dbzh

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...