Jump to content
Daemon_Weaver

[WIP] [ROM Custom] Portage de la ROM MIUI v5

Recommended Posts

Alpha maintenant disponible les amis ;D
N'hésitez pas à l'essayer, j'y ai mis  un fichier de remerciements :) 


@@RaBBiTz it's normal if your stuck in bootloop, you have to port ROM even if the hadware is similar ;) I will port this ROM for CinkPeax2 if i'm stuck with Wi-Fi problems with the Stairway ROM ;) 
From wich country are you from ? And how did you arrive here ? :) 

Share this post


Link to post
Share on other sites

Pour la traduction avec jbart, il faut traduire la rom officielle (http://en.miui.com/download.html) sur laquelle on se base, après on prend les apks traduits et les fichiers frameworks : "framework-miui-res.apk"  et "framework-res.apk" pour les injecter dans notre rom...

Edited by Dayhlirium

Share this post


Link to post
Share on other sites

@Daemon_Weaver: Im from Germany. I started searching for a Custom Rom that improves GPS. Found the Miui Port for the Canvas 2 Plus which has similair hardware.

After some Softwarebricks i started looking for a Wiko Port of the Rom. Thats why im here ;) 

 

And the GPS-Problem for my Peax 2 is still not fixed :P

Share this post


Link to post
Share on other sites

@@RaBBiTz Yah it's a very commun problem, because of the cheaps components, the GPS sucks :P 
I have hear that some custom Roms (including MIUI) improved the GPS sensitivity but in fact I can't clearly understand how, and personally I don't use the GPS ^^ 
 

Edited by Daemon_Weaver

Share this post


Link to post
Share on other sites

@@RaBBiTz Yah it's a very commun problem, because of the cheaps components, the GPS sucks :P 

I have hear that some custom Roms (including MIUI) improved the GPS sensitivity but in fact I can't clearly understand how, and personally I don't use the GPS ^^ 

 

GPS is basically improved with gpsconfig and kernel source tweaks. 

 

for kernel 

http://www.wikogeek.com/

https://github.com/varunchitre15/MT6589_kernel_source/blob/master/mediatek/platform/mt6589/kernel/core/mt_cpufreq.c

http://forum.xda-developers.com/showthread.php?t=2670044

Share this post


Link to post
Share on other sites

[iMPORTANT] Ä partir de maintenant, je vais me baser sur une ROM MIUI v5 d'un clone du Cink Peax 2( le Micromax canvas 2 Plus A110q de son petit nom ) qui contiens pas mal d'améliorations de la ROM de base ( vous pouvez retrouver le changelog ici ) et je pense que mes problèmes de Wi-Fi seront corrigés grace à cette mise à jour ;) Je teste ça ce soir :) 

@@RaBBiTz I will try to import some tweaks for improve GPS in final release especially for you ;) 

Share this post


Link to post
Share on other sites

par contre, il faut que tu saches sur qu'elle rom elle même est basée, pour la trad

Share this post


Link to post
Share on other sites

Alors je viens de la tester, elle boot très bien, et elle est en Full FR par contre encore le problème de Wi-Fi, il est partiellement résolu puisque les autres fois j'avais l'option WLAN et là j'ai bien le Wi-Fi... 
Je vais essayer d'importer certaines librairies on va voir ça ;)

Share this post


Link to post
Share on other sites

Le lien vers la alpha en première page est celui de cette deuxième version (a110) ?

Share this post


Link to post
Share on other sites

Je suis en train de télécharger le kernel du Wiko Cink Peax 2 je vais essayer de le flasher voir ce que ça fait... 


@@flat6 Non, celle du A110 je suis en train de l'uploader, elle va arriver d'ici 20 minutes :) 

Share this post


Link to post
Share on other sites

Bon beh si tu te base sur une autre ROM je pense que ça va pas être trop utile que je la traduise x)

Si jamais tu as besoin de quoique ce soit à traduire, sinon je suis là.

Plus sérieusement j'ai vraiment envie de tester l'alpha mais je sais pas si je dois attendre ton autre version ou non :P

Share this post


Link to post
Share on other sites

@@Marcoux D'ici 5 minutes sort la version 2 qui amène pas mal de nouvelles choses je vais faire un changelog d'ici quelques temps, donc patiente encore un peu ;)
Par contre si tu connais ou si quelqu'un connais une personne assez compétente dans le portage de ROM qu'il puisse me mettre en contact avec ce serait vraiment sympa parce que là j'ai toujour ce problème de WiFi et j'ai beau trainer sur des centaines de forums je ne trouve pas de solution exacte.... :/

[EDIT] La version 2 est en ligne ;) 

Edited by Daemon_Weaver

Share this post


Link to post
Share on other sites

J'aurais bien voulu t'aider mais je peux pas t'aider pour ça :/

J'ai une question, avant le Wiko j'avais un ZTE Blade qui pour flasher se faisait comme ça :

Backup -> Différents wipes -> Installation de la Rom + GApps -> Reboot
Pour notre Wiko ça sera aussi simple ?
Si oui je l'installe ce soir ! :D

Share this post


Link to post
Share on other sites

Ah moi aussi j'avais un Blade :D 
J'ai mis un tutoriel dans l'archive, suis-le et il n'y à pas de soucis ^^ 
Tu as bien un custom Recovery ? 

Share this post


Link to post
Share on other sites

Ah un copain ^^

Non faut que je l'installe mais bon ça doit pas être bien dur ;)

Share this post


Link to post
Share on other sites

Bon petit retour après 5 minutes de test, j'ai un "paramètres ne répond pas" au démarrage, et le laucher qui plante aussi, sinon  la rom est plutôt fluide, superbe :D

Je confirme, pas d'appareil photo fonctionnel ni de wifi ni de bleutooth par contre la 3G + appel/sms fonctionnent.

Merci :D

 

EDIT: 

 

Ce qui ne vas pas :

Les transferts par usb sont capricieux --> j'ai changé de mode usb, en stockage usb c'est bon

L'app thèmes plante a tous les coups

Impossible d'installer une apk que ce soit en 3g ou depuis la carte micro sd

Et surement d'autres petits bug mais c'est correct pour une première rom :)

Edited by Julien34000

Share this post


Link to post
Share on other sites

Oui j'ai eule problème des paramètres aussi, un petit reboot et c'est bon ;)


@@Marcoux Non c'est pas bien difficile, tu télécharges l'image du recovery et tu la flashes depuis android avec MTUncletool ;)

Share this post


Link to post
Share on other sites

dis moidans ton tuto il ne manquerait pas une lligne pour installer la ROM ?

Après les différents wipes tu dis juste qu'il faut rebooter !! Mais du temps de mon vieux HD2 sous android, fallait installer le .zip via CWM avant de rebooter !

 

J'suis à la rue ou quoi ?

Share this post


Link to post
Share on other sites

@@flat6 Non tu as bien raison j'ai complètement oublié le plus important ^^ 
Install zip from sd card ou alors internal storage, choisir le zip, confirmer et reboot ^^ 

Edited by Daemon_Weaver

Share this post


Link to post
Share on other sites

Install OK. Effectivement "paramètres" nécessite un reboot pour ne plus planter.

 

Le tel sonne quand je l'appelle, c'est déjà ça.

 

Vais réessayer d'installer mes applis via titanium pour voir.

 

Un truc marrant, ilme dit que je suis chez Orange alors que je suis chez Free. Peut-être suis je sur une antenne orange à cet instant ?

 

[edit] du coup j'ai l'impression que la 3G déconne....

Edited by flat6

Share this post


Link to post
Share on other sites

Install OK. Effectivement "paramètres" nécessite un reboot pour ne plus planter.

 

Le tel sonne quand je l'appelle, c'est déjà ça.

 

Vais réessayer d'installer mes applis via titanium pour voir.

 

Un truc marrant, ilme dit que je suis chez Orange alors que je suis chez Free. Peut-être suis je sur une antenne orange à cet instant ?

 

[edit] du coup j'ai l'impression que la 3G déconne....

Merci de ton retour, bizarre, je capte très bien en H+ et en 3G l'installations d'APKs marche chez moi :)

Share this post


Link to post
Share on other sites

Free utilise le réseau Orange là où il n'a pas d'antennes, donc c'est possible. De toute façon tu ne pourrais pas t'appeler si tu n'étais pas sur le bon réseau ;)

Share this post


Link to post
Share on other sites

Merci pour vos retours, quelqu'un connaitrait quelqu'un qui s'y connais en portage de ROM ? 
Parce que là je ne trouve plus de solutions pour le WiFi... 


 

Ce qui ne vas pas :

Les transferts par usb sont capricieux --> j'ai changé de mode usb, en stockage usb c'est bon

L'app thèmes plante a tous les coups

Et surement d'autres petits bug mais c'est correct pour une première rom :)

Oui le but de l'Alpha c'était surtout de voir si elle bootait chez tout le monde :) 
Pour l'application Themes, je ense que c'est lié au WiFi 
Pour la caméra et la radio FM je corrigerai ça d'ici la Bêta ce sont des problèmes récurrents ;) 
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...