Jump to content
napster_666

Problème avec capteur de proximité lors des appels

Recommended Posts

Bonjour,

Il y a environ deux moi j'ai changé l'écran de mon Nexus 5. Le changement c'est bien déroulé et tous était parfaitement fonctionnel.

Depuis peu, le capteur de proximité de mon nexus ne fonctionne plus et détecte continuellement l'état "proche". 

Au début le capteur marchait par intermittence mais depuis 2-3 jours il ne fonctionne plus du tout.

 

Cela est très dérangeant, surtout lors des appels car des que mon appel démarre, l'écran devient noir (le capteur détecte comme si le téléphone était collé à ma joue) et il m'est impossible de le rallumer même avec le bouton Power.

 

Je ne sais pas trop d'ou le problème peux venir. Est il possible que le capteur ai rendu l'âme ?

Je ne possède pas de protection d'écran donc le soucis n'est pas lié à ça.

 

Le problème peut il être software ? Je tourne sur la dernière Beta 2 de PA 4.5.

 

Sinon existe il une application permettant de "calibrer" ce capteur ou de le désactiver lors des appels ?

 

 

Merci d'avance

 

Nap ;) 

Share this post


Link to post
Share on other sites

Salut, @

J'avais eu un problème similaire sur un galaxy s2 à l'époque et on m'avait diagnostiqué une panne du capteur de proximité et j'avais également changé l'écran.

En fait sur le capteur de proximité il y'a comme une lentille très sensible à la moindre once de poussière et lorsque par exemple yen a une dessus (je pense a ça dans ton cas) il passe automatiquement en mode veille comme ci tu l'avais mis à la joue. Donc en fait quand tu as changé l'écran une poussière ou autre chose est venu entraver le fonctionnement de ce capteur.

Après ce que tu peux faire c'est le désactiver dans les paramètres mais un petit tour en SAV? Ne te ferait pas de mal.

Edited by Rex99

Share this post


Link to post
Share on other sites

Salut. Il me semble qu'il est possible de ne pas désactiver l'écran lors d'un appel. Reste à retrouver la fonction.

Share this post


Link to post
Share on other sites

J'ai pu le désactiver à l'aide de Xposed Framework.

Pour le SAV je ne pense pas que sa soit possible vu que j'ai changé l'écran moi-même...

 

Ce qui est bizarre c'est que le capteur marchait nickel après le changement d'écran, une pousière peut s'y glisser une fois remonté ?

Share this post


Link to post
Share on other sites

Je pense également qu'une poussière a pu rentrer a l'intérieur et entrave le fonctionnement de ce capteur

Share this post


Link to post
Share on other sites

Question de 2014, et j'ai une réponse en 2016 ?

 

Lorsqu'on change l'écran, on a systématiquement le problème, et ça se résout avec un petit morceau de papier ?

 

Sur le cache en plastique noir qui vient par dessus la carte mère, il y a un petit téton rectangulaire qui appui sur le capteur de proximité pour le coller à l'écran.

Et bien, sur les écrans de rechange, le logement des capteurs est différent, et le téton n'appuie pas correctement, donc, il suffit de plier un petit bout de papier pour faire une cale d'épaisseur, et le placer entre le téton et le capteur, et ... le problème est réglé ?

 

Photo de l'ergot :  

Nexus 4.jpg

Edited by jim

Share this post


Link to post
Share on other sites


je ne comprends pas ton image j'ai pas du tout pareildbf0acb5649bac73a4800cd44838e960.jpg


b839793cc35f4251a920d3d11fa1ae23.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...