Jump to content
titusIII

Camera is unable to initialize

Recommended Posts

Bonjour,

Cet aprem j'ai voulu prendre un photo avec la caméra 8Mpx de mon Razr i (la grosse, pas la frontale) et mon téléphone m'a répondu : "Camera is unable to initialize."

La caméra frontale fonctionne très bien par contre.

 

J'ai supprimé le cache et les data de l'appli "Camera" et ça a marché une fois.

Quelques heures après, j'ai eu le même problème, la suppression des données n'a rien changé. J'ai rebooté, pas de changement non plus.

 

Mon téléphone étant très modifié, je l'ai démarré en mode sans echec pour ne pas lancer toutes mes appli Root. Visiblement ça fonctionne, la caméra se lance bien pour l'instant. 

 

J'ai pas mal de module du côté de Xposed. Le seul qui est susceptible de toucher à la caméra est celui de snapchat. Je l'ai désactivé et elle ne fonctionnait toujours pas.

 

Je pense que je vais pas m'embêter à désinstaller mes applications une par une. Je vais flasher une ROM clean et tester au long terme.

 

J'ai lu sur un forum que quelqu'un avait eu le même problème, il avait ouvert son portable et retendu les ressorts qui servent de connecteurs entre les modules fixés sur la carcasse et la carte mère.

 

Avant de flasher une nouvelle ROM et de le démonter, est ce que quelqu'un pourrait me conseiller quelques tests?

Nous pourrions peut être cibler le problème avant d'employer "la manière forte".

 

D'avance, merci

 

Titus.


Je rectifie, en mode sans echec ça ne fonctionne pas non plus.

 

Problème Hard alors je pense...

Edited by titusIII

Share this post


Link to post
Share on other sites

Ok, j'ai une théorie.

 

J'ai voulu installer une appli pour récupérer les log de la caméra, histoire de voir si je pouvais avoir plus de détail. Le play store m'a dit que j'avais pas assez d'espace dispo sur mon téléphone pour installer une appli de quelques Mo.

J'ai donc fait un peu de ménage malgré les 2 Go qu'il me restait sur la mémoire interne du téléphone... La grosse caméra s'est remise à fonctionner.

 

D'après ce que j'ai vu, la mémoire interne du téléphone est comme partitionnée en deux parties (system et data) La partie system contiendrait tout ce qui est application et ce dont je vais parler après et la partie data serai libre pour l'utilisateur (photos/ musiques/ ...).

Le morceau de code qui calcule la place restante doit regarder toute la mémoire sans faire de détail je suppose.

 

Lors de sa mise en marche, la caméra se réserve un buffer sur la carte, pour enregistrer temporairement la photo qu'elle est sur le point de prendre. Le buffer serait donc une sorte de fichier raw (brut) qui contiendrait exactement ce que renvoie la caméra. Avec mes 8Mpx la taille de ce fichier serai assez gros (11.9 Mo, j'ai fait le calcul). Par contre pour la caméra frontale et ses 0.3Mpx le fichier serai bien moins gros (460Ko). 

 

Il restait donc sans doute assez de place pour stocker le buffer de la caméra frontale mais pas assez pour la caméra principale.

L'application "Camera" se met simplement en défaut, informant l'utilisateur du mauvais fonctionnement de la caméra.

 

J'ai quand même voulu aller plus loin en essayant de récupérer les log mais j'ai pas trouvé comment faire.

 

 

Quelqu'un pourrait-il confirmer mes théories et me dire comment je pourrais faire pour récupérer les log d'une application en particulier?

 

Titus.

Edited by titusIII

Share this post


Link to post
Share on other sites
J'ai trouvé une application qui m'indique la place restante dans toutes les partitions, le problème ne semble pas être là.

 

"Camera is unable to initialize." est revenu, j'ai réussi à récupérer les log cette fois ci : 

 

Process App. photo(com.motorola.camera)

W/13:06:20.815 :0: gralloc_unregister_buffer: ID: 11016 handle: 0x617503c0 size: 540 x 903 fmt: 5 usage: 0xb00

W/13:06:20.815 :0: gralloc_unregister_buffer: ID: 11014 handle: 0x6174ce30 size: 540 x 903 fmt: 5 usage: 0xb00

W/13:06:20.815 :0: gralloc_unregister_buffer: ID: 11013 handle: 0x61575220 size: 540 x 903 fmt: 5 usage: 0xb00

W/13:06:20.445 :0: gralloc_unregister_buffer: ID: 11019 handle: 0x61753f30 size: 513 x 251 fmt: 1 usage: 0x933

E/13:06:20.425 loading failed!

E/13:06:20.425 Preference group is null!

D/13:06:20.415 caller of unregisterListener:15357,sensor type: ALL

W/13:06:20.405 :0: gralloc_register_buffer: ID: 11019 handle: 0x61753f30 size: 513 x 251 fmt: 1 usage: 0x933

W/13:06:20.405 :0: gralloc_unregister_buffer: ID: 11018 handle: 0x6174f9c0 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:20.405 :0: gralloc_unregister_buffer: ID: 11017 handle: 0x61757e60 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:20.405 :0: gralloc_unregister_buffer: ID: 11015 handle: 0x6174e180 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:20.265 :0: gralloc_register_buffer: ID: 11018 handle: 0x6174f9c0 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:19.275 :0: gralloc_register_buffer: ID: 11017 handle: 0x61757e60 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:19.265 :0: gralloc_register_buffer: ID: 11016 handle: 0x617503c0 size: 540 x 903 fmt: 5 usage: 0xb00

W/13:06:19.225 :0: gralloc_register_buffer: ID: 11015 handle: 0x6174e180 size: 513 x 251 fmt: 5 usage: 0xb00

W/13:06:19.195 :0: gralloc_register_buffer: ID: 11014 handle: 0x6174ce30 size: 540 x 903 fmt: 5 usage: 0xb00

W/13:06:19.135 :0: gralloc_register_buffer: ID: 11013 handle: 0x61575220 size: 540 x 903 fmt: 5 usage: 0xb00

D/13:06:19.075 caller of registerListener:15357,sensor type:1

=========================================================================================

 

Et j'ai également celui là :

 


E/13:18:22.935 Camera_ControlThread(15037)

Error initializing ISP with id 0

E/13:18:22.935 Camera_ISP(15037)

Failed to open first device!

E/13:18:22.935 Camera_ISP(15037)

V4L2: capture_open failed: Invalid argument

W/13:18:22.935 Camera_ISP(15037)

Open device 0 with fd -1

E/13:18:22.935 Camera_ISP(15037)

Error opening video device /dev/video0: Invalid argument

D/13:18:22.935 Camera_ISP(15037)

Kernel with multiplexed preview and main devices detected

D/13:18:22.935 Camera_HAL(15037)

ATOM_OpenCameraHardware

I/13:18:22.935 CameraService(15037)

Opening camera 0

D/13:18:22.935 Camera_HAL(15037)

ATOM_GetCameraInfo

I/13:18:22.845 ActivityManager(  452)

START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x14000000 cmp=com.motorola.camera/.Camera u=0} from pid 15357

=========================================================================================

 

 


On voit bien qu'il y a un problème... 

Quelqu'un peut m'aider? Je commence à être un peu largué là...

Edited by titusIII

Share this post


Link to post
Share on other sites

Visiblement le fait de rebooter en supprimant le cache et les data de l'apk 'Camera' la rend utilisable pendant environ 1h.

 

J'ai mis en cause un plugin de snapchat avec Xposed mais même en le désinstallant cela ne change rien.

Xposed installe quelque chose dans '/system'. Peut être que la désinstallation du plugin ne le supprime pas?

 

J'ai comparé mes logs avec un autre téléphone dont la caméra fonctionne, il n'y a visiblement aucun log qui sort de l'apk Camera.

Il faut pas être se pencher sur le warning "gralloc" qui est aussi présent quand ma caméra fonctionne.

Share this post


Link to post
Share on other sites

Quels sont les apps' installées sur ton téléphone qui utilisent la caméra ?

Share this post


Link to post
Share on other sites

Le problème est revenu...

Il reste peut etre un bout de soft entre la ROM et la caméra?

Un genre de bios ou quelque chose que je pourrais flasher?

J'ai peur que ce soit un problème matériel...

Share this post


Link to post
Share on other sites

Un nouveau log lors du crash de l'appli :

----------------------------------------------

Process Camera(com.motorola.camera)

E/08:34:03.307 loading failed!

E/08:34:03.307 Preference group is null!

D/08:34:03.297 caller of unregisterListener:27155,sensor type:ALL,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56b3fc58

I/08:34:02.007 Total arena pages for JIT: 18

I/08:34:02.007 Total arena pages for JIT: 17

I/08:34:02.007 Total arena pages for JIT: 16

I/08:34:02.007 Total arena pages for JIT: 15

I/08:34:02.007 Total arena pages for JIT: 14

I/08:34:02.007 Total arena pages for JIT: 13

I/08:34:01.997 Total arena pages for JIT: 12

I/08:34:01.997 Total arena pages for JIT: 11

W/08:34:01.857 Camera service died!

W/08:34:01.857 media server died

E/08:34:01.857 Unable to load sample: (null)

E/08:34:01.847 Unable to load sample: (null)

W/08:34:01.847 An error occurred while connecting to camera: 0

D/08:34:01.727 caller of registerListener:27155,sensor type:1,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56b3fc58

E/08:33:44.847 loading failed!

E/08:33:44.847 Preference group is null!

D/08:33:44.847 caller of unregisterListener:27155,sensor type:ALL,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56c4c9d0

D/08:33:43.527 caller of registerListener:27155,sensor type:1,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56c4c9d0

D/08:33:43.447 GC_CONCURRENT freed 1064K, 9% free 14555K/15984K, paused 5ms+4ms, total 43ms

W/08:33:43.417 An error occurred while connecting to camera: 0

E/08:33:29.707 loading failed!

E/08:33:29.707 Preference group is null!

D/08:33:29.707 caller of unregisterListener:27155,sensor type:ALL,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56c12ac0

D/08:33:28.487 caller of registerListener:27155,sensor type:1,listener:android.view.OrientationEventListener$SensorEventListenerImpl@56c12ac0

W/08:33:28.467 An error occurred while connecting to camera: 0

----------------------------------------------

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...