Aller au contenu
6riloo

Bump!, loki, bootloader, bootsatck, kernel... Quelques bonnes bases sur le G2

Recommended Posts

Merci.

Si je comprend bien, l'imei est définitivement rattaché à un opérateur ?

 

Si je veux mettre mon g2 à l'abris des bricks, il faudrait mieux installer un custom recovery

J'ai lu aussi qu'il fallait sauver son efs.

Si je root, j'installe un custom recovery, je sauve l'efs et je flash la rom 20h, je me retrouve avec quoi ? Je n'ai plus de root? de recovery ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci.

Si je comprend bien, l'imei est définitivement rattaché à un opérateur ?

 

Si je veux mettre mon g2 à l'abris des bricks, il faudrait mieux installer un custom recovery

J'ai lu aussi qu'il fallait sauver son efs.

Si je root, j'installe un custom recovery, je sauve l'efs et je flash la rom 20h, je me retrouve avec quoi ? Je n'ai plus de root? de recovery ?

L'imei est rattaché à un appareil

http://fr.wikipedia.org/wiki/International_Mobile_Equipment_Identity

 

Si tu veux le mettre à l'abri des bricks tu peux lui laisser sa rom d'origine, ou tu lui flashes un kdz où tu y désactives les mises à jours.

Si tu n'as pas l'utilité du root et d'un custom recovery, pourquoi en installer ?

Si tu flashes une rom en zip, selon la rom, tu peux garder ton recovery et la rom sera prerootée, donc tu auras une stock rootée + custom recovery (se rapprocher des fils traitant de ces sujets pour les détails).

Si tu flashes un kdz, tu feras sauter root et recovery.

Modifié par 6riloo

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai upgradé en 20h avec le kdz. Tout s'est bien passé, mais je ne peux plus faire de factory reset, pas moyen d'entrer dans le menu.

J'ai installé le lg mobile support tool. Il me détecte bien la 20h, mais il me propose une autre maj (lolipop ?)

Je dois aussi upgrader le recovery avec la 20h ?

Edit:

J'ai commencé une "Mise à niveau de la récupération après erreur" avec mobile support tool, et il me charge une 80230e.

C'est normal ?

Je vais me retrouver avec un 30e?

Modifié par Qwench

Partager ce message


Lien à poster
Partager sur d’autres sites

Ben voilà...

J'ai flashé la 30e (lollipop) avec mobile support tool et j'ai plus de réseau. Je pense que je suis en cdma avec une rom non europe.

Il faudrait que je downgrade en 20h europe, mais est-ce possible ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu lisais un peu et faisais quelques recherches avant de poursuivre ? Ca serait un gain de temps pour tout le monde ; -)

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir

Merci pour ce tuto très détaillé. Cela pemet de mieux comprendre le loki et le bump. Une petite question. Comment savoir si mon recovery est bump. Je suis actuellement sous lollipop v30a avec twrp 2.8.6.1 soit la dernière version a ma connaissance. Je précise que j'ai utilisé autorec pour dowgrader le bootloader sur kk.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir

Merci pour ce tuto très détaillé. Cela pemet de mieux comprendre le loki et le bump. Une petite question. Comment savoir si mon recovery est bump. Je suis actuellement sous lollipop v30a avec twrp 2.8.6.1 soit la dernière version a ma connaissance. Je précise que j'ai utilisé autorec pour dowgrader le bootloader sur kk.

Bonsoir,

Autorec lp => recovery et kernel bumpé

Bl kk sur fw LP=> recovery et kernel bumpé

Modifié par 6riloo

Partager ce message


Lien à poster
Partager sur d’autres sites

Heu . . . je crois bien que Autorec downgrade le bootloader vers Jelly Bean et non KK.

Partager ce message


Lien à poster
Partager sur d’autres sites

Heu . . . je crois bien que Autorec downgrade le bootloader vers Jelly Bean et non KK.

Tu as un peu de lecture en retard ; -)

Depuis lp stock, autorec downgrade le bl en kk et flash un recovery et kernel bumpè.

https://play.google.com/store/apps/details?id=b007.autorec2

Modifié par 6riloo
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Oh put... j'avais pas vu le new autorec + dipo sous play !

Merci !^^

Partager ce message


Lien à poster
Partager sur d’autres sites

Avec un peu de retard, merci pour cette information, mais Google Play me dit que cette application n'est pas compatible avec aucun de mes appareils.

 

Mon LG G2 tourne avec ta ROM D80220H_20HBL_prerooted_recovery_friendly_by_6riloo.zip (mais j'avais installé autorec "ancienne manière" avant TWRP 2.8.6.1 et flashage de la rom).

Partager ce message


Lien à poster
Partager sur d’autres sites

@@ribou

Autorec sur le playstore est la version 2 pour lp, or tu es sur kitkat.

Modifié par 6riloo

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai vu que l'app TWRP propose l'instalation de son recovery sur le d802. Je ne l'ai pas fais, mais depuis un g2 root, mais toujours avec son recovery d'origine, ça fonctionne ? je ne pense pas que ça fasse comme autorec...

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai déjà installé des tas de ROMs sur pas mal de téléphones, y compris sur le LG G2.

 

C'est le premier appareil où il y a autant de confusions entre les boatloaders (il est quasiment impossible de savoir sur lequel on est. je ne suis pas certain que les manips pour entrer sur le recovery soient fiables à 100% : power + vol bas, puis vol bas + vol haut pour KK).

 

Il y a donc également plusieurs versions d'autorec : une en JB, une autre en KK, une troisième en LP ?? Ou bien 2 seulement ??  Et elles portent le même nom !!!!! Comment s'y retrouver ??

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut à tous,

J'ai quitté mon G2 depuis un petit moment et je suis super occupé, vous comprendrez que dans ces conditions c'est impossible de faire un support digne de ce nom.

Ceci dit, @@ribou, il y a deux versions d'autorec, la première qui exploite la faille loki et la deuxième qui exploite bump, donc deux bootloader, cf le topo. La sécurité du BL LP n'est pas contournable à l'heure actuelle. autorec 2 (bump) est sur le playstore et est dédié à LP. autorec 1 est téléchargeable ailleurs sur le web et est pour kk. Les 2 utilisent le processus de downgrade du BL (un en kk pour les rom en L¨P  et l'autre en JB pour les rom en KK) pour exploiter les failles qui s'y rapportent (voir topo). Si tu as des doutes sur ton bootloader, le mieux est de partir sur du propre, et de suivre ensuite ce que tu fais. Sinon de flasher celui qui t'intéresse.

Modifié par 6riloo

Partager ce message


Lien à poster
Partager sur d’autres sites

Effectivement, je suis actuellement en KK avec ta ROM, donc en principe avec un bootloader KK. Quand je passerais sur LP, par précaution, je flasherai soit le bootloader KK sur le site de Dorimanx, soit un BL lollipop avant de flasher une rom lollipop.

 

J'attends encore un peu, car les roms LP ont encore quelques bugs, xposed est en version beta.

 

Bref, rien ne presse :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoignez la conversation

Vous pouvez poster maintenant et vous enregistrez plus tard. Si vous avez un compte, connectez-vous maintenant pour poster.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.






×
×
  • Créer...