bill73

Problème pour utiliser la valeur d'un EditText

Recommended Posts

Bonjour à tous,

 

Je suis nouveau ici et j'espère avoir une réponse rapide... Je développe ma première application Android donc j'ai forcément eu de nombreux soucis. L'aide des différents forums a été précieuse, cependant je bloque sur un "petit" problème qui m'empêche d'avancer.

J'ai créé un EditText de type "number" pour que l'utilisateur puisse entrer un nombre qui me servira ensuite. Cependant, il semble que, peu importe le nombre entré, la valeur de l'EditText ne change pas. En effet, j'aurai ensuite 2 cas: le cas où l'utilisateur a rentré "1" et l'autre cas. Comme j'ai initialisé mon EditText avec la valeur 1, il suit toujours cette condition.
Je vous mets la partie intéressante de mon script (désolé si la manière de rédiger n'est pas parfaite...), dites-moi si vous avez besoin du sript complet ou d'autres infos.

 

public class numberoftrips extends AppCompatActivity  {
    private EditText nbtrip;

 

    @Override
    protected void onCreate (Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.activity_numberoftrips);

 

        //l'objectif est ici de récupérer le nombre entré par l'utilisateur (j'ai essayé plein d'autres manières, aucune ne fonctionne...)

        nbtrip=(EditText)findViewById(R.id.nbtrip1);
        int n=Integer.parseInt(nbtrip.getText().toString());

        //Le bouton Next ne mène pas à la même activity suivant si l'utilisateur a rentré 1 ou un autre chiffre
        if (n==1){
            btnNext2.setOnClickListener(new View.OnClickListener(){
                public void onClick (View view) {
                    Intent myIntent =new Intent(getBaseContext(), trip.class);
                    startActivityForResult(myIntent,0);
                }
            });
        }

        else {
            btnNext2.setOnClickListener(new View.OnClickListener(){
                public void onClick (View view) {
                    Intent myIntent =new Intent(getBaseContext(), ID_informations.class);
                    startActivityForResult(myIntent,0);
                }
            });
        }

    }
}

 

 

 

EDIT: J'ai découvert qu'il ne fallait pas que je mette le if dans le onCreate. Ceci dit, quand je le sors l'application ne veut même plus se lancer, elle ne "reconnaît" pas le if  je pense. Quelqu'un a une solution?

 

Edited by bill73

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






  • Similar Content

    • By HoMiCiDe
      Bonjour, je suis nouveau sur ce forum...merci de m’accueillir. Donc j'ai un problème pour flasher une tablette logicom L-EMENT tab 1043BT (ZM1027TN-MB-V1.1.2015.06.13) ... Après beaucoup de recherches sur le web j'ai trouvé un dump complet apparemment, mais comme je n'y connais pas grand chose ....😑 J'ai donc essayé de la flasher avec RK android tool V 2.33 tout se passe bien jusqu'au check system qui s’arrête à 6% suivi d'un message d'erreur "download image fail". Étant novice je ne sais pas trop d’où vient le soucis ...pilotes ? mauvais dump ? fichiers manquants ? Si un pro passe par là et pouvais m'aider ou si quelqu'un a déjà eu ce problème auparavant je suis intéressé par vos propositions . Merci et bonne journée 😀
    • By kenjhy78
      Bonjour la communauté,
      je vous expose mon problème, depuis 2 jours mon Asus ne fait que redémarré en boucle 😭, à l'affichage de la batterie . je ne saurai vous dire de quoi cela provient mais j'ai le seul souvenir que je me rendais au travail en écoutant de la musique.
      Il venait d'être reseté d'usine depuis 3 semaine et mais apk du store et différents comptes réinstallés.
      Savez-vous s'il est possible de flasher le boot avec une image d'origine ? si oui vous fort aimable de m'orienter vers la solution, démarche comprise.
      je reste à votre entière disposition pour d'éventuelles questions ou détails omis de ma part.
       
      avec mes remerciements d'avance.
    • By Kingu Prima
      Bonjour, 
       
      Depuis la mise à jour vers MIUI 11, les badges de notifications n'apparaissent plus sur les applications tierces comme Twitter, Whatsapp, Gmail, Telegram...
      Les notifications sont bien activées pour ttes les applications du smarphones.
      Ce problème semble toucher les Mi 9 Lite et d'autres produits Mi 9:

      https://forum.xda-developers.com/Mi-9/help/notification-badges-gone-miui11-t4002701
      https://xiaomi.eu/community/threads/miui-11-notification-icon-bug.52496/
      http://c.mi.com/thread-2598569-1-0.html?sources=1
       


      Est-ce que vous auriez une solution ou faut-il attendre une nouvelle màj par Xiaomi, et si oui comment les contacter pour les prevenir de ce bug ?

      Merci

    • By Daniel8821
      Bonjour a tous,
       
      Suite a une mauvaise manip de ma part sur mon telephone Nokia 3.2 TA-1156.
      Je voulais le root ..et suite a la manip fait ,sur mon telephone j'ia plus rien c'est a dire que plus d'appareil photo, plus aucun moyen de faire un partage de connexion,etc.
      J'ai essaye de faire via le telephone mettre a jour , ça me donne que j'ai deja la derniere MAJ a jour.
      Esssaye de suivre ,les tutos trouver sur le internet ,j'arrive a rien..

      Pouvez-maidez ? me donnez une procedure a suivre ?
    • By dam3340
      Bonjour à tous ! Bon j'espère que vous allez être d'une précieuse aide.. Donc voilà, plus de 2 ans que j'ai mon MI5, j'avais changé une première fois mon écran moi même, quand j'ai posé l'écran, la vitre s'est fissuré (dû à un accroc) mais tout été OK. Donc j'ai recommandé, j'ai voulu le rechanger en déformant l'accroc afin de bien le poser et cette fois... 💩 ! la vitre va bien, mais c'est le logiciel. Il ne s'allume plu du tout ! Et quand je le branche au secteur il réagi normalement et affiche très bien la batterie verte. Impossible d'aller dans le recovery etc... La nappe des touches sur le côté défectueuse ? Combinaison de touche pour debloquer ? Aucune idée..
      Je serais ravis que des personnes tentent de me donner un coup de pouce, merci d'avance.. 
       
      (pour infos je ne sais pas s'il existe des réparateur qui peut entrer dans le logiciel en France..)