matorel

Leagoo Z6 : publicités bloquantes et tentative de Flash de la Rom

Recommended Posts

Posted (edited)

Bonjour à tous,

J'ai acheté un Leagoo Z6 en Juillet 2018 pour ma mère sur Amazon. 4 à 5 mois plus tard, des pubs à foison empêchent l'utilisation nominale du téléphone.

2 applications sont en cause : Android Notes et DABrower qui se réinstallent régulièrement. Une réinitialisation d'usine remet ses applications, elles sont dans le code d'usine donc...

Je souhaiterai donc pouvoir flasher une autre ROM, un Android standard sans surcouche mais ça fait bien longtemps que je n'ai plus fait une telle opération. J'ai donc téléchargé SP Flash Tool et v5.1824 et une ROM, LEAGOO_Z6_OS2.0_Lite_E_20171225, et suivi la méthode pas à pas tel que c'est décrit sur cette vidéo (https ://www.youtube.com/watch?v=H8JIBDhuZFM)

 

 

Malheureusement, le process n'aboutit pas, j'ai une erreur [EMI] Enable DRAM Failed, code erreur 4032

J'ai bien mis à jour les drivers USB et j'ai cherché sur le net sans trouver une aide concrète. Merci de m'avoir lu et de l'aide que vous pourriez m'apporter.

Edited by matorel

Share this post


Link to post
Share on other sites

C'est un problème connu des Leagoo. Ils arrivent avec de l'adware dans le firmware d'origine.

Je n'ai pas la solution à ton problème avec SP Flash Tool. Es-tu sûr d'utiliser une version assez récente ? le bon Download Agent à la ligne correspondante ? de le lancer en tant qu'administrateur sur le PC ?

D'après ce que je lis cela peut venir aussi d'un preloader incorrect. Essaye de décocher la case preloader pour le flash.

Attention quand même avec ces firmwares non-officiels... moi je m'assurerais d'abord de pouvoir reflasher le firmware d'origine.


Je peux en revanche expliquer comment je suis venu à bout des pubs sur mon Leagoo M5 :

- j'ai désactivé ou désinstallé toutes les applis Leagoo : ça avait déjà bien arrangé les choses

- j'ai fait un reset usine puis j'ai installé https://play.google.com/store/apps/details?id=com.drweb qui, comme tous les anti-virus Android, peut servir à détecter des choses (celui-là est bien meilleur que les autres dans l'adware à mon avis) mais ne protège de rien

- après avoir coupé data+wifi, full scan pour que Dr Web me repère tous les APK suspicieux, et bien entendu il y en avait dans les applis système ou préinstallées

- je l'ai rooté puis j'ai carrément viré ces applis détectées (en en gardant une copie bien sûr). Si je me souviens bien il n'y en avait pas comme sur certains autres smartphones chinois, qui étaient carrément des applis qui sont au coeur d'Android comme Settings.apk qu'on ne peut pas supprimer bien sûr 

Depuis, plus une pub.

Sur un autre smartphone du même tonneau (Blackview A7 pro) je n'ai pas réussi à tout nettoyer, cela touchait des APK système, j'ai installé un pare-feu root (https://play.google.com/store/apps/details?id=dev.ukanth.ufirewall) et j'ai bloqué l'accès à internet des APK concernés. Ca les empêche d'aller télécharger leur adware... 

Share this post


Link to post
Share on other sites

Super tes conseils, vraiment merci. Je vais tester ça mais, sans abuser, pourrais tu me dire comment le rooter ? La recherche sur internet est rendue complexe parce qu'on tombe sur une tonne de logiciels plus ou moins bidons.

Share this post


Link to post
Share on other sites
Posted (edited)

Moi je roote tous ces smartphones Mediatek de la même façon :

Etape 1 - je cherche un firmware d'origine flashable par SP Flash Tool - étape indispensable comme filet de sécurité et pour avoir le fichier scatter.txt (table des partitions). Si pas de source fiable, stop. Je m'arrête là.

Etape 1bis - je déverrouille le bootloader (OEM unlock dans les paramètres puis fastboot oem unlock en mode bootloader)

Etape 2 - avec le fichier scatter et SP Flash Tool, je fais un dump de mon firmware actuel - 2eme sécurité et pour avoir une image de boot à modifier (https://www.leakite.com/backup-mediatek-firmware/ - je n'utilise pas MtkDroidTools, pas besoin si on a un scatter d'origine)

Etape 3  - je modifie l'image de boot - moi je fais ça "à la mano" sur un PC Linux avec les outils de PHH (https://github.com/phhusson/super-bootimg/tree/master) qui ont d'ailleurs servi de base au développement de Magisk. On peut aussi le faire sur le smarphone lui-même avec Magisk et en mettant le dump de la partition de boot sur la SD (https://www.thecustomdroid.com/install-magisk-root-android-devices/ - Method 2)

Etape 4 - je reflashe la partition de boot (et parfois aussi une partition system modifiée, débarrassée des bloatwares système) avec SP Flash Tool ou en fastboot

Alors, c'est pas "plug and play" ni "en un clic", je l'admets. Un jour peut-être je ferai un tuto réunissant tout ça...

Edited by Ultrix
Oublié une étape et la flemme de renuméroter donc étape 1bis :-)

Share this post


Link to post
Share on other sites

Bon, je n'y arrive pas :
- J'ai bien débloqué les options développeurs, j'ai bien activé OEM Unlock.
- j'arrive au menu du boot (vol haut + power)

Le menu se résume à recovery, fasboot et normal boot

Recovery est un boot long... qui ne change rien

Fasboot n'aboutit à rien.

Normal boot...beh, ça boote.

 

sur XDA, il y a des liens qui sont morts, j'ai testé plein d'outils mais sans root, j'arrive à rien... vraiment désolant. 

65euros filé à une société qui vend un téléphone inexploitable, pas de recours... pénible.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

"Fastboot n'about à rien" : c'est à dire ? en mode fastboot l'écran du téléphone reste noir, avec ou sans un petit message "Fastboot mode" (ou "Bootloader mode") dans un coin de l'écran. C'est parfaitement normal.

Ce mode est destiné à être utilisé depuis un PC connecté en USB avec la commande "fastboot". Et c'est ce qu'il faut utiliser pour débloquer le bootloader.

Edited by Ultrix

Share this post


Link to post
Share on other sites
Posted (edited)

Ha oui, désolé, j'étais fatigué par une nuit très courte.. mes investigations continuent : pour l'instant, je ne vois pas le tél sous fastboot.
J'ai pourtant les drivers installés, ainsi que les drivers du téléphone.

adb devices ne retourne rien.

Je commence à croire que ce tél est méchamment verrouillé...

Edited by matorel

Share this post


Link to post
Share on other sites
36 minutes ago, matorel said:

adb devices ne retourne rien.

C'est normal parce que la commande appropriée est fastboot devices

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






  • Similar Content

    • By Enzo Migliani
      Bonjour à tous 
      J'ai récemment acheté une box H96 Max pour ma TV qui fonctionne bien. Seul soucis quand je veux regarder Nimvon par exemple, impossible de mettre l'image en plein écran. J'ai essayé sous chrome, Firefox et opéra c'est pareil... 
      Quelqu'un a t'il une idée svp ? Merci à tous 😀 ! 
    • By HoMiCiDe
      Bonjour, je suis nouveau sur ce forum...merci de m’accueillir. Donc j'ai un problème pour flasher une tablette logicom L-EMENT tab 1043BT (ZM1027TN-MB-V1.1.2015.06.13) ... Après beaucoup de recherches sur le web j'ai trouvé un dump complet apparemment, mais comme je n'y connais pas grand chose ....😑 J'ai donc essayé de la flasher avec RK android tool V 2.33 tout se passe bien jusqu'au check system qui s’arrête à 6% suivi d'un message d'erreur "download image fail". Étant novice je ne sais pas trop d’où vient le soucis ...pilotes ? mauvais dump ? fichiers manquants ? Si un pro passe par là et pouvais m'aider ou si quelqu'un a déjà eu ce problème auparavant je suis intéressé par vos propositions . Merci et bonne journée 😀
    • By petitefeuille
      Bonjour,

      le titre est explicite "la touche de l' Applications récentes de ma Tablette tactile ASUS ZENPAD 3S 10  ne fonctionne plus" 
      J'ai recherché sur google  mais rien de probant !

      Note importante : lorsque j'allume l'écran, les deux touches s'allument !

      Merci d'avance si certains ont des solutions à proposer !
       

    • By bb67
      Bonjour,
      Je viens d'acquérir un P30 Pro, pour lequel, j'ai également acheté une protection d'écran en verre trempé.
      J'ai l'impression que sur l'écran du P30 Pro, il y a déjà une protection d'écran d'origine ?
      Quelqu'un peut-il confirmer ?
      Il y a une "surface" qui ne couvre pas la partie courbe de l'écran, mais, je n'ai pas osé l'enlever avant de poser la protection d'écran ?
      On voit bien qu'il y a une couche en dessous de l'écran de protection !!!
      Est-il conseillé de l'enlever avant d'installer la protection d'écran ?
      Merci pour vos réponses