Jump to content
CrYpTeKk_

Root Lenovo Tab M10 FHD PLUS TB-X606F?

Recommended Posts

Bonjour tous le monde voilà je viens de m'acheter cette tablette : Lenovo Tab M10 FHD PLUS TB-X606F en version 9.

J'ai parcouru beaucoup de forum à la recherche d'une méthode compatible au modèle mais je n'ai rien trouver pour le moment.

Si quelqu'un aurait une solution miracle j'accepte☺️ Je prend supersu ou majisk, les autres méthode comme towelroot, kingroot ect je ne fait pas confiance.

je [color=red][b]tien[/b][/color]a préciser que je n'ai rien flasher ou quoi que se soit vu que je peut pas Root.

Je vous remercie d'avance🖐️

15810559781092848292006725363766.jpg

Edited by CrYpTeKk_

Share this post


Link to post
Share on other sites

Bonjour,

Je vois deux approches possibles :

- trouver un TWRP pour cette tablette et flasher Magisk avec. Ca risque d'être dur sur un modèle récent et pas très répandu

- trouver un firmware à télécharger qui soit exactement la même version que celle que tu as dessus (sur le site Lenovo de préférence, ou ailleurs), au besoin en la mettant à jour, et utiliser l'appli Magisk Manager (qui s'installe sous Android) pour patcher l'image de boot extraite du firmware et déposée sur le stockage de la tablette, puis la reflasher.

Dans un cas comme dans l'autre le préalable indispensable est de déverrouiller le bootloader. Je n'ai pas encore cherché si c'était faisable sur ce modèle.

 

Share this post


Link to post
Share on other sites

Bonsoir. Oui j'ai vu cette méthode mais le seule firmware téléchargeable il faut un compte premium, je ne connais pas d'autre site, si vous en avez a proposée [color=red][b]sa[/b][/color] m'arrangerait un peu☺️

Et pour le twrp j'ai chercher mais il propose que pour le modèle tb-x605f je pense que je vais devoir attendre un moment avant qu'il en fasse un pour le modèle tb-x606f

Si vous trouvez quelque choses de votre côté je suis à l'écoute👌

Edited by CrYpTeKk_

Share this post


Link to post
Share on other sites

bonjour

lien gratuit pour les firmwares :

https://mirrors.lolinet.com/firmware/lenovo/TB-X606F/

 

exemple du TB-X606F_USR_S100032_1912122002_V5.180_BMP_ROW :

 

lznovo TB X606F.PNG

 

et pour magisk prendre exemple ici :

https://forum.xda-developers.com/general/help/lenovo-tb-x605f-magisk-root-t3992477

Edited by yakapa40
  • Like 1

Share this post


Link to post
Share on other sites

A priori c'est bien la même version du firmware qu'il a à bord.

Donc ça doit être jouable. Les instructions du tuto XDA sont claires.

EDIT : j'ai téléchargé le firmware TB-X606F_USR_S100032_1912122002_V5.180_BMP_ROW pour voir, le boot.img y est bien sous forme utilisable, pas encrypté, sparsé ou je ne sais quoi.

Edited by Ultrix

Share this post


Link to post
Share on other sites

Je vous remercie de vos recherche je teste sa demain soir et je vous tien au courant des avancements.

Et oui j'ai vu les tutos donc sa devrait pas être un probleme normalement.

Share this post


Link to post
Share on other sites

Bon premièrement j'ai essayer cette commande "fastboot oem unlock-go" [color=red][b]sa[/b][/color] me met FAILED, ensuite j'ai fait les commandes suivantes "fastboot oem unlock" "fastboot oem devices-info" et FAILED encore une fois.

Deuxièmement j'ai fait le flash pour patcher le boot.img [color=red]sa[/color] fonctionne sans soucis mais quand je fait la commande "fastboot flash boot magisk_patched.img [color=red][b]sa[/b][/color] me mets sa:  Capture.PNG.c3a2bc307fd4b16e13967420dd07241b.PNG

 

Du coup esque c'est lier au bootloader, j'ai chercher un moyen de savoir si il y'en a un mais je n'ai rien trouver...

Au passage j'utilise minimal adb fastboot parcque avec le adb setup si je fait shift+clic droit j'ouvre powershell et je fait la commande adb devices [color=red]sa[/color] fonctionne mais la commande fastboot devices donne rien. Du coup esque sa change quelque chose sachant que j'ai mit les 2 fichiers a flash dans le dossier d'origine de minimal adb fastboot ?

Help!

Edited by CrYpTeKk_

Share this post


Link to post
Share on other sites

Oui, c'est clairement le fait que ton bootloader n'est pas déverrouillé qui t'empêche de flasher le boot patché. Et heureusement, parce que sinon la tablette ne démarrerait sans doute plus.

Avant de faire de fastboot oem unlock-go, est-ce que tu es allé dans les options de développement pour activer le "OEM unlock" (je ne sais pas quel est l'équivalent en français, j'utilise mes appareils en anglais - Déverrouillage OEM ?)

Share this post


Link to post
Share on other sites

D'accord et oui tout est activé et je connais pas la méthode de déverrouillage chez lenovo esque tu en connais ? 

Share this post


Link to post
Share on other sites

Le problème c'est que le tuto XDA s'applique à une TB-X605F et que tu as une TB-X606F

Visiblement, une différence entre les deux c'est justement que la méthode "habituelle" de déverrouillage du bootloader expliqué dans le tuto ne marche pas sur ton modèle.

Pour l'instant, une recherche Google sur le sujet ne ramène pas grand'chose.

Je crains qu'il ne faille s'armer d'un peu de patience.

Share this post


Link to post
Share on other sites

Salut, 

J'ai finalement trouver un moyen de déverrouiller le bootloader et rooter la tablette.

je vient de faire un tuto pour expliquer comment faire pour les personnes qui achèteront se modèle, jetez-y un oeil :

 

 

Bonne journée.

Edited by CrYpTeKk_
  • Like 1

Share this post


Link to post
Share on other sites

Hi all,

 

Sorry I don't speak french I had to translate this page :).

I managed to root my TB-X606F using the magisk method discribed by @ yakapa40 .

Instead of the "fastboot oem-unlock" you have to do "fastboot flashing unlock" on the tabled you will have to confirm with volume up or down.

You really helped me out with posting the lenovo firmware so I hope I will be able to help you by this reply.

 

Oops I missed the post above. sorry

 

Kind regards,

 

Dylan van Elst

 

Edited by Dylan-e

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






  • Similar Content

    • By Xiaomi47
      Bonsoir , j'ai un redmi note 8
       
      lors que je reçois un mms ( aperçu dans le message) mais quand je clique dessus pour voir en grand j'ai une autre photo qui s'affiche (voir PJ)et cela quelque soit  le contact.SI je transfère l image c'est la bonne image et si je télécharge également.Cest l aperçu qui bug.
      Avant cela fonctionner très bien.
       
      Si vous avez la solution je suis preneur merci d'avance 
    • By Kaguma
      Bonjour,
      j'ai actuellement un p8 lite 2017, mais je n'ai plus assez de mémoire interne. J'ai trouvé un tutoriel pour avoir une partie de la mémoire de la carte sd et donc de l'ajouter à la mémoire interne.
      En revanche, j'ai besoin d'accéder aux option de l'opérateur (appuyer plusieurs fois sur le numéro de build) et je suis dans l'impasse car il me faut un code.
      Je serai reconnaissant à ceux ou celles qui m'aident pour ce problème.
      Cordialement.


      (PS: c'est ma première fois donc vous pouvez me dire si je dois mettre ma question autre part)
    • By Liquid E2 Duo-Galaxy sII
      Bonsoir,
       
      Je rencontre un problème avec l'écran de mon Samsung Galaxy S7 (~ 3 ans) depuis quelques temps.
       
      il y a un moment que j'ai ce qu'on voit dans :
      - image 1 : un cercle
      - image 2 : un texte (écrit "300 m")
      les deux persistent sur tous les écrans, visibles surtout sur écran blanc.
       
      puis depuis quelques jours :
      - image 3 : une barre horizontale noire en bas de l'écran, persistante sur tous les écran et pourtant le tactile fonctionne au clic dessus (si j'ai un bouton caché en dessous de la barre, j'arrive quand même à cliquer dessus).
       
      j'ai réinitialisé le téléphone aux valeurs d'usine et les problèmes persistent.
       
      Qu'en pensez-vous ? devrais-je changer l'écran au complet ?
      Je suis preneur de tout conseil.
       
      Merci pour votre aide



    • By Patapin
      Bonjour,
       
      Pourriez-vous m'aider à faire apparaître dans mon explorateur sur PC les directoires de mon téléphone lorsque je le branche par un câble USB ?
      J'y arrive sur Windows 10, mais pas sur mon vieux PC (Windows 7).
       
      Comment pourrais-je procéder ?
       
      Cordialement,
       
      Patapin.
       
    • By AlexisBR
      Bonjour à tous,

      Je viens d'acheter mon Mate 30 Pro sans les services Google et j'ai découvert une super application qui s'appelle Trouvapp ! Elle me permet de trouver toutes les applications dont j'ai besoin, je vous la recommende fortement !
      Vous pouvez la télécharger directement sur l'AppGallery de Huawei 😉
      https://www.mediafire.com/file/hvqnnxnac2vf5ya/TrouvApp3.1.apk/file

×
×
  • Create New...