Recommended Posts

Bonbonbon,

Le ping pour 10.20.19.16 (:64788)

Paquets envoyés 4, reçus 0, perdus 4

Heu... Voilà

Je n'ai aucune idée de ce que cela signifie !

Ah oui, et je t'ai envoyé le log :)

Edited by Prydwen

Share this post


Link to post
Share on other sites
Bonbonbon,

Le ping pour 10.20.19.16 (:64788)

Paquets envoyés 4, reçus 0, perdus 4

Heu... Voilà

Je n'ai aucune idée de ce que cela signifie !

Ah oui, et je t'ai envoyé le log :)

en gros ça veut dire que tu ne pourra pas établir de connexion entre ton pc et ton portable

ça ne marchera jamais

et ce n'est pas la faute de mon programme

essaye quand même une chose : coupe la 3G, et active le wifi

peut etre que ça ira mieux ...

Share this post


Link to post
Share on other sites

Beuheuheu...

Même si tu m'envoies le fichier directement ? C'est bien dommage, j'étais curieuse...

Merci de ton aide en tout cas, j'aurai appris à faire un ping. Toujours ça de gagné !

Share this post


Link to post
Share on other sites
Beuheuheu...

Même si tu m'envoies le fichier directement ? C'est bien dommage, j'étais curieuse...

Merci de ton aide en tout cas, j'aurai appris à faire un ping. Toujours ça de gagné !

C'est le même problème !

Si je t'envoie le fichier du serveur, tu ne pourra pas t'y connecter avec ton téléphone !

On peut voir une dernière chose :

sur ton netbook, ouvre la fenetre "cmd" comme tout à l'heure

tapes : ipconfig

et dis moi ce que tu as pour "adresse ipv4"

Share this post


Link to post
Share on other sites

Hum je n'ai pas d'ipv4, mais à adresse IP j'ai : 10.20.16.107

Et tant qu'on y est, pour le masque de sous-réseau j'ai 255.255.240.0

Et la passerelle par défaut, 10.20.16.1

Je rêve de comprendre ce que ce genre de chose signifie... J'achète quel bouquin "... pour les nuls" ? :)

Edited by Prydwen

Share this post


Link to post
Share on other sites

ok ok, ton téléphone et ton netbook sont bien sur le même réseau...

Mais comme dans "ping", tous les paquets sont perdus, ça veut dire que tu ne peux pas faire de "lien" entre ton téléphone et ton netbook.

Ca doit être une mesure de sécurité dans ton école qui empêche ça.

Je ne peux rien y faire :(

ça veut dire que mon programme ne pourra pas fonctionner à ton école.

mais je vais essayer de sortir un jour une version bluetooth, qui permettra de le faire

Je n'ai rien appris dans les livres :P

J'ai plutôt choisi la technique "je reste plusieurs heures par jour devant un pc" :D

Edited by Pierre87

Share this post


Link to post
Share on other sites

@Prydwen

Ca vient de toi le message de log collector ?

Je t'ai répondu par mail

J'avais oublié de préciser : il faut aller dans les options de premotedroid et cocher "debug", pour que je puisse voir les messages d'erreur.

(Mais je doute que ce soit très utile...)

Share this post


Link to post
Share on other sites

Oui merci pour ton mail, mais du coup je vais juste essayer ce soir chez moi pour avoir un aperçu et puis désinstaller, puisque c'est à l'école que je voulais l'utiliser anyway...

Share this post


Link to post
Share on other sites

oui, bien sûr,

à mon avis, chez toi tu n'aura pas de problème

si tu rencontres une difficulté, pour le faire fonctionner, je suis dispo quasi h24 :P

Share this post


Link to post
Share on other sites
Je sais pas on m'a conseillé ça.

En tout cas avec PRemotoroid' date=' téléchargé sur le market, le fichier .jar ne s'exécute pas sous Ubuntu 9.10....[/quote']

Et tu l'executes de quelle façon ? Chez moi cela marche :/

D'ailleurs j'ai testé l'explorateur de fichier, et cela fonction sur Ubuntu 9.10 :)

Ben normalement :

=> clic droit> Ouvrir avec Sun Java 6 Runtime

Share this post


Link to post
Share on other sites

Houlalalalala

J'ai essayé l'appli chez moi, sur mon laptop. J'ai réussi à dl le fichier, lancer le serveur, l'appli...

Sur l'appli, écran noir sauf les 3 boutons. Par contre mon pc... Il s'est mis à clignoter en noir. Même en fermant l'appli via mon tél, même en la fermant sur le pc. Et la souris ne répondait plus.

J'ai du forcer le redémarrage, l'écran de démarrage (le windows) clignotait aussi pendant le lancement... Là il a l'air de s'être lancé correctement. :rolleyes:

Ca n'a fait ça a personne ??

Edited by Prydwen

Share this post


Link to post
Share on other sites

Heu... sur l'appli c'est normal l'écran noir, les screenshot sont désactivé par défaut, et donc c'est un pavé noirs + les trois boutons.

Pour ton PC, je saurais pas te dire, ça m'étonnerais que ça soit du au logiciel ! En tout cas, j'ai jamais eu de problèmes avec ce logiciel, sous Windows comme sous Linux !

Share this post


Link to post
Share on other sites

Ok merci pour les screenshots lol je m'attendais à voir mon écran "en direct"...

Cela dit ça m'étonnerait que ce soit une coïncidence : je lance le serveur, mon écran se met à clignoter, la souris ne répond plus... Je redémarre, et ça fonctionne. Ce genre de but n'est pas habituel sur mon pc !

Share this post


Link to post
Share on other sites

Peut-être que ton java n'est pas à jour :/

Edited by Se7h

Share this post


Link to post
Share on other sites

application très sympas excellente même. Peut-être créer un slide sur le côté ça pourrait-être encore mieux ;)

Share this post


Link to post
Share on other sites

@Prydwen : jamais rencontré ce genre de problème :O

et jamais personne ne l'a eu à ma connaissance

il est possible que ça pose problème si tu as une version de java trop vieille (car mon serveur utilise java)

la derniere version : http://java.com/fr/download/

tu peux nous en dire plus sur ton PC ?

Quel système d'exploitation ? Windows ? Quelle version ?

ensuite, cette application n'est pas un "VNC"

http://fr.wikipedia.org/wiki/Virtual_Network_Computing

Si tu veux contrôler ton pc à distance, je te conseille de te tourner vers un vrai client vnc

PRemoteDroid remplace juste une souris sans fil (et bientot un clavier)

La transmission d'image, c'est juste une fonction "pour faire joli" et est difficilement utilisable

Elle n'est pas en temps réel, mais j'y arriverai peut etre un jour \o/

Share this post


Link to post
Share on other sites
application très sympas excellente même. Peut-être créer un slide sur le côté ça pourrait-être encore mieux ;)

un slide ?

Share this post


Link to post
Share on other sites

Bon, je bosse sur le support du clavier là, et j'ai plusieurs possibilités :

- une solutions extrêmement simple,

qui permet d'utiliser quasiment toutes les touches du clavier Android,

mais qui ne marche que sous Windows (j'utilise ALT+xxx)

- une autre solution plus complexe,

qui me permet d'utiliser les caractères a-z A-Z 0-9 très simplement,

et qui marche partout (Linux Windows),

les autres caractères sont assez compliqués à utiliser,

et ne sont pas tous disponible ("?" par exemple)

Je pense que je vais essayer de mélanger les 2...

Share this post


Link to post
Share on other sites

le slide c'est comme sur les touch pad a droite ca permet de scroller ou plus siimple permet d'imiter la roulette

Share this post


Link to post
Share on other sites

Il faudrait que je vois, mais je l'ai déjà implémenté !

Sur mon téléphone ça marche, car j'ai une boule à la place des fleches directionnelles.

Et ça me permet de scroll !

Il faudrait que je vois ce que ça donne sur les téléphones qui n'en ont pas ...

Share this post


Link to post
Share on other sites

ouip mais par exemple je suis sur un archos 5 et je n'ai aucun bouton pour faire cela :).

Sinon question plus dev tu utilise quelle protocole pour transmettre les info vers le serveur udp? (parsque j'ai commencer a faire un log dans le même genre avant de m'appercevoir que tu as déjà fait une version pas mal avancer).

Et sinon ajouter un support bluetooth pourrait être sympa.

Il faudrait aussi que tu bloque l'orientation parce que si je met mon archos en horizontal les bouton se place bizarement.

Et egalement une sorte de fonction tablette graphique lol.

Je suis exigeant mais bon ca pourra te donner des idée à développer ;)

Edited by rafffel

Share this post


Link to post
Share on other sites

Ok, c'est une bonne idée.

Mais il faut que j'étudie de plus près les Layouts de type "overlay".

Non j'utilise TCP

Je manipule le flux avec des informations plutôt "bas niveau", les bytes, et tout ...

Je ne fais pas de xml kikoolol, même si ça permet une flexibilité et une stabilité plus grande dans le protocole.

J'avais essayé UDP, mais il y a un méchant bug dans Android 1.5,

qui fait que les paquets UDP reçus sur le téléphone sont tronqués après le byte 1.

SUPAIR

Donc j'ai choisi TCP, et c'est très rapide, et sans latence !

Mon code source est en libre accès :

http://code.google.com/p/premotedroid/source/browse/

Il y a un dépôt SVN.

Toute suggestion ou contribution est la bienvenue !

Mais comme je dev assez vite, et que mon code bouge pas mal,

c'est pas évident de rajouter des patchs tiers :P

Share this post


Link to post
Share on other sites

A plutôt cool tous ça je vais pourvoir jeter un coup d'oeil sur la manière dont tu ti prend :).

En tout cas il y a déjà du beau boulot de fait félicitation ^^.

Share this post


Link to post
Share on other sites
A plutôt cool tous ça je vais pourvoir jeter un coup d'oeil sur la manière dont tu ti prend :).

En tout cas il y a déjà du beau boulot de fait félicitation ^^.

Petite précision :

Je bosse avec Eclipse (le nom de mon plugin SVN est subclipse)

Les 3 dossiers sur le SVN sont des projets Eclipse

J'utilise le SDK 7 (Android 2.1), mais je reste rétro compatible avec le SDK 3 (Android 1.5)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now