Jump to content
CoolRaoul

Tasker: aide,infos,creation de profils

Recommended Posts

Merci beaucoup CoolRaoul ça fonctionne ! :) Ton message était vide quand j'ai répondu, t'as du l’éditer depuis.

 

Du coup je comprends toujours rien aux variables, j'en aurai besoin pour d'autres idées que j'ai. J'vais essayer de continuer de lire des tutos.

Edited by Hypnoz

Share this post


Link to post
Share on other sites

Ton message était vide quand j'ai répondu, t'as du l’éditer depuis.

En effet: j'avais posté une première réponse à coté de la plaque  :wacko:.

Je l'ai effacée le temps de rédiger le seconde version.

 

Du coup je comprends toujours rien aux variables, j'en aurai besoin pour d'autres idées que j'ai. 

Pas d'inquiétude, on est là pour aider. Quand tu coinces, n'hésites pas à revenir dans le fil discuter de tes idées et nous décrire ta façon de les implémenter et on verra ce qu'on peut essayer de corriger

Share this post


Link to post
Share on other sites

Plus simple, ajouter une condition supplémentaire d'activation au profil avec la condition "non wifi connecté":

  • Appui long sur le profil
  • "ajouter"
  • "état"
  • réseau
  • wifi connecté
  • cocher "inverser"

Ca rendra l'activation du profil conditionnelle au fait que le wifi ne soit *pas* connecté:

dSlYx7o.png

 

**complément**

 A savoir également: les actions de type "toggle" ,reconnaissables à la roue dentée:

p7velfm.png

sont par défaut automatiquement inversées quand le profil cesse d'être actif. Pas besoin dans ce cas de le faire explicitement dans une tache de sortie (par exemple un profil qui active le wifi dans sa tache d'entrée aura pour effet de le désactiver des qu'il devient inactif). Ce comportement peut être désactivé au cas par cas en décochant "restaurer les paramètres" dans les propriétés du profil.

ben j'ai appris quelque chose :) merci

Share this post


Link to post
Share on other sites

ben j'ai appris quelque chose :) merci

A propos, j'ai oublié une précision dans mon complément sur le comportement de l'option "restaurer les paramètres": en pratique ça n'inverse pas l'action effectuée dans la tache d'entrée, ca rétablit le paramètre à son état initial.

Pour reprendre l'exemple du wifi, à la sortie d'un profil dont la tache d'entrée l'active, il sera remis dans l'état qu'il avait lors de l'activation du profil. Autrement dit, si il était déjà activé il ne se retrouvera pas désactivé en sortie de profil. C'est un peu plus subtil qu'une action inverse.

  • Like 1

Share this post


Link to post
Share on other sites

J'viens de me rendre compte que l'activation au profil de la condition "non wifi connecté" (avec la case inversée cochée) arrête le profil dès qu'il est lancé, je m'explique : 

 

Le wifi est lancé manuellement, je lance mon application, le profil s'active puis se désactive immédiatement et ne prend donc plus aucune action du profil, à savoir déconnecter le wifi en quittant l'application. Je me retrouve avec un wifi actif qui reste actif.

 

J'ai également essayé en activant pas le wifi manuellement, le problème est le même.

 

​Dans mon cas la tâche de sortie est configurée pour désactiver le wifi après 10 secondes. Dans les faits avec ton réglage CoolRaoul l'application se lance, le profil se lance et se coupe immédiatement. La tâche de sortie se lance quand le profil se coupe et m'arrête le wifi 10 secondes après son lancement. Je me retrouve avec une application sans wifi.

 

Y'a moyen de contourner ce problème ?

Edited by Hypnoz

Share this post


Link to post
Share on other sites

Je ne comprend pas tres bien comment il est possible que, comme tu le cite "Le wifi est lancé manuellement, je lance mon application, le profil s'active puis se désactive immédiatement"

Quand le wifi est déja activé, la condition "non wifi connecté" est fausse, et donc il n'y a pas de raison que le profil s'active (pour qu'on profil soit actif il faut que toutes les conditions soient réalisées)

Serait utile que tu copies ton profil ici dans le fil (appui long sur le profil, menu -> "exporter", puis "Description dans le presse papier" et copier le résultat dans le le message)

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

Voilà le profil :

Profil: APPS WIFI ON W-E (20)
Application: AdAway, Google Cast, Imgur..., App/Services
Jour: Dim ou Sam
Etat: Non Wifi connecté [ SSID:* MAC:* IP:* ]
Entrée: WIFI ON (13)
A1: Secure Settings [ Configuration:Wifi Enabled Paquet:com.intangibleobject.securesettings.plugin Nom:Secure Settings Délai (Secondes):0 ]

Sortie: WIFI OFF (14)
A1: Attendre [ MS:0 Secondes:10 Minutes:0 Heures:0 Jours:0 ]
A2: Secure Settings [ Configuration:Wifi Disabled Paquet:com.intangibleobject.securesettings.plugin Nom:Secure Settings Délai (Secondes):0 ] 
Edited by Hypnoz

Share this post


Link to post
Share on other sites

Voilà le profil :

Profil: APPS WIFI ON W-E (20)
Application: AdAway, Google Cast, Imgur..., App/Services
Jour: Dim ou Sam
Etat: Non Wifi connecté [ SSID:* MAC:* IP:* ]
Entrée: WIFI ON (13)
A1: Secure Settings [ Configuration:Wifi Enabled Paquet:com.intangibleobject.securesettings.plugin Nom:Secure Settings Délai (Secondes):0 ]

Sortie: WIFI OFF (14)
A1: Attendre [ MS:0 Secondes:10 Minutes:0 Heures:0 Jours:0 ]
A2: Secure Settings [ Configuration:Wifi Disabled Paquet:com.intangibleobject.securesettings.plugin Nom:Secure Settings Délai (Secondes):0 ] 

Pour commencer, je ne comprend pas pourquoi tu passes par "Secure Settings" pour activer/désactiver le wifi vu que Tasker dispose nativement de cette fonction: ajouter action -> "réseau" -> wifi, état -> "on" (de plus la restauration auto des paramètres que j'ai expliquée ne s'applique pas dans le cas d'un plugin)

Il est fort possible que le problème soit lié à ça.

 

Ensuite, autant supprimer la tache de sortie, le wifi se désactivera tout seul immédiatement au lieu de 10 secondes plus tard, apres tout qu'est ce ça change?

***EDIT***

Ah je comprend ce qui se passe, en effet la condition d'entrée devient fausse des que le wifi est activé bien entendu

Attend, je reviens avec une solution..

 

**EDIT #2**

En fait c'est très simple:

  • supprimer la condition "non wifi connecté"
  • retirer la tache de sortie.

Le profil deviendra actif des qu'une des appli et active et le wifi sera alors activé si il ne l'était pas

En sortie du profil, tasker va désactiver le wifi si et seulement si il était déja off à l'entrée du profil. Ce qui correspond à ta spec (aux 10 secondes pres)

 

Reste un truc a savoir: la condition "Application" reste vraie tant que l'appli est au premier plan (affichée). Si ti lance par exemple un lecteur audio qui continue à streamer en background, pour garder le wifi actif, ça risque d'être tout de suite plus sportif.

Edited by CoolRaoul
  • Like 1

Share this post


Link to post
Share on other sites

J'ai modifié le profil comme tu l'indiques :

Profil: APPS WIFI ON W-E (20)
Application: AdAway, Google Cast, Imgur..., App/Services
Jour: Dim ou Sam
Etat: Non Wifi connecté [ SSID:* MAC:* IP:* ]
Entrée: WIFI ON (13)
A1: WiFi [ Mettre sur:Bascule ] 

Même problème, je lance mon application, le profil se désactive et se réactive à la chaîne tant que l'application est lancée.

Edited by Hypnoz

Share this post


Link to post
Share on other sites
Entrée: WIFI ON (13)
A1: WiFi [ Mettre sur:Bascule ] 

Même problème, je lance mon application, la tâche se désactive et se réactive à la chaîne tant que l'application est lancée.
Pour l'action WIFI; mettre sur "on", pas "bascule"

Sinon, tu utilises quelle application pour ton test?

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

J'ai créé le profil suivant:

Profil: AppWIFI (15)
Application: YouTube
Entrée: Anon (51)
A1: WiFi [ Mettre sur:Activé ] 

Et je n'arrive pas à reproduire le comportement que tu observes.

Quand je lance Youtube avec le wifi désactivé, Tasker l'active et le laisse actif ainsi que le profil "AppWIFI" (peut se vérifier dans la notification) tant que Youtube est au premier plan. 

Si je le lance avec le wifi déjà activé, il reste actif pendant et après avoir quitté Youtube.

 

**EDIT**

As-tu bien supprimé la condition "Etat: Non Wifi connecté [ SSID:* MAC:* IP:* ]" comme j'ai demandé ?

 

PS:

Se fait tard, on reprendra à partir de demain.

Edited by CoolRaoul
  • Like 1

Share this post


Link to post
Share on other sites

**EDIT #2**

En fait c'est très simple:

  • supprimer la condition "non wifi connecté"
  • retirer la tache de sortie.

Le profil deviendra actif des qu'une des appli et active et le wifi sera alors activé si il ne l'était pas

En sortie du profil, tasker va désactiver le wifi si et seulement si il était déja off à l'entrée du profil. Ce qui correspond à ta spec (aux 10 secondes pres)

 

Reste un truc a savoir: la condition "Application" reste vraie tant que l'appli est au premier plan (affichée). Si ti lance par exemple un lecteur audio qui continue à streamer en background, pour garder le wifi actif, ça risque d'être tout de suite plus sportif.

 

 

**EDIT**

As-tu bien supprimé la condition "Etat: Non Wifi connecté [ SSID:* MAC:* IP:* ]" comme j'ai demandé ?

 

J'avais pas vu ton deuxième EDIT ! Effectivement là ça fonctionne.

Donc en gros c'est Secure Settings qui m'a fait vouloir modifier un état qui n'aurait pas eu de souci si le profil avait été créé avec Tasker. J'avais pris un profil GPS ici et l'avais adapté au wifi sans me douter que Tasker proposait l'activation du wifi.

 

Je perdu ma soirée et t'ai fait perdre la tienne.. Désolé !  

Share this post


Link to post
Share on other sites

perdu ma soirée et t'ai fait perdre la tienne...

T'inquiètes: on ne pert jamais son temps quand on apprend des choses, et de mon côté, ça me fait plaisir quand je peux être utile. Edited by CoolRaoul

Share this post


Link to post
Share on other sites

Bonjour les taskers,

 

Je souhaiterais faire une action qui paraît simple :

 

Assigner une tâche "verrouiller / déverrouiller mon téléphone" sur tasker pour ensuite pouvoir la délencher avec le boutton "Pressy".

 

En effet, j'ai un bug avec mon bouton latéral droit sur mon nexus 5 (qui sert à verrouiller / déverrouiller le téléphone), il reste parfois bloqué et redémarre mon téléphone en boucle. Je souhaite avec le boutton Pressy le substituer afin de pouvoir verrouiller / déverrouiller mon téléphone.

 

Une idée ?

 

Merci

 

Mun 

Share this post


Link to post
Share on other sites

Je souhaiterais faire une action qui paraît simple :

Assigner une tâche "verrouiller / déverrouiller mon téléphone" sur tasker pour ensuite pouvoir la délencher avec le boutton "Pressy".

 

Sous réserve que l'appui sur le bouton "Pressy" soit capable de déclencher une tache Tasker, ca peut se faire avec l'aide du plugin "Secure Settings"

 

La tache devrait ressembler à:

Enter: ToggleLock
A1: If [ %SCREEN ~ on ]
A2: System Lock 
A3: Else 
A4: Secure Settings [ Configuration:Screen & Keyboard Lights On
1 Second Package:com.intangibleobject.securesettings.plugin Name:Secure Settings Timeout (Seconds):0 ] 
A5: End If 

La configuration de l'action de l'étape A4 étant la suivante:

wglCS9T.png

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

Hello,

Quelqu'un sait comment tester le statut des données ?

Un peu comme "si %WIFI = on" mais pour les data... J'ai pas trouvé la variable "%?????" pour les données mobiles.

En gros ce que je veux faire :

Uniquement si les données sont allumees >> quand l'écran s'éteint, mettre les data off... Puis les rallumer quand écran se rallume

(ça marche pour le WiFi)

Comme ça :

Si "data=on"

+ sur état "screen=off"

"data->off" & var. "%AutoDataOff=on"

Ensuite

Si "%AutoDataOff=on"

+ sur état "screen=on"

"data->on" & var. "%AutoDataOff=0"

Mais il me manque ce putxxxrée de test Si "data=on"

Merci d'avance si vous avez des idées

PascR

Edited by Pascr001

Share this post


Link to post
Share on other sites

quand l'écran s'éteint, mettre les data off... Puis les rallumer quand écran se rallume

Pour ca aussi tu vas avoir des problèmes: sans le root, activer/désactiver les data c'est pas possible (et même avec, ça risque de marcher plus ou moins bien suivant la version d'Android)

 

Quand à la commande pour tester l'état du mode data, voici ce que répond Tasker quand on essaie de l'ajouter à une tache:

4sa3V7N.png

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

bonjour

@@Pascr001

tu peux activer/désactiver les datas avec une commande shell et tu dois etre root :

1- Créer une nouvelle tâche

2- Choisir la catégorie « Code » puis choisir l’option « Lancer un Shell »  (Run Shell) et saisir les commandes suivantes dans l’option « Commande »

 

   setenforce permissive;

   # disable : désactive les données mobile et  enable les activent

   svc data enable;             

   setenforce enforcing

 

  À la ligne « Utiliser root » (Use root), vérifier que la case à cocher est bien cochée sinon ça ne fonctionnera pas.

 

 

Pour moi celà fonctionne sous kitkat et lollipop et avec des roms stock.

 

ps1 : si l'exécution de la tâche reste bloquée sur le shell (point rouge) réessayer en ne conservant que la commande svc data ....

 

ps2 : et pour faire la même chose avec le wifi, remplacez svc data par svc wifi  

 

++

Edited by philgoodgood

Share this post


Link to post
Share on other sites

Merci mais c'est pas ce que je veux faire

(le on/off via ta manip je l'utilise déjà ^_^)

Ce que je veux c'est pouvoir tester si les datas à sont ON ou OFF.

C'est possible pour le wifi en testant la variable %WIFI...

Donc j'aimerais trouver pareil pour les données mobiles ;)

PascR

Share this post


Link to post
Share on other sites

Ce que je veux c'est pouvoir tester si les datas à sont ON ou OFF.

Dans ce cas me semble que la solution triviale est de créer un profil "Data" qui positionne la variable %DATA = 1 en tache d'entrée et l'efface en sortie:

Profile: Data (67)
State: Mobile Network [ 2G:On 3G:On 3G - HSPA:On 4G:On ]
Enter: Anon (69)
A1: Variable Set [ Name:%DATA To:1 Do Maths:Off Append:Off ] 

Exit: Anon (110)
A1: Variable Clear [ Name:%DATA Pattern Matching:Off ] 

et ensuite de tester si la variable %DATA est "set"

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

bonsoir

@PascR : ah .. OK 

alors tu choisis la catégorie "Réseau" puis l'action "Test Réseau" puis dans type tu déroule la liste et tu choisis le type "Données mobiles activées" que tu stockes dans la variable %data (par exemple) laquelle contiendra la valeur yes ou no  selon que Données mobiles est activé ou non 

 

+

  • Like 2

Share this post


Link to post
Share on other sites

alors tu choisis la catégorie "Réseau" puis l'action "Test Réseau" puis dans type tu déroule la liste et tu choisis le type "Données mobiles activées" que tu stockes dans la variable %data (par exemple) laquelle contiendra la valeur yes ou no  selon que Données mobiles est activé ou non 

 

Ah oui exact, m'étais completement sorti de l'idée l'existence de cette fonction, c'est évidemment comme ça qu'il faut faire.

Share this post


Link to post
Share on other sites

bonsoir

@PascR : ah .. OK

alors tu choisis la catégorie "Réseau" puis l'action "Test Réseau" puis dans type tu déroule la liste et tu choisis le type "Données mobiles activées" que tu stockes dans la variable %data (par exemple) laquelle contiendra la valeur yes ou no selon que Données mobiles est activé ou non

+

Je vois pas l'option "test réseau"...?

En fait je voudrais faire comme ça mais pour les data :

Voici ce que j'ai actuellement :773c95c1ec95f93fbcf6ddd0e84e0c0f.jpg

1deeac080ff223555426d4067c59b9dc.jpg

c353f48f8e3c4d3e2a486ed6308a50fa.jpg

Du coup il faut à l'extinction que je test si data=ON (ou pas)... Mais à quel moment affecter la variable dont tu parles ?

PascR

Edited by Pascr001

Share this post


Link to post
Share on other sites

Je vois pas l'option "test réseau"...?

En fait je voudrais faire comme ça mais pour les data

 

Le besoin n'était pas clair jusqu'ici: on pensait que tu voulais mettre une condition "type de connexion réseau" *dans une tache*

Si c'est une condition de profil, faut utiliser état -> "réseau" -> "réseau mobile"

A4heDIS.png

C'est la méthode sur laquelle s'appuyait mon message précédent mais comme mon Tasker est en anglais par défaut, tu n'as sans doute pas fait le lien

Edited by CoolRaoul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...