CoolRaoul

Tasker: aide,infos,creation de profils

Recommended Posts


 

Il y a 4 heures, Totriet a dit :
Raoul toi qui as un s9, as-tu constaté une consommation excessive du à l'utilisation de Tasker ? La batterie flambe tellement vite que je n'ai pas osé le réinstaller...

 


J'ai pas forcément suffisamment de recul vu que je n'ai mon S9 que depuis peu. Mais à priori mes stats batterie restent du même ordre de ce que j'avais sur mes appareils précédents.
Mon Nova Launcher est bien devant Tasker par exemple (ce qui me gonfle d'ailleurs)
Après faut comprendre que la consommation due à Tasker est forcément corrélée au nombre de profils et du nombre d'événements déclencheur de conditions.
Et dans mon cas j'ai un setup Tasker bien touffu.
Donc en résumé, la consommation due à Tasker me semble maîtrisée chez moi.

 

Share this post


Link to post
Share on other sites
Le 29/03/2019 à 14:27, CoolRaoul a dit :

Pas pour activer/désactiver la type de localisation (je viens de vérifier, en tout cas sur mon S9 sous Pie)

  • Avant:
    image.png.f1658210b1011bd62fa675d47bcbcbaf.png
  • exécution de la tache Tasker ci dessous::
    image.png.3f3e3cbd929bd1e2922f9108fac8107f.png
  • Après
    image.png.a4480d051008d6a78c1c0b24dae44cda.png

 

Et l'effet est exactement le même (et mon appareil n'est pas rooté)

 

Je viens de retest ce matin et je te confirme bien qu'activer / désactiver le gps via tasker (ou autre chose d'ailleurs) n'est pas possible sans root ou rom custom. Ou alors c'est une spécificité du S9, je sais pas.

Quoi qu'il en soit voila le message que j'ai quand j'essai : "This is a secure setting witch needs special permissions. Look in the help page for this action for info on how to enable".

 

Share this post


Link to post
Share on other sites
il y a une heure, Sorkar a dit :

Je viens de retest ce matin et je te confirme bien qu'activer / désactiver le gps via tasker (ou autre chose d'ailleurs) n'est pas possible sans root ou rom custom. Ou alors c'est une spécificité du S9, je sais pas.

Quoi qu'il en soit voila le message que j'ai quand j'essai : "This is a secure setting witch needs special permissions. Look in the help page for this action for info on how to enable".

Pourquoi à nouveau parler de "root" et de "rom custom"? Cette action nécessite (comme le message d'erreur l'indique d'ailleurs) seulement de donner à Tasker l'autorisation "WRITE_SECURE_SETTINGS".

Et la méthode pour le faire est documentée dans la page d'aide comme c'est aussi indiqué aussi ("Look in the help page for this action for info").
Lien direct vers la rubrique: https://tasker.joaoapps.com/userguide/en/help/ah_secure_setting_grant.html

Share this post


Link to post
Share on other sites
Posted (edited)

Hum, intéressant. Via une commande ADB, ok. Je te parles de root parce que jusqu'ici j'ai lu absolument partout sur le net que ce n’était pas possible depuis je ne sais plus quelle maj d'android.

Je ne savais pas qu'on pouvais ajouter de telles autorisations via adb et sans root.

 

Comme tes réponses sont bien utiles, aurait tu une idée de comment utiliser le nfc avec écran éteint ? Toujours sans root cela va de soit :)

 

Merci pour les retours en tout cas.

Edited by Sorkar

Share this post


Link to post
Share on other sites



, aurait tu une idée de comment utiliser le nfc avec écran éteint ? Toujours sans root cela va de soit


Ah, ça, me semble bien que c'est sans espoir.
Rien vu dans ce sens en tout cas.

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

J'ai découvert Tasker depuis peu et je me lance dans quelques liens avec la petite domotique que j'ai à la maison.

Je souhaiterais ouvrir mon portail quand je suis en dessous de 100m de chez moi.

La gestion et le calcul de la distance en fonction de ma position c'est bon.

 

Mais je ne trouve pas comment aller chercher dans l'appli ihc For EU, le bouton ouvrant mon portail.

 

J'ai vu du shell passé dans ce sujet, mais c'était la 1ère fois que j'en voyais et je ne saispas si ça peut répondre à ma demande.

 

Par avance merci !

 

Romaiiin

Edited by Romaiiiin47

Share this post


Link to post
Share on other sites

A lire, utlisateurs présent ou futurs de Tasker, Darkness is coming.

 

Share this post


Link to post
Share on other sites

Coucou, j'utilise Tasker depuis 6 mois avec mon auto, pour simplement activer le partage de wifi du téléphone une fois le Bluetooth connecté. Ca a bien marché jusqu'à il y a deux semaines, depuis un reset de mon tel. J'ai recréé le même profil, mais Tasker ne se lance plus seul, il faut que je sorte mon tel de sa veille pour que les actions s'enchainent. Peut être que mon problème n'est pas lié à Tasker mais plutôt le Bluetooth qui se coupe le téléphone en veille ... mais je ne vois quand même pas quoi faire :( 

Share this post


Link to post
Share on other sites
il y a une heure, Wapdoubap a dit :

Tasker ne se lance plus seul,

je ne suis pas sur de comprendre cette phrase: Tasker se lance une fois pour toutes au démarrage (boot) de l'appareil et reste ensuite actif en permanence. 

Citation

il faut que je sorte mon tel de sa veille pour que les actions s'enchainent.

Ca ressemble à un problème d'économie d'énergie

Dans Tasker (configuré en anglais chez moi), ouvrir le menu "More" -> "Android settings"  -> "Power save mode" et suivre les instructions

Share this post


Link to post
Share on other sites

Oui, il se lance normalement au boot, mais si je m'approche de ma voiture en ayant le téléphone dans la poche, rien ne se passe, il faut que j'allume l'écran, que j'attende la connexion automatique du bluetooth pour voir que mon tel partage le wifi, et que mon poste s'y connecte. Si je ne reveille pas mon tel, rien ne se passe.

J'ai été revoir dans les paramètres d'énergie, mais le mode économie est déjà désactivé ... Je n'arrive pas vraiment a savoir d'ou vient le problème :s

Share this post


Link to post
Share on other sites
Le 05/06/2019 à 15:02, Wapdoubap a dit :

il faut que j'allume l'écran,que j'attende la connexion automatique du bluetooth pour voir que mon tel partage le wifi, et que mon poste s'y connecte. Si je ne reveille pas mon tel, rien ne se passe.

Si je comprend bien tes explications ce n'est pas un probleme Tasker, si tu définis un profil dont une condition est "bluetooth  connecté à ..." c'est normal que ce dernier ne se déclenche pas tant que le bluetooth n'est pas *effectivement* connecté

Reste à comprendre pourquoi le bluetooth de ton appareil ne se connecte pas tant que son écran est éteint. Mais ça c'est un autre problème, faut poser plutôt la question dans la section dédié à ce modèle de téléphone.

  • Like 1

Share this post


Link to post
Share on other sites

Oui j'en déduis la même chose donc, merci pour ton éclairement, j'arrête de polluer ce topic :p

Share this post


Link to post
Share on other sites

Bonjour, j'utilise tasker sur mon téléphone avec un profil pour le partage de connexion lorsqu'il est connecté à mon autoradio Android.

J'ai également installé tasker sur mon autoradio et créé des profils pour ouvrir des apps (dashcam et tpms) une fois connecté à mon tel en Bluetooth. Seulement, [color=red]qd[/color] j'allume mon autoradio (sous Android 8.1),tasker est bien ouvert, mais avec le message " pas de profil actif". Pourtant, si je regarde ds tasker, ils sont bien actifs.

une idée ?

Share this post


Link to post
Share on other sites
23 hours ago, thierry34 said:

avec le message " pas de profil actif".

Il parait où ce message?

Si c'est dans la barre de notification, il est possible que dans le cas de ces profils, l’attribut de les rendre visible dans la notification ait été simplement désactivée.

image.png.9ac0984f35cebde86900b6195783264d.png

(désolé je préfère l'interface de mon Tasker an anglais, c'est plus facile quand on doit chercher de l'aide sur internet)

Share this post


Link to post
Share on other sites

j'ai jamais regardé ds les préférences. j'ai regardé ds celui de mon tel mais je n'ai pas trouvé.

je regarderais ds celui installé dans mon autoradio. peut etre une option qui est mal définie. je te tiens au courant dés que j'ai regardé.

Share this post


Link to post
Share on other sites
30 minutes ago, thierry34 said:

j'ai jamais regardé ds les préférences. j'ai regardé ds celui de mon tel mais je n'ai pas trouvé.

Je ne comprend pas de quelles préférences tu parles (ce n'était pas dans mon message en tout cas).

Sinon tu n'as pas répondu à ma question "Il parait où ce message?"

Ce que je veux dire par là est :

  • sur le téléphone ou sur l'autoradio?
  • et dans quelle partie de l'interface: la notification Tasker, un popup, autre?

Share this post


Link to post
Share on other sites

alors ,apres quelques jours ou je n'arrivais pas à répondre sur le forum ....

mon soucis se trouve sur l'autoradio. (sur mon téléphone, le profil fonctionne trés bien . c celui du partage de connexion).

sur mon autoradio,[color=red]qd[/color] je suis sur  la page principale, si je tire l'écran a partir du haut , les applications démarrées y apparaissent sous la forme d'une ligne. C'est dans la ligne de l'application tasker qu'il y a marqué "aucun profil actif".

dans la barre de notification (en haut ou il y a l'heure, le bluetooth, la 4g etc , il y a l'icone de tasker qui prouve bien que l'application a bien démarré. Seulement ,j'ai ce souci de "aucun profil actif"

si tu as une idée d'ou ça peut venir . je t'en serais trés reconnaissant !!!!!

 

Share this post


Link to post
Share on other sites
il y a 15 minutes, thierry34 a dit :

apres quelques jours ou je n'arrivais pas à répondre sur le forum

Tu n'étais pas le seul si cela peut te rassurer. Panne générale à laquelle nos "chers" administrateurs ont mis un temps fou à réagir :angry::(

Et tout n'est pas encore réglé, même si le forum est redevenu utilisable.

Je passe la main pour ton problème Tasker, pas dans mes cordes.

Share this post


Link to post
Share on other sites
18 minutes ago, thierry34 said:

si je tire l'écran a partir du haut , les applications démarrées y apparaissent sous la forme d'une ligne. C'est dans la ligne de l'application tasker qu'il y a marqué "aucun profil actif

Appuie sur cette ligne. Ca va va avoir pour effet d'ouvrir l'interface principale de Tasker. Là, vérifie si le profil que tu considère comment devant être actif l'est effectivement (son nom dans la liste des profils en surbrillance).

Si c'est bien le cas, faire la vérification que j'ai détaillée un peu plus haut: pour accéder aux paramètres du profil, faire un appui long sur son nom et ensuite sur l'icone "roue dentée" qui apparaît dans la bande supérieure. Les profils dont l'option "show in notification" (ou son équivalent en français) n'est pas cochée ne seront pas listés dans la notification. Si tous les profils actif sont dans ce cas, ce que tu observes est normal.

 

Share this post


Link to post
Share on other sites

ok, donc si je comprends bien, les profils que j'ai créé devrait etre coché dans leur option "show in notification" respective . je vérifie ça demain et te tiens au courant.

Share this post


Link to post
Share on other sites

je viens d'enlever la croix ds "show in notification" de mes 3 profils, mais c'est toujours pareil.

[color=red]qd[/color] j'allume l'autoradio, tasker est bien ouvert, mais aucun de mes profils ne démarrent et il y a toujours marqué "aucun profil actif".

Pourtant ,[color=red]qd[/color] j'ouvre tasker, les 3 profils sont bien sur "actif" .

je fais une photo ds la journée.

Share this post


Link to post
Share on other sites
Quote

je viens d'enlever la croix ds "show in notification" de mes 3 profils, mais c'est toujours pareil.

C'est sur que si tu *enlève* la croix, que  ça ne s''affiche pas!

A part ça, si ça n'est pas affiché dans la notif pour les notifications actives quand "show in notification" est coché, c'est doute un bug de Tasker spécifique à l'appareil alors.

Mais, l'important est que le reste de Tasker fonctionne surtout.

Share this post


Link to post
Share on other sites

je viens d'enlever la croix ds "show in notification" de mes 3 profils, mais c'est toujours pareil.

[color=red]qd[/color] j'allume l'autoradio, tasker est bien ouvert, mais aucun de mes profils ne démarrent et il y a toujours marqué "aucun profil actif".

Pourtant ,[color=red]qd[/color] j'ouvre tasker, les 3 profils sont bien sur "actif" .

je fais une photo ds la journée.

IMG20191101121834.jpg

IMG20191101121844.jpg

IMG20191101121900.jpg

Edited by thierry34

Share this post


Link to post
Share on other sites

@thierry34

Depuis le début tu as mal présenté ton problème, pas étonnant qu'on se comprenne pas.

je cite:

Citation

 j'allume mon autoradio (sous Android 8.1),tasker est bien ouvert, mais avec le message " pas de profil actif". Pourtant, si je regarde ds tasker, ils sont bien actifs.

Contrairement à ce que tu as écris, tes profils ne sont *pas* actifs, et ça se voit bien sur la photo #2. Ce n'est donc pas un pb de notification.

Et si ils ne passent pas actif c'est que les conditions de leur activation ne sont pas présentes. C'est aussi bête que ça.

Exemple chez moi:

image.png.e5ff28194e37858294d98c5a9a18b3c6.png

ici le profil 1 est actif (il est en surbrillance), le profil 2 est non activable (la coche de droite est off) et enfin le profil 3, bien qu'activable, est inactif (pas en surbrillance)

La couleur de surbrillance dépend du thème choisi pour Tasker bien entendu. Dans ton cas aucun des 3 profils n'est actif.

Reste maintenant à comprendre pourquoi.

Tu peux poster la description d'un profil pour comprendre: appui long sur son nom, menu -> "exporter" -> description dans email?

Le menu "partager" d'Android va apparaître et permettra d'envoyer la description en format lisible vers une autre application (comme Google Keep par exemple) pour la récupérer en format texte.

Sinon, exporter directement dans le presse-papier est aussi possible directement.

Pas utile de publier les 3, mieux vaut procéder par petites étapes.

Share this post


Link to post
Share on other sites

désolé de m’être mal fait comprendre !! je pensais que le fait d'avoir le profil sélectionné comme activable donc, (photo 2), était actif.!!! 

j'édite le message des que je retourne à ma voiture !!!! merci de m'aider en tout cas . :)  :)  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.