Jump to content
CoolRaoul

Tasker: aide,infos,creation de profils

Recommended Posts

Citation

Je pensais que le fait d'avoir le profil sélectionné comme activable donc, (photo 2), était actif.!!! 

Faut bien comprendre (sinon Tasker n'aurait aucun intéret) que les profils s'activent *automatiquement* dès que les conditions qui leur sont attribuées deviennent activent.

Exemple extrêmement basique:

  • condition : écran allumé
  • actions:
    • entrée: activer le wifi
    • sortie: désactiver le wifi.

 

NB: le fait d'avoir une action/tache de sortie, ("exit task" en anglais), est facultatif. Mais bon c'est pas l'endroit ici pour faire un tutoriel complet sur Tasker, ça se trouve facilement sur le net (plus facilement en Anglais toutefois je suppose)

Share this post


Link to post
Share on other sites
Alors, voilà un profil créé sur mon autoradio :
Profil : Cpu (9)
     Priority: 0 Notification: no
     Etat: Bluetooth connecté [ Nom:OPPO Find X Adresse:B4:CB:57:14:E7:F6 ]
    Entrée: Cpu On (8)
     A1: Charger une appli [ App:Cpu Monitor Donnée: Exclure des applis récentes:Désactivé Toujours démarrer une nouvelle copie:Désactivé ] 
    
    Sortie: Cpu Off (4)
     A1: Tuer une appli [ App:Cpu Monitor Utiliser root:Désactivé ]
 

 

t'en penses quoi ?

Share this post


Link to post
Share on other sites
Citation

t'en penses quoi ?

Si le profil ne s'active pas c'est que Tasker ne détecte pas la connexion bluetooth du téléphone (est-il bien connecté au moins?)

Tu peux éventuellement désactiver le filtre sur l'adresse MAC (laisser le champ vierge), il ne sert qu'a cibler de façon un peu plus spécifique le téléphone.

Pour avoir une visualisation de l'activation du profil, tu peux ajouter une alerte "popup" ("alert" -> "flash" en anglais) en début de la tache "Cpu On" et connecter/déconnecter le bluetooth du téléphone et voir si ça réagit.

En dehors de ça j'ai pas d'autre idée

Au passage, faut savoir que la fonction "tuer une appli" à peu de chance de marcher, en particulier sans le root.

 

Share this post


Link to post
Share on other sites

Ok je vais essayé ça.

Le Bluetooth est bien connecté puisque c'est la même condition qui établie le partage de connexion.. Enfin, le partage de connexion, c'est sur tasker de mon téléphone. Mais si tasker voit la connexion Bluetooth du tel à l'autoradio, ça marche aussi ds l'autre sens non ? (de plus, j'ai bien ma liste de contact pour les appels sur l'autoradio).

Sinon, faudrait que je change la condition de démarrage de l'appli. Vu que waze s'allume des le démarrage de l'autoradio (c'est une option ds les paramètres de l'autoradio) je pourrais dire que des que waze est démarré, une autre appli démarre. Comment je fais ? Je commence par "état"?

 
Edited by thierry34

Share this post


Link to post
Share on other sites
Quote

si tasker voit la connexion Bluetooth du tel à l'autoradio, ça marche aussi ds l'autre sens non ?

C'est pas le même Tasker (celui du téléphone VS celui de l'autoradio), donc on ne peut rien déduire. 

Quote

 j'ai bien ma liste de contact pour les appels sur l'autoradio).

Sauf erreur de ma part ca signifie que les contacts ont été synchronisés à un moment donné, pas que la synchro bluetooth est active au moment même.

Quote

c'est la même condition qui établie le partage de connexion

Ce ne peut pas être *exactement* la même condition: dans le cas ce Tasker-là, les paramètres "Nom" et "Adresse" du profil "Bluetooth connecté" doivent correspondre aux  caractéristiques bluetooth de l'autoradio au lieu de ceux du téléphone.

Share this post


Link to post
Share on other sites

Ce ne peut pas être *exactement* la même condition: dans le cas ce Tasker-là, les paramètres "Nom" et "Adresse" du profil "Bluetooth connecté" doivent correspondre aux  caractéristiques bluetooth de l'autoradio au lieu de ceux du téléphone.

 

Sur l'autoradio, la condition, c'est la connexion Bluetooth du téléphone. Il trouve bien le téléphone quand il me montre les choix.

J'ai essayé de faire une condition pour allumer l'appli "cpu" quand waze est ouvert, mais je ne sais pas quoi mettre. Je dois commencer comment pour la condition ?

 

 
Edited by thierry34

Share this post


Link to post
Share on other sites
Quote

J'ai essayé de faire une condition pour allumer l'appli "cpu" quand waze est ouvert, mais je ne sais pas quoi mettre. Je dois commencer comment pour la condition ?

Pour ça il faut utiliser un profil de type "application" et sélectionner "Waze" dans la liste.

 

Share this post


Link to post
Share on other sites
Le 02/11/2019 à 18:26, CoolRaoul a dit :

Pour ça il faut utiliser un profil de type "application" et sélectionner "Waze" dans la liste.

 

Slt, je viens d'essayer cette condition là, mais si je sélectionne "waze" ds l'application et que ds le profil je mets "démarrer l'app cpu", au démarrage de waze, tasker me remplace waze par l'application cpu !! Donc pas bon... Why ?

Share this post


Link to post
Share on other sites

 Ce que tu cherchais à faire c'est, je te cite:

On 11/2/2019 at 5:41 PM, thierry34 said:

allumer l'appli "cpu" quand waze est ouvert

Et ce que tu constates et:

3 hours ago, thierry34 said:

au démarrage de waze, tasker me remplace waze par l'application cpu

Dès que Waze est ouvert, la condition du profil devient active, et donc cette fameuse appli "CPU" démarre.

Ca fait bien ce que tu demandais non ? 

Share this post


Link to post
Share on other sites
Il y a 1 heure, CoolRaoul a dit :

 Dès que Waze est ouvert, la condition du profil devient active, et donc cette fameuse appli "CPU" démarre.

Ca fait bien ce que tu demandais non ? 

oui , tout à fait. faut que je vérifie mais l'icone waze est remplacée par celle de cpu ds la barre de notif .. j'ai pas vérifié si waze était encore ouvert :( :( :) :) (je vérifie ça dés demain !!! )

en admettant que waze soit toujours ouvert , comment je demande a tasker qu'une fois l'appli cpu ouverte , de retourner sur l'écran de waze ? 

Share this post


Link to post
Share on other sites



en admettant que waze soit toujours ouvert , comment je demande a tasker qu'une fois l'appli cpu ouverte , de retourner sur l'écran de waze ? 
ca devient très compliqué la, si on ajoute un profil qui lance Waze (ce qui revient à le faire passer au premier plan) des que cette appli CPU est active, tu dois bien imaginer que ça va boucler à l'infini.
Ajouté à ça le fait que tu dois à chaque fois retourner dans ta voiture pour tester chaque modification je ne vois pas le bout du tunnel.

Ça serait quand même plus simple que la détection du bluetooth fonctionne sur l'autoradio mais hélas je n'ai plus de piste à proposer la non plus.

Share this post


Link to post
Share on other sites
il y a 15 minutes, CoolRaoul a dit :


 

ca devient très compliqué la, si on ajoute un profil qui lance Waze (ce qui revient à le faire passer au premier plan) des que cette appli CPU est active, tu dois bien imaginer que ça va boucler à l'infini.
Ajouté à ça le fait que tu dois à chaque fois retourner dans ta voiture pour tester chaque modification je ne vois pas le bout du tunnel.

Ça serait quand même plus simple que la détection du bluetooth fonctionne sur l'autoradio mais hélas je n'ai plus de piste à proposer la non plus.

waze n'est pas lancé par tasker. il y a un parametre de l'autoradio qui permet de lancer le gps au démarrage de l'unité. (appli gps que l'on choisit). pour ça que j'avais pensé à cette condition pour démarrer cpu. Mais comme je veux waze toujours à l'écran ...

autre piste que je testerai demain, la condition de l'alimentation. j'ai vu que ça y étais ds les conditions du profil. (état -> alimentation). en mettant une attente de temps, le temps que l'unité charge waze, se connecte au tél etc etc .. peut etre que ça pourrait le faire .

merci pour ton aide en tout ças. (c'est clair que c'est pénible de devoir descendre a la voiture a chaque fois lol !! surtout que j'habite ds une grande residence ...)

Share this post


Link to post
Share on other sites

je viens de tester autre chose. J'ai créé un profil dont la condition est que les taches s'exécutent si le bluetooth est activé sur l'autoradio. (vu qu'il s'active [color=red]qd[/color] il voit mon téléphone).

du coup, j'ai créé mes taches, ouverture de l'appli de la daschcam et ouverture de l'appli cpu,avec une attente de 15 secondes au démarrage de l'autoradio,le temps que le bluetooth soit actif et un retour à la page d'accueil pour finir.

Le truc, c'est qu'a l'allumage de l'autoradio,Tasker est bien ouvert, le profil créé est bien en vert ainsi que la tache ,mais rien ne se passe .Or ,si je vais dans Tasker, que je vais dans la tache que je viens de décrire et que je fais le test (play en bas à gauche) ,ben ça fonctionne nickel !!!!! et j'ai bien toute les icones des applis ouvertes suite au test dans la barre de notif !!!!

un truc bloque au démarrage de Tasker [color=red]qd[/color] l'autoradio s'allume.. Mais quoi ??? that is the question !!! 

Share this post


Link to post
Share on other sites
De retour
https://www.reddit.com/r/tasker/comments/f47lsk/tasker_removed_from_google_play/
Google dégaine à vue sans prévenir les devs... de moins en moins cool et de plus en plus evil
Google file un mauvais coton.
Il commence à piéger les webmaster avec ses api soit disant gratuites et dès le dépassement de quota envoie la facture.

Envoyé de mon SM-N950F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Bonjour à tous, Merci pour ce topic, qui est fort intéressant .

J'ai un petit problème que je n'arrive pas à résoudre:

J'ai créé un profil, qui ne s'exécute, que si l'écran est déverrouillé(je ne parle pas du code PIN ou autre, mais de "faire glisser le doigt pour déverrouiller").
Je ne trouve pas comment faire avec Tasker pour que ce "faire glisser le doigt pour déverrouiller", se fasse automatiquement.

Je pensais trouver la solution avec secure setting, mais sauf erreur de ma part, l'option ne semble pas être proposée. Avez-vous une idée s'il vous plaît ? Merci par avance pour votre aide, et bonne journée.

Envoyé de mon SM-N950F en utilisant Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...