Le forum a été mis à jour! (lire la suite...)
chioubaca

Rooter Xperia SP ?

22 posts in this topic

Salut,

Je viens de recevoir mon Xperia SP et j'aimerai savoir si il existe une méthode pour le rooter ?

J'ai cherché vite fait sur le net mais j'ai trouvé que des articles fake, j'ai l'impression qu'il n'y a pas encore de méthode mais peut-être que j'ai mal cherché :P

Share this post


Link to post
Share on other sites

Dans la logique, il faudrait suivre ceci

http://forum.xda-developers.com/showthread.php?t=2272741&page=3

Tout en débloquant le bootloader comme indiquer ici

http://unlockbootloader.sonymobile.com/instructions

Mais j'attends des retour sur des forums français pour vraiment me lancer (je reste un poil septique vis a vis de la localisation)

Share this post


Link to post
Share on other sites

J'ai acheté mon Sony aux US, du coup la localisation me semble pas un problème.

Je vais tenter cette méthode et je ferai quand j'aurai un peu de temps.

Share this post


Link to post
Share on other sites

J'ai acheté mon Sony aux US, du coup la localisation me semble pas un problème.

Je vais tenter cette méthode et je ferai quand j'aurai un peu de temps.

Regarde juste déjà si tu peux dévérouiller ton bootloader

Quand vous dites que le bootloader est bloqué? c'est à dire qu'il est écrit Bootloader unlock allowed: NO quand vous allez dans Service info puis configuration dans la ligne tout en bas Rooting status? (ce menu est dispo en tapant ∗#∗#7378423#∗#∗ dans le dialer)

Share this post


Link to post
Share on other sites

Bootloader dévérouillé sans problème en suivant les instructions du site de Sony.

Je ferai un retour sur la procédure de root dès que j'aurai toruvé du temps pour la faire ^_^

Slainou likes this

Share this post


Link to post
Share on other sites

Mon tel est maintenant rooté, j'ai utilisé la commande fournie sur XDA (voir plus haut le message de Feodark) et tout s'est passé nickel.

Pour info mon modèle est le C5302

J'ai une question par rapport à ça: je viens de voir qu'il y a plusieurs versions (C5302, C5303 et C5306) et la mienne est surnommée HSDPA ==> ça veut dire que je n'aurai pas la possibilité de me connecter au réseau 4G en France ?

Share this post


Link to post
Share on other sites

Oui malheureusement la 4G c'est pour la version C5303 il me semble

Tu l'as acheté ou ton téléphone?

Share this post


Link to post
Share on other sites

salut tous le monde,

es ce que une personne aimable :P pourrais faire un petit tuto pour pouvoir root cette merveille?

Je vous remercie d'avance.

Share this post


Link to post
Share on other sites

Salut Wok et jeromedu59,

De ce que j'ai pu voir, pour le moment seul les modèles C5302 (qui sont des modèles US et asiatiques pour la plupart) ont été rooté. Le C5303, qu'on achète chez nous, pas encore. D'ailleurs chioubaca, sur ce topic, qui l'a fait, a un modèle US.

Donc pour le moment, je pense pas qu'il y aura un tuto, car ça ne concerne pas nos modèles de télépones. Car si on en fait un, que pleins de gens se lancent à le faire, sans lire que c'est réservé aux modèles C5302, il y en a qui vont pleurer! (risque de bricker leur téléphone, etc..)

Vaudrait mieux attendre d'avoir des retours avant de se lancer dans un tuto ^^

Edited by Slainou
murdoc575 likes this

Share this post


Link to post
Share on other sites

Tu l'as acheté ou ton téléphone?

Sur ebay mais j'avais pas fait attention qu'il existait une version 4G et une version non-4G de ce tél. Bon ça m'apprendra à faire plus attention...au moins j'ai pu le rooter directement :x

Pour dévérouiller le bootloader c'est assez simple. En ce qui concerne ça http://forum.xda-dev...=2272741&page=3 J'y comprends rien de rien.

Si tu es parvenu à dévérouiller le bootloader c'est que tu as exécuté la commande

fastboot.exe -i 0x0fce oem unlock 0xKEY'

Pour rooter (ATTENTION la commande ci-dessous n'a été testée qu'avec un SP C5032) il faut faire quasiment la même chose mais à la place c'est la commande

fastboot flash boot kernel.elf

(où kernel.elf est le fichier téléchargeable sur la page XDA dont tu cites le lien)

Edited by chioubaca

Share this post


Link to post
Share on other sites

Bonjour à tous, j'aimerai bootloader mon Xperia SP mais j'ai un problème à l'étape 13. Au moment où je branche mon téléphone au PC et que j'appuie sur le bouton volume haut en même temps, la diode en bas du téléphone est bleue quelques secondes. Seulement qu'aussi bien sous Win 7 que 8, il ne me demande pas les drivers, il les trouve automatiquement. Ce qui fait que lorsque je tape la commande fastboot, j'ai un "waiting for device", car il ne trouve pas mon téléphone. Je suppose que mon erreur doit être toute bête car j'y suis presque. A savoir que j'avais bootloadé mon Xperia Play sans problème à l'époque.

Merci d'avance pour votre aide !

Share this post


Link to post
Share on other sites

Bonjour à tous, j'aimerai bootloader mon Xperia SP mais j'ai un problème à l'étape 13. Au moment où je branche mon téléphone au PC et que j'appuie sur le bouton volume haut en même temps, la diode en bas du téléphone est bleue quelques secondes. Seulement qu'aussi bien sous Win 7 que 8, il ne me demande pas les drivers, il les trouve automatiquement. Ce qui fait que lorsque je tape la commande fastboot, j'ai un "waiting for device", car il ne trouve pas mon téléphone. Je suppose que mon erreur doit être toute bête car j'y suis presque. A savoir que j'avais bootloadé mon Xperia Play sans problème à l'époque.

Merci d'avance pour votre aide !

essai d'activer le mode debug sur le tel

Share this post


Link to post
Share on other sites

Non ça ne change rien, merci pour l'info quand même. Juste une petite précision, une fois que la diode bleue s'éteint, elle passe au rouge puis orange, pour indiquer que le tel est sous tension et qu'il charge. Je ne sais pas si ça peut aider...

J'ai essayé pour le peu de laps de temps que j'ai quand la diode est bleue de mettre le driver de S1Fastboot (c'est comme ça que le téléphone est reconnu quand la diode est bleue), mais le driver sélectionné, à savoir celui fourni par Sony ne fonctionne pas...

Merci d'avance.

Edited by LtBlight

Share this post


Link to post
Share on other sites

bonjour

J’aimerais de l'aide car j'ai allumé mon xperia sp et en bas à gauche de mon écran il y a marque "mode sécurisé"

j'y connais rien merci d'avance

Share this post


Link to post
Share on other sites

Bonsoir les amis,

J'ai un C5303 acheté chez Orange avec Bootloader verrouillé et non déverrouillable. Je n'arrive pas à trouver comment le rooter. Une idée ?

Pour les C5302, il y a un tuto. Je voudrais pas flasher mon C5303 avec une ROM de C5302.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now