Jump to content

Probleme avec le clavier physique


MrGreez94
 Share

Recommended Posts

Bonjour,

Depuis le dernier root de mon xperia pro (supposition) les touches du clavier physique ne correspondent plus à ce qui s'affiche bien que je sois bien en azerty et que layout associé ne semble pas avoir subit de modifications.

Pour exemple

le "m" du clavier affiche une virgule et c'est le cas pour plusieurs touches, auriez vous une solution ?

Merci d'avance :)

Link to comment
Share on other sites

J'avais vu mais ce qui m'intrigue c'est que dans le keyprint de mon téléphone, il y a bien marqué :

<Script name= "latin" keylayout= "azerty" />

donc le problème ne vient pas de là, je suis donc directement allé voir le layout "azerty" et toujours aucun problème:

par exemple pour le "m", il y a bien <Key id= "C3.7" data= "m" /> mais ça m'affiche quand même une virgule :(

Si tu pouvais donc me fournir le layout azerty, cela règlerait peut-être le problème qui sait ? ce n'est qu'une supposition

P.S: j'ai essayé de remplacé le keyprint, sans succès :(

Edited by MrGreez94
Link to comment
Share on other sites

C'est le numéro de série sous la batterie sous le forma xxxx-xxxx. Si vous êtes correctement rooté, root explorer doit vous attribuer les droits sur les fichiers et vous laisser les changer. Pouvez-vous le faire sans avertissements ou messages d'erreurs ?

Link to comment
Share on other sites

Eh bien, à part une demande d'autorisation provenant de super-user, je n'ai rencontré aucun problème. J'utilise d'ailleurs plusieurs applications demandant l'accès au root et ces dernières fonctionnent parfaitement.

J'essaie à tout prix d'éviter de "réparer" mon téléphone via pc companion mais il me semble que c'est la dernière option qu'il me reste malheureusement. Je suis néanmoins toujours preneur quant à d'autres hypothèses.

Edited by MrGreez94
Link to comment
Share on other sites

Donc à priori, c'est tout bon pour le root. Avez-vous tenté d'effacer et copier le keyprint en dernier ressort ?

Si vous avez flashé la rom intégralement dans la procédure de root, votre SI ne sera pas le même que celui de votre mobile à la base. La réparation vous réinstallerait probablement le clavier en qwerty.

Link to comment
Share on other sites

Je viens de regarder le SI inscrit derrière ma batterie, c'est le suivant 1249 5155.

Sinon en ce qui concerne le réparage, j'ai déjà eu à le faire car il y a justement eu des problèmes lors du rootage car je m'y prenais mal, il me semble que cela à ramener le clavier à son état originel donc je suppose que cela pourrait fonctionner mais je perdrai aussi le root par la même occasion donc j'essaie d'éviter.

Link to comment
Share on other sites

J'ai trouvé le fichier en question, pourriez vous m'indiquer où se situe plus précisément le SI car je ne trouve pas, où plutôt je n'ai pas reconnu le SI de mon téléphone parmi les différentes informations ?

Je crois l'avoir trouvé,

ro.product.name=MK16i_1250-1387

Serait-ce les 8 derniers chiffres ? Si oui il ne correspond pas au SI de mon téléphone...

Edited by MrGreez94
Link to comment
Share on other sites

Effectivement, c'est le SI de la rom Central Europe, et pas de la rom france. Vous avez donc flashé la rom entière et pas juste le kernel.

Si vous n'êtes pas trop sur de vous et que vous voulez revenir sur la ROM France sans vous casser la tête à un moment ou un autre, il est bon de songer à Wotan. Le service de flash coûte 2€, mais vous pouvez choisir la rom que vous désirez flasher et être sur d'avoir le bon SI et clavier pour votre Xperia.

Link to comment
Share on other sites

Ce qui est étonnant c'est que je l'avais déjà rooté il y a un moment et ce sans aucun problème. Comme je l'ai formaté pour lui refaire une petite jeunesse, j'ai du le rooter à nouveau et c'est à ce moment là que le problème est survenu, c'est étrange...

Link to comment
Share on other sites

  • 2 weeks later...

Au cas où des gens auraient le même problème, je tenais juste à dire que tout est réglé de mon côté, c'est juste swiftkey qui gère mal le clavier physique apparemment. Plus de peur que de mal :lol:

Link to comment
Share on other sites

je l'avais rooté avec la méthode décrite dans ce forum pour la mise a jour vers ICS (la première). J'avais le probleme de clavier qwerty mais avec ghost commander j'avais réussi a éditer le fichier systeme

Ensuite j'ai fait très récemment la derniere mise à jour de façon classique (avec PC compagnion) et visiblement ça a fait sauter le root + j'ai le probleme du clavier en qwerty qui est revenu

Link to comment
Share on other sites

Vous aviez du flasher la rom totalement et pas juste le Kernel. De ce fait, votre SI a du changer, et du coup vous ne flashez plus la rom française.

Deux solutions : refaire le rootage (cette fois la rom est un dump d'une rom française pour sûr vu que ça vient de mon SEUS) et recopier le fichier keyprint, ou passer par Wotan pour forcer le flash d'une rom France.

Link to comment
Share on other sites

ok alors je fais refaire le rootage.. :(

EDIT : c'est bon le téléphone est rooté et j'ai pu modifier le fichier keyprint, le clavier est désormais en azerty merci ;)

Edited by xelan
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...