Jump to content
sonor

[eZee'Tab 1003] ]Problème avec applications "Votre appareil n'est pas compatible avec cette version"

Recommended Posts

Bonjour/bonsoir

J'ai eu pour cadeau récement une tablette "Ezee tab 1003" de Storex, comme il n'y avait pas le google play store d'installé dessus j'ai regardé sur votre forum comment l'installer, je suis tombé au depart sur une methode avec une application "old market" qui a bien fonctionné.

Ensuite j'ai lu dans un sujet plus récent qu'apparement avec cette méthode tout n'était peut etre pas installé au bon endroit, et que l'on puvait installé une MAJ avec livesuit "1001 playstore" qui permet d'avoir le playstore "proprement".

Apres avoir "flashé" la tablette, tout fonctionne bien avec le playstore d'installé par defaut, mais en voulant re-télécharger toutes mes applications, je me suis aperçu qu'ils y en avaient que je ne pouvais plus installer, avec ce message d'affiché en description "votre apppareil n'est pas compatible avec cette version", alors qu'avant l'avoir flashé ces applis étaient disponible et fonctionnels (Caisse d'epargne, showroom privée, vente privée, pôle emploi).

- J'ai contacté STOREX pour avoir le fichier d'origine de la tablette 1003 et la remettre comme je l'ai eu au départ mais ils m'ont donné le même fichier qui est dispo sur le forum ici (le fichier hebergé par uploading) que j'ai deja utilisé.

- j'ai essayé de changer la résolution (DPI 160 à 120) sans succès

- j'ai effacé les donnés et forcé l'arret des applis play store et framework, ensuite avec "es explorer" remplacé 4 fichiers xml se trouvant dans system/etc/permissions et reboot la tablette sans succés

Si vous avez d'autres solutions je suis preneur.

Merci et à bientôt.

Edited by sonor

Share this post


Link to post
Share on other sites

Bonjour - donne-nous le lien web exact vers une de ces applis dans le Play Store STP, que j'aille voir dans l'APK ce qu'elle réclame pour être compatible.

Peux-tu également mettre dans un fichier zip les fichiers suivants :

/system/build.prop

/system/etc/permissions/*.xml (tous les fichiers .xml, donc)

puis l'attacher à ton message ou l'uploader vers un hébergeur gratuit (Mediafire etc.) et mettre le lien ici

Je vois quand même un problème dans l'ordre des actions : il faut faire un clear data+cache de Google Play + Google Services Framework après avoir remplacé les fichiers, puis reboot.

  • Like 1

Share this post


Link to post
Share on other sites

Bonsoir

Voici le lien pour l'application caisse d'eparne "banque pour tablette android" https://play.google....nRhYmxldHRlIl0.

et voici le fichier zip ici, je l'ai egalement mis en fichier joint, juste pour info par rapport au fichier build.prop j'ai modifié la ligne product.model=eZee'Tab1001 en product.model=eZee'Tab1003, je l'ai fait après avoir remarqué que l'appli n'était pas compatible.

En tout cas merci pour la réponse, et je vais tester de refaire dans l'ordre l'opération pour remplacer les fichiers xml.

Edited by sonor

Share this post


Link to post
Share on other sites

Hmmm... j'ai pu installer l'appli sans problème sur une tablette no-name chinoise avec son firmware d'origine (celle que j'avais sous la main ce matin). C'est curieux... à moins que ce soit un problème de version ? es-tu en 4.0.4 ? (ma tablette générique est en 4.0.3).

En regardant l'APK de l'application on ne trouve rien de bien remarquable, voila les permissions qu'elle utilise :

<uses-permission android:name="android.permission.READ_CONTACTS" />
<uses-permission android:name="android.permission.WRITE_CONTACTS" />
<uses-permission android:name="android.permission.INTERNET" />
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

Donc pas de Bluetooth requis (qui manque dans ton tablet_core_hardware.xml), elle demande la localisation qui ne devrait pas poser de problème d'après ton fichier. Aussi internet, bon, ça... je ne vois que la gestion des contacts qui pourrait être un souci ? les permissions sont bien définies dans ton platform.xml, mais les applis sont-elles là ?

As-tu un fichier /system/app/ContactsProvider.apk ?

Quant au build.prop, ma tablette chinoise a ceci dans les lignes concernées :

ro.product.model=A710
ro.product.brand=BRONCHO
ro.product.name=crane_a710
ro.product.device=crane-a710
ro.product.board=crane
ro.product.manufacturer=unknown
ro.build.product=crane-a710
ro.build.description=crane_a710-eng 4.0.3 IML74K 20120409 test-keys
ro.build.fingerprint=BRONCHO/crane_a710/crane-a710:4.0.3/IML74K/20120409:eng/test-keys

On ne peut pas vraiment dire qu'elle essaye de se faire passer pour ce qu'elle n'est pas :) (c-a-d pour une tablette de marque)

Edited by Lannig
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour Lannig,

C'est curieux... à moins que ce soit un problème de version ? es-tu en 4.0.4 ?

Oui je suis bien en 4.0.4

As-tu un fichier /system/app/ContactsProvider.apk ?

Oui j'ai bien le fichier /system/app/ContactsProvider.apk, mais pour le reste je t'avoue que je ne comprends pas trop car je ne suis pas connaisseur dans le domaine,

les permissions sont bien définies dans ton platform.xml, mais les applis sont-elles là ?

Je ne sais pas comment vérifier, peux tu me dire comment faire STP?

Share this post


Link to post
Share on other sites

Je n'avais pas vu cela la première fois dans le manifest de l'appli :

<uses-library android:name="com.google.android.maps" />

As-tu Google Maps installé sur ta tablette ? si non, installe-le.

Share this post


Link to post
Share on other sites

Bonsoir,

Je ne l'avais pas, je l'ai installé mais les applications concernées ne sont toujours pas compatible, voici les liens vers les autres applis qui ne sont également pas compatible , si cela peut aider dans la vérification:

vente privée

pole emploi

showroomprivé

Edited by sonor

Share this post


Link to post
Share on other sites

@Antepli49 : ton post a été supprimé. Ici c'est la section des tablettes Storex. Merci de poster dans la section du Galaxy Ace.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...