Jump to content

Donnée capteur


Recommended Posts

Bonjour,

 

L'écran de mon HOX ne veut pas s'incliné en paysage.

J'ai du coup téléchargé phone tester, pour essayer sensors status et la aucune donnée !!!

Accelerometer

(vide)

 

Gyroscope

Waiting for data...

 

Compass

Waiting for data...

 

Magnetic field sensor

(vide)

 

 

Quand je clique sur Properties (accelerometer) j'obtiens

Name: MPL accel

Vendor: invensense

Version: 1

Power: 0,5mA

Range: 10240.0

Resolution: 0,5

 

Je me demandais si il me manqué juste pas un ou plusieurs fichier qui ferais fonctionné les capteurs ?

Y a t-il une solution ? 

J'espère évité le S.A.V.

 

Merci de votre aide.

Link to comment
Share on other sites

perso j'avais utilisé celle-là d'appli plutôt >> https://play.google.com/store/apps/details?id=zausan.zdevicetest&hl=fr

 

tu es sous quelle ROM?

car sur ROM stock le mode paysage est bloqué sur l'écran d'accueil normalement.

pour l'accéléromètre il y a un truc tout kon a tester sinon ; c'est l'appli teeter (tu sais la bille qu'il faut mettre dans le dernier trou sans la faire tomber) qui est d'origine sur le tel si mes souvenirs sont bons

Link to comment
Share on other sites

Oui j'avais teeter mais rien ne fonctionnait.

J'étais sous rom stock, les capteurs ne fonctionnaient pas puis j'ai vu que la prochaine mise à jour se ferais fin août j'ai donc rooté mon HOX avec la rom cyanogenmod 10.1 mais toujours aucun changement. Que se soit pour l'appareil photo, la galerie, les jeux, fin tout enfaîte :(

J'ai aussi z device test mais pareil aucune donnée, androsensor aussi, rien ne change ...

A noté aussi que quand je regarde une vidéo avec quickpic elle apparaît en portrait mais il est possible de la mettre en paysage. Et quand je reviens en arrière tout est en paysage....

Link to comment
Share on other sites

Ça m'avais fait pareil mais en ROM custom et ça venait d'une mauvaise manip de ma part mais là j'vois pas, tes photo sont a l'endroit ?car moi en plus elles pivotait.

Édit a j'ai mal lu, tu n'es plu en ROM stock donc fait un reset complet reflash ton boot.img et n'installe rien d'autre....

Link to comment
Share on other sites

Non j'ai remis les valeurs d'usines, puis dans le recovery factory reset, wipe cache.

Puis flash du boot. Mais toujours pas d'écran qui s'incline.

Il fonctionnait bien avant mais j'ai voulu installé l'appareil photo android 4.2 avec photosphère puis mes capteurs ne fonctionnaient plus.

C'es pourquoi je me demande si il suffit pas juste d'installé un fichiers avec les bonnes données pour les capteurs.

Link to comment
Share on other sites

Ahahaha  :P  et tu connais pas la solution ? 

J'ai déjà eu le problème,mon HOX avait buggé puis redémarré et tout c'est remis d'origine.

Quelque jour après j'ai fais une mise à jour vers 3.20 et depuis rebelote impossible de faire fonctionné les capteurs.

Link to comment
Share on other sites

Les photos ? 

Mais je me demande toujours si il me manque juste pas un fichiers avec les données.

Parce que quand j'avais utilisé g-sensor l'étalonnage c'est fait correctement.

Mais l'écran ne s'incline pas. Quand j'utilise z-device test, je n'ai pas de valeur x,y,z.

Link to comment
Share on other sites

Ah d'accord, et tu connais pas une autre solution ? J'ai effacé toute les données mais rien n'y fait.

Ne faut il pas simplement installé un dossier dans le fichier sys/devices/virtual ?

Un dossier avec des données qui ferait fonctionné les capteurs ? 

Link to comment
Share on other sites

Ha mais je pari gros sur le fait que c'est matériel hein , si tu as fais une install clean avec le bon boot.img et tout je ne pense pas que ce soit logiciel.

Tu as eu utilisé un kernel overclocké auparevant ?

Ha oui au fait, tu n'aurais pas un backup de quand ça fonctionnait desfois ?car moi c'est ça qui me faisait pensait que c'était logiciel vu qu'avec le backup ça remarchait nikel

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...