Jump to content

Downgrader de 2.2 Froyo Officiel à 1.5


Nahayiah
 Share

Recommended Posts

Bonjour à tous,

Je sais que je risque de me faire taper sur les doigts car le sujet dont je vais parler a sans doute été traité notamment dans les topics suivants :

Mais bon je tente le coup car personnellement, j'ai pas eu la réponse à mon problème :

Voilà, j'ai récemment acquis un LG GW620 orange,

j'ai suivi le tuto suivant pour remettre une rom nue : http://mountainview.frandroid.com/topic/4582-tuto-mettre-rom-officielle-lg/

Ce qui a marché nickel, je suis retombé en V10C toujours avec le micrologiciel en 1.5

Ensuite, j'ai mis à jour le téléphone avec l'application LG Mobile Update jusqu'en V10G je crois,

puis j'ai passé le téléphone en froyo officiel 2.2 en utilisant le fichier cab 2.2-fb du tuto suivant :

en utilisant la méthode utilisé pour remettre une rom nue du tuto suivant : http://mountainview.frandroid.com/topic/4582-tuto-mettre-rom-officielle-lg/

Pour info, j'ai fais le teste pour verifier la présence de fastboot et j'obtiens bien en démarrant touche espace enfoncé par le cable les lignes suivantes sur l'écran :

USB fastboot:V0.5

Machine ID:3003 v

Build Date:Dec 31 2009, 14:32:48

Serial number: unknown

Après avoir gouter à Froyo je préfère revenir à la rom Officiel 1.5 de base pour de multiples raisons, donc j'ai essayé de rentrer le code qui permet d'accèder à la fonction Enable Root Acess mais il ne marche plus et si je suis le tutoriel pour remettre la rom nue le processus plante avant l'accès au téléphone.

Est ce que quelqu'un aurait une idée pour m'aider dans ma démarche ? Je sais que c'est possible puisque de nombreuses personnes le disent mais comment ?

Merci d'avance.

Link to comment
Share on other sites

Je sais pas si c'est à moi que tu parles, mais je suis revenu en 1.5 pour renvoyer mon téléphone au SAV. Plus ça va, moins je me vois sur autre chose qu'OpenEtna. Sur la 1.5... y a plus rien qui marche ! Il manquerait trop d'appli que j'ai en 2.2. Quand à la 2.2 officielle, je suis sur Bouygues et y a pas les SMS, donc out.

Si tu te tates à passer en 2.2 OpenEtna, les meilleurs perf sont sur la version 6.1rc5 (inconvéniant : wifi instable chez certain, pas de camera video, appareil photo bloqué à 3mp), et le panel de fonctionnalité est plus large sur la 6.3rc7 (au detriment de performance brut). J'ai choisi d'etre sur la 6.3rc7 pour 1) être à la page! 2) avoir tout qui fonctionne, même si certaines apps mettent parfois 2s de plus pour se lancer.

Link to comment
Share on other sites

La dernière fois que j'ai voulu revenir en rom nu, j'ai fait :

récupérer une rom 1.5 nimporte laquelle (vodafone v10e : http://www.n2k1.openetna.mayix.net/firmware/VF_v10e.rar)

la flasher avec fastboot

puis refaire le tuto pour la rom nue LG

vala !

Si je ne dis pas de betises (ecaheti nous confirmera ca ;) ) :

- tu recuperes le fichier donné par ecaheti et tu le decompresses sur ton disque dur afin d'extraire les fichiers system.img et boot.img

- tu suis les indications suivantes :

-Connectez votre téléphone au PC en mode fastboot.

-Ensuite, on efface toutes données:

fastboot-w

-Dans le dossier des outils de votre installation SDK, décompressez le fichier téléchargé depuis le serveur de N2k1 (le mots de passe étant «openetna ')

-Maintenant, retour à la console, tapez:

fastboot flash boot boot.img

fastboot flash system system.img

Vous verrez OK dans les deux écrans, celui de votre téléphone et celui en votre PC.

Débranchez le téléphone et le redémarrer.

Je crois qu'il y a egalement une manip à faire pour reinstaller les applications google. Ecaheti pourra nous confirmer ce dernier point B)

Edited by JackInTheBox
Link to comment
Share on other sites

C'est tout à fait ça.

Pour les applis google, il convient de mettre le fichier gapps-mdpi-tiny-20101020-signed.zip (un coup de google pour le trouver) à la racine de la carte SD.

Comme la dernière version de OpenEtna à quelques soucis avec l'utilisation du téléphone en mode clé usb, je recommande de le faire AVANT de flasher.

Link to comment
Share on other sites

C'est tout à fait ça.

Pour les applis google, il convient de mettre le fichier gapps-mdpi-tiny-20101020-signed.zip (un coup de google pour le trouver) à la racine de la carte SD.

Comme la dernière version de OpenEtna à quelques soucis avec l'utilisation du téléphone en mode clé usb, je recommande de le faire AVANT de flasher.

Et ne pas oublier de faire la toute derniere etape ;-)

puis refaire le tuto pour la rom nue LG

vala !

Link to comment
Share on other sites

oula mais je me suis completement fourré de topic ! En fait on aurai rien du dire depuis le post numéro 4 !

quand on veu downgrader, pas besoin de s'emmerder avec les gapps et compagnie.

Je vais peut etre faire un tuto complet sur le downgrade à partir de 2.2 vers 1.5

Link to comment
Share on other sites

Hello à tous,

Me revoilà avec des nouvelles pas très réjouissantes.

1- j'ai réussi à remettre avec Fastboot une version vodafone trouvé sur ce tuto :https://forum.frandroid.com/topic/45744-tuto-remettre-le-firmware-de-base-android-15/

Malheureusement, après cela se gate méchamment :

J'essaie avec l'utilitaire KP500-utils-FR de flasher avec la rom V10C-00 et à chaque fois, ca plante le logiciel et me force à quitter.

A force d'acharnement, finalement, cela lance le flashage de la rom mais à 4% le téléphone passe en "Emergency Mode" puis la barre de progression stagne un temps (on entends deux sons windows), puis le logiciel dit que le téléphone n'est pas connecté et le flash est interrompu.

Vingt fois que je refais la manipulation et je craque.

Un peu d'aide serait la bienvenue car ce que j'ai vu sur les autres posts, c'est que les gens voyaient se résoudre tout seul le problème, sans raison apparente...

Link to comment
Share on other sites

Je précise que le téléphone me dit que la version est la V20G, cela pourrait il venir de cela ?

Voilà le log du logiciel :

[21:15:34:114] : =============================================

[21:15:34:114] : Log is started on 04.03.2011, at 21:15:34:114,

executable: C:\Users\Infocore\Desktop\LG-Utils-0.4.2\KP500-Utils-EN.exe (ProcID: 0x0000032c),

compile time : Oct 6 2009 09:34:45

[21:15:34:114] : Version : LGMobileAX Control

[21:15:34:130] : Get Usb Port

[21:15:34:130] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 1 - COM6

[21:15:34:130] : Port = COM6

[21:15:34:146] : >> DIAG_STATUS_F FAILED

[21:15:34:161] : >>Get Model Name [DIAG_VERNO_F]

[21:15:34:177] : strModel = KH5200

[21:15:34:177] : Read NV item: 71 NV ITEM 71 [71]

[21:15:34:192] : CSW

[21:15:34:192] : Banner : CSW

[21:15:34:192] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 0 - KH5200

[21:15:34:208] : Write NV item:9028 NV ITEM 9028

[21:15:34:208] : 9028 - NV_DONE_S Item

[21:15:34:317] : _DloadMode()

[21:15:34:317] : ¸Þ½ÃÁö º¸³¿ TYPE_WPARAM_CHANGE_DLOAD 4

[21:15:34:317] : >>Change Offline Mode [DIAG_CONTROL_F/Mode = 1]

[21:15:34:333] : >>Change Dload Mode [DIAG_DLOAD_F]

[21:15:34:333] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 3 - DLOAD

[21:15:34:333] : DIAG_DLOAD_F DLOAD_RESET_F do not wait for response

[21:15:34:333] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 3 - Close Port

[21:15:34:333] : Close Port<<

[21:16:14:347] : EMERGENCY Booting Mode

[21:16:14:347] : >>Get Model Name in Emergency Mode [DLOAD_VERREQ_F]

[21:16:14:362] : BS/GW620/8

[21:16:14:362] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 0 - GW620

[21:16:14:362] : >> GET DLOAD COMM MODE

[21:16:14:378] : [GetCommMode] Communication mode : 2

[21:16:14:378] : Pre Nand Download

[21:16:14:378] : >>Set Trusted Mode [DLOAD_NAND_SEC_MODE] sec_mode = 1 (1=trusted 0=NonTrusted)

[21:16:14:378] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 3 - TRUSTED MODE

[21:16:14:394] : [COM6] >>NandFlashInitWithFile(PARTITION TBL)

[21:16:14:394] : WM_COPYDATA ¸Þ½ÃÁö º¸³¿ 3 - INIT PARTITION TBL

Edited by Naha
Link to comment
Share on other sites

alors déjà prends ce lien pour le KP500-utils-FR http://www.assembla.com/spaces/ks360/documents/cCrKUYI_4r3QndeJe5afGb/download?filename=LG-Utils-0.4.2.zip et utilise bien le FR, comme je vois que tu as exécuter la version anglaise :)

executable: C:\Users\Infocore\Desktop\LG-Utils-0.4.2\KP500-Utils-EN.exe

et re teste, vu que tu as bien téléchargé la bonne version que j'avais mise sur mon tuto, le fastboot est donc bien présent, ensuite fais bien un fastboot-w avant toute chose, puis refais la manip.

puis le logiciel dit que le téléphone n'est pas connecté et le flash est interrompu

vérifie d'ailleurs que ton portable n'est pas en mode débogage et regarde le tuto de ecaheti ;)

Edited by s2ada
Link to comment
Share on other sites

  • 1 year later...

Bonsoir,

J'ai essayer cette méthode pour Downgrader d'une rom froyo 2.2 en 1.5 (V10C) Mais a 4% j'ai un message d'erreur et mon mobile redémarre. Quelqu'un aurait une Solution sa fait 3jours que je suis dessus pour downgrader :(

Link to comment
Share on other sites

Le bug du plantage à 4% est un grand classique. C'est du au soft LG qui rentre parfois dans une boucle infinie et qui fait tout planter :P

Grosso modo, à 4%, le soft LG tente de communiquer avec le téléphone et rentre parfois, comme je le disais, dans une boucle infinie.

Plusieurs solutions pour remédier à ce problème :

- redémarrer le PC et ne faire rien d'autre que la mise à jour.

- réinstaller les drivers du GW620

- réinstaller l'outil LG de mise à jour

Perso, je suis deja tombé plusieurs fois sur le bug du 4% et je m'en suis sorti à chaque fois en redémarrant le PC et en faisant immédiatement les manips pour la mise à jour B)

Link to comment
Share on other sites

D'accord je vais essayer tout sa et je vous tien au courant :)

Edit : J'ai essayer comme tu m'a dit mais sa fonctionne toujours pas

Voici l'erreur :

21:08:22 : ### Start Upgrade - 3GQCT ###

21:08:22 : ********* 3GQCT Model.dll input Parameter *************

21:08:22 : MODEL_EVENT : 32769

21:08:22 : PhoneBinaryPath : C:\ProgramData\LGMOBILEAX\Phone\TEST.dz

21:08:22 : ModuleDir : C:\ProgramData\LGMOBILEAX\Phone\

21:08:22 : BootWaitTime : 15000

21:08:22 : UsbHighSpeed : TRUE

21:08:22 : PhoneMode : 1

21:08:22 : NewPhoneBinVersion: V10C_00

21:08:22 : ClearSI : TRUE

21:08:22 : AuthMark : 12200

21:08:22 : ********* 3GQCT Model.dll input Parameter End *********

21:08:28 : wParam : 4, lParam = 0

21:08:28 : TYPE_WPARAM_DLOADCHANGE

21:09:08 : wParam : 3, lParam = 0

21:09:08 : TYPE_WPARAM_CDRIVEERASE

21:09:08 : wParam : 205, lParam = 0

21:09:08 : wParam : 100, lParam = 4008

21:09:08 : _DetachDLL Call

21:09:08 : _DetachDLL Call End

21:09:08 : TYPE_WPARAM_UPGRADE_ERROR Error Code = 4008

21:09:08 : Page_Error ºÎºÐÀÔ´Ï´Ù

21:09:09 : ¿©±â´Â Retry ºÎºÐÀÔ´Ï´Ù

Edited by azerty95400
Link to comment
Share on other sites

Si tu es en 2.2 officiel, que tu as reinstallé les drivers et le soft LG, il n'y a pas de raison que ca ne fonctionne pas

A la rigueur, si tu as un autre PC à ta disposition, essaie de le faire sur cet autre PC.

Perso, j'ai deja fait la manip sur des PC windows XP et Vista, et lorsque je tombais sur le bug du 4%, je rebootais la machine et ca marchais nickel

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...