Jump to content

Problème appel et réception en 2G


SteC

Recommended Posts

Ayant toujours mon problème mentionné dans >>>ce thread<<<.

J'ai entrepris de prendre des logs de l'activité du téléphone lors d'un appel et d'une réception d'appel en utilisant ma carte SIM de Bouygues et celle de mon épouse de chez Orange.

J'ai mis les logs anonymisées >>>ICI<<<

N'ayant pas les compétences pour analyser les différences, je lance donc un appel pour avoir une analyse de la situation, a vot'bon coeur ;)

Link to comment
Share on other sites

Dans un monde parfait tu aurais les logs de la seule fois où ça marche :) sur la bouygues pour pouvoir voir la différence :)

On va essayer de faire sans quand même ^^

Bon ça, déjà ça veut dire qu'il reçoit un appel et que tu es en 2G.

02/09/2010 12:44:49 [iNFORMATION] ActivityManager(1157) Starting activity: Intent { act=android.intent.action.MAIN flg=0x10840000 cmp=com.android.phone/.InCallScreen }

02/09/2010 12:44:49 [WARNING] UsageStats(1157) Something wrong here, didn't expect com.android.phone to be paused

02/09/2010 12:44:49 [DEBUG] PhoneApp(1207) mReceiver: ACTION_ANY_DATA_CONNECTION_STATE_CHANGED

02/09/2010 12:44:49 [DEBUG] PhoneApp(1207) - state: SUSPENDED

02/09/2010 12:44:49 [DEBUG] PhoneApp(1207) - reason: 2GVoiceCallStarted

02/09/2010 12:44:49 [DEBUG] PhoneApp(1207) setIgnoreTouchUserActivity(true)...

Entre temps tu as tout un blabla pour detecter si tu as un kit bluetooth..

La suite

2/09/2010 12:44:49 [DEBUG] CallCard(1207) updateRingingCall()...

02/09/2010 12:44:49 [DEBUG] CallCard(1207) displayMainCallStatus(phone Handler{44cc2f18}, call INCOMING)...

02/09/2010 12:44:49 [DEBUG] CallCard(1207) - call.state: INCOMING

02/09/2010 12:44:49 [DEBUG] CallCard(1207) updateCardTitleWidgets(call INCOMING)...

02/09/2010 12:44:49 [DEBUG] CallCard(1207) - getTitleForCallCard(Call INCOMING)...

02/09/2010 12:44:49 [DEBUG] CallCard(1207) ==> result: Appel entrant

02/09/2010 12:44:49 [DEBUG] CallCard(1207) updateCardTitleWidgets: Appel entrant

02/09/2010 12:44:49 [DEBUG] CallCard(1207) - CONN: incoming: true state: INCOMING post dial state: NOT_STARTED, state = INCOMING

02/09/2010 12:44:49 [DEBUG] CallCard(1207) - displayMainCallStatus: starting CallerInfo query...

02/09/2010 12:44:49 [DEBUG] PhoneUtils(1207) startGetCallerInfo: query already done, returning CallerInfo

Là, le tel a un appel entrant, il se prepare à te montrer l'appel et il choppe les infos de l'appelant.

02/09/2010 12:44:49 [DEBUG] InCallTouchUi(1207) - updateState: phone state is RINGING

02/09/2010 12:44:49 [DEBUG] InCallTouchUi(1207) - updateState: RINGING! Showing incoming call controls...

et là ton telephone sonne

il fait l'opération quelques fois

02/09/2010 12:45:38 [DEBUG] CallNotifier(1207) onDisconnect()... phone state: IDLE

02/09/2010 12:45:38 [DEBUG] CallNotifier(1207) resetAudioStateAfterDisconnect()...

Je dirais que c'est là que tu as arreté d'appeler

02/09/2010 12:45:39 [DEBUG] CallNotifier(1207) showMissedCallNotification: Querying for CallerInfo on missed call...

Il te dit que tu as manqué un appel

02/09/2010 12:45:39 [DEBUG] InCallScreen(1207) [okToDialDTMFTones] foreground state: IDLE, ringing state: false, call screen mode: UNDEFINED, result: false

là et quelques lignes en dessous il desarme l'appel, il coupe les haut parleurs tout ça.

Donc d'après ma déduction de fin de journée, pour les logs tu as reçu ton appel 2G!

Pour les logs orange tu as bien les logs d'un appel qui est reçu, accepté et terminé:

02/09/2010 12:55:23 [DEBUG] CallCard(1207) updateCardTitleWidgets(call INCOMING)...

02/09/2010 12:55:23 [DEBUG] CallCard(1207) - getTitleForCallCard(Call INCOMING)...

02/09/2010 12:55:23 [DEBUG] CallCard(1207) ==> result: Appel entrant

02/09/2010 12:55:23 [DEBUG] CallCard(1207) updateCardTitleWidgets: Appel entrant

02/09/2010 12:55:23 [DEBUG] CallCard(1207) updateCardTitleWidgets(call ACTIVE)...

02/09/2010 12:55:23 [DEBUG] CallCard(1207) - getTitleForCallCard(Call ACTIVE)...

02/09/2010 12:55:23 [DEBUG] CallCard(1207) ==> result: Appel en cours

02/09/2010 12:55:23 [DEBUG] CallCard(1207) updateCardTitleWidgets: Appel en cours

02/09/2010 12:55:32 [DEBUG] CallCard(1207) updateCardTitleWidgets(call DISCONNECTED)...

02/09/2010 12:55:32 [DEBUG] CallCard(1207) - getTitleForCallCard(Call DISCONNECTED)...

02/09/2010 12:55:32 [DEBUG] CallCard(1207) ==> result: Fin de l'appel

02/09/2010 12:55:32 [DEBUG] CallCard(1207) updateCardTitleWidgets: Fin de l'appel

Edited by Guest
Link to comment
Share on other sites

Ce qui est bizarre, c'est que je ne vois nulle part l'action de décrocher OFFHOOK.

Le téléphone passe de RINGING à INCOMING après ces actions

02/09/2010 12:44:50 [DEBUG] ThumbnailIntentReceiver(1431) received Intent android.intent.action.SCREEN_ON, mGalleryRunning is false

02/09/2010 12:44:53 [DEBUG] InCallTouchUi(1207) onDialTrigger(whichHandle = 1)...

02/09/2010 12:44:53 [DEBUG] InCallTouchUi(1207) LEFT_HANDLE: answer!

02/09/2010 12:44:53 [DEBUG] PhoneUtils(1207) answerCall()...

02/09/2010 12:44:53 [DEBUG] CallCard(1207) updateRingingCall()...

02/09/2010 12:44:53 [DEBUG] CallCard(1207) displayMainCallStatus(phone Handler{44cc2f18}, call INCOMING)...

02/09/2010 12:44:53 [DEBUG] CallCard(1207) - call.state: INCOMING

puis cette erreur sur AudioMgr

02/09/2010 12:44:53 [ERROR] AudioPostProcessor(1054) AudioMgr Error:Invalid output format flag; disabling PostProcessing

02/09/2010 12:45:08 [DEBUG] AudioMsgHandler(1054) AudioMgr:audTAPIMsgHandler called

02/09/2010 12:45:08 [DEBUG] AudioMsgHandler(1054) AudioMgr:Received AUD_MSG_TAPI_DISABLE_VOICEPATH from socket client fd 16

02/09/2010 12:45:38 [DEBUG] CallNotifier(1207) onDisconnect()... phone state: IDLE

Le client répond de désactiver le périphérique pour la voix puis passe à IDLE.

On dirait que le dialogue entre le téléphone et le serveur Bouygues se passe mal au moment de la réponse du téléphone.

La différence entre Orange et Bouygues est là,

Orange

02/09/2010 12:55:23 [DEBUG] CallCard(1207) updatePhotoForCallState(INCOMING)...

02/09/2010 12:55:23 [DEBUG] CallCard(1207) displayOnHoldCallStatus(call =null)...

02/09/2010 12:55:23 [DEBUG] BT HS/HF(1207) updatePhoneState()

02/09/2010 12:55:23 [DEBUG] BT HS/HF(1207) audioOn()

Bouygues

02/09/2010 12:44:53 [DEBUG] CallCard(1207) updatePhotoForCallState(INCOMING)...

02/09/2010 12:44:53 [DEBUG] CallCard(1207) displayOnHoldCallStatus(call =null)...

02/09/2010 12:44:56 [DEBUG] AudioHardwareMot(1054) AudioMgr:AudioStreamOutMot::standby called

02/09/2010 12:44:56 [DEBUG] AudioHardwareMot(1054) AudioMgr:Output 0xb538 entering standby

02/09/2010 12:44:56 [DEBUG] AudioHardwareMot(1054) AudioMgr:Closing stereo device

02/09/2010 12:45:05 [DEBUG] OpenSSLSessionImpl(1215) Freeing OpenSSL session

Pourquoi AudioHardwareMot ne réagit pas de la même manière ? Chez Orange après ces lignes, le téléphone passe à OFFHOOK (décroché) alors qu'il passe à IDLE chez Bouygues (avec le gel de l'écran après avoir essayé de décrocher).

Voilà, mon analyse à deux balles de la réception d'appel. Je ne suis pas plus avancé mais on dirait un problème d'incompatibilité des paramètres échangés provoquant une erreur dans le protocole de connexion (maintenant, je ne suis pas plus avancé pour savoir quel en est l'origine) ???

Link to comment
Share on other sites

En plus il y a aussi des erreurs chez orange aussi et ça n'influe pas sur le bon fonctionnement. de tte la comme ça tu peux pas faire grand chose. a part tenter une reinstallation. parce que y'en a qui ont pas de prob avec bouygues.

Link to comment
Share on other sites

En plus il y a aussi des erreurs chez orange aussi et ça n'influe pas sur le bon fonctionnement. de tte la comme ça tu peux pas faire grand chose. a part tenter une reinstallation. parce que y'en a qui ont pas de prob avec bouygues.

Enfin ça peut aussi être le matos du relais BT près de chez lui qui merdouille.

Tu as les problèmes en 2G partout ?

Link to comment
Share on other sites

En plus il y a aussi des erreurs chez orange aussi et ça n'influe pas sur le bon fonctionnement. de tte la comme ça tu peux pas faire grand chose. a part tenter une reinstallation. parce que y'en a qui ont pas de prob avec bouygues.

J'ai déjà tenté la réinstall, ça n'a rien changé.

Je me demande si beaucoup de monde fait attention à ces problèmes, car c'est furtif en région parisienne (bien souvent le réseau est bon et tout passe en 3G).

Et je pense qu'en zone Full 2G, le problème de choix du réseau ne se pose pas et donc tout fonctionne. Je testerais cela pendant mes vacances en zone full 2G en mars mais d'ici là, ce n'est pas possible.

Link to comment
Share on other sites

En plus il y a aussi des erreurs chez orange aussi et ça n'influe pas sur le bon fonctionnement. de tte la comme ça tu peux pas faire grand chose. a part tenter une reinstallation. parce que y'en a qui ont pas de prob avec bouygues.

Enfin ça peut aussi être le matos du relais BT près de chez lui qui merdouille.

Tu as les problèmes en 2G partout ?

Oui, j'ai reproduit le problème sur deux sites différents (en forçant la 2G).

Link to comment
Share on other sites

Salut à tous

je confirme le problème de 2G/voice.

Ce que je ne comprends pas c'est que même en désactivant tout activité data je ne peux toujours pas téléphoner hors zone 3G même avec 3 barrettes. Je pense qu'il y a un gros soucis dans la conf du tel et/ou du réseau bouygues

Link to comment
Share on other sites

Klee a écrit:

En plus il y a aussi des erreurs chez orange aussi et ça n'influe pas sur le bon fonctionnement. de tte la comme ça tu peux pas faire grand chose. a part tenter une reinstallation. parce que y'en a qui ont pas de prob avec bouygues.

Enfin ça peut aussi être le matos du relais BT près de chez lui qui merdouille.

Tu as les problèmes en 2G partout ?

moi a la maison j'ai que 2G et tout fonctionne bien par contre au bureau 3G et bien si je force en 2G j'ai la data mais pas voice donc je pense que c'est niveau bouygues.J 'ai deja appele et le mec m'a dit les tel de maintenant sont tous 3G donc faut laisser en 3G la batterie ils s'en cognent eux ...

--

Posté depuis BBFoC

Link to comment
Share on other sites

Salut à tous

je confirme le problème de 2G/voice.

Ce que je ne comprends pas c'est que même en désactivant tout activité data je ne peux toujours pas téléphoner hors zone 3G même avec 3 barrettes. Je pense qu'il y a un gros soucis dans la conf du tel et/ou du réseau bouygues

Mardi soir, j'ai réussi à passer et recevoir en appel en forçant la 2G dans une zone 3G (une grande surface dans la commune d'à côté). Ce problème est donc lié aux antennes Bouygues puisque ça fonctionne avec certaines et pas avec d'autres.

Link to comment
Share on other sites

moi a la maison j'ai que 2G et tout fonctionne bien par contre au bureau 3G et bien si je force en 2G j'ai la data mais pas voice donc je pense que c'est niveau bouygues.J 'ai deja appele et le mec m'a dit les tel de maintenant sont tous 3G donc faut laisser en 3G la batterie ils s'en cognent eux ...

Leur réponse est inadaptée, car un téléphone 3G passe en 2G en zone d'ombre ou mal couverte (c'est pour cela que j'ai découvert le problème dans une zone théoriquement 3G).

Le fait de le reproduire en forçant la 2G ne doit pas occulter ce phénomène qui fait que les appels ne sont pas possibles ou recevables même en zone 3G avec un téléphone 3G.

A chaque fois que je les ai appelés, ils mettent le téléphone en cause et me dise de le faire remplacer. Mais, sachant qu'il fonctionne avec Orange et maintenant avec Bouygues sur certaines antennes, il n'est pas question que je le renvoie chez Motorola pour qu'ils me le retournent en disant qu'il fonctionne très bien. C'est donc l'impasse actuellement, pourvu que la 2.1 débloque ce problème :|

Edited by SteC
Link to comment
Share on other sites

moi au bureau j'ai remarque que si je commence une comm en 3G et ensuite je rentre dans un batiment et la je passe en 2G pas de souci tant que la comm est en cours mais si je raccroche et bien la impossible de faire un appel ou etre appelé, je dois retrouver la 3G pour ça.

Link to comment
Share on other sites

Pour ma part cela commence vraiment a devenir gênant car il m'arrive souvent d'être en edge et donc aucun appel ne passe et l'on tombe sur mon répondeur immédiatement savez vous si il est possible de mettre la pression a BT ?

Car ce n'est pas normal d'avoir ce genre de problème surtout avec un forfait a 40 euros ou plus / mois ...

Link to comment
Share on other sites

Savez vous si il est possible de mettre la pression a BT ?

Car ce n'est pas normal d'avoir ce genre de problème surtout avec un forfait a 40 euros ou plus / mois ...

J'ai l'impression qu'il s'en fiche. Lorsque j'ai décrit le problème, le téléphone est mis en cause et pour eux, le réseau était OK.

La seule solution est de les menacer de résiliation pour non respect des engagements mais là, c'est le parcours du combattant à mon avis. :( :mad:

Link to comment
Share on other sites

Oui c'est clair d'autant plus que le mobile n'est pas vendu par eux cela doit être encore plus chiant chaque partie accusant l'autre ...

Mais bon même si la 2.1 d'android devrait sortir dans pas mal de temps et que je doute qu'elle corrige le problème je pense que si à sa sortie le problème persiste je ferais des actions car payer 40.90/mois ( même si je compte passer en evasio en avril ) et ne pas pouvoir profité de son forfait surtout que c'est un 3h il sont bien gentil si on ne peut pas appeler .. et ne parlons pas des appel illimité le soir.

Edited by beup
Link to comment
Share on other sites

Oui c'est clair d'autant plus que le mobile n'est pas vendu par eux cela doit être encore plus chiant chaque partie accusant l'autre ...

Mais bon même si la 2.1 d'android devrait sortir dans pas mal de temps et que je doute qu'elle corrige le problème je pense que si à sa sortie le problème persiste je ferais des actions car payer 40.90/mois ( même si je compte passer en evasio en avril ) et ne pas pouvoir profité de son forfait surtout que c'est un 3h il sont bien gentil si on ne peut pas appeler .. et ne parlons pas des appel illimité le soir.

Je suis entièrement d'accord. De mon côté, j'hésite car le problème est limité au centre commercial ou je mange à midi, le reste du temps la 3G fonctionne bien. Cela dépendra du bon fonctionnement du téléphone en zone 2G ou je passe mes vacances. Mais comme il n'y a pas d'équivalent au forfait Evasio à 28,9 € chez les concurrents, j'aimerais bien le conserver. :mad:

Enfin, si tu te lances dans l'aventure, je suis preneur d'informations sur son déroulement.

Edited by SteC
Link to comment
Share on other sites

Ce problème est vraiment bizarre.

Alors qu'il se produit fréquemment chez moi ou à mon boulot. Je viens de voir de faire plusieurs tests dans le métro à Paris et jamais il ne s'est produit. C'est désespérant :(

A croire que je suis tombé sur les deux seules antennes incompatibles avec le Milestone (enfin, maintenant, je sais qu'il y en a d'autres mais ce n'est pas rassurant). Au final, cela met hors de cause le fonctionnement du téléphone, mais jette un doute sur son utilité puisque sans prévenir, il est possible d'être dans une zone non fonctionnelle.

Enfin, j'espère que Bouygues va uniformiser ses antennes (ou leur paramétrage), en tout cas, je vais les contacter pour les informer de la situation et décrire un incident réseau puisque c'est comme cela qu'il appelle çà.

Edited by SteC
Link to comment
Share on other sites

Bonsoir,

C'est clair que ce probleme est très énervant sinon je ne pense pas que BT va vite réagir ou même ne pas réagir du tout vu que ce problème ne semble concerné que ceux qui possèdent un milestone et nous ne sommes pas nombeux ...

Mais merci de partager tes différentes infos sur ce problème quand a moi je crois bien n'avoir jamais pu appeler en 2g cela raccroche immédiatement ...

Link to comment
Share on other sites

Il semble que ce problème touche aussi certaines personnes qui ont un htc HD2 http://win-mobile.forumpro.fr/touch-hd2-general-f159/appels-impossibles-en-mode-edge-t21469.htm

Et il semblerait que le problème vient particulièrement du forfait NEO 3 ( 3h ? ) j'ai celui la pour ma part et la plupart des personnes qui ont ce problème semble aussi avoir un NEO 3, bien que steC semble avoir un evasio 1+1.

Serait-il possible pour ceux qui sont chez BT et qui n'ont pas de problème en 2g de dire quel forfait possède il ?

Cordialement,

Link to comment
Share on other sites

Serait-il possible pour ceux qui sont chez BT et qui n'ont pas de problème en 2g de dire quel forfait possède il ?

neo3 (2h+nuit)

Je suis quasi jamais en 3G : réception moyenne chez moi et quasi nulle dans mon bureau (la même qu'en orange ou sfr en fait : seul le relai 2G de BT est beaucoup mieux placé pour le bâtiment où je bosse, à part pour le dernier étage).

En 2G j'ai peu de problèmes sur les lieux principaux où je suis, de temps en temps les datas ont du mal, mais aucun pb évident pour les coms, et mes mails avec k9 marchent très bien, aussi bien en push idle qu'en pull.

Link to comment
Share on other sites

Il semble que ce problème touche aussi certaines personnes qui ont un htc HD2 http://win-mobile.forumpro.fr/touch-hd2-general-f159/appels-impossibles-en-mode-edge-t21469.htm

Et il semblerait que le problème vient particulièrement du forfait NEO 3 ( 3h ? ) j'ai celui la pour ma part et la plupart des personnes qui ont ce problème semble aussi avoir un NEO 3, bien que steC semble avoir un evasio 1+1.

Serait-il possible pour ceux qui sont chez BT et qui n'ont pas de problème en 2g de dire quel forfait possède il ?

J'ai un doute sur la liaison entre le forfait et le problème.

Pour moi, le problème vient uniquement de certains relais de l'opérateur. J'avais un forfait Simyo (MVNO porté par Bouygues Telecom)avant mon forfait Evasion. Mon crédit s'étant terminé récemment, j'ai pu faire des tests et j'avais exactement les mêmes problèmes (en appel et réception 2G).

J'en déduis que le problème doit être matériel, les différences de gestion de forfait doivent être significatives entre un opérateur et ses MVNO.

Avez-vous essayé de prendre des logs juste après une tentative d'appel ? Pour voir si les messages d'erreur sont les mêmes (problème sur les tonalités et sur la partie audio).

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...