Jump to content

[Xperia RAY] - Petite question aux possesseurs de ce téléphone


Recommended Posts

Bonjour à tous,

Voilà ma question est simple, je voudrais me procurer le Xperia Ray, mais je voudrais savoir si dans Paramètres > Affichage > Luminosité vous avez la possibilité de désactiver le capteur de luminosité.

Normalement vous avez une options à cocher, si il y a juste une barre de % c'est que non.

S'il vous plait ne dites pas ça de mémoire, ou un oui comme ça, vérifiez le si ça ne vous dérange pas.

Car j'en ai marre de la non possibilité de désactiver ce capteur sur les Xperia.

J'ai lu ça dans un test du Xperia Ray :

En revanche, on regrette l’absence de capteur de luminosité, qui aurait permis de régler automatiquement l’éclairage de l’écran en fonction de la lumière ambiante. Réglé au maximum, le rétroéclairage est en effet assez énergivore. Il faut donc modifier manuellement la luminosité de l’écran pour concilier autonomie et visibilité. C’est assez gênant.

Mais moi c'est ce que je veux ! :)

Mais je veux en avoir le coeur net avec vous, pouvez vous me confirmer qu'il n'y a pas de luminosité automatique ? Que la lumière de votre Ray reste toujours égale à ce que vous avez régler ?

Merci d'avance pour votre aide.

Edited by garcon_etoile
Link to comment
Share on other sites

Bonjour à tous,

Voilà ma question est simple, je voudrais me procurer le Xperia Ray, mais je voudrais savoir si dans Paramètres > Affichage > Luminosité vous avez la possibilité de désactiver le capteur de luminosité.

Normalement vous avez une options à cocher, si il y a juste une barre de % c'est que non.

S'il vous plait ne dites pas ça de mémoire, ou un oui comme ça, vérifiez le si ça ne vous dérange pas.

Car j'en ai marre de la non possibilité de désactiver ce capteur sur les Xperia.

J'ai lu ça dans un test du Xperia Ray :

Mais moi c'est ce que je veux !

Mais je veux en avoir le coeur net avec vous, pouvez vous me confirmer qu'il n'y a pas de luminosité automatique ? Que la lumière de votre Ray reste toujours égale à ce que vous avez régler ?

Merci d'avance pour votre aide.

Le Ray est doté d'un capteur de luminosité, le fait qu'il ne soit pas exploitable est seulement logiciel. Tu peux y remédier en installant une custom rom ou en rootant ta rom d'origine et en changeant quelques données, je posterai un tuto' prochainement.

Sent from my ST18i using Tapatalk

Link to comment
Share on other sites

Non moi c'est justement l'inverse, je suis très content que ce capteur ne fonctionne pas, car je déteste ça, je voulais juste être sur que cette info est vraie. Que le RAY a bien une luminosité qu'on peut réglé soit même sans qu'un capteur de luminosité vienne s'en charger.

Je sais que je déborde de sujet, mais comme tu as l'aire de t'y connaitre, J'ai un Xperia Mini (ST15i) qui lui est doté d'un capteur de luminosité qui marche, et j'aimerais le désactiver, mais bien sur bridé par Sony.

Tu saurais comment faire pour désactiver ce capteur? Personne n'arrive à m'aider.

Voilà le sujet d'origine si ça t'intéresse :

Ca me serais d'une grande aide.

Je précise que mon tel n'est pas root et que je ne suis pas un grand connaisseur du coté technique.

Link to comment
Share on other sites

Désolé j'avais mal compris ta question. Je ne suis pas sur la rom d'origine, donc je ne peux pas faire de tests désolé, mais si d'ici demain personne ne trouve réponse à ton problème, je pourrai passer sur la rom d'origine pour essayer. Mais connaissant les manips' à faire pour activer le capteur sur le Ray, je peux en déduire qu'il n'est pas activé d'origine (ou peu activé, soit réagissant seulement à un gros manque de lumière ou à une grosse entrée lumineuse. Essaye par toi-même, en passant par exemple d'une pièce sombre à une pièce lumineuse et observe le comportement de l'écran).

Sinon pour ton second téléphone, je me renseigne et je te tiens au courant.

Merci de ta patience, j'essayerai de trouver une solution au plus vite.

Cordialement,

aragog53

Link to comment
Share on other sites

C'est plutôt à moi de te remercier pour tes réponses :)

Le RAY je ne l'ai pas, justement je me renseignais pour l'acheter ou non car moi justement je ne veux pas que ce capteur soit actif sur le RAY, car ça me pourri sur le Mini, ça baisse trop la luminosité, et c'est énervant car des fois tu veux un écran plus lumineux pour regarder agréablement un jeu ou une vidéo sombre.

En tout cas merci pour tes recherches, d'habitude personne arrive à m'aider, j'avais déjà tenté le coup avec le X10 mini et rien, et là j'ai le meme probeème avec le MINI (ST15i), donc comme ça ma souler, je me suis dit que je prendrais le RAY vu que lui n'a pas d'activé ces capteurs que je n'aime pas.

Link to comment
Share on other sites

Effectivement le capteur de luminosité n'est pas activé sur la ROM officielle.

Il est activable avec des ROM alternatives.

Par contre rien ne te garanti que dans la prochaine mise a jour (ICS) celui-ci ne sera pas activé ...

Edited by piflechien
Link to comment
Share on other sites

Au pire des cas il sera toujours désactivable, pour le Ray sur n'importe quelle rom c'est facile à faire. De plus je ne pense pas que ça en soit la peine, sur la version alpha qui a été postée par Sony, ICS ne contient toujours pas de luminosité automatique. Peut-être que la firme a compris que cette fonctionnalité certes pratique a aussi ses défauts.

@garcon_etoile, pour ton Xperia Mini, il te faut le rooter pour pouvoir modifier les fichiers système et désactiver la luminosité automatique. Je te recommande cette méthode, c'est la plus simple, facilement réversible et aucun risque de brick. Si tu as besoin d'un tutoriel simplifié et en français, n'hésite pas à me demander.

Une fois ton téléphone rooté, il te faut une application "explorateur root", telle que Root Explorer, ES File Explorer ou d'autres. Grâce à une de ces applications modifier le fichier /etc/hw_config.sh, trouver la ligne :

echo 1 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h

et la modifier en :

echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 1 = on, reg 90h

Sauvegarder cette modification et redémarrer ton téléphone.

J'espère t'avoir été utile, si tu as besoin de détails quant à ces informations, n'hésite pas à me contacter.

Edited by aragog53
Link to comment
Share on other sites

EDIT

Alors j'ai root, et j'ai modifié le fichier hw_config.sh comme tu me l'a expliqué.

Après un redémarrage du tel, effectivement le capteur ne fonctionne plus et la luminosité est la même tout le temps. :)

Mais le problème maintenant c'est que la luminosité est basse en permanance, pourtant c'est en 100% de luminosité dans les paramètres.

Tu saurais comment faire pour mettre la luminosité au max ?

En tout cas je suis déjà content que le capteur soit désactivé, merci beaucoup pour ton aide, reste plus que la luminosité au max et ça sera parfait :)

Edited by garcon_etoile
Link to comment
Share on other sites

j'ai réussi je crois bien en changeant ça :

echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 0 = OFF, reg 90h

Et là je pense avoir une pleine luminosité et permanente :)

Enfin !

Je ne met pas encore en résolu, car je vais faire des petits tests, remettre le capteur mettre devant une lumière et comparer voir si j'ai vraiment le vraie pleine luminosité.

Je te tiens au courant :)

Edited by garcon_etoile
Link to comment
Share on other sites

j'ai réussi je crois bien en changeant ça :

echo 0 > $dev/lcd-backlight/als/enable #Sensor on/off. 0 = OFF, reg 90h

Et là je pense avoir une pleine luminosité et permanente

Enfin !

Je ne met pas encore en résolu, car je vais faire des petits tests, remettre le capteur mettre devant une lumière et comparer voir si j'ai vraiment le vraie pleine luminosité.

Je te tiens au courant

Ca marche ! C'est bien d'avoir pris l'initiative d'essayer en modifiant toi-même le fichier, c'est ca qui fait avancer le développement. Si tu peux poster cela sur le forum du Mini, ca servira sûrement. J'attends les résultats de tes tests !

Sent from my ST18i using Tapatalk

Link to comment
Share on other sites

Bon j'ai crier victoire trop tôt :( :(

Je résume :

- Le capteur de luminosité se désactive bien, donc plus de variation de luminosité.

Le nouveau problème est que...

- Le téléphone test la luminosité au démarrage quand on l'allume, et comme j'étais en journée il a garder la luminosité de la journée tout le temps durant.

- Je croyais le problème réglé mais, comme il fait plus sombre et que je l'ai rallumer cette fois il s'est allumé avec une luminosité faible, et reste donc dans cette basse luminosité tant que je ne l'éteins pas.

- Donc pour le moment si je veux une luminosité max constante, il faut que je démarre le tel près d'une source de lumière les quelques secondes pendant le démarrage, le téléphone restera ensuite tout le temps en luminosité max tant que je ne l'éteins pas.

Donc bien sur ça peut pas rester comme ça,

Là je vois plus ce que je peux faire, je ne m'y connais pas du tout, tu n'aurais pas une idée ? Ou quelqu'un d'autre ?

Tout ce que je peux dire c'est que le téléphone test la luminosité au démarrage, donc surement un fichier de config de démarrage je sais pas, ou désactiver ce test, ou trouver la luminosité max permanente pour l'activer.

:( :( :( Je me décrourage là, j'ai bien peur que plus beaucoup de monde puisse m'aide sur ce problème qui m'a l'aire bien spécial

Link to comment
Share on other sites

567147599.png

-----------------------------------------------------------------------------------

Je t'ai fait une capture d'écran car je ne sais pas comment on fait pour récupérer en texte brut du fichier hw_config.sh, j'ai pourtant copier coller le contenu dans des éditeurs de texte sur le téléphone, mais quand je branche ils n'ont pas créer de .txt en tant que tel.

Enfin voilà la partie LMU, en image :)

Note: J'ai remis juste le écho 0, car finalement mes modifs n'ont servi à rien.

Edited by garcon_etoile
Link to comment
Share on other sites

Essaye en oubliant pas de faire un backup de ton fichier avant modifications, de supprimer les lignes ici en gras et rouge :

# LMU AS3676 Configuration

dev=/sys/devices/i2c-0/0-0040/leds

echo 0 > $dev/lcd-backlight/als/enable

#Sensor on/off. 1 = on, reg 90h

echo 3,2,2,0 > $dev/lcd-backlight/als/params

#[gain],[filter_up],[filter_down],[offset]

echo 8000 > $dev/button-backlight-rgb1/

max_current

echo 8000 > $dev/button-backlight-rgb2/

max_current

echo 1,30,255,54,52,1,65 > $dev/lcd-

backlight/als/curve # ALS curve display BL

[grp],[Y0],[Y3],[K1],[K2],[X1],[X2]

echo 2,48,0,128,128,4,10 > $dev/button-

backlight-rgb1/als/curve# ALS curve key LED

1 [grp],[Y0],[Y3],[K1],[K2],[X1],[X2]

echo 2,48,0,128,128,4,10 > $dev/button-

backlight-rgb2/als/curve# ALS curve key LED

2 [grp],[Y0],[Y3],[K1],[K2],[X1],[X2]

echo 3,71,255,64,32,5,37 > $dev/red/als/curve

# ALS curve RGB(red) [grp],[Y0],[Y3],[K1],

[K2],[X1],[X2]

echo 3,71,255,64,32,5,37 > $dev/green/als/

curve # ALS curve RGB(green) [grp],[Y0],

[Y3],[K1],[K2],[X1],[X2]

echo 3,71,255,64,32,5,37 > $dev/blue/als/

curve # ALS curve RGB(blue) [grp],[Y0],[Y3],

[K1],[K2],[X1],[X2]

Encore une fois je suis dans l'incapacité de tester, n'ayant pas le téléphone, mais d'après ce qu'indique le code, ces lignes pourraient être responsables de ton problème, et leur suppression ne devrait pas poser de problème tierce.

Edited by aragog53
Link to comment
Share on other sites

Coucou !

Eh bien là chapeau mec :)

Ca à marcher, c'est fou, j'y croyais pas trop je t'avoue. Mais suit à tes modifications, le tel reste enfin en luminosité constante et surtout il n'y a pas cet espèce de test de luminosité au démarrage, génial, je peux ENFIN profiter de mon tel avec une belle luminosité et tout ça grâce à toi, car personne d'autres ne s'est investi.

VRAIMENT MERCI aragog53, je ne sais pas comment te remercier, mais je prépare déjà un tuto clair que je vais poster dans la rubrique des MINI pour désactiver cette saleté de luminosité.

Bon je ne marque pas encore RESOLU, car la dernière fois j'ai crier victoire trop tôt, et je veux être sur que suis à ces motif il n'y a pas d'autres choses qui clocherais, j'utilise un peu le tel et je te tiens au courant.

Merci t'es un God :)

Edited by garcon_etoile
Link to comment
Share on other sites

Bonjour,

Sur mon Ray, la luminosité est automatique par défaut (impossible à désactiver), j'ai la dernière mise à jour SE. Et le capteur fonctionne et fait varier la luminosité.

Je ne comprends pas que chez d'autres elle soit désactivée sur la ROM constructeur.

Personnellement ça ne me gène pas, je trouve ça bien et logique que la luminosité s'adapte à l'environnement.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...