Jump to content

Bug lecteur de musique + bluetooth ou jack


Gerg

Recommended Posts

Bonjour,

J'ai remarqué que depuis la mise a jour en 2.1, le lecteur de musique réagit de façon étrange.

Quand je déconnecte mon milestone (de mon kit main libre en bluetooth) de temps en temps la musique se déclenche.

Pour arrêter la musique il me faut faire play et stop... C'est comme si le lancement était fantôme.

Quelqu'un à remarqué ce problème ?

Merci.

ps : par contre mon réveil refonctionne correctement. ;)

Edited by Gerg
Link to comment
Share on other sites

salut !

ah j suis pas le seul dans ce cas la , ça me rassure lool

ouai moi pareil a chaque fois que je débranche mon casque de la prise jack sa met en route le lecteur mp3 , c'est galère !

erf... j'ai tester avec un casque dans le jack, idem la musique ce lance...

hep M.Moto tu peux corriger tes bugs stp ?

Link to comment
Share on other sites

Bon,

je ne sais pas si ça va aider,mais:

-le bug ne vient pas de l'application musique,mais du service multimedia (avec n'importe quel app utilisant le service,le même bug apparaît)

-ce matin par hasard,j'ai débranché la fiche jack avant de faire pause sur la musique,et ohhh miracle,la musique s'est arrêtée(pause) toute seule et ne s'est pas redéclanchée ensuite...j'utiliserais la même méthode demain et on verra :)

Link to comment
Share on other sites

Moi je suis en root et j'ai carrément desinstalle l'application musique d'origine avec titanium backup ! En fait j'utilise l'application musique du nexus one que je trouve plus pratique. Du coup ça à résolu le problème du bug du lecteur musique !

Link to comment
Share on other sites

pour ceux que ça interesse j'ai résolu le problème en installant l'appli music du nexus pui je l'ai définie en player par défaut. J'ai fini le tout en vidant le cache de l'appli music de base et la merveille tout fonctionne, on peut enfin débrancher son casque sans probleme.

et je ne suis pas en root.

Edited by tobby
Link to comment
Share on other sites

Moi j'ai eu le même problème hier soir, à savoir que la musique s'est déclenchée toute seule quand j'ai débranché mes écouteurs de la prise Jack, alors que je regardais des vidéos sur youtube.

Pour arrêter la musique j'ai lancé mon task manager, pas de Musique dedans, comme si l'app ne s'était pas lancée, j'ai du lancer l'app Musique et arrêter la musique.

J'ai branché / débranché plusieurs fois les écouteurs, ça ne l'a plus jamais refait pour l'instant.

Link to comment
Share on other sites

Motorola commence à me gonfler on a même plus la notification quand on écoute de la musique, ce bug qui est juste chiant, les live wallpapers qui sont des sketches (faudra m'expliquer pourquoi d'ailleurs car sur le droid ils fonctionnent normalement) !

Link to comment
Share on other sites

Salut tout le monde, ce bug m'arrive parfois aussi. Je voulais juste vous informer qu'en fait dans les versions précédentes à la 2.1, il ne s'agissait pas vraiment d'un bug mais plutôt d'une petite particularité pratique qu'avait fait Motorola : quand on écoutait de la musique au casque, écran éteint, et qu'on enlevait le casque par erreur tout en laissant la musique, alors la musique s'arrêtait nette, une sorte de sécurité pour éviter de se faire remarquer en jouant la musique sur le haut parleur ... ;)

Là j'ai l'impression que ça fait plutôt l'inverse.

Link to comment
Share on other sites

effectivement motorola avait fait en sorte que lorsque l'on branchait un casque la musique se mettait en route et s'arraitait quand on débranchait ce casque. Mais maintenant je constate que la musique ne se lance plus quand on plug et si jamais pas on fait preuve de malchance elle se lance quand on débranche, m'enfin c'est juste sur leur appli don cmerci moto on moins on se fait remarquer avec son milestone :)

Link to comment
Share on other sites

Pour les personnes qui utilise l'application du Nexus sur le Milestone:

Avez-vous déjà rencontré ce problème? où se situe votre app? dans /system/app ? Avez-vous renommé l'apk?

Perso j'ai mis l'app du Nexus dans /system/app et je l'ai renommé Music.apk (comme celle par défaut) et j'ai eu ce bug. Donc il semblerait que le système essaye de lancer Music.apk lorsque l'on débranche le casque. Une solution simple consisterait donc à renommer l'appli d'origine autrement que Music.apk (donc pas besoin de celle du nexus)

Edit: Théorie du "nom de fichier" à oublier: j'ai le même problème alors que je l'ai renommé MusicInstallable.apk. Le problème serait donc situé autre part...

Edited by Anarki
Link to comment
Share on other sites

Moi j'utilise l'application Music du Nexus One et j'ai le même problème mais uniquement avec le backup de The Solutor car avec la 2.1 FR j'avais installé l'appli du N1 dans /system/app sous le nom MusicInstallable.apk et ca ne me l'avait jamais fait.

Ca n'arrive pas systématiquement mais c'est génant quand ca arrive.

Pire encore, la musique s'est lancée toute seule sans même toucher au tel ! Donc maintenant je met tout le temps le son de la musique au minimum au cas où ca se lancerait en plein amphi ^^

Link to comment
Share on other sites

  • 5 weeks later...
Salut,

Alors toujours personne pour une solution ? ne me dites pas que je suis le seul à avoir encore le problème....

J'ai bien une solution mais il faut être root: Changer le nom de l'appli music.

Pourquoi? et bien tout simplement parce qu'apparemment le mécanisme qui bug chercherait à lancer Music.apk donc si on renomme l'appli en MusicPlayer.apk (par exemple) il ne devrait plus y avoir de problème...

Je me suis aperçu de ça lors des diverses manipulations que j'ai testées:

- Faire cohabiter les deux lecteurs* => bug toujours présent

- Supprimer le lecteur Motorola par défaut et laisser uniquement MusicInstallable.apk (celui du Nexus One) => aucun problème

- Renommer MusicInstallable.apk en Music.apk => réapparition du bug

- Renommer Music.apk avec un nom différent de Music.apk (par exemple TataYoyo.apk) => plus de bug

Quelqu'un veut tester ?

* Les deux lecteurs étant celui d'origine et celui du Nexus

EDIT: je précise que je n'utilise pas de backup modifié. Je suis en 2.1 officielle et rien n'a été modifié.

Edited by Anarki
Link to comment
Share on other sites

Merci pour ta réponse mais elle n'est pas très utile, ta manipulation ne corrige pas le bug mais le contourne.

J'explique :

Le problème ne vient pas de l'appli de musique mais du processus qui coupe la musique quand on déplug/déconnect un casque ou un périphérique bluetooth.

du coup au lieu de couper la musique, elle ce relance....

Link to comment
Share on other sites

Merci pour ta réponse mais elle n'est pas très utile, ta manipulation ne corrige pas le bug mais le contourne.

J'explique :

Le problème ne vient pas de l'appli de musique mais du processus qui coupe la musique quand on déplug/déconnect un casque ou un périphérique bluetooth.

du coup au lieu de couper la musique, elle ce relance....

Oui c'est un contournement, mais pour le moment c'est déjà ça de pris non? en plus depuis le temps, aucune solution n'as été trouvée donc bon...

Link to comment
Share on other sites

J'ai bien une solution mais il faut être root: Changer le nom de l'appli music.

Pourquoi? et bien tout simplement parce qu'apparemment le mécanisme qui bug chercherait à lancer Music.apk donc si on renomme l'appli en MusicPlayer.apk (par exemple) il ne devrait plus y avoir de problème...

Je me suis aperçu de ça lors des diverses manipulations que j'ai testées:

- Faire cohabiter les deux lecteurs* => bug toujours présent

- Supprimer le lecteur Motorola par défaut et laisser uniquement MusicInstallable.apk (celui du Nexus One) => aucun problème

- Renommer MusicInstallable.apk en Music.apk => réapparition du bug

- Renommer Music.apk avec un nom différent de Music.apk (par exemple TataYoyo.apk) => plus de bug

Quelqu'un veut tester ?

* Les deux lecteurs étant celui d'origine et celui du Nexus

EDIT: je précise que je n'utilise pas de backup modifié. Je suis en 2.1 officielle et rien n'a été modifié.

Salut,

Moi j'ai toujours ce problème alors que j'ai l'application du Nexus nommée MusicInstalable.apk dans /system/app (avec le backup 2.1 de the solutor).

Ce n'est pas systématique mais j'ai remarqué que ca le faisait surtout lorsque la musique n'était pas en lecture car dans le cas où elle l'est, elle s'arrête quand je débranche les écouteurs.

Link to comment
Share on other sites

Salut,

Moi j'ai toujours ce problème alors que j'ai l'application du Nexus nommée MusicInstalable.apk dans /system/app (avec le backup 2.1 de the solutor).

Justement le Backup de The Solutor est victime du bug y compris avec MusicInstallable.apk (Nexus), donc il semblerait que The Solutor a modifié quelque chose qui soit capable de lancer ce mécanisme et donc pourquoi pas le réparer?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...