Jump to content

Problème Wireless Tether


Recommended Posts

Bonjour,

ROM 2.1.5 FaB

Je souhaite utiliser l'application Wireless Tether, afin d'avoir internet sur mon PC.

J'ai cependant quelque soucis a le faire fonctionner, lorsque je démarre l'application, j'ai un message : "Sorry, but your kernel does not have all necessary features for running this applcation"

J'ignore alors ce message, et lorsque je démarre le WIFI tether, j'obtient alors un message, qui me dit une error, je vais voir le Log, et effectivement : Failed to enabeling NAT rules

Je me suis un peu renseigner sur le problème (ici entre autre https://forum.frandroid.com/forum/viewtopic.php?id=12361), mais ne sachant pas ce qu'est SamdroidMod, kernel LK2.03 et la version de Leshack, je vien vous demander quelque information pour faire fonctionner cette application.

Si vous avez des liens utiles vers un tuto, ou même m'expliquer comment mettre ceci en place, je vous serez reconnaissant.

Merci de votre aide, et bonne journée :)

Link to comment
Share on other sites

Salut,

Le kernel est le noyau d'android celui qui contient la plupart des pilotes et des fonctions système. Un firewall du nom de netfilter est nécessaire pour faire fonctionner Wifi tether et ce module n'est pas présent dans les kernels d'usine.

Dans les ROM de Fab il me semble qu'elle sont toutes rootées avec les kernels de Leshak (LK2.XX).

Ces kernels implémentent netfilter mais une application modifiée par Leshak est nécessaire pour en profiter => http://forum.samdroid.net/threads/610-Dev-Testing-WiFi-tether-for-i5700-Eclair-upd-19.04

La suite du topic que tu as trouvé devrais t'aider à résoudre la suite des problèmes. :)

Pour tester essai sans WEP ni contrôle d'adresse et sur le canal 11 dans un premier temps.

Edited by Gonfreecs
Link to comment
Share on other sites

Coucou, j'ai un peu avancer sur mon problème en utilisant l'application de LeshaK .

Plusieurs chose par contre, je continu d'avoir le message : "Sorry, but your kernel does not have all necessary features for running this application" lorsque je démarre mon application.

J'ai aussi une erreur dans mon log lorsque je démarre le WIFI, cette erreur est : Tearing Down firewall rules ... (failed).

Cependant, j'arrive a détecter mon réseaux sur mon PC en wifi (bluetooth non fonctionnel a ce que j'ai lut) puis, j'arrive a me connecter dessus, mon PC récupère une adresse IP via DHCP dans le range de mon téléphone, mais je n'ai qu'une connexion limité, et donc pas d'accsé a internet, même si sur mon téléphone les kbps (rouge et vert pour la réception et l'émission) fonctionne quand même.

Merci de ton aide Gonfreecs.

Link to comment
Share on other sites

Bon ça parait évident que tu n'as pas netfilter.

Il est pourtant compilé dans les LK2.XX, en fait il gère la transmission des paquets entre le modem USB et le Wifi, ce que le kernel dont tu dispose ne peut pas faire, donc les 2 parties modem et Point d'accès Wifi fonctionnent correctement, mais pas le "forwarding".

La seule solution est de changer de kernel (ou au pire de ROM) pour un qui possède netfilter. Cela me paraît bizarre quand même qu'il n'y soit pas dans la ROM de Fabricez. J'espère qu'il lira ce post, ou PM le pour plus d'infos.

EDIT : Ha bah voila il a posté juste avant :P

Conclusion => Change le kernel si tu t'en sent capable, ou de ROM.

Edited by Gonfreecs
Link to comment
Share on other sites

dans mes premieres rom j'avais utiliser les kernels samsung donc pas de netfilter installer..

Dans tes premières, sauf que j'utilise ta dernière, la 2.1.5 que j'ai obtenu ici : https://forum.frandroid.com/forum/viewtopic.php?pid=142396#p142396

La seule solution est de changer de kernel (ou au pire de ROM) pour un qui possède netfilter.

As-tu des liens a me donner vers de telles ROM ? En 2.1 ? Rooter evidement :P

Merci de votre aide :)

Edited by jerome01
Link to comment
Share on other sites

Pour faire simple vu que tu connais ODIN, et que tu possède déjà une ROM assez récente, il te suffit de changer de kernel.

Je te conseillerais celui-ci => http://forum.samdroid.net/threads/624-Spica-v.LK2.02-Root-Recovery-Apps2SD-Busybox-Wifi-tether-etc-04-15-2010-EN

L'installation est plutôt simple, il suffit de flasher i5700_LK2-02_PDA.tar sans rien d'autre avec ODIN comme un fichier PDA, puis d'utiliser le recovery pour installer "update.zip" que tu auras mis au préalable sur ta carte SD.

Ce qui est bizarre c'est que normalement c'est ce kernel qui est installé dans la ROM 2.1.5 de Fabricez il me semble. Enfin après avoir mis celui la tu disposera de Netfilter, et donc de Wifi tehter.

Link to comment
Share on other sites

Pour faire simple vu que tu connais ODIN, et que tu possède déjà une ROM assez récente, il te suffit de changer de kernel.

Je te conseillerais celui-ci => http://forum.samdroid.net/threads/624-Spica-v.LK2.02-Root-Recovery-Apps2SD-Busybox-Wifi-tether-etc-04-15-2010-EN

L'installation est plutôt simple, il suffit de flasher i5700_LK2-02_PDA.tar sans rien d'autre avec ODIN comme un fichier PDA, puis d'utiliser le recovery pour installer "update.zip" que tu auras mis au préalable sur ta carte SD.

Ce qui est bizarre c'est que normalement c'est ce kernel qui est installé dans la ROM 2.1.5 de Fabricez il me semble. Enfin après avoir mis celui la tu disposera de Netfilter, et donc de Wifi tehter.

Coucou, merci de ta réponse, mais si tu pouvais me dire de façon lus détailler ce que je doit faire.

Ce que je vien de faire : Mettre le .Zip de Leshak sur ma SD card

J'ai essayer de faire avec Odin, seulement quelque chose dans PDA, rien dans OPS ou One Package, mais j'obitent un message d'erreur : Check Image Files.

bref, jme suis dit qu'il fallait remettre l'ops et le One package, du coup j'ai reflash mon spica, mais sa na pas fait ce qu'il y a dans le Tuto de leshak.

COmment puis-je mettre le.zip en éxécution ? Puisque c'est sa qui me bloque apparemment ... (j'ai pas compris sa : (mount or with help adb)) Ou exécutio du .zip avec ASTRO (comment on fait ? j'ai lut sa quelque part ...)

Merci de ton aide :)

Edited by jerome01
Link to comment
Share on other sites

0. You should have any Android 2.1 firmware since JC3.

1. Download '.zip' файл: LK2-02-1_update.zip -->Télcharger le fichier ZIP

2. Put it to root of SD card! (mount or with help adb) --> Le mettre à la racine de ta carte SD

3. Download Kernel: i5700_LK2-02_PDA.7z --> Télécharger le Kernel

4. Flash i5700_LK2-xx_PDA by Odin as PDA file. --> Flasher avec Odin

Dans Odin slectioner le fichier .OPS et le fichier PDA et NE PAS COCHER "one package"

5. Kernel will flash and Spica reboot and enter in Recovery --> Le flash s'effectue et le tel reboot en mode Recovery

6. select "apply any zip from SD': --> Sélectionne "apply any zip from SD"

7. select: LK2-xx_update.zip --> Sélectionne LK2-02-1_update.zip et press OK

8. when you see "Install from sd card complete" press ОК for reboot. --> Quand tu vois "Install from sd card complete", tu appuies sur OK

Ton tel reboot et ca doit être bon

Edited by Razboul
Link to comment
Share on other sites

  • 1 month later...

Bonjour à tous,

J'ai la même config initiale (Fab 215), je voud[color=red]rai[/color] savoir si cette manip a été concluante pour toi (retour d'expérience ?)

Ou si je dois apprendre le russe pour pouvoir faire du tether avec mon spica...

Merci

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...