Jump to content

Très gros problème HTC Hero


Porkepix

Recommended Posts

Bonjour,

Tout d'abord, excusez-moi si la section du forum n'est pas la bonne, j'ai cherché mais n'ai rien trouvé de dédié aux problèmes rencontrés.

(Mal)heureux possesseur d'un Hero depuis quelques mois sous la désormais et malheureusement classique ROM 2.73.73.73 je me suis abstenu d'un changement de rom pour des raisons de garantie, chose dont j'ai visiblement eu tort, je m'explique :

Hier après-midi, mise à jour classique de 3/4 applications sur le market (je précise bien mise à jour, aucune nouvelle application installée), ayant prit l'habitude étant juste en mémoire de parfois faire cela pour vider cache et autres de manière plus rapide, je redémarre le téléphone.

Et là très gros problème : Le téléphone passe l'écran écrit Hero, puis l'animation orange et le droid faisant signe sur l'image Hero, assez longtemps comme toujours, et arrive sur l'écran de chargement avec le logo HTC.

Là, il reste bien presque 5 minutes sur le-dit logo....avant de redémarrer à la phase animation orange, le tout de manière indéfinie, il redémarre en boucle.

J'ai pas mal fouillé le net hier, n'ai rien trouvé qui ai fonctionné, étant donné que je n'ai aucune sauvegarde des contacts du téléphone, j'aurais souhaité les récupérer, ainsi qu'éventuellement le reste, mais surtout les contacts avant que le téléphone ne refonctionne, au pire avec un Hard reset.

adb ne détecte aucun appareil en mode fastboot usb, j'aurais directement copié toute l'arborescence du téléphone sinon.

Certains indiquaient qu'en essayant de booter sur une image de la rom déjà installée, tout n'était pas effacé, je ne sais pas si c'est vrai mais de toutes manières pas trace d'une 2.73.73.73 sur le net.

Donc si quelqu'un avais une quelconque solution pour faire refonctionner le téléphone que je sauvegarde le tout, ou un moyen d'accéder à la mémoire via adb ou autres faire une sauvegarde :s

PS: Je fonctionne sur Linux si quelqu'un a de quelconques solutions, pourrais éventuellement accéder à un Windows mais clairement pas facilement.

Merci à toute aide éventuelle =s

EDIT : Et désolé pour le roman...

Link to comment
Share on other sites

étant donné que je n'ai aucune sauvegarde des contacts du téléphone, j'aurais souhaité les récupérer, ainsi qu'éventuellement le reste, mais surtout les contacts avant que le téléphone ne refonctionne, au pire avec un Hard reset.
Tes contacts sont soit sur la carte SIM, soit sur ton compte Google, non ? Si tu as des contacts sur la mémoire interne du téléphone, je crains que tu ne sois bloqué là car à part le factory reset je ne vois pas comment te sortir de ça, d'autant plus qu'adb ne te détecte pas en mode fastboot (ç'aurait été la première solution sur je te propose mais tu y as déjà pensé).
Link to comment
Share on other sites

Non, mes contacts sont exclusivement sur le téléphone.

Je n'ai pas de forfait internet donc exit la synchronisation Google et ne les ai pas mis sur la carte SIM à cause du trop petit nombre d'informations possibles.

EDIT: je ne suis pas expert d'adb, il y a peut-être une manipulation spéciale à faire pour connecter que j'ai raté, c'était la première fois que je me servais d'adb.

Link to comment
Share on other sites

J'avais vu la section dédiée au Hero, mais n'était pas certain que cela concerne les problèmes de système qui ne démarre plus etc.

Le sujet aurais du être placé à cet endroit?

Un wipe, comprendre un Hard reset avec aucune récupération possible? :/

Link to comment
Share on other sites

EDIT: je ne suis pas expert d'adb, il y a peut-être une manipulation spéciale à faire pour connecter que j'ai raté, c'était la première fois que je me servais d'adb.
Peu de chances que ça ne marche pas, tu as téléchargé le SDK depuis Google, puis tu t'es placé dans le répertoire "tools" en ligne de commande, et tu as exécuté "adb devices" ?
Link to comment
Share on other sites

clement@dell:~/android-sdk-linux_86/tools$ ./adb devices
* daemon not running. starting it now *
* daemon started successfully *
List of devices attached 

clement@dell:~/android-sdk-linux_86/tools$ ./adb devices
List of devices attached 
clement@dell:~/android-sdk-linux_86/tools$ ./adb get-state
unknown
clement@dell:~/android-sdk-linux_86/tools$ ./adb start-server
clement@dell:~/android-sdk-linux_86/tools$ ./adb shell
error: device not found
clement@dell:~/android-sdk-linux_86/tools$ 

Voilà ce que ça me donne, je ne sais pas s'il faut faire autre chose d'autre entre deux, j'avoue ne pas m'y connaître beaucoup pour une accession plus pointue des appareils Android :/

Link to comment
Share on other sites

Si tu es sous linux il y a peut-être un truc à ajouter dans dans /etc/udev, perso j'avais ajouté ceci qui fonctionne chez moi :

/etc/udev/rules.d/51-android.rules

SUBSYSTEM=="usb", SYSFS{idVendor}=="0bb4", MODE="0666"

Une commande sudo /etc/init.d/udev restart plus tard, et ça reconnaissait mieux mon matériel.

Mais moi j'avais quand-même une ligne en réponse de adb devices, c'est juste qu'il me mettait "unknown" à la place du numéro de série :(

Link to comment
Share on other sites

le fichier /etc/udev/rules.d/51-android.rules est à créer? Je ne l'ai pas dans le dossier personnellement

clement@dell:~$ ls -l /etc/udev/rules.d/
total 12
-rw-r--r-- 1 root root 1129 2010-05-16 10:20 70-persistent-cd.rules
-rw-r--r-- 1 root root  597 2010-05-02 12:51 70-persistent-net.rules
-rw-r--r-- 1 root root 1157 2010-04-19 11:30 README

Link to comment
Share on other sites

De même, pas de 51 Android :

clement@dell:~/android-sdk-linux_86/tools$ ls /lib/udev/rules.d/
40-fuse-utils.rules                70-printers.rules
40-gnupg.rules                     75-cd-aliases-generator.rules
40-hplip.rules                     75-net-description.rules
40-ia64.rules                      75-persistent-net-generator.rules
40-infiniband.rules                75-tty-description.rules
40-isdn.rules                      77-mm-ericsson-mbm.rules
40-libgphoto2-2.rules              77-mm-longcheer-port-types.rules
40-libpisock9.rules                77-mm-zte-port-types.rules
40-libsane.rules                   78-graphics-card.rules
40-pilot-links.rules               78-sound-card.rules
40-ppc.rules                       79-fstab_import.rules
40-usb-media-players.rules         80-alsa.rules
40-xserver-xorg-video-intel.rules  80-drivers.rules
40-zaptel.rules                    80-udisks.rules
45-fuse.rules                      85-brltty.rules
45-libmtp8.rules                   85-console-setup.rules
50-firmware.rules                  85-hdparm.rules
50-udev-default.rules              85-hplj10xx.rules
55-dm.rules                        85-lirc.rules
56-hpmud_support.rules             85-pcmcia.rules
60-cdrom_id.rules                  85-regulatory.rules
60-floppy.rules                    85-usbmuxd.rules
60-persistent-alsa.rules           90-hal.rules
60-persistent-input.rules          90-libgpod.rules
60-persistent-serial.rules         90-pulseaudio.rules
60-persistent-storage-dm.rules     95-keyboard-force-release.rules
60-persistent-storage.rules        95-keymap.rules
60-persistent-storage-tape.rules   95-udev-late.rules
60-persistent-v4l.rules            95-upower-battery-recall-dell.rules
61-gnome-bluetooth-rfkill.rules    95-upower-battery-recall-fujitsu.rules
61-mobile-action.rules             95-upower-battery-recall-gateway.rules
61-option-modem-modeswitch.rules   95-upower-battery-recall-ibm.rules
61-persistent-storage-edd.rules    95-upower-battery-recall-lenovo.rules
64-device-mapper.rules             95-upower-battery-recall-toshiba.rules
64-xorg-xkb.rules                  95-upower-csr.rules
66-xorg-synaptics.rules            95-upower-hid.rules
69-xorg-vmmouse.rules              95-upower-wup.rules
69-xserver-xorg-input-wacom.rules  97-bluetooth.rules
70-acl.rules                       README
70-hid2hci.rules

Donc dois-je le créer? Si oui où, dans /etc ou dans /lib ?

Link to comment
Share on other sites

Porkepix a écrit:

étant donné que je n'ai aucune sauvegarde des contacts du téléphone, j'aurais souhaité les récupérer, ainsi qu'éventuellement le reste, mais surtout les contacts avant que le téléphone ne refonctionne, au pire avec un Hard reset.

Vérifie quand même sur ton compte Google/gmail/contact on ne sait jamais qu'il y en aurait quelques uns de copiés. Depuis un oubli de sauvegarde une fois, j'ai tout copié sur mon compte Google, comme ça, dès que j'installe une nouvelle rom mes contacts reviennent tout de suite. Et avant de les copier, j'en avais quelques un qui s'y étaient mis.

Pour la garantie, il me semble que si tu as fait une image de ton hero lorsqu'il était sous rom officielle, elle fonctionne encore.

Link to comment
Share on other sites

Oui mais je n'ai aucune image 2.73.73.73 et n'en trouve pas sur Internet, par ailleurs je n'ai pas de forfait internet et quand j'ai créé les contacts, je les ai créés en contact téléphone, donc exit la synchro =s

Link to comment
Share on other sites

Oui mais je n'ai aucune image 2.73.73.73 et n'en trouve pas sur Internet, par ailleurs je n'ai pas de forfait internet et quand j'ai créé les contacts, je les ai créés en contact téléphone, donc exit la synchro =s

Tu ne t'es jamais connecté à internet via wifi? Si tu as téléchargé des applis sur l'android market, tu dois avoir un compte Google donc il est possible que Google ait du transférer quelques uns de tes contacts dans gmail.

Moi aussi je n'ai pas de forfait internet, juste le wifi de la maison et une partie de mes contacts se sont retrouvés dans gmail avant que je ne les mettent tous dans gmail.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...