Jump to content
Majorasshole

TUTO - Root Xperia Pro - ERoot [Nouvelle méthode]

Recommended Posts

A lire avec précautions et attention !

Vous étiez réticents au root à cause de la valse des kernels ?

Cette nouvelle méthode va vous simplifier la vie !

Prérequis :

  1. Eroot Pack (Le dernier V1.3.1 en exclu) ou son mirroir comprenant l'application eRoot, le dernier flashtool et la rom .587 pour le Pro en version FR accompagnée de son Kernel "au cas où". Il y a aussi les drivers ADB founis avec Flashtool. N'hésitez donc pas à l'installer, ou le réinstaller avec les drivers "qui vont bien" pour l'accès au mode debug sous windows. Ca se passe dans le répertoire "Drivers" créé dans le répertoire d'installation de Flashtool !
  2. Activez le stockage en mode MSC (câble usb débranché du PC) dans "Réglages" - "Xperia" - "Connectivité" - "Mode de connexion USB".
  3. Activer dans les "options pour les développeurs", activez le "Déboggage USB"
  4. Activez dans le menu "Sécurité", "Sources inconnues"
  5. Prenez-vous un café, et 15 minutes de marge manoeuvre

Attention, l'application ERoot est en chinois, mais est tellement simplifiée que ça ne pose aucun souci particulier.

  1. Relancez votre Xperia avec les options ci-dessus cochées, cable USB débranché.
  2. Branchez votre Xperia Pro
  3. Lancez l'application ERoot, attendez quelques instants au cas où une mise à jour serait appliquée.
  4. Appuyez sur le gros bouton vert "一键root", et patientez quelques instants.
  5. Lorsque s'affiche "恭喜您,获取root 权限成功", votre Xperia Pro est rooté.
  6. Allez dans le google Market, et profitez-en pour installer X-Parts, ça peut toujours dépanner, cela vous ouvre toutes les possibilités du Root.

Vous êtes prêts, SuperUser est installé, à vous le root, les MODs et les ROMs alternatives !

Edited by Majorasshole
  • Like 1

Share this post


Link to post
Share on other sites

Merci..

ca a l'air de bien fonctionner..(j'ai pu désinstallé les jeux préinstallés et que je n'utilise jamais.;)

Share this post


Link to post
Share on other sites

J'arrive pas à télécharger le pack sur Hubic, des problèmes chez OVH ?

Share this post


Link to post
Share on other sites

J'arrive pas à télécharger le pack sur Hubic, des problèmes chez OVH ?

Il semblerait effectivement, faut que je mirrore ça !

Share this post


Link to post
Share on other sites

Ayez rooté aussi ! Merci beaucoup Major !

Par contre pour supprimer définitivement les applications, vous utilisez quoi ? Titanium ?

Eroot semble vouloir se mettre à jour mais le serveur avance pas. T'as une source pour ce soft ?

Share this post


Link to post
Share on other sites

Merci pour cette méthode !

Vu l'extrême simplicité et rapidité de la méthode, j'en ai profité pour reset mon Pro qui commençait à ramer un peu ces derniers temps et je l'ai re rooté par cette méthode par la suite.

Vraiment un gain de temps considérable!

Share this post


Link to post
Share on other sites

salut à tous, et merci à ceux qui ont posté le logiciel, en effet y'a vraiment pas plus enfantin et ce même si c'est "du chinois". Et le plus marrant dans l'histoire, c'est que chez moi ça n'a pas marché du premier coup! je m'explique: y'a quelques mois j'avais essayé donc téléchargé superuser, titanium et rootchecker.......oui, tout mais pas l'exploit! (à ce moment là je croyais que seules des apps suffisaient) aujourd'hui je tombe sur ce post et je télécharge eroot (avec la kernel que je n'installerai pas car le mien est qwerty et donc je voudrais pas dérégler le clavier) donc je branche le tout et je fais un coup de eroot et là patatras! message d'erreur: com.noshufou.android.su plante, de la je comprend que c'est superuser que j'ai désinstallé pour rooter le téléphone et là ça marche OK! Et même si je me suis planté, c'est simple et un poil plus rapide que easy rooting de doomlord (pour le play que j'a rooté hier soir) Quelle joie!!! enfin j'ai pu virer facebook, wisepilot, timesync et une dizaine d'autres applis inutiles imposées par sony.

Share this post


Link to post
Share on other sites

J'essaye çà dés que je rentre chez moi ce soir !!!

 

edit ps :Si je root comme ca je perds toutes mes données sur le téléphone / SD ou pas ?

Edited by Kushiel

Share this post


Link to post
Share on other sites

J'essaye çà dés que je rentre chez moi ce soir !!!

 

edit ps :Si je root comme ca je perds toutes mes données sur le téléphone / SD ou pas ?

Bien sûr que non, le root ne touche qu'aux fichiers systèmes et n'a aucun impact sur les données perso, ni même la SD de loin ou de près.

Share this post


Link to post
Share on other sites

Bien sûr que non, le root ne touche qu'aux fichiers systèmes et n'a aucun impact sur les données perso, ni même la SD de loin ou de près.

Merci de la précision j'avais bien un doute

Share this post


Link to post
Share on other sites

Bonjour,

 

Je possède un XPERIA Active avec une version ICS en 4.0.x. J'ai suivi les étapes listées dans ce topic et ai lancé eRoot 1.3.4 (téléchargé quelques posts plus haut). Malheureusement, cela aboutit à la fenêtre suivante : http://img11.hostingpics.net/pics/241908eRootPasdeplace3.jpg (celle de gauche).

 

En faisant quelques recherches, j'ai appris qu'il me fallait faire le ménage dans mes applis car eRoot manquait de place pour s'installer. Il me reste 186 Mo de libre (ce qui me semble suffisant) mais la même fenêtre apparaît.

 

Auriez-vous une idée pour me dépanner ?

 

Merci par avance de votre aide,

Share this post


Link to post
Share on other sites

Libre sur la mémoire interne ou dans la SD ? Vous avez bien basculé le mode de connexion USB en MSC et surtout pas en MTP ?

Share this post


Link to post
Share on other sites

Oui sur la carte interne. Par contre, j'etais sur du MTP et non du MSC. Je vais refaire l'essai et vous tiens au courant ;-)

Share this post


Link to post
Share on other sites

J'ai redémarré mon phone après être passé en MSC mais le résultat est toujours le même...

Share this post


Link to post
Share on other sites

Auquel cas, je ne vois pas d'où ça pourrait venir. Eroot est compatible avec les versions 2.3, 4.0.3 et 4.0.4 de la gamme Xperia 2011, donc il y a un souci quelque part, peut être du côté des drivers adb absents par exemple, si vous n'avez jamais utilisé flashtool ou autre auparavant.

Share this post


Link to post
Share on other sites

Je ne l'ai effectivement jamais utilisé. A quoi sert-il ? Ou puis-je le trouver ?

Share this post


Link to post
Share on other sites

Téléchargez le dernier Flashtool, et installez les drivers nécessaires placés dans le répertoire drivers de Flashtool. Tous sont fournis dans l'installeur.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...