Jump to content

Google Navigation : Recherche du signal GPS


Recommended Posts

Bonjour,

Nouveau venu depuis 1 mois dans le petit monde Androïd, je parcours cet excellent site/forum pour me familiariser avec cet OS !

Ce téléphone est parfait, SAUF que je n'arrive pas à faire fonctionner le GPS.

Par exemple, pour le trajet Lyon / Gap qui dure 2h45, j'ai eu environ 2h40 avec l'information "Recherche du signal GPS" indiquée à l'écran de l'application Google Navigation ...

Je peux concevoir que ça ne capte pas dans les montagnes gapençaises, mais sur le périphérique lyonnais ou sur l'autoroute de Grenoble ça devient plus problématique :mad:

Le plus étonnant est qu'il a déjà fonctionné (pas longtemps mais parfaitement pour un petit trajet : Villeurbanne / Lyon - Croix-Rousse). J'avais bel et bien la petite voix qui me disait de tourner à gauche ou à droite ;)

Avant d'écrire ce post, j'ai fait plusieurs recherches sur le forum, mais aucun article ne semblait se rapprocher de mon problème.

J'ai donc installé l'application "GPS Test" qui m'indique le GPS en état "ON" avec une valeur pour "Accuracy" de 419.9 alors que j'ai cru comprendre qu'il fallait une valeur la plus basse possible (https://forum.frandroid.com/forum/viewtopic.php?id=17279)

Plusieurs articles évoquent des problèmes de précision du GPS (erreurs de quelques dizaines de mètres) avec des possibilités de correction ( https://www.frandroid.com/25815/samsung-galaxy-s-la-methode-pour-corriger-les-problemes-du-gps/ testé sans succès) ou alors le fait de changer de firmware. S'il le faut je le ferai mais pour l'instant je ne me suis pas encore aventuré ici, étant toujours dans ma version d'origine Bouygues Android 2.1 (XXJF3).

Que dois-je faire :

- Mettre à jour le firmware ?

- Le renvoyer en SAV ?

- Acheter un iPhone ? :P

Merci d'avance ...

Link to comment
Share on other sites

Bonjour protion,

Oui, je veux bien tenter de changer de firmware, mais je ne suis pas sûr que ce soit uniquement un temps d'accroche raccourci qui règle mon problème, car celui-ci n'était pas de 3min mais plutôt inexistant car il n'a rien capté pendant plus de 2h lors de mon trip vers Gap ...

Link to comment
Share on other sites

Salut,

Question toute bête mais est ce que cela ne viendrais pas du pare brise?

J'ai remarqué que dans mon 1er véhicule le signal est plus dur à accroché que dans ma 2ieme voiture... Certain GPS nomade ne fonctionne pas ou peu avec des pare-brises athermique il me semble.

Est ce qu'en extérieur le GPS fonctionne correctement?

Link to comment
Share on other sites

Bonjour.

Juste un petit mot pour rappeler que la "perméabilité" de certains pare-brise n'est pas une légende.

Renault qui fut l'un des premiers à généraliser cet équipement (comme sur bien d'autres accessoires) s'est très vite aperçu que les badges de télépéages devenaient muets. C'était en toute fin des années 90...

Depuis, des lucarnes sont ménagées dans le traitement athermique à base de particules métalliques : on distingue une interruption dans le reflet rosâtre, soit au pied du pare-brise, soit dans la zone du rétroviseur central.

Link to comment
Share on other sites

En fait, comme dit dans d'autre thread.., c'est un problème reconnu par samsung. D'après eux, c'est certainement un souci de drivers. Ils sont en train de préparer un vrai correctif. Il est annoncé pour septembre.

Nef.

Je pourrais savoir s'il te plait ta source ? Ca vient vraiment de Samsung?

Link to comment
Share on other sites

@Bl4ckc4t: Je ne retrouve plus l'article de presse de Samsung, mais voici un lien qui en parle:

http://www.planete-android.com/2010/08/15/samsung-travaille-sur-le-probleme-de-gps-du-galaxy-s/

Samsung annoncaient reconnaitre qu'il y avait un problème sur les GPS pour les telephones GS US (Vibrant) et qu'il travaille dur dessus. On peut espérer un bon correctif en septembre avec Froyo.

Depuis que j'ai mon tel (firmware JM5), j'ai réussi à accroché un signal que 3 fois. Et pourtant j'habite en région parisienne. :P

Etre en région et une circonstance aggravante :P :lol: ce que je veux dire, c'est que pour accrocher facilement les satellites, il ne faut rien au dessus de soit mais aussi pas de batiments autour de soit.

Pour les pare Brise athermique, le problème est connu et partiellement contourner par les nouvelles puce GPS, la puce de notre téléphone devrait fonctionné derrière un pare prise athermique mais avec une moins bonne réception (comme tout GPS dans ce cas).

Ls GS est équipé du même GPS que le HTC Desire, ce dernier n'a pas de soucis du coté du GPS, donc un espoir de solution software reste permis

Link to comment
Share on other sites

Pour info, le GPS avait fonctionné dans ma voiture sur mon petit trajet Villeurbanne / Lyon - Croix-Rousse, mais n'avais pas fonctionné dans cette même voiture pour le trajet Lyon / Gap.

Je ne pense donc pas que j'ai un problème de pare-brise.

A part ça,

Sur vos conseils, j'ai donc tenté de flasher mon téléphone en JM5 selon un tuto trouvé sur FrAndroid mais j'ai un "petit" problème :

Dans ODIN, cela fait 25 min que ça reste bloqué sur la ligne : "

Link to comment
Share on other sites

@Bl4ckc4t: Je ne retrouve plus l'article de presse de Samsung, mais voici un lien qui en parle:

http://www.planete-android.com/2010/08/15/samsung-travaille-sur-le-probleme-de-gps-du-galaxy-s/

Samsung annoncaient reconnaitre qu'il y avait un problème sur les GPS pour les telephones GS US (Vibrant) et qu'il travaille dur dessus. On peut espérer un bon correctif en septembre avec Froyo.

Merci, c'est rassurant parce que là, vaut mieux pas montrer à ses amis "le meilleur des android" qui galère à rester sur une autoroute. Enfin, le reste est génial, ça compense (un peu).

Link to comment
Share on other sites

Pour info, le GPS avait fonctionné dans ma voiture sur mon petit trajet Villeurbanne / Lyon - Croix-Rousse, mais n'avais pas fonctionné dans cette même voiture pour le trajet Lyon / Gap.

Je ne pense donc pas que j'ai un problème de pare-brise.

A part ça,

Sur vos conseils, j'ai donc tenté de flasher mon téléphone en JM5 selon un tuto trouvé sur FrAndroid mais j'ai un "petit" problème :

Dans ODIN, cela fait 25 min que ça reste bloqué sur la ligne : "

Link to comment
Share on other sites

Ouf !! J'ai réussi à installer le nouveau firmware ! J'étais à 2 doigts d'appeler Dr House pour le soigner :)

Après un simple redémarrage de l'ordi, Odin s'est lancé correctement comme par magie ...

Là je suis en train de restaurer mes applis et tout ce qui va bien avec Titanium, et l'étape suivante sera de voir si mon fameux GPS marche mieux avec ce nouveau firmware (ce qui est quand même le but de la manoeuvre). Je vous tiens au courant ...

Link to comment
Share on other sites

J'ai fait un petit tour en voiture, et il semblerait que ça fonctionne plutôt bien maintenant !!

La position initiale est trouvée assez rapidement, et l'itinéraire est dicté sans souci.

Il reste tout de même quelques approximations de position, mais je vais tenter le hack proposé dans l'article que j'ai indiqué plus haut pour améliorer la précision.

En tout cas, merci FrAndroid, maintenant mon GPS fonctionne à peu près bien, et en plus avec cette nouvelle version de firmware, le téléphone est plus fluide qu'avant !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...