Jump to content

Fix GPS


Recommended Posts

Bonjour à tous.

Je me permets de vous retranscrire un post de samdroid sur la création d'un fix pour le gps.

Post d'origine : http://forum.samdroid.net/f28/working-gps-finally-we-have-2-1-2-2-a-3880/

Tous les honneurs vont donc à Sucka & à FranzyRoy et PixieBob

Tutorial :

Installation :

Avant propos : le fichier à télécharger est le "lbstestmode_gpsconf_fr_v2.zip" (mise à jour du 04/02/11)

01. Télécharger update.zip joint au post.

02. Le placer sur votre sd.

03. Sous recovrey, l'installer et redémarrer.

04. Depuis votre Home, créer un raccourci personnalisé vers Activité>LbsTestMode>.LbsTestMode (le premier de Lbs)

05. Une fois le raccourci créé, le lancer.

06. Dans le menu principal, aller à SUPL/CP : mettre comme serveur : supl.google.com (sans les www devant), mettre le port 7276, secure mode : off, gps mode : supl

07. Appuyer sur retour.

08. Depuis le menu principal, aller dans application settings, mettre "MS Based" dans "operation mode".

09. Appuyer sur retour.

10. Depuis le menu principal, faire "delete gps data" (cette étape peut être réalisée par la suite directement sous l'appli "GPS status"

11. Redémarrer le téléphone.

12. Installer GPS status (ou autre appli du genre), activer votre gps, lancer l'appli pour forcer le téléchargement des dernières données gps.

Notes importantes :

01. Si vous aviez appliqué la première version du fix, il vaut mieux avec root explorer effacer lbstestmode sous system>app, rebooter et ensuite appliquer la nouvelle version du fix.

02. Des réglages alternatifs ont fonctionné pour certains forumeurs :

- Lolorible

Problème réglé : retenté nouveaux settings et c'est OK

supl auto, server on, skyhook on

NB : le fichier donné en pièce jointe supprime tout fix gps éventuellement présent (Thx FranzyRoy et PixieBob)

ENJOY....

Une explication du quoi fait quoi :

EDIT : Voici là dernière mise à jour par PixieBob :

j'ai commis une erreur d'ecriture(desolé) dans l'update-script de LbsTestMode_gpsconf_fr qui fait que LBSModeApp.apk n'etait pas effacé.

l'erreur est corrigé dans le nouveau package , j'ai rajouté l'effacement de 50gpsfix car si vous l'avez il rentrerait en conflit avec gps.conf.

rappel:

ce fichier va installer le dernier LbsTestMode.apk de sucka, effacer LBSModeApp.apk(qui est perimé mais installé avec la cm8.3), installer le nouveau gps.conf avec les serveur francais.

si vous avez la bande de base JC1, qu'on obtient en installant le firmware JCE, alors vous pourrez avoir le fix gps(le temps que le gps met pour se fixer, cesse de clignoter) en moins de 10 secondes la premiere fois et moins de 5secondes les autres fois.il faut telecharger les data gps avec l'application GPSstatus.

je vous laisse consulter le post original de sucka pour les explications:

http://forum.samdroid.net/f28/working-gps-finally-we-have-2-1-2-2-a-3880/

Plus de soucis de gps bloqué, qui ne rafraîchit rien du tout et qui traine 5 ans pour fixer les satellites.

Même si ce n'est toujours pas instantané, au moins le gps se rafraîchit 2 fois plus vite et se connecte toujours aux satellites.

Le gps les fixe presque toujours et démarre vraiment vite.

SVP, à tester et donner vos retours. Vous pouvez tester différentes configurations de l'appli pour qu'elle puisse être améliorée.

Info : Le gps répond très bien et se connecte presque systématiquement et instantanément en utilisant une rom basée sur JC1 et non pas JD1.

JD1 a des soucis avec le gps qui se bloque parfois. Cela fonctionne avec toutes les baseband, mais la JC1 est la plus rapide.

Merci à tous pour votre participation et merci aux créateurs, les Dieux de ce téléphone car sans eux, ce téléphone ne serait qu'un jouet bas de gamme et sans intérêt.

Maintenant, c'est un véritable outils.

Note : le fichier que j'ai joint diffère de celui posté originellement, j'ai juste modifié le serveur europe par le serveur français. Du coup je n'ai pas traduit cette partie pour éviter les problèmes de compréhension.

Voici le lien donné par l'auteur pour les serveurs : http://www.pool.ntp.org/zone/europe

MàJ du 19/01/11 : mise à jour du fichier update joint sur le post original et modifié par PixieBob

MàJ du 26/01/11 : rajout du script de Franzyroy.

MàJ du 04/02/11 : remplacement du script par la dernière version de PixieBob

MàJ du 05/02/11 : simplification, un seul fichier qui fait tout, c'est plus simple (et retour dans le présent ^^" thx Sky-Dexter)

MàJ du 15/02/11 : Rajout solution Lolorible

Edited by Guest
Link to comment
Share on other sites

  • Replies 127
  • Created
  • Last Reply

Top Posters In This Topic

Je dirais même plus, "réglé sur ceux fr" vu que j'ai modifié le gps.conf dans ce sens ;°)

Ha je savais pas ;) ! Autant pour moi :P ! Tu as fais la manip' avec l'appli ? Ca donne quoi ? Si ca fait réellement quelques choses de plus je l'insère dans ma nouvelle cm, sinon je met que le Gps.conf ... a voir .... si l'appli sert vraiment a un meilleur fonctionnement en plus du gps.conf .

Link to comment
Share on other sites

J'ai fait la manip cet aprèm, donc je n'ai pas encore trop de retour dessus.

Le update install une nouvelle appli qui permet de bien configurer le gps, donc ça ne peut pas faire de mal.

Je vais tester tout ça demain dans l'après midi, donc je donnerai mon retour demain.

Link to comment
Share on other sites

Je l'ai testé hier.

Aucune comparaison avec l'ancien gpsconf.

Sur l'ancien le fix varie entre 2 et 7 minutes, des fois 10 bonnes minutes.

Sur le nouveau le fix se fait entre 25 et 45 secondes.

Et encore je suis sur jd1

Edited by mcao
Link to comment
Share on other sites

j'arrive a avoir le fix en 15 secondes max, trop bon.j'ai utilise le gps.conf modifié de mek(pour la cm8.3 ca suffit), merci :P je suis en JD1

Ouaaa ! Enorme ! Faut que je test ca :P !

J'ai apprit que ce n'était plus compatible avec le tweak gps apparemment ... et je vois ca aussi sur le tuto..

Edited by IT4ALii3EN
Link to comment
Share on other sites

par contre ca bug souvent au premier lancement de gmaps le fix ne se fait pas il cherche sans jamais trouver. alors je le kille et le relance et la normalement plus de probleme que je lance ou relance gmaps le fix se fait tjrs tres rapidement en 15 secondes max

Ok, je test là ! J'ai finit la CyanogenMod 6.1.1 Spica alpha8.3 IT4ALii3EN new1 et je vais testé tout ca ;) ! Avant les test, dodo. Je ferais ca demain apres avoir chargé le spica a fond :P

Link to comment
Share on other sites

la cm8.3 contient l'ancien LBSModeApp.apk alors que sucka a sorti le nouveau LbsTestMode.apk.

je vais vous faire un update.zip

edit: le voila , donc il contient le nouveau LbsTestMode.apk voir ici pour plus de precision.

j'ai aussi rajouté le nouveau gps.conf france(celui qu'a edite mek).

l'update.zip va aussi effacer l'ancien LBSModeApp.apk contenu dans la cm8.3.

edit2:normalement avec ca vous devriez avoir le fix en moins de 15 secondes

Edited by pixiebob
Link to comment
Share on other sites

la cm8.3 contient l'ancien LBSModeApp.apk alors que sucka a sorti le nouveau LbsTestMode.apk.

je vais vous faire un update.zip

edit: le voila , donc il contient le nouveau LbsTestMode.apk voir ici pour plus de precision.

j'ai aussi rajouté le nouveau gps.conf france(celui qu'a edite mek).

l'update.zip va aussi effacer l'ancien LBSModeApp.apk contenu dans la cm8.3.

edit2:normalement avec ca vous devriez avoir le fix en moins de 15 secondes

qu'est ce qu'il faut faire avec le fichiers joint ?

Edited by davidspicadroid
Link to comment
Share on other sites

sinon ya pas beaucoup de commentaire concernant cette amelioration du gps pourtant ca dechire.

Bha j'ai meme pas testé moi-même :P ! Je suis sur ma cm, et y'a pas mal de nouvelle update de krnl/tweak/fichier system/... faut pensé a tout et je viens de réinstaller une nouvelel cm que j'ai faite, avec encore toutes les maj . Pour l'instant il est sur la bootanimation...

Link to comment
Share on other sites

sinon ya pas beaucoup de commentaire concernant cette amelioration du gps pourtant ca dechire.

J'ai posté une vidéo pixie, mon gps me localise à 3ou4 rue près et d'un coup il me localise je ne sais pas ou... j'ai fait les modifs comme sur le tuto mais rien toujours pareil

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...