Jump to content

MapView qui ne charge pas la carte après mise à jour


macuserlambda

Recommended Posts

Bonjour !

Je rencontre un problème avec une MapView:

Ma MapView montre le cadrillage gris, mais la carte ne s'affiche pas.

Ca fonctionne bien lorsque j'installe l'application pour la première fois, mais quand je la met à jour, la carte ne fonctionne plus ...

Je dois désinstaller et réinstaller pour la faire fonctionner.

Je n'ai pas changé la map key pour la nouvelle version, j'ai essayé de regénérer la clé et j'ai obtenu la même (puisqu'à partir du même keystore). Elle ne fonctionne toujours pas ...

J'ai essayé en 3G et en Wi-Fi, sur deux téléphones différents ...

Internet Permission est mis, la map library est mise aussi...

Comment puis-je corriger ce bug?!

Link to comment
Share on other sites

J'avais ce genre de problème depuis l'emulateur. J'ai du mettre les permissions net a la fois sur l'application et sur l'activty de la map view. Mais je suis pas sur que cel corrige ton problèmes. :/

Sent from my Nexus S using Tapatalk

Link to comment
Share on other sites

Merci pour vos réponses.

Mon but c'est justement que les gens qui installent mon application n'aient pas à faire une clean install à chaque mise à jour...

Ils ont des données à conserver.

Dans tous les cas j'ai tenté de poster la mise à jour quand même et ça marche... Comment retarder d'une semaine la mise en prod pour rien...

Merci d'avoir pris le temps de me répondre en tout cas :-)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...