Jump to content

[ROM] Galaxo V1.6.2 (Donut)

Recommended Posts

[h]GALAXO VERSION V1.6.2[/h]





Due to differences between Galaxy and other android phone about internal memory, you MUST use the recovery : https://www.frandroid.com/forum/viewtopic.php?id=1803. Sorry for the inconvenience. Perhaps we can agree on this subject between other rom cookers, for use the same definition of the internal memory (i use "INTERNAL" definition)

BE CARREFULL. This rom doesn't include Google's experience apps. After flashing, use the option "Restore Gapps" in recovery to restore those applications.

Changelog :


- based on JC6


- Restore original SMS/MMS app

- Fixed phone issue

Features :

- Based on last 1.6 (Donut) update from Samsung

- Most languages :

  • - Czech
    - Danish
    - German
    - English
    - Spanish
    - Finnish
    - French
    - Italian
    - Dutch
    - Norwegian
    - Polish
    - Portuguese
    - Swedish

- Root (with superuser)

- ADB root whith personnalised bash prompt

- All applications optimised with zipalign

- Full market

Applications :

- MMS app from rgv151 on XDA(http://forum.xda-developers.com/showthread.php?t=540651)

- Loccy's BetterBrowser (http://forum.xda-developers.com/showthread.php?t=551119)

- Donut Advanced Launcher (rogro82/irrenhaus on XDA (http://forum.xda-developers.com/showthread.php?t=540880) :

- New applications Galaxo : GalaxoParameters & GalaxoApps :

- GalaxoParameters : enable/disable camera button, remount fs in rw/ro, shown hidden menu (does not work because samsung apps are removed)

- GalaxoConf : manage galaxo (vnc, sshd..)[/indent]

System :

- rc with configuration (GalaxoConf)

- Full SSHD/SCP support (/etc/passwd, /etc/shadow..). Changing the root passwd : adb shell, then "changepasswd"

- Script to activate/deactivate the camera button (camenable/camdisable with adb)

- Script to remount in rw/ro the filesystems in both recovery/system (remountro, remountrw). Already exist with adb (adb remount) but usefull in recovery to remount correct partition, and with connectbot.

- VNC server on port 5901 (can be activated in GalaxoConf).

- Busybox 1.15.1 with full applets

- Moving all app to internal memory to keep space on /system (like app2sd)

- New adbd where replacing default shell from sh to bash with custom bashrc

- Recompile some tools for android-arm : zsh, nano, vim, inadyn

- Lot of tools in xbin/

- Telnetd

- Debug tools

- Access phone, contacts, market and other without sim cards (wifi)

Other tweak/improvment :

- Tweaked CPU freq rules, improved responsiveness (sampling can be managed in GalaxoConf)

- Mount rw device with noatime option

- Disable some services (NPS service, debug devel binary)

- Remove all samsung apps

- Home app is now locked in memory to avoid reloading of it

Nota :

- Because i haven't the 2.6.29 kernel source right now, all kernel stuff doesn't work (included some option from galaxoconf, compcache, vnc keyboard..)

- Because Samsung apps are removed, some options from galaxo+ doesn't work anymore

If you like my work, give me beer, or give my girlfriend a flower :


File archive :http://drakaz.sfhost.net/GALAXY/

Enjoy !

Edited by drakaz
Link to comment
Share on other sites

How to correctly flash this rom :

A) Backup your current system

1) Flash the latest recovery (see https://www.frandroid.com/forum/viewtopic.php?id=1803)

2) Boot in recovery mode

3) Use nandroid backup to make a backup of your current system

B) Flash with Galaxo

1) Flash the latest recovery (see https://www.frandroid.com/forum/viewtopic.php?id=1803)

2) Reboot in recovery

3) Push the update.zip on your internal sdcard (adb push update.zip /sdcard/update.zip)

4) Push the official JC6 PDA update on the sdcard renamed as SAMSUNG.tar on your internal sdcard (adb push YOURJC6UPDATE/sdcard/SAMSUNG.tar)

7) Wipe using the recovery

8) Flash the update using the recovery

9) Restore Gapps using the recovery

11) Reboot

12) Enjoy

Edited by drakaz
Link to comment
Share on other sites

Hi drakaz,

i have some problems with this rom regarding 3g connection, when i turn on the phone 3g is working as expected, but after a while the connection breaks down, the 3g icon is still there, but only the up arrow is blinking and i get no data down. when i start market after a while it tells me network error... when i check use only 2g network everything is working fine.

on android-hilfe.de it looks like i am not the onlyone with this issue, but it seems to be also not verry common.

for the rest i really love this rom except of the missing netfilter, but i guess thats nothing you can do at the moment.

best regards and keep up your good work


Link to comment
Share on other sites

As I said, I got my Galaxy and now try to install new ROM, but...

I can't force my system to install drivers for Recovery Mode.

I've got Windows 7 and when I switch to Debug USB mode, my Windows fails to install drivers required for ADB (usb_driver riconoscimento).When I switch to Fastboot mode and try to install those drives too, I get the same error message:


Any idea how to solve it ?

Link to comment
Share on other sites

Great, please post your solution in the drakaz's recovery topic.

If you want there are many themes to modify the skin of your androphone.

For example :

- GNGH : https://www.frandroid.com/forum/viewtopic.php?id=5137

- Buuf : https://www.frandroid.com/forum/viewtopic.php?id=8157

- GalaxAir (my theme :P ) : https://www.frandroid.com/forum/viewtopic.php?id=8640

Link to comment
Share on other sites

  • 3 weeks later...


after not getting my 3g problem sorted i decided to flash another custom firmware (archers italy rom) but the 3g problem did not go away. some guy suggested this could maybe be solved by flashing back to ii5 because this also changes baseband, so i would like to know if it could be possible to only flash baseband and keep the rest?

any suggestions?

Link to comment
Share on other sites

hi drakaz, sorry for crossposting, but i thought it would be better to talk here.

actually it looks like i found a way to circumvernt the no sleep bug as well as the wifi problems just by replacing baseband with ii5 version, there are atm several people testing with good results so far.

Edited by FadeFX
Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...