Jump to content
Sign in to follow this  
GauthierBenat

[TUTO] [Android] Régler le problème de CarteSD montée en ReadOnly

Recommended Posts

OPTION 1 :

suivez ce tuto (en anglais désolé) merci AdamL

OPTION 2 :

Démarrer votre Touchpad sous WebOs

La connecter au PC sans activer le stockage USB (on la branche et on touche à rien)

Ouvrir NovaTerm.bat (par défaut dans C:\Program Files\Palm, Inc\terminal)

Dans la fenêtre qui s'ouvre : * si ça s'ouvre pas, voir fin du post

Cliquer sur File puis Connect (vous avez alors une petite fenêtre qui s'affiche et qui correspond à la détection du bon périphérique, en l'occurrence le Touchpad).

Une fois connecté taper : fsck.vfat -vy /dev/store/media

Valider par la touche enter

Fermer la fenêtre et débrancher votre Touchpad

Voilà c'est fait, y'a plus qu'à redémarrer sur CM7 (normalement le boot se fait en 2fois au premier redémarrage donc pas de panique si vous croyez que ça bootloop) !

source : XDA - LateralOctober

Si à l'ouverture de NovaTerm vous avez un message d'erreur "manque javaw" c'est que vous n'avez pas installé la bonne version de java (genre vous avez un ordi x64 et vous avez installé la version x86) donc désinstallez complètement Java puis télécharger le JDK correspondant à votre configuration sur cette page

Edited by crap's

Share this post


Link to post
Share on other sites

C'est censé régler le problème de carte SD endommagée dans CM7 a3 ou pas?

Share this post


Link to post
Share on other sites

Je n'en sais rien du tout, faudrais que tu essayes pour voir et nous faire un retour par la suite.

Share this post


Link to post
Share on other sites

Finalement je l'ai résolu en reinstallant la alpha 2.1 ;)

Sent from my ZTE-BLADE using Tapatalk

Share this post


Link to post
Share on other sites

non il n'y en a pas :-) c'est juste que comme notre touchpad n'a pas de version de cm propre et qu'on a porte la version telephone il reconnait la memoire comme une carte sd, ou bien les devs ont pas voulu s'embetter a changer la boite de dialogue :-D

Share this post


Link to post
Share on other sites

Alors surement la fatigue d'hier soir, mais ce matin ça fonctionnais (tout pareil qu'hier) :

151211011216good.JPG

Pourtant ensuite lors du redémarrage de la tablette : pas de double boot, et la carte SD fail toujours. Si quelqu'un à une idée.

Share this post


Link to post
Share on other sites

Dans le recovery fait un wipe cache et dis nous ce que ça donne.

Tu as quelle rom de flashée aussi ?

Et que veux-tu dire par "pas de double boot " quand tu la redémarres tu passes bien par moboot ?

Edited by crap's

Share this post


Link to post
Share on other sites
Et que veux-tu dire par "pas de double boot " quand tu la redémarres tu passes bien par moboot ?
(normalement le boot se fait en 2fois au premier redémarrage donc pas de panique si vous croyez que ça bootloop) !

Je passe bien par moboot 0.3.3 qui démarre normalement (la 0.3.4 et la 0.3.5 ne fonctionne pas).

J'utilise l'alpha 3 de CM7 et le wipe cache n'a rien changé (même après avoir refais la manipulation avec la console).

Edited by KdK

Share this post


Link to post
Share on other sites

Damned it !

Pourtant cela a très bien fonctionné chez moi...

Fais un backup de ta rom et flash la nouvelle version (la 3.5) peut-être cela va-t-il résoudre ton problème.

Sinon malgré le wipe cache et la commande ça ne solutionne rien faudra que tu refasses une installation complète au propre (un coup de webosdoctor pour tout remettre à zéro puis réinstallation de la rom android)

En plus en lisant ta capture d'écran il marque bien "not automatically fixing this" ce qui veut dire que rien n'a été résolu en fait et donc c'est pour ça que tu n'as pas le redémarrage de la tablette en 2fois aussi.

Edited by crap's

Share this post


Link to post
Share on other sites

La bonne nouvelle c'est que la Touchpad ne peut plus être montée en tant que sous Windows :/

Je suis à l'étape WebOS Doctor là.

Share this post


Link to post
Share on other sites

Bonjour,

C'est un gros fiasco de mon côté :( J'avais aussi ce problème de carte sd endommagée, j'ai tenté la manip NovaTerm mais impossible de connectée la tablette. Elle ne se monte plus (sous windows) donc j'imagine que c'est pour ça.. Du coup j'ai plus non plus accès à mon répertoire cminstall pour balancer une autre rom.

J'ai toujours moboot 0.3.3 au démarrage, quand je tente le Clockworkmod je n'ai pas non plus accés au zip à flasher, le répertoire n'est plus là !! (Pourtant j'ai toujours Android CM7 a3 dessus).

Bref... si quelqu'un à une illumination je suis preneur, c'est la loose là :huh:

Merci !

Share this post


Link to post
Share on other sites

Si elle démarre sous WebOS, connecte la au PC et sauvegarde le backup que tu avais fait (si tu en as fait un) comme ça tu pourras retrouver ta ROM android comme avant (le backup se trouve dans clockworkmod/backup, c'est le dossier avec une date et une horaire).

Puis tu fais un coup de WebOSDoctor comme ça tu retrouveras une tablette totalement neuve et tu réinstalleras android ensuite puis ta sauvegarde (si pas de sauvegarde faudra que tu te retapes tout le paramétrage d'Android)

Share this post


Link to post
Share on other sites

Si elle démarre sous WebOS, installe remove android ou android-uninstaller (je ne me souviens plus du nom exact) via Preware !

Share this post


Link to post
Share on other sites

Ce qui m'étonne c'est que ta tablette ne soit pas détectée par le Doctor, tu dois faire une mauvaise manip quelque part je pense

Share this post


Link to post
Share on other sites

Il faut pas la mette en mode USB (Vol+ et Power au démarrage) pour qu'elle soit détectée?

Share this post


Link to post
Share on other sites

@Mickajo et @crap's : merci.

Vu que beaucoup de chose déraillaient j'ai préféré supprimer Android.

J'ai rendu ma Touchpad accessible à mon pc par appui long sur Power + Vol+, quand le logo USB apparaît j'ai branché ma tablette (là elle à été reconnue car driver novacom installés).

Ensuite j'ai procédé comme dans ce tuto

en récupérant le ACMEUnistaller de l'alpha 3 ici http://rootzwiki.com/topic/10121-r [...] -touchpad/ .

Tout s'est bien déroulé.

Je vais faire une réinstall au propre en espérant que tout roule.

Share this post


Link to post
Share on other sites

Help me !

Après pas mal d'heures de réglage, j'avais enfin une tablette parfaite et maintenant j'ai une erreur "carte SD retiré"

Impossible de lancer les applications sur sd (elles plantent ou sont marquées "non installées") Pourtant j'ai encore accès à mes photos...

Dans les paramètres je vois la répartition du stockage de la SD, mais la ligne "espace libre" a disparu.

Juste avant l'apparrition du problème, j'étais en train de bouger des applications vers la SD.Je venais aussi d'installer/désinstaller une application pirate (je voulais voir si fruit ninja THD marchait), ça peut être un virus ?

La solution de ce topic marche toujours sur CM9 ?

Sinon j'ai quoi comme solution sans devoir faire un wipe data ?

Merci !

Share this post


Link to post
Share on other sites

quel est l'utilité de bouger les applications vers la sd sur le touchpad, puisque celui ci ne possède pas de sd

Share this post


Link to post
Share on other sites

Help +1 !!!

Je suis dans le même cas que toi ElReV31 , sous CM9 A2 et depuis que j''ai essayé de transférer des applis sur la SD j'ai ce fameux message "carte sd retirée" , et avant de tous reinstaller si il y aurai une bonne ame qui aurait la soluce...

Pour répondre à monfiston , j'ai voulu transferer les applis sur la sd parceque j'avais moulte applis et qu'il me restait trés peu de place pour faire les mise à jour de celles qui était déjà installé,d coup certaines refusé carrement la mise à jour, donc pour eviter des manips afin d'augmenter les 2 Gb de partition dédier à android , le transfert des applis sur la sd me paraissait le mieux à faire ;-)

Du coup si ya vraiment pas de soluce, je vais devoir me résignerà faire un backup et pourquoi pas installer AOPK...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  





×
×
  • Create New...