Jump to content
samco08

Installer une ROM Custom sur Acer A100

Recommended Posts

d'ans l'ordre:

si vous n'êtes pas sous ICS :

1/ aller dans les paramètres pour faire un reset complet d'usine de la tablette (sauvegardez vos documents avant)

2/ installer le leak de la "Vache" (même procédure que n'importe quelle MAJ (renommer en "update.zip")

http://vache-android...=files&file=148

A placer à la racine de la SD (external sd) puis renommer le ficher en "update" (attention qu'il n'y ai pas de fichier au même nom !)

Éteindre et rallumer en recovery (power + volume up) et la mise à jour se fera automatiquement !

si vous êtes sous ICS:

3/rebooter

4/ activer la fonction usb debug mod dans les options de la tablette.

Rootage Sous windows:

5/ installer les drivers de la A100 !! et pas ceux que Windows installe par défaut

http://global-downlo...Acer&SC=EMEA_13

......

redémarrer

....

..

6/connecter la tablette et attendre la détection par windows.

7/ lancer en administrateur "runit-win.bat" du dossier ics_rooting (extrait au préalable)

http://depositfiles....files/70gkiwjfm

8/ une fois l'opération éffectuée la tablette redémarrera toute seule.

9/ sur le market télécharger et installer "SuperUser"

10/ une fois l'opération éffectuée redémarrer la tablette

11/ sur le market télécharger "ROOT Checker basique" pour être certain du root de de busybox.

voila vous êtes rooté et sous ics.

déblocage du bootloader :

!!!!!!!!!!! attention à ce que vous faites !!!!!!!!!! (ne me tenez pas pour responsable si vous flinguez votre tablette.

ceci-dit, elle doit être chargée avant de continuer les étapes suivantes.

12/ connecter de nouveau la tablette

13/extraire le contenu de "2_Fastboot_Recovery.zip"

http://depositfiles....files/b8pm44ddk

14/ lancer en administrateur le fichier "install-eng.bat"

il faut d'abord depuis windows lancer "cmd.exe" et aller à l'emplacement du dossier et du fichier.

ex: cd C:\Fastboot&Recovery

attention la tablette redémarrera "de mémoire" 3 fois avant de vous afficher l'image du cadenas (ne débranchez pas la tablette avant!)

15/ au moment ou vous voyez les deux icônes sur votre tablette faites vol- pour aller sur le cadenas ouvert puis vol+ pour valider ou Vol_gauche puis Vol_droit (si ou avez les boutons vers le haut)

16/ attendre la fin de la procédure de déblocage.

17/ une fois que tout est terminé (et pas avant) redémarrer manuellement la tablette.(vous aurez un message qui vous demande de redémarrer)

18/ vous aurez un message du type "bootloader unlocked 0.03.06-ics" suivi d'une image détériorée (pas de panique)

voila vous êtes sous ics+root+bootloader débloqué

maintenant, installation de ClockWork Recovery:

19/ extraire à la racine de votre mémoire "sdcard" et non pas sur votre carte mémoire" external_sd" le contenu de "A100_recovery.zip" (deux fichier dont un .sh)

20/ installez "Terminal Emulator" de l'android market /Play store et démarrez le. (autoriser l'acces en mode Root naturellement)

21/ tapez: su

22/puis tapez: sh /mnt/sdcard/rec.sh (cela vous installera le fichier recovery.img que vous avez collé à la racine de la mémoire interne et remplacera le recovery d'origine.

23/ du market téléchargez et installez "Quick Boot"

24/ Une fois installé lancé le (il devrait vous demander des droits super utilisateur, acceptez)

25/ choisissez "recovery"

26/ la tablette doit redémarrer et vous ouvrir CWM version v5.5.04

26/ naviguez avec le bouton vol+ et vol - vers le menu "backup and restore" validez par la touche power

27/ de la même façon choisissez "backup" et attendez..... c'est long.... trés long....

28/ une fois le backup effectué allez au menu principal puis dans advanced choisissez 'show log"

29/ si le log n'affiche pas de message d'erreur c'est bon.

30/ redémarrer la tablette.

CWM à normalement créé un dossier sur votre carte sd.

faites une copie de ce dossier et conservez la en lieux sure (comme la prunelle de vos yeux)

Ce dossier c'est "l'image" de votre tablette qui vous sauvera en cas de pépin !!

la suite pour installer une ROM Custom.

1/ télécharger une ROM CUSTOM : http://api.viglink.c...2" (20-Apr-2012)%20-%20xda-developers&txt=FLEX-A100-REAPER-R2-ICS-TWEAKED&jsonp=vglnk_jsonp_13352555872671

ci après le md5 du fichier : : 8B201848BD17540B378B6944E8A33825

puis coller le fichier zip téléchargé à la racine de votre carte mémoire.

2/ redémarrer la tablette en recovery avec "quick boot" téléchargé au préalable

3/ choisisez de" flasher un fichier zip" et sélectionnez la ROM que vous venez de télécharger.

4/ redémarrer la tablette et voila vous ête en Custo_Rom !!

Si la ROMM ne vous convient pas vous pouvez faire une restauration de votre backup d'origine (la prunelle de vos yeux ;-) )

voila j'éspère ne rien avoir oublié est avoir été le plus clair possible.

pour finir :

!!!!!!!!!!! attention à ce que vous faites !!!!!!!!!! (ne me tenez pas pour responsable si vous flinguez votre tablette.

Dans tous les cas , ne redémarrez pas la tablette "à l'arrache" sans être certain que l'opération en cours est terminée.

Merci pour vos retours.

Edited by samco08

Share this post


Link to post
Share on other sites

Bon bah pour moi le pc refuse de rooté la tablet je bloque a l'étape 7, quand je lance en administrateur runit-win.bat du dossier ics_rooting il n'y a rien qui se passe ! ça me met " *daemon not running. starting it now on port 5037 * puis *daemon started successfully* et ça reste comme ça. Qu'elqun a une idée ? parce que la je sèche !

Edited by executer2

Share this post


Link to post
Share on other sites

J'ai tout essayer sebenett j'ai activé le debogage usb , j'ai essayé avec ou sans administrateur mais sans succès :mellow:

Edited by executer2

Share this post


Link to post
Share on other sites

tu accede bien a ta tablette depuis windows ?

la rom de "vache" est bien installee ?

sinon dans le fichier il y a aussi une version linux du programme de rootage.

c'est celle que moi j'utilise.

tu as pas une version de linux portable a tout hasard ? (sinon tu peux en telecharger une).

je referai un essai demain sous windows pour te confirmer que le .bat est bien fonctionnel (normalement oui)

a moins que sebenette l'ai deja testé sous win.

normalement si ta tablette est bien détectée par win ça devrai t'afficher ça :

Full root for A100 ICS. Simple method.

Wait for connect device...

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

Device connected. Preparation for executing of the main script.

mkdir failed for /data/local/tools, File exists

push: tools/busybox -> /data/local/tools/busybox

push: tools/delroot.sh -> /data/local/tools/delroot.sh

push: tools/mempodroid -> /data/local/tools/mempodroid

push: tools/runit.sh -> /data/local/tools/runit.sh

push: tools/busybox.sh -> /data/local/tools/busybox.sh

push: tools/getroot.sh -> /data/local/tools/getroot.sh

push: tools/mount.sh -> /data/local/tools/mount.sh

push: tools/su -> /data/local/tools/su

8 files pushed. 0 files skipped.

948 KB/s (839527 bytes in 0.864s)

503 KB/s (37273 bytes in 0.072s)

Preparation is finished.

Executing of the main script.

link failed File exists

mkdir failed for /system/sbin, File exists

reboot returned

265 KB/s (22364 bytes in 0.082s)

Root it is received!

For the further work it is necessary to establish SuperUser and,

at will, Titanium Backup

ATTENTION! Don't install Busybox! It is already established!

If reinstall, some programs will cease to receive root!

Press 'enter' for continue.

Edited by samco08

Share this post


Link to post
Share on other sites

Salut samco ! oui j’accède bien a la tablette sous windows et la rom de la vache est bien installé, pour ce qui est de linux non je ne l'est pas . Voila ce que [color=red][b]sa[/b][/color] m'affiche :

Full root for A100 ICS. Simple method.

Wait for connect device...

* daemon not running. starting it now on port 5037 *

* daemon started successfully *

et ça ne va pas plus loin.

Share this post


Link to post
Share on other sites

on dirait que ca communique pas......

a tout hasard t'as testé en desactivant ton firewall (sait on jamais..)

sinon pour linux tu peux telecherger UBUNTU et l'utiliser en version portable avec : Linux live USB creator.

tu pourra utiliser linux sans l'installer sur ton pc.

autre piste... les fichiers serait pas corrompus ? t'as essayé de les retelecharger ?

tu execute bien le .bat en administrateur hein ?

sinon pour etre fixé tu lance cmd.exe en administrateur puis tu tape le chemin du répertoire du logiciel de root

ex: cd c:\ICS_ROOTING puis tu valide.

une fois dans le repertoire, tu tape #adb devices# sans les #

ru aura un message qui ressemble a celui du .bat suvi normallement du numero unique de ta tablette.

si t'as rien non plus c'est mauvais signe.

ps: g testé le .bat sous windows et ça fonctionne nickel

Edited by samco08

Share this post


Link to post
Share on other sites

Salut samco ! Déjà merci pour ton aide ! J'ai désactiver mon firewall et c'est toujours pareil et j'éxecute bien en administrateur , les fichier ne son pas corrompue. j'ai bien une version de ubuntu je sais comment booter dessus sans l'installer mais arriver dans l'interface qu'est ce que je fait? je suis perdu.

Share this post


Link to post
Share on other sites

si c'est ubuntu que tu as,

tu re telecharge le fichier depuis ubuntu.

avec l'explorateur tu te rends dans le repertoirebou tu l'as telechargé.

tu extrais le fichier avec le gestionnairevd'archive zip (c'est automatique, juste un double clic sur le fichier zip)

puis tu clic sur le fichier avec l'extention .sh (c'est l'equivalent du .bat sous windows).

A ce moment la tu choisis dans la fenetre # lancer dans un terminal#.

si ta tablette est bien connectée ça doit dérouler.

ps: t'asbtesté la commande #adb devices# pour savoir si ta tablette etait bien accessible ?

ps2: t'as re-réléchargé le fichier ICS_ROOTING que j'ai posté

...................

tu peux aussi télécharger # ROOT CHECKER de l'android market (play store) et l'executer stp !?

c'est juste pour verifier un truc.

@+

Edited by samco08

Share this post


Link to post
Share on other sites

J'ai essayer sous unbuntu quand je lance le fichier runit-linux.sh ya rien qui ce passe ! je pense que la tablette n'est pas détecté.

Sous windows 7 quand je lance la commande "adb devices" je pense que c'est mort aussi ça me met "liste of devices attached" mais ya rien.

J'ai re telecharger le fichier ICS_rooting et c'est la même chose je ne pense pas que cela viennent du fichier.

Pour Root Checker quand je verifie le root acces il me met: Sorry, this device does not have proper root access!.

comme tu dit il y a un problème de communication entre la tablette et le pc, bizarre vu que quand je connecte ma tablette elle est bien reconnu en tant qu'appareil multimédia. A mon avis il y a un soucis avec le mode debug qu'est ce que t'en pense ?

Share this post


Link to post
Share on other sites

attention !!

la fonction Debug est différente de la fonction multimédia/appareil photo !!

c'est dans les options pour développeurs normalement qu'il faut l'activer....

tu dois avoir deux sympboles en bas quand tu connecte la tablette

Edited by samco08
  • Like 1

Share this post


Link to post
Share on other sites

Je pense qu'il y a encore quelques problèmes avec les scripts et qu'ils doivent être fait sous linux pour marcher correctement !

  • Like 1

Share this post


Link to post
Share on other sites

Samco08 j'ai bien les deux symboles ,un symbole usb et un symbole Débogage quand je connecte le cable usb.

Enfin c'est pas grave , Merci beaucoup pour ton aide Samco.

Share this post


Link to post
Share on other sites

tu utilise le câble USB d'origine ?

Tu as bien fait un reset complet de la tablette ?

et ça fonctionne pas sous Linux ?

C'est vraiment bizarre car ces fichiers fonctionnent nickel pour quasi tout le monde ......

Edited by samco08

Share this post


Link to post
Share on other sites

Oui j'utilise bien le cable usb d'origine et j'ai aussi fait un reset complet , sous linux il détecte que dalle !

oui c'est plus que bizarre , bah que veut- tu j'ai la poisse on dirait bien.

Share this post


Link to post
Share on other sites

bon beh la... a part installer le sdk android sous windows et retenter je vois plus d'autres options...

c'est un peu long a l'installation mais tu auras tous les outils et drivers pour ta tablette et no pasvdes fichiers extraits du sdk que tu trouve dans le dossier ICS Rooting.

pour linux c'est tout a fait normal que la tablette n'apparaisse pas dans l'explorateur ! mais ce n'est pas pour ca que ca ne comunique pas ;-)

une fois branchee et sous linux tu dois lancer le fichier qui se termine par .sh (c'est un script) par contre et cest tres important, il faut choisir quand tu clic sur le fichier # lancer dans un terminal# et non pas #lancer# ca devrait fonctionner.......enfin normalement hein :D

a+

Share this post


Link to post
Share on other sites

Bon je reviens un peu tard mais j'ai enfin trouvé le problème ...

En réalité, si tu utilise Windows seven x64, au moment ou tu connecte ta tablette, windows t’installe des drivers par défaut.

Et naturellement ce ne sont pas les bons !!! tu peux accéder à ta tablette comme un stockage de masse mais pas communiquer avec en adb ! (je sais c'est visselard !)

il faut donc se rendre sur le site de Acer et télécharger les 39 mb de drivers...

http://global-download.acer.com/GDFiles/Driver/USB/USB_Acer_1.000_A32H_A.zip?acerid=634486286202185014&Step1=Tablet&Step2=ICONIA%20TAB&Step3=A100&OS=a08&LC=fr&BC=Acer&SC=EMEA_13

ensuite ça roule ........... (j'ai testé sur un pc vierge et j'ai rencontré le même problème que toi ;-) )

je sais que tu as vendu ta tablette , mais cela peu toujours servir à kelk1 !

ps: je vous informe que des ROM sont dispo

  • Like 1

Share this post


Link to post
Share on other sites

plus de 1000 lectures et pas un retour .............. -_-

a priori, aucun geek qui veut faire joujou avec sa tablette sur ce site.

.

Share this post


Link to post
Share on other sites

Bon bootloader dévérouillé, Flex reapper flashé !

Très bonne ROM, le ring Acer est très pratique !

Nettement plus fluide que la Stock et pour l'autonomie je vais attendre un peu (même si je constate que c'est pas top...)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...