Jump to content

Problème avec les reseaux ad hoc


Recommended Posts

Bonjour,

j'ai un problème avec les reseaux ad hoc sur ma tablette a chaque fois que je veux me connecté sur un reseau ad hoc via l'application wifi analyser sa me renvoix le message comme quoi "Wifi Adhoc is not supported by android platform yet" avec l'outil de recherche wifi dans parametre sa nevoit meme pas le reseau Adhoc.S'il vous plait aidez moi a resoudre mon problème.

Link to comment
Share on other sites

  • 5 months later...

Bon, après recherches, voilà ce que j'ai pu trouver... mais attention, je suis une brêle, et ne comprenant rien aux procédures que j'ai appliquées, je ne vous garantie donc pas que ça marche pour vous.

Mes sources (pour amateurs d'anglais) :

http://androidtablet...ndroid-tablets/

Il semble que ce soit efficace pour toutes les tablettes Samsung Galaxy Tab (moi, j'ai une vieille P1000 de 7")

Mon "découpage"

- avoir rooté sa tablette

- avoir installé Busybox (market)

- télécharger un fichier zip du nom de : adhoctablets.zip (721ko)

- créer un dossier à la racine de votre disque dur nommé Adhoctablets, y mettre et y dézipper votre fichier zip (il y a 6 fichiers qui permettent de procéder aussi bien avec MacOS, que Linux, mais mois je m'arrête à Windows

- dans ce dossier, il y a un fichier nommé wpa_supplicant (290ko), il faut le copier dans la carte SD de la tablette

- mettre sa tablette en mode USB debugging

- neutraliser le wifi de la tablette, et la mettre en mode "avion"

- brancher la tablette au PC (il faut bien évidemment avoir installé les drivers au préalable)

- Sur Windows, faire "Démarrer", "Exécuter", et taper "cmd" et cliquer sur "OK"; ça ouvre un tableau barbare noir

- taper dans ce tableau : cd \adhoctablets (enter)

- puis : adb shell (enter)

- puis : su (enter)

A ce moment là il est important de remarquer la présence du symbole "#" et non pas "$" qui apparaît : ceci est la preuve du bon déroulement des opérations et surtout de la bonne connexion avec les "pouvoir" permettant d'appliquer la suite des opérations, sinon, laisser tomber !

- puis :mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system (enter)

- puis :cp /system/bin/wpa_supplicant /sdcard/wpa_supplicant.original (enter)

- puis :cp /sdcard/wpa_supplicant /system/bin/. (enter)

- puis : chmod 755 /system/bin/wpa_supplicant (enter)

- puis :chown system.wifi /data/misc/wifi/wpa_supplicant.conf (enter)

pour ma part, cette dernière commande a généré un message d'erreur, et je l'ai remplacée par :

chown system.wifi /etc/wifi/wpa_supplicant.conf et ça a marché

- débrancher la tablette

- la rebooter

- sortir du mode "avion"et réactiver le Wifi

- ne pas hésiter à rebooter de nouveau

Les 3 premiers essaies me semblaient longs et hasardeux, puis tout est rentré dans l'ordre.

En conclusion : J'ai un vieux téléphone LG GW620 dans ma poche qui me sert de "box wifi" et ma Galaxy Tab GT-P1000 peut aller sur internet via ce Wifi, de manière efficace. C'est même encore un succès à travers 3 cloisons et 12 mètres d'éloignement..

Edited by HYVERT
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...