Jump to content
berni66

[Tuto] Comment résoudre les problème d'installation de Jellybean !

Recommended Posts

Comme certain d'entre vous on pu le constater, il y a parfois quelques soucis d'installation de la mise à jour Jellybean...

Pas d'inquiétude il y a des solutions...

Si comme moi, lors de l'installation de la mise à jour vous avez eu un joli petit message "Update failed" et retour à ICS, voici comment forcer la mise à jour.

Je tiens à préciser que ces infos viennent du forum XDA, et que la solution à été fournie par Trekest de ce même forum, donc un grand merci à lui!

1er conseil LIRE ATTENTIVEMENT TOUTES LES ÉTAPES DU TUTO AVANT DE COMMENCER!

Je ne saurai être tenu responsable de mauvaise manipulation de votre part!

Bon commençons,

1er PARTIE

1° Votre Prime est-elle Rootée? (Etape indispensable pour la suite du tuto)

Si oui passez à l'étape 2°, mais par précaution refaite une sauvegarde avec Voodoo OTA RootKeeper

Si non, voici comment faire, c'est très simple!

Commencez par télécharger ce fichier sur votre pc,

Branchez votre Prime sur votre pc et installez le driver ASUS si ce n'est déja fait (
)

Décompressez le fichier DebugfsRoot_Generic_v2.3.zip et lancez le fichier RootDebugfs.bat

Il suffit ensuite de suivre les infos à l'écran...

Voilà vous avez Rooté votre prime.

Merci à sparkym3 du forum XDA!

Installez ensuite l’application Voodoo OTA RootKeeper, lancez et cliquez sur protect root

(Cette étape permet de conserver le Root après la mise à jour)

2° Vérifiez si ces 3 fichiers sont présent dans /system/xbin/

  • dexdump
  • ps3bttest
  • rfcomm

(avec Root Explorer par exemple..)

Si oui passez à l'étape 3°

Si non, les voici

Il suffit donc, à l'aide d'un explorer root, en prenant soin de vous mettre en mode read and write (cliquer sur Monter en r/w dans root explorer) de copiez les 3 fichiers dans /system/xbin/.

ou
en passant par l'application
(Installez aussi
pour avoir accès à la commande "cp") et en tapant ceci
  • su
  • mount -o remount,rw /system
  • cp /mnt/sdcard/dexdump /system/xbin/dexdump
  • cp /mnt/sdcard/ps3bttest /system/xbin/ps3bttest
  • cp /mnt/sdcard/rfcomm /system/xbin/rfcomm
  • chmod 777 /system/xbin/dexdump
  • chmod 777 /system/xbin/ps3bttest
  • chmod 777 /system/xbin/rfcomm
  • mount -o remount,ro /system

Fermez Le terminal

3° Téléchargez le fichier update Jellybean

ou

Copiez ce fichier dans le dossier /sdcard/

Utilisez terminal explorer (Installez aussi
pour avoir accès à la commande "cp") et tapez ce qui suit
  • su
  • cp /mnt/sdcard/dlpkgfile /cache/dlpkgfile
  • echo '--update_package=/cache/dlpkgfile' >> /cache/recovery/command

Fermez le terminal.

4° Eteindre la tablette

5° Démarrez la tablette en gardant le bouton volume bas appuyé, lorsque la tablette vibre relâchez le bouton démarrer mais gardez le bouton volume bas appuyé. Il y a 3 lignes qui vont apparaître au dessus de l'écran relâché volume bas et appuyez sur volume haut.

6° La mise à jour commence

(si la tablette redémarre normalement sans faire de mise à jour, vous avez raté l'étape 5, il faut donc retapez les commandes suivante dans le terminal et recommencer à l'etape 4°)

  • su
  • echo '--update_package=/cache/dlpkgfile' >> /cache/recovery/command

7° A vous Jellybean!

pensez à faire un restore du root avec Voodoo OTA RootKeeper

-----------------------------------------------------------------------------------------

2ème PARTIE

Alors pour ceux chez qui ça ne fonctionne toujours pas, vous avez sans doute un soucis avec le fichier build.prop, dans ce cas il vous faudra passer par une réinstallation complète à l'aide du nouveau firmware JB Version V10.1.2.15 dispo sur le site d'Asus

Attention ceci wipe la tablette donc pensez aux sauvegardes!

Et sachez que dans ce cas plus de root après mise à jour... pour l'instant en tout cas...

La seul solution pour conserver le Root est de restaurer la Version V9.4.2.28(WW) dispo sur le site d'Asus en utilisant la même méthode expliquée ci-après et en reprenant au point 1° de la 1er partie du tuto pour l'installation de Jellybean.

Bon c'est pas bien compliqué non plus,

1° Téléchargez le firmware Version V10.1.2.15 pour version WW sur le site d'Asus

Attention il y a un petit couac sur le site d'Asus, il y a 2 versions indiquée comme WW prenez la 2éme qui fait 313,41 (MBytes), nom du fichier, WW_epad_10_4_2_15_UpdateLauncher.zip

http://support.asus....tf201&p=20&s=16

2° Extraire le fichier WW_epad-user-10.4.2.15.zip contenu dans WW_epad_10_4_2_15_UpdateLauncher.zip

3° Extraire les fichiers contenu dans WW_epad-user-10.4.2.15.zip que vous avez obtenu au point 2

4° Placez le fichier blob dans le dossier /sdcard/ de votre tablette, sur votre micro SD ou sur votre SD du dock clavier

5° Ouvrez terminal explorer et taper ceci

Si dans /sdcard/

  • su
  • dd if=/sdcard/blob of=/dev/block/mmcblk0p4

Si dans Micro SD

  • su
  • dd if=/Removable/MicroSD/blob of=/dev/block/mmcblk0p4

Si dans SD

  • su
  • dd if=/Removable/SD/blob of=/dev/block/mmcblk0p4

Attendre un certain temps... jusqu’à ce qu'une série de données apparaisse dans le terminal

10....+1 records in

10....+1 records out

..... bytes transferred in .... secs (...... bytes/sec)

à la suite tapez
  • reboot

6° La tablette redémarre et exécute la mise à jour.

Une fois que la tablette à redémarré vous voila avec un système tout beau tout propre sous Jellybean!

Pour moi cette méthode à fonctionner, et franchement cette mise à jour vaut le coup!

Edited by Berni66
  • Like 1

Share this post


Link to post
Share on other sites

Je tente ça aussi ce soir, j'espère que ça fonctionnera

Envoyé depuis mon GT-I9300 avec Tapatalk

Share this post


Link to post
Share on other sites

j'ai copié le fichier dans sdcard( ringtone,notification,..)

Ok... terminal ok...mais triangle rouge au demarrage.

J'ai fermé le terminal normalement...mais on doit pas enregister le fichier?

Edited by lolobuc54

Share this post


Link to post
Share on other sites

essaye en le copiant dans le dossier /cache/ à l'aide de root explorer.

une fois fait retape

  • su
  • echo '--update_package=/cache/dlpkgfile' >> /cache/recovery/command

dans terminal explorer

j'ai oublier de préciser que pour pouvoir utiliser la commande cp il faut installer busybox...

Share this post


Link to post
Share on other sites

Bonsoir, j'ai une petite question le passage du root :

ça marche sur une transformer 300?

et petite question de grande newbie, il n'y a vraiment que cela a faire ?

cela me semble trop simple :P :huh:

Share this post


Link to post
Share on other sites

version supportée

v9.2.1.27 for the TF101 (ICS 4.0.3)

v9.2.2.6 for the TF101G (ICS 4.0.3) (3G version)

v9.4.2.28 for the TF201 (ICS 4.0.3)

v9.4.3.30 for the TF300T (ICS 4.0.3)

v9.4.4.40 for the TF300TG (ICS 4.0.3) (3G version)

v9.4.5.30 for the TF700T (ICS 4.0.3)

v9.18.8.41 for the PadFone (ICS 4.0.3)

Et oui c'est aussi simple que ça!

Edited by Berni66

Share this post


Link to post
Share on other sites

Re !

Je teste ta méthode mais j'ai systématiquement, lors du reboot et en faisant les manipulations adéquates, le petit android avec un triangle rouge. Je commence à désespérer !

Share this post


Link to post
Share on other sites

Un gros MERCI!!!

Ce la fonctionne chez moi! C'est quand même dingue pour une OTA...

Donc j'avais pas les 3 fichiers ( dexdump ps3bttest et rfcomm)

et j'avais réussi, avec du mal, à avoir l'OTA, mais cela n'avait pas fonctionné, et plus de mise à jours disponible...

Là je suis bien en 4.1.1, par contre, j'ai pas fais l'étape 6, je vois pas trop l’intérêt? ( de lui dire qu'il y a une mise à jour, encore??)

J'ai refait une restauration d'usine, j'en étais pas à une prêt, maintenant, y'a plus qu'a tester!

Encore MERCI!

Share this post


Link to post
Share on other sites

@NicoLab28

cool que ça marche pour toi!

l'étape 6, n'est pas très clair je l'admet, c'est pour ça que je l'ai mis entre parenthèse, elle n'est nécessaire que si on foire l'etape 5 et que la tablette redémarre "normalement", sans faire de mise à jour...

pour les autres avez vous modifier le fichier build.prop, en installant par exemple des tweak divers?

Share this post


Link to post
Share on other sites

"pour les autres avez vous modifier le fichier build.prop, en installant par exemple des tweak divers?"

En dernier recours j'ai chargé celui dispo sur xda, mais nada

Share this post


Link to post
Share on other sites

lequel as tu chargé? pas la version US j'espère?

Share this post


Link to post
Share on other sites

Non, de toute façon elle me nargue en redémarrant comme si de rien n'était!!!!

Comme dit ma femme : LA GARANTIE!!!!!

arghhh!!!

Share this post


Link to post
Share on other sites

genre pour augmenter les performances, la durée de la batterie ou changement de fréquence du processeur des différents modes...

@lolobuc54

qu'as tu chargé de XDA j'ai pas bien compris?

Share this post


Link to post
Share on other sites

un fichier build, mais sans changement. je pense que le firmware est verrouillé.

Allez, au dodo (debout à 4h) et la nuit porte conseille.

Bonne soirée et bonne nuit et surtout un grand merci pour votre aide (Berni66 ;) )

Share this post


Link to post
Share on other sites

pas de soucis, mais le fichier que tu as trouver sur XDA est une version uniquement réservé pour les versions US

donc pas valable pour les version WW comme les nôtres!

tu vas devoir passer par l'étape de réinstallation du firmware .28

Je vais mettre à jour mon post pour expliquer la démarche!

Edited by Berni66

Share this post


Link to post
Share on other sites

Mouais, j'abandonne aussi pour le moment ... Je retente dans les prochains jours !

Il faudrait vraiment qu'on m'explique pourquoi ça ne marche pas ... J'ai pourtant rechargé les paramètres d'usine et même comme ça l'upgrade ne se fait pas. C'est à devenir cinglé (ou fan d'apple :) )

Share this post


Link to post
Share on other sites

Voila, tuto mis à jour :)

Edited by Berni66

Share this post


Link to post
Share on other sites

Berni,

Merci pour le complément.

Mais lorsque je rentre les 2 lignes dans le terminal emulator, il n'y a rien qui apparaît ...

Share this post


Link to post
Share on other sites

huhhhhh .... regarde dans paramettre > a propos de ma tablette > numero de serie ou ??? s'il y a une ligne avec unknow!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...