Jump to content

X10: Extinction intempestive après 2-3mn d'utilisation


Recommended Posts

Bonjour à tous !

Je sais que ce problème a déjà été débattu sur ce forum, seulement voilà, j'ai tout essayé, rien à faire.

De plus les sujets en question datent d'un petit bout de temps maintenant (oui, je sais, le x10 est un peu vieux ^_^ ) donc je retente ma chance aujourd'hui, dans l'espoir qu'une nouvelle solution ait émergé quelquepart.

J'ai un SE X10 sous 2.3.3 rooté avec flashtool. Il s'éteint systématiquement après 2 ou 3mn d'utilisation, parfois même à peine après avoir démarré si la carte sim est présente.

Le problème était déjà présent lorsque j'étais sous 2.1 non rooté; c'est d'ailleurs pour ça que j'ai upgradé et rooté etc.

J'ai installé xrecovery et fait un "wipe battery stats" avec la batterie à 100% comme conseillé dans les autres sujets concernant ce problème.

J'ai formaté ma carte SD (fat32).

J'ai fait un retour aux réglages d'usine (quand bien même ce serait utile après avoir installé 2.3.3).

Le seul truc que je n'ai pas pu faire, c'est de décharger complètement la batterie à plusieurs reprises: pour ça il faudrait que je le rallume une bonne centaine de fois. J'espère ne pas devoir en arriver là.

Parfois, et de façon parfaitement aléatoire (du moins de mon humble point de vue), après avoir chargé le téléphone à 100%, puis débranché le chargeur, puis constaté son extinction après 2mn, puis l'avoir rallumé, je constatais que la batterie était soudainement descendue à 50-60% (alors qu'elle était à 97% 2mn auparavant).

La seule et unique situation dans laquelle il ne semble pas s'éteindre de la sorte, c'est quand il n'y a ni sim ni SD, et que je ne m'en sers pas.

Par dépit (et bêtise ?), désespérant de voir le bout du tunnel, j'ai finalement fait tous les "wipe" du xrecovery:

wipe cache partition, wipe dalvik cache, wipe battery stats, ainsi que fix permissions.

Cela a entrainé le problème du freeze sur le logo SE indéfiniment, que j'ai résolu grâce à un post à ce sujet ici, et réinstallé le 2.3.3 avec flashtool.

Il ne me reste plus, à ma connaissance, que l'option du rachat d'une batterie neuve ou d'une réparation dans une boutique spécialisée (garantie expirée).

J'aimerais savoir si je suis dans l'obligation d'en arriver là, et si oui, laquelle de ces deux options privilégier ?

Si non, quelle autre manip au niveau software puis-je faire de mon coté ?

Merci d'avance.

Link to comment
Share on other sites

Perso je pencherais plutôt vers une panne de la carte mère !!

Mon X10 m'a fait ce genre de chose à 2 reprises. Il est donc retourné 2 fois au SAV (encore sous garantie à l'époque) et à chaque fois ils ont changé cette carte mère !

Tu dis ne pas réussir à le décharger à 100 %. Si tu veux vraiment faire cela, tu peux toujours le redémarrer en Recovery et le laisser comme ça jusqu'à ddéchargement.....sauf s'il s'éteint même en recovery !

  • Like 1
Link to comment
Share on other sites

C'est vrai, je vais essayer de le décharger en recovery.

S'il n'y a pas d'autre solution, je devrai donc aller lui faire changer sa carte mère ?.. c'est légèrement abusé de la part de SE ça... à peine ma garantie expirée, boum la carte mère lâche.

Puisque j'y suis, c'est faisable soi-même ça ? Acheter une cm sur le net, et la changer soi-même ? Je suis bricoleur ;)

Link to comment
Share on other sites

Tu as un tutoriel photo pour le démontage http://forum.frandro...son-xperia-x10/

Ça pourra surement te servir si tu veux faire la réparation toi même.

EDIT: Owned =(

Prendre un téléphone plus récent ne te sera que plus rentable plus tard en effet.

Vois par exemple de ce côté là, le rapport qualité prix est très bon, la marque Wiko a eu de très bon retours jusqu'ici.

Edited by Crackmort
  • Like 1
Link to comment
Share on other sites

Merci ! Impeccable le tuto.

Pour l'option du nouveau téléphone, oui bien sûr... Mais dans ce cas je préfère attendre un peu et investir dans le xperia Z :)

Ici je cherchais une solution à court terme. Tant pis, et merci pour vos réponses rapides et efficaces ;)

Desspil, j'ai lu dans ce topic que ton problème, c'était que le tel freezait puis s'éteignait ?

Pour moi, comme pour l'auteur du topic en question, le téléphone s'éteint "normalement" ("arrêt en cours..." puis extinction)

De plus il ne s'éteint jamais s'il est branché. (carte mère => ?)

Il dit que son problème a été réglé en changeant de batterie (15€ environ), je vais essayer ça.

Merci encore :)

Edited by Oleg
Link to comment
Share on other sites

Ce que je fais jusqu'à présent (avant d'aller acheter une batterie neuve), je le rallume, dès que j'y pense. Il s'éteint directement mais généralement j'ai le temps de lire le %age de batterie restant, et c'est relativement aléatoire: 0% trois fois d'affilée, puis d'un coup 16%, puis plus de 50% (donc le %age n'est pas affiché sur l'écran de déverrouillage, seul écran que je voie avant qu'il s'éteigne).

Ca doit bien faire un petite 50aine de fois que je répète l'opération. J'ai dans l'idée qu'au bout d'un moment j'atteindrai le "véritable" 0%, et peut-être que le téléphone enregistrera cette valeur comme étant effectivement 0%.

(ma vision du problème est que le téléphone interprète le %age restant, et pour une raison quelconque il avait dû enregistrer une valeur plus élevée (90% par exemple) comme étant 0%... raison pour laquelle il s'éteignait "normalement")

Je vous tiendrai au courant :) J'atteindrai forcément tôt où tard un stade à partir duquel il n'y aura plus assez de batterie "réèlle" pour que le tel s'allume...

Edited by Oleg
Link to comment
Share on other sites

Si, mais il s'éteint quand même.

J'imagine que le problème auquel je fais référence devrait être corrigé par un wipe battery stats, mais ça n'a pas été le cas, alors je le fais "à l'ancienne" :) sans trop de convictions mais sait-on jamais, ça me paraît sensé

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...