Jump to content
hdcine

[TUTO][TF700T] Installer un Recovery : TWRP 2.8.7.4

Recommended Posts

Installer un Recovery : TWRP 2.8.7.4

 

Il est indispensable d'avoir un bootloader Asus JB 4.2.1 version 10.6.1.14.10.

 

 

Le choix du recovery se fera en fonction de votre préférence, mais parfois en fonction de la rom et des préconisations du développeur.

De plus certains scripts ou mod s'installeront plus facilement avec CWM.

 

Pour résumé, si l'installation de la rom ou du script ne fonctionne pas avec TWRP, essayer avec ClockWordMod (CWM).

 

Pour information, si votre rom n'est pas rootée, TWRP vous proposera d'installer SuperSU, voir détail à la fin du tuto.

 

Attention : cette opération comporte des risques. Ni moi, ni le site FrAndroid.com seront responsables des problèmes rencontrés.

 

Une fois le recovery TWRP installé, ne jamais faire un Wipe/Data en mode bootloader.

 

 

Pré-requis :

- Avoir déverrouiller le bootloader. ( voir ici ou ici )

- Télécharger le dossier Fastboot Recovery. Ce dossier contient touts les fichiers nécessaires pour installer TWRP.

- Sur la tablette, assurez vous que Débogage USB soit cochée dans Paramètres - Options pour les développeurs

Si vous ne voyez pas les Options pour les développeurs appuyez 7 fois sur Numéro de build dans A propos de la tablette

 

- Installation de TWRP :

 

24371111033916upper.png

 

 

Connecter maintenant votre tablette allumée sur un port USB.

Sur le dossier Fastboot Recovery téléchargé, faire shift + clic droit puis sélectionner Ouvrir une fenêtre de commande ici. Une fenêtre dos s'ouvre.

Vérifier que la tablette est reconnue par l'ordinateur pour se faire taper ceci : ( faire un copier/coller pour respecter la syntaxe )


adb devices

316290adb.jpg

 

Vous devez voir votre numéro de série apparaître.

 

Redémarrer la tablette en mode bootloader (Fastboot), taper ceci :


adb reboot bootloader

La tablette doit redémarrer en mode bootloader.

 

Vérifier que la tablette est toujours reconnue par l'ordinateur pour se faire taper ceci :


fastboot devices

733820adb3.jpg

 

Vous devez voir une série de chiffre suivi de fastboot apparaître.

 

Maintenant, pour installer le recovery, taper ceci :


fastboot -i 0x0B05 flash recovery twrp.img

147770fastboottwrp.jpg

 

Vous devez voir une barre bleue progressée sur l'écran de la tablette.

Patienter pendant l'installation.

 

Pour finir taper ceci :


fastboot -i 0x0B05 reboot

Le recovery TWRP est maintenant installé sur votre tablette.

 

Vous pouvez également utiliser l'outil Install Recovery v1.2 (mis à jour par votre serviteur) qui fera les commandes à votre place ;) .

Télécharger et extraire Install_Recovery_v1.2 sur votre PC, connecter la tablette et exécuter le fichier Recovery Install Tool.bat

 

 

Pour redémarrer facilement en mode recovery, télécharger et installer Rebooter sur la tablette. Donner lui les droits root.

 

640572Screenshot20130923124706.jpg

 

Ou tablette éteinte appuyer et maintenir vol- puis appuyer et maintenir power, lorsque la tablette vibre relâcher power, à l'apparition du texte en haut à gauche, relacher vol-.

Sélectionner l’icône RCK ( Recovery Kernel ) avec vol+.

 

 

- Installer SuperSu avec TWRP :

 

Si votre rom n'est pas rootée, lorsque vous rebooter à partir de TWRP, il vous sera proposé d'installer SuperSU.

 

791153supersu.png

 

TWRP installera en fait les fichiers binaires qu'il faudra mettre à jour par la suite.

 

Une fois la tablette redémarrer, installer SuperSu à partir du Play Store.

Lancer l'application et suivre les instructions.

 

917136Screenshot20130923083602.jpg

149752Screenshot20130923083607.jpg

596909Screenshot20130923083620.jpg

 

Votre tablette est maintenant rootée.

Edited by hdcine

Share this post


Link to post
Share on other sites

Merci pour ce tuto, hdcine.
De plus, l'utilitaire reboot économise l'appui sur les touches power et de volume, super :)

  • Like 1

Share this post


Link to post
Share on other sites

Salut,

J'ai un problème au moment où je vérifie si ma tablette est bien reconnue en mode fastboot avec la commande "fastboot devices" : rien ne se passe (pas de numéros) et je retrouve l'invite de commande...

Je précise que je suis en 10.6.1.14.10, que ma tablette n'est pas rootée (elle l'était avant de passer dans cette version, mais j'ai perdu le root), mais que j'ai déjà débloqué le bootloader avec le programme d'asus, que j'ai bien activé le débogage usb, que ma tablette est bien reconnue par mon pc (qui est en W 8.1) et que j'ai même fait une réinstall des pilotes avec les fichiers "adb_fastboot_and_other_tools" que je suis allé récupérer sur le site de xda.

Mon but est évidemment de mettre une nouvelle rom, plus réactive que la stock (genre la cromi x).

Voilà

Merci de votre aide !

Share this post


Link to post
Share on other sites

Bonjour tornavelo,

Avant de taper la commande Fastboot, tu as bien démarré la tablette en mode bootloader/fastboot ?

Sinon, avec la tablette en fonction et connectée au PC, que donne la commande ADB ?

Share this post


Link to post
Share on other sites

Salut !

Merci de ton aide.

J'ai bien redémarré ma tablette en mode bootloader, grâce à l'invite de commande, et la commande adb renvoie une série de chiffres, mais sans fastboot à la fin. Plus précisément, cela me donne : "C8OKAS090813 device".

Je suis aussi allé voir ici : https://forum.frandroid.com/topic/139590-tuto-adb-fastboot-drivers-root-recovery-backup-sans-toolkit/

J'ai fait ce qui est préconisé, mais même chose. Par contre, en mode bootloader, mon pc ne reconnait pas ma tablette, et pourtant il me dit que mon pilote est à jour. Concrètement, il m'indique "périphérique usb inconnu (échec de demande de descripteur de périphérique)".

Share this post


Link to post
Share on other sites

Ok, dans ce cas tu n'as pas les bons drivers.

Quand la tablette est connectée au PC en mode bootloader/Fastboot, essayes de mettre à jour les drivers en utilisant ceux-ci..

Share this post


Link to post
Share on other sites

Pfff... Il me répond que j'ai déjà les meilleurs pilotes pour ce périphérique ! Je précise que j'ai bien demandé à aller chercher les pilotes dans un emplacement de mon pc.

J'ai redémarré ma tablette en mode normal et tenté de remettre à jour les pilotes avec les tiens. La commande adb devices me renvoie toujours la même chose, et en redémarrant en mode bootloader, mon pc ne le reconnait toujours pas. Il me dit que windows a rencontré une erreur : c'est pour ça qu'il ne reconnait pas ma tablette.

Je suis pourtant en mode débogage usb sur ma tablette. Bref, je ne vois pas ce qui peut coincer !

Share this post


Link to post
Share on other sites

Essayes de désinstaller les anciens drivers avant d'utiliser les nouveaux.

 

Edit: je viens de relire ton précédent post, il y a un truc que je ne comprends pas, comment ce fait-il qu'il t’indique que tes drivers sont à jour alors qu'il t'indique "périphérique usb inconnu (échec de demande de descripteur de périphérique)" ?

 

Tu as bien essayé d'installer les drivers que je t'ai donné en étant sur le mode bootloader/Fastboot sur le périphérique usb inconnu.

Edited by hdcine

Share this post


Link to post
Share on other sites

Oui, j'ai bien fait ça.

Je ne le comprends pas non plus. Il doit y avoir une erreur d'installation du périphérique. Ma tablette est bien reconnue en mode normal, mais plus en bootloader.

Pour désinstaller les drivers, c'est bien clic droit sur "périphérique usb inconnu", puis je débranche et je rebranche ? J'ai déjà fait ça, mais le pc doit réinstaller automatiquement des pilotes génériques qui manifestement ne marchent pas. Comment forcer l'installation de tes pilotes? C'est peut-être ça la clé...


Bon, va comprendre, j'ai changé de prise usb, et maintenant ça marche... Merci beaucoup, je poursuis ton tuto !


Bon, maintenant, lorsque je tape la commande suivante, Windows me dit que fastboot a cessé de fonctionner... Du coup, je ne peux pas aller plus loin !

Je recommence du début. Aller, soyons persévérant !!! -_-


Verdict : même problème. "fastboot.exe" a cessé de fonctionner !


Idem avec le powershell de windows (en mode admin bien sûr)...


Bon, maintenant, j'ai tenté d'enlever la précision "-i 0x0B05", après quelques recherches sur le net. A présent, après avoir validé la commande "fastboot flash recovery twrp.blob", rien ne se passe.

J'ai voulu voir si, en retéléchargeant le twrp, ça pouvait améliorer les choses, mais apparemment, le site officiel n'est pas dispo...

Share this post


Link to post
Share on other sites

Me revoilà, tu as bien exécuté la commande Fastboot à partir du dossier téléchargé dans les pré-requis du tuto ?

Tu n'as plus de périphérique inconnu maintenant ?

Share this post


Link to post
Share on other sites

C'est ça. Plus de périphérique inconnu, et j'ai bien exécuté la commande fastboot à partir du dossier téléchargé. Comprends pas. A moins que je n'attende pas assez longtemps. Je l'ai laissé tourner 15 minutes. Dans le vide me semblait-il.

Mais c'est bizarre qu'avec la précision "-i 0x0B05", l'application fastboot.exe plante...

Share this post


Link to post
Share on other sites

Tu as fait un copier/coller avec la commande suivante pour éviter les erreurs de syntaxes ?

fastboot -i 0x0B05 flash recovery twrp.blob

Tu as essayé en copiant le dossier fastboot à la racine du disque dur ?

 

Je ne connais pas Windows 8, as-tu la possibilité de démarrer en Invite de commande en mode sans échec, au démarrage F5 puis F8 pour entrer dans les options de démarrage.

Share this post


Link to post
Share on other sites

Me revoilà.

J'ai bien fait tout ce que tu as dit : le copier/coller, la copie du dossier à la racine...

Quant au mode sans échec de windows 8, je n'y arrive pas.

Je vais me trouver un pc sous win 7 et je vais refaire le truc. A suivre...

En tout cas, je te remercie pour ton aide ! C'est sympa !

Je te tiens au courant.

Share this post


Link to post
Share on other sites

Excellent ! J'y suis arrivé ! Par contre, lors du 1er lancement de twrp, il ne m'a pas proposé d'installer supersu...

Share this post


Link to post
Share on other sites

Ce n'est pas au premier lancement, mais quand tu redémarres le système à partir de TWRP et uniquement si la rom n'est pas rootée.

 

 

Si votre rom n'est pas rootée, lorsque vous rebooter à partir de TWRP, il vous sera proposé d'installer SuperSU.

 

Share this post


Link to post
Share on other sites

Bonjour,

TWRP 2.6.3.2 disponible; compatible CM11 : KitKat.
Dossier Fastboot Recovery mis à jour.

Share this post


Link to post
Share on other sites

Attention risque de Softbrick avec la version 2.6.3.2.

 

Il ne faut pas utiliser la fonction Wipe Data, le faire manuellement via le terminal de TWRP en utilisant la commande suivant :

mke2fs -T ext4 /dev/block/mmcblk0p8

ou installer le TWRP 2.6.3.1

Share this post


Link to post
Share on other sites

Bonsoir à tous

 

je voulais installer cromi 5.3, étant en rom officiel je me suis lancé dans les divers tuto disponible

et la je bloque sur l'installation de TWRP

j'ai tout d'abord deverouiller le bootloader avec la méthode asus unlock device tools

j'ai ensuite suivi ce tuto mais déjà quand je tape la commande:

adb reboot bootloader

ca reboot bien et j'ai le menu avec le 3 icones qui apparait:

quand je choisis RCK => ca veut installer une mise à jour et ca plante

quand je choisis Android=> ca demarre "normalement"

quand je choisis Wipe => oui je l'ai fais une fois pour voir..... et bah j'ai tout remis à zero

 

ensuite une fois démarré quand je tape:

fastboot -i 0x0B05 flash recovery twrp.blob

il me met ensuite

< waiting for device >

et il ne se passe rien

 

je precise qu'apparement j'ai bien les bons drivers récuperer un peu plus haut sur le post de hdcine

je suis en build 10.6.1.14.10

j'ai essayé la méthode motochopper mais j'ai vu que ca marchais pas avec ma version

 

C'est pourquoi je viens vers vous tous

Merci d'avance de votre aide

 

WocaM

 

Share this post


Link to post
Share on other sites

ensuite une fois démarré quand je tape:

fastboot -i 0x0B05 flash recovery twrp.blob

il me met ensuite

< waiting for device >

et il ne se passe rien

 

Bonjour WocaM,

Tu veux dire qu'à ce stade ta tablette a démarré sur la rom.

Si c'est le cas, ce n'est pas la bonne manipulation.

Il faut taper la commande fastboot en mode bootloader/fastboot, cela correspond au menu des 3 icônes.

Share this post


Link to post
Share on other sites

Merci beaucoup hdcine

 

c'était tellement simple que j'ai pas trouvé  quel c.....   :( ! ! ! 

 

pour les autres néophytes comme moi il serais peut être bon de modifier un tout petit peu le tuto

en indiquant l'état attendu lorsqu'on reboot en bootloader car moi j'avais compris que la tablette devais redémarrer sur la rom

 

En tout cas merci, TWRP est installé je vais voir ce soir pour installer cromi-x 5.3,si j'ai un soucis je posterais dans le fil adéquate

 

Bonne journée

Edited by WocaM

Share this post


Link to post
Share on other sites

Mise à jour en version 2.7.0.0

Share this post


Link to post
Share on other sites

Bonsoir à tous,

 

Quand j'éxécute la commande 

 

fastboot -i 0x0B05 flash recovery twrp.blob

 

Voici ce qui s'affiche dans l'invité de commande : error : out of memory :(

 

Quelqu'un aurait-il une solution ?

 

Je vous remercie  :)

Share this post


Link to post
Share on other sites

Bonjour

je ne parviens pas à installer twrp 2.7 avec goomanager (qui n'est plus sur le playstore d’ailleurs ) : ce dernier ne le trouve pas ...

Merci

Edited by tonytk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...