Jump to content
Sign in to follow this  
knut

GPS ne fonctionne pas

Recommended Posts

Bonjour,

 

Après avoir beaucoup cherché sur les forums, je n'ai rien trouvé qui pourrait m'aider. J'ouvre donc un nouveau post.

 

J'ai un Z1 compact fonctionnant sous Android 4.4.4 (build 14.4.A.0.157) tout neuf.

J'ai débloqué le bootloader suivant la procédure officielle de SONY.

Je l'ai rooté (en flashant D550X_14.4.A.0.108_KernelOnly.ftf, root, puis flash D550X_14.4.A.0.157_KernelOnly.ftf)

 

Tout semble fonctionner correctement, sauf le GPS.

 

En synthèse, il "voit" les satellites (parfois plus de 20), mais ne les fixe jamais (même après plusieurs heures).

J'ai modifié le fichier system/etc/gps.conf pour faciliter les choses, mais rien n'y fait.

 

 

Quelqu'un a-t'il une idée ?

 

Merci d'avance de votre aide.

Share this post


Link to post
Share on other sites

Non, ce n'est pas çà.

 

En fait, tout se passe comme si l'antenne GPS avait une sensibilité très faible (voir l'image de GPS Status)

 

post-23880-0-59117700-1427915511_thumb.j

Edited by knut

Share this post


Link to post
Share on other sites

Je ne sais pas si j'ai le même problème, mais ça y ressemble (depuis que je suis passé à Lollipop (j'ai d'abord fait la mise à jour officielle de Sony, puis je suis revenu en 4.4, root, puis repassage en lollipop à la main pour garder le root)), sauf qu'un arrêt-marche du téléphone résout (temporairement) le problème.

Le scénario est le même tous les jours :

- le matin, je prends le telephone, le GPS ne fixe pas (gps test voit ~20 satellites, mais jamais de fix, niveau très faible)

- au bout de 5-10 min, j'éteins le téléphone, puis je le rallume

- j'obtiens le fix GPS en quelques secondes.

- au cours de la journée, le GPS continue de fonctionner, en particulier le soir pour le retour à la maison.

- le soir je pose le téléphone sur son support

- le lendemain matin, à nouveau plus de GPS

 

ça donne l'impression qu'un service s'est arrêté ou qu'une action n'est réalisée qu'au démarrage, puis se "périme".

J'ai essayé aussi de modifier mon gps.conf, sans résultat.

(au passage, si quelqu'un pouvait me poster un gps.conf original, ça m'intéresserait)

Share this post


Link to post
Share on other sites

J'ai le même problème sur un HTC one m7 rooté lollipop 'insert coin ' je désespère de trouver une solution......

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  





×
×
  • Create New...