Jump to content

Root impossible suite MAJ Oreo


Recommended Posts

Slt à tous,

 

je me suis re-lancé dans la tentative de root après passage en Oreo, mais toujours les mêmes problèmes.

 

Je lance Minimal ADB et Fastboot. Je démarre mon OP5 en mode fastboot (ou recovery, mais je vois pas la différence, on arrive au même écran bleu).

Mon téléphone est vide, remis état usine.

Je lance "adb devices", réponse "56fd7e4d     sideload". Tout va bien

Je lance "adb sideload OP5-Oreo.zip". Ça passe encore, la rom est installée.

 

1-/ Je crois que c'est @Gaja  qui, dans son how-to, faisait à ce stade un "wipe userdata". Cette étape se fait tjrs sous fastboot ? C'est la ligne bleue "erase pictures, musics etc" ??

2-/ il parlait ensuite de redémarrage et au "pinscreen", repartir en fastboot. Qu'est qu'il appelle le pinscreen ?? C'est après la configuration, et 1er redémarrage ou il demande soit un code, soit un schéma ??  Si oui pourquoi allez si loin ??

 

Revenons au fastboot et tentative install recovery et root. C'est là que ça se gate.......

Donc, je redémarre en fastboot (ou recovery). Quand je vais sur "install from ADB", que je tape la ligne "adb sideload twrp codeworkx.img", ça me un "Total xfer: 0.00x", et l'OP5 passe en "installation failed"

si je tape "fastboot flash twrp codeworkx.img", il me met <wiating for device>.

 

je vous mets une capture qui relate tout.

 

image.png.6bff5538d755560cc2a6b6930f238cfd.png

 

 

voilà, j'abandonne, j'attends vos retours et surtout votre aide

 

Merci

 

 

Link to comment
Share on other sites

il y a 6 minutes, latriche a dit :

Slt à tous,

 

je me suis re-lancé dans la tentative de root après passage en Oreo, mais toujours les mêmes problèmes.

 

Je lance Minimal ADB et Fastboot. Je démarre mon OP5 en mode fastboot (ou recovery, mais je vois pas la différence, on arrive au même écran bleu).

Mon téléphone est vide, remis état usine.

Je lance "adb devices", réponse "56fd7e4d     sideload". Tout va bien

Je lance "adb sideload OP5-Oreo.zip". Ça passe encore, la rom est installée.

 

1-/ Je crois que c'est @Gaja  qui, dans son how-to, faisait à ce stade un "wipe userdata". Cette étape se fait tjrs sous fastboot ? C'est la ligne bleue "erase pictures, musics etc" ??

2-/ il parlait ensuite de redémarrage et au "pinscreen", repartir en fastboot. Qu'est qu'il appelle le pinscreen ?? C'est après la configuration, et 1er redémarrage ou il demande soit un code, soit un schéma ??  Si oui pourquoi allez si loin ??

 

Revenons au fastboot et tentative install recovery et root. C'est là que ça se gate.......

Donc, je redémarre en fastboot (ou recovery). Quand je vais sur "install from ADB", que je tape la ligne "adb sideload twrp codeworkx.img", ça me un "Total xfer: 0.00x", et l'OP5 passe en "installation failed"

si je tape "fastboot flash twrp codeworkx.img", il me met <wiating for device>.

 

je vous mets une capture qui relate tout.

 

image.png.6bff5538d755560cc2a6b6930f238cfd.png

 

 

voilà, j'abandonne, j'attends vos retours et surtout votre aide

 

Merci

 

 

Pour flasher twrp la ligne c'est

Fastboot flash recovery tontwrp

Link to comment
Share on other sites

Ok c'est déjà ça. Le reste c'est facile :

 

1. Options développeur => Activer l'option de démarrage avancé.

2. Reboot en fastboot. Tu dois avoir des inscriptions en vert.

3. Téléphone branché au PC, tu lances une fenêtre adb et la commande de flash du recovery comme l'a donnée @Papi72. Je te conseille le recovery de Codeworkx (dispo ici au cas où).

4. Reboot en recovery avec la commande adb => fastboot boot "ton_recovery".img 

5. Flash Magisk.

6. reboot système.

  • Like 1
Link to comment
Share on other sites

Pour le 2/ [color=red]qd[/color] tu redémarres en fastboot, tu restes sur cet écran, c'est à dire, celui ou tu fais défiler en haut les options, vert reboot je crois, rouge bootloader ou recovery, etc..???
On active pas le debogage usb, avant le restart en fastboot ?
La ligne de commande c'est "adb sideload", ou "fastboot flash" mon nom de recovery.zip ?

Depuis ma Galaxy Tab A6

Link to comment
Share on other sites

Oui il faut aussi activer le débogage USB.

 

Il faut bien redémarrer en fastboot donc avec le redémarrage avancé c'est plus simple et il faut rester dessus.

 

Envoyé de mon ONEPLUS A5000 en utilisant Tapatalk

 

 

 

 

  • Like 1
Link to comment
Share on other sites

Bon ben pas mieux.

En démarrant en fastboot, donc sur l'écran avec le gros "start" en vert, je reste là dessus, et j'envoie la commande "fastboot devices".... RIEN. La ligne réapparait, sans rien.

Et quand je lance "fastboot flash recovery le mien", là ça répond "waiting for any device"......

 

Bon et bien sur, si je vais plus loin, adb en l'occurence, si je "install from adb", tout pas mieux......

 

C'est à se les prendre et se les bouffer........

 

Lexomil, où es tu ???

 

Depuis ma Galaxy Tab A6

 

 

 

 

Link to comment
Share on other sites

C'est un souci de pilotes. Comment est reconnu ton téléphone par le gestionnaire de périphériques ?

 

Si il y a un point d'interrogation, c'est que le pilote USB Windows est mal ou pas installé. Regarde ce lien (en anglais).

Edited by julz
Link to comment
Share on other sites

J'ai tout installé : minimal adb and fastboot, adb driver qui me lance les drivers Google inc., les drivers Oneplus.
Pour ce soir, fini l'ordi, mais il semble pas avoir de point d'exclamation jaune. Mais par contre, il me semble pas avoir vu non plus de "console adb".
On verra demain......

Depuis ma Galaxy Tab A6

Link to comment
Share on other sites

YYYYYYYYEEEEEEEEEEEESSSSSSSSSSSSSSSSSSSSSSSSSSS  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

excusez moi de gueuler comme ça, mais c'est tellement bon !!!!!

 

donc je l'ai eu. Je m'y suis pris en traitre aussi, à l'heure du laitier, quand il était froid, pas vigilant........

 

Merci @julz j'ai suivi ton lien, installé le fichier .INF, désinstallé les drivers Google inc.

Sur le OP5, je suis passé en PTP, plutot que MTP. Et redémarrer en fastboot.

ADB a réagi à la commande fastboot devices. Là je me suis dit ton compte est bon.

et du coup je l'ai achevé et lui balancant un, fastboot flash etc auquel il n'a pu résister.........

 

Aaaaahhhhh, la journée commence bien.

 

Gros merci à vous les gars 👍💪😊

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...