filsdepub

Comment activer javascript dans Gmail

Recommended Posts

Bonjour,

 

Lorsque je consulte mes mail dans l'application Gmail (version 2019.08.18) et que je clique dessus pour ouvrir le lien, je me retrouve souvent avec un message me demandant d'activer JavaScript alors que ce dernier est bien activé dans les options de Chrome.

Quelqu'un aurait-il une idée de comment résoudre ce problème ?

Share this post


Link to post
Share on other sites

Gmail a son propre navigateur web intégré pour ouvrir les liens web. Possible qu'il ne supporte pas Javascript. Regarde dans les options de Gmail, il y en a une pour utiliser ce navigateur intégré ou appeler le navigateur par défaut quand on clique sur un lien.

Share this post


Link to post
Share on other sites

Merci pour la réponse.

J'ai bien cherché dans les options de Gmail mais je n'ai rien trouvé pour indiquer quel navigateur utiliser.

Share this post


Link to post
Share on other sites

Salut,

 

À priori ces options sont maintenant dans :

Paramètres > Applications (menu) > Applications (liste) > Liens ouverts par l'application (dans le menu 'trois points' en haut à droite) > faire ici les réglages souhaités

 

Voilà !

Si ça peut aider

 

Bonne journée

 

Edit : évidemment les intitulés, etc... Peuvent variés suivant la version d'Android, constructeur, et autre interface personnalisée..

 

Tapa'DoC'eD

 

 

 

 

Share this post


Link to post
Share on other sites

Ce sont deux choses différentes.

@DoC : ce dont tu parles définirait le navigateur web par défaut sur l'appareil

Ce dont je parle c'est un paramètre de Gmail qui lui dit d'aller ouvrir ce navigateur ou d'afficher la page avec son afficheur intégré.

Pas pareil.

Dans la version de l'appli Gmail que j'ai sur mon J7, c'est dans : menu trois traits horizontaux > Paramètres > Paramètres généraux > Ouvrir les liens dans Gmail [X]

Décoche-le.

 

Edited by Ultrix

Share this post


Link to post
Share on other sites

Totalement d'accord avec toi !
Mais justement depuis un moment, du moins sur mes derniers devices, ce paramètre dans Gmail n'est plus présent.
Et j'ai donx désactivé, dans le menu indiqué, la possibilité.
La conséquence est, encore sur mon phone, d'avoir un pop-up de choix de navigateur lorsque que je clic sur un lien dans une app.

Remarque : le chemin indiqué dans mon premier message correspond bien au menu 'lien externe'. La gestion 'par défaut' que tu décris est une option dans le détail d'un objet de la liste (sorte de sous-menu, d'ailleurs accessible également par d'autres chemins comme par exemple directement depuis le détail d'une application) .
Je comprends ce que tu as voulu dire.
Mais ce n'est pas exactement la même chose.

Après, comme aussi précisé, la version d'Android, de Gmail, de l'interface surcouche ou pas, etc... Sont impactants.

Par exemple, dans certains navigateurs sous Android, il y a également un réglage pour autorisé ou pas l'ouverture de 'WebView' quand ce navigateur est défini par défaut.
Ce qui rajoute un autre niveau de réglage, en plus du système et de l'application 'appelante'....

Courage dans votre quête



Tapa'DoC'eD

  • Like 1

Share this post


Link to post
Share on other sites

Respect... tu es beaucoup plus au point sur le sujet que je le pensais et j'ai fait une approximation dans ce que tu écrivais. Donc effectivement si cette option n'existe plus dans Gmail, ton approche doit être la bonne.

Je ne mets plus trop l'appli Gmail à jour sur mes appareils, je n'aime pas du tout l'évolution actuelle de l'interface, qui devient de plus en plus désagréable à mes yeux.

 

  • Like 1

Share this post


Link to post
Share on other sites

Mutuel...

 

Je partage également ton point de vue sur l'évolution de l'os ou autre, même si j'imagine que les raisons sont différentes (un point de vue est par définition assez personnel : )

 

Pour revenir à la problématique initiale :

J'espère que les pistes évoquées ici et autres recherches du posteur lui permettront de solutionner son sujet.

 

La réponse est quelque part entre Gmail, les paramètres par défaut du système et ceux du navigateur utilisé.

 

@+

 

Tapa'DoC'eD

 

 

 

 

Share this post


Link to post
Share on other sites

Merci beaucoup pour vos réponses mais je n'ai malheureusement toujours pas trouvé le paramétrage dont vous parlez dans les options des divers menus...

Share this post


Link to post
Share on other sites

Sans plus d'explications, de détails, de description, ce que tu as fait ou pas, comment, etc ....

À moins d'être dans un forum de télépathe,
¯\_(ツ)_/¯

Tapa'DoC'eD

Share this post


Link to post
Share on other sites

Je vais dans Applications/Gmail/Ouvrir par défaut et la seule option que je peux changer est "Ouvrir les liens compatibles" avec les possibilités suivantes :

 

-Ouvrir dans cette application

-Toujours demander

-Ne pas ouvrir dans cette application

 

Mais quelle que soit l'option que je sélectionne, les liens s'ouvrent toujours de la même façon, avec l'erreur Javascript sur certains sites.

Share this post


Link to post
Share on other sites

Salut,

Suivant ma compréhension :
Ce que tu décris correspond au comportement du système pour les événements associés à (pour faire simple) l'envoi d'un message de type email.

Cela n'est donc pas, toujours suivant mon entendement, au besoin décrit initialement.

Pour résumer,
- dans la dernière version de Gmail sur Android 9, au niveau des ''paramètres généraux'', il y a une option ''ouvrir les liens dans Gmail'' que j'ai désactivé.
- dans chaque application de navigation sur internet installées sur ton mobile, il faudrait désactiver le paramètre d'ouverture par défaut.
Exemple : ouvrir les paramètres système (depuis la roue dentée en haut à droite du bandeau de notification) / menu 'Applications' / liste 'Applications' / ouvrir l'application (Firefox, Chrome, etc... ) / menu 'ouvrir par défaut' / et enfin 'supprimer les paramètres par défaut' pour chacune des applications concernées.

Normalement ça devrait être bon...

Tapa'DoC'eD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.