Jump to content
blabla3869

clavier xperia s et bug de caractere

Recommended Posts

Bonsoirs sur le clavier du xperia S je n'ai pas les fles pour descendre , monter , reculer , avancer quand j'ecri un texte j'avai cela sur mon desire hd et c'etait plutot pratique , sauriez vous comment les rajouter ?

Share this post


Link to post
Share on other sites

J'utilise celui là

https://play.google.com/store/apps/details?id=com.moo.android.inputmethod.latin#?t=W251bGwsMSwxLDUwMSwiY29tLm1vby5hbmRyb2lkLmlucHV0bWV0aG9kLmxhdGluIl0.

Il manque que le swipe, sinon il est vraiment bien (encore plus customisable en version payante) et pour avoir les fleches, il suffit de maintenir l'appui sur la barre espace et aller vers le haut (vers le bas pour les faire disparaitre)

Share this post


Link to post
Share on other sites

Ces touches sont propres aux claviers des HTC, que les questions n'intègrent pas. perso, elle me font ch*er plus qu'autre chose, donc tant mieux. Cependant, un appuis bref ou long et tu as de quoi te déplacer, sélectionner du texte .

Share this post


Link to post
Share on other sites

Le problème de Swiftkey, en dehors de son coté un peu intrusif avec l'autorisation qui permet de voir les appels du téléphone, c'est que ça fait un bail (un ou deux ans) que les utilisateurs français réclament une modification pour que les règles de ponctuation françaises soient respectées (devant le ? et et le !) et que les créateurs en ont absolument rien à faire (ils ont promis plusieurs fois mais bon...)

Share this post


Link to post
Share on other sites

Le problème de Swiftkey, en dehors de son coté un peu intrusif avec l'autorisation qui permet de voir les appels du téléphone, c'est que ça fait un bail (un ou deux ans) que les utilisateurs français réclament une modification pour que les règles de ponctuation françaises soient respectées (devant le ? et et le !) et que les créateurs en ont absolument rien à faire (ils ont promis plusieurs fois mais bon...)

Ya as une version alpha qui tente de corriger le problème.

Elle n'est dispo que pour les membres mais ça prouve qu'on a enfin été entendu (il était temps).

Share this post


Link to post
Share on other sites

Ils ont corrigé le problème sur une beta de la nouvelle version puis ça été retiré ensuite. A croire qu'ils le font exprès. Tous les claviers quasiment le font sauf eux.

Share this post


Link to post
Share on other sites

En parlant de clavier, j'ai installé un clavier alternatif (le clavier ICS proposé sur XDA). Je viens de constater un problème : lors de la correction automatique avec ce clavier, l'encodage est mauvais. Avec le clavier de base Xperia (le machin copié sur le clavier de l'iphone ... absolument pas pratique à mon goût car réinvente le clavier azerty), aucun souci.

Est-ce que ce serait lié à l'appli SMS de Sony qui utilise un encodage bidon absolument pas standard ? Je pose la questions aux connaisseurs de la gamme Sony.

Share this post


Link to post
Share on other sites

En parlant de clavier, le bug des mots avec accents est toujours présent (le mot été à été transformé en iti chez mon correspondant, pareil pour fenêtre qui est devenu fenhtre ...) dans le nouveau firmware.

Quelqu'un a t'il une solution ?

Share this post


Link to post
Share on other sites

Pour mon problème de clavier, utiliser cette application permet de le résoudre : https://play.google.com/store/apps/details?id=inputmethod.latin.ported&feature=more_from_developer#?t=W251bGwsMSwxLDEwMiwiaW5wdXRtZXRob2QubGF0aW4ucG9ydGVkIl0.

D'ailleurs, le problème rapporté par Stitchou est celui que je rencontrait avec le clavier alternatif (jamais rencontré avec le clavier Xperia par contre).

Share this post


Link to post
Share on other sites

je rejoint votre su jet, ayant le même bug

pour ma part l'utilisation d'un autre clavier ne résoud rien (testé avec le clavier d'origine, smart keyboard et le lien donné par burin_khazad)

de même ce n'est pas la correction automatique qui provoque le probleme puisque même en écrivant moi même les caractères accentués le texto devient illisible

le bug semble vraiment lié à l'application d'origine des sms, j'utilise pour l'instant handcent sms (au passage horrible) qui supprime ces caractères accentués à l'envoi du texto et empeche ainsi tout problème d'encodage

vraiment problématique...

PS : test sur envoi a HTC desire

Share this post


Link to post
Share on other sites

Je ne comprends pas, c'est quoi votre bug exactement ?

Share this post


Link to post
Share on other sites

J écrit un sms avec l application d origine, je met a m l'intérieur un caractère tel que ê ou ç, le texto devient illisible pour le destinataire (tout le texto pas seulement le caractère)

Share this post


Link to post
Share on other sites

T'es sûr que ça vient pas plutôt de ton opérateur (ou alors de certains téléphones destinataires mal configurés ou concernés) ?

Je viens d'envoyer "Allons fêter noël, ça ira mieux après." sur un autre téléphone en utilisant mon clavier alternatif puis le même avec celui d'origine et les deux sont parfaitement lisibles sur le téléphone cible.

Edited by ToonSpirit

Share this post


Link to post
Share on other sites

alors ma config de test:

moi xperia s en bouygues -> desire en bouygues : bug texto completement illisible

moi xperia s en bouygues -> iphone en bougues : bug mais seulement les caractères incriminés impactés, pas tout le texto

moi xperia s en bouygues -> desire en orange : bug texto completement illisible

si d'autres peuvent apporter leur pierre à l'édifice ^^, je rajouterais d'autres test quand j'en aurais l'occasion

Share this post


Link to post
Share on other sites

J'ai exactement le même problème. Je suis chez Bouygues et j'utilise le clavier d'origine du xperia.

En gros quand je mets un accent,ça sort du genre: "c'est où?" => "Cay goy?" (constaté sur le blackberry qui la reçu).

Du coup,je dois tout écrire sans accents,virgules,points d'exclamations...

En revanche,quand le sms va suru n phone android,pas de problème(vu sur un Samsung galaxy).

Share this post


Link to post
Share on other sites

comment ça pourrait venir de bouygues?

Certains reçoivent les sms sans problèmes et d'autres,c'est illisible.

(j'ai oublié de dire aussi que l'envoi sur un iphone 3GS est passé parfaitement).

Share this post


Link to post
Share on other sites

Si j'ai bien compris toi, moi et bobby51, nous sommes tous 3 chez bouygues et lorsque l'on envoi un sms avec accent ca plante.

point commun XPERIA S et bouygues

  • Like 1

Share this post


Link to post
Share on other sites

Non mais j'ai le problème même si j'écris moi même le mot correctement (avec le cliavier natif ou celui de swiftkey).

Et le problème ne survient qu'avec certain caractère. notament le " ê "

Share this post


Link to post
Share on other sites

bon après différent test avec ToonSpirit, y a vraiment un problême

je vous propose de compléter ce spreadSheet https://docs.google.com/spreadsheet/ccc?key=0Ag_pUE-LqMWVdHRDMzMtUGpjaC1xMy1Rb2ZZVlQwZXc avec vos tests si vous en avez l'occasion

la phrase de test est : tout de même ça avec plusieurs accents à plus tard tôt (n'y chercher aucun sens caché ^^ ca veut rien dire)

utilisez ce message car d'autres messages contenant pourtant les caractères incriminés ne font pas planter le message chez le destinataire bizarrement

tests à effectuer du xperia s vers d'autres appareils en précisant l'opérateur, on arrivera peut-être avec assez de données à en faire découler un schéma récurrent

configuration : clavier natif (ou pas, avec le iceCreamSandwich keyboard ca fait pareil) et l'application sms native

suite des tests avec toonSpirit: il semblerait que le mot noël à l'intérieur du texto annule tout bug, je sais c'est n'importe quoi mais c'est comme ca

si quelqu'un pouvait faire le test d'un android sans surcouche -> un android sans surcouche, ce serait génial ca nous permettrait d'exclure (ou d'incriminer) android dans le problème

Share this post


Link to post
Share on other sites
il semblerait que le mot noël à l'intérieur du texto annule tout bug
Merci bobby51, grace à toi je viens de dire non à la drogue !!! :P

Perso depuis la dernière maj, j'ai l'impression que certain accent passe mieux, le é devient e au lieu de disparaitre

Edited by kaskran

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...