Jump to content

Recommended Posts

slt a tous depuis la maj je ne voit plus les noms de mes contact quand ils m'appellent c'est frustrant on ma parler d'enlever le numero 33 mais j'en est tellement ya t'il une autre solution?

Share this post


Link to post
Share on other sites

Salut,

Depuis quelle Màj ? JB ? Tu as essayé de mettre des espaces entre tes chiffres ? (du style xx xx xx xx xx) Le fait d'enlever le numéro 33 fait disparaitre le problème ?

Share this post


Link to post
Share on other sites

Salut, mon amie qui possède un wiko cink slim à le même problème depuis que je lui ai fait la mise à jour JB il y à une semaine.

J'ai trouvé qu'en retirant le +33 ça fonctionnait mais pour ceux qui ont beaucoup de contact à modifier ça va devenir énervant ^^

Donc si quelqu'un à une autre solution plus rapide je suis preneur :)

Share this post


Link to post
Share on other sites

oui depuis la MAJ JB, et quand j’enlève le +33 le nom s'affiche mais j'en est tellement que c'est long

Share this post


Link to post
Share on other sites

En redémarrant le wiko les noms ne s'affichent plus à nouveau, donc si faut s'amuser à retirer le +33 à chaque fois ^^

Vous avez pas une solution ?

Share this post


Link to post
Share on other sites

svp j'ai besoin d'aide c'est vraiment chiant a force de demander a chaque fois qui nous appelle

Share this post


Link to post
Share on other sites

Si personne ne répond, c'est vraisemblablement que personne n'a de solution hormis les actions habituelles possibles :

- reset usine

- reflashage du firmware...

Share this post


Link to post
Share on other sites

Lannig, je pense plutôt qu'il parlait de ses contacts :P

 

A part supprimer le +33, je n'ai pas d'autres solutions... Tu peux toujours les modifier depuis gmail sur ton ordi, c'est bien plus rapide que sur le portable.

Share this post


Link to post
Share on other sites

Le problème c'est que chez moi sur mon wiko quand je le redémarre tous les +33 que j'ai supprimé reviennent.

Edited by Julianinho

Share this post


Link to post
Share on other sites

Mais si tu rajoutes un numéro maintenant, ça le fait aussi ? Ou le problème ne se pose qu'avec tes anciens contacts ?

Share this post


Link to post
Share on other sites

En faite quand je redémarre le wiko il remet sur tous mes contacts déjà existants le +33 et de ce fait lorsque que l'un de ces contacts m'appel son nom ne s'affiche pas, c'est son numéro qui apparaît et si je supprime le + 33 ça refonctionne

Je vais faire un test avec un nouveau numéro pour voir.

Edited by Julianinho

Share this post


Link to post
Share on other sites

@Max3d8 : tu vois que ça n'était pas aussi simple que cela ...  ;)

En fait cela sent quand même le bug à plein nez, d'où mes suggestions. Mais bon, c'est un peu en désespoir de cause.

EDIT : correction de faute. Oups.

Edited by Lannig

Share this post


Link to post
Share on other sites

Je me permet de relancer car j'ai eu à nouveau le même problème et j'ai réussi à le résoudre en supprimant puis en ajoutant de nouveau mon compte gmail, vous aviez déjà essayé de faire ça feb77 et julianinho ?

Share this post


Link to post
Share on other sites

sa marche pas.. j'ai trouver une solution radicale virer la MAJ jelly bean depuis que je l'est sa m****. % de batterie fausse, affichage des contact ras le bol lol

Share this post


Link to post
Share on other sites

Nan j'ai pas essayé de supprimer le compte gmail et de le remettre, vais tenter ça avant de virer la mise à jour comme Feb77 ;)

Share this post


Link to post
Share on other sites

Merci MAX3D8, il semblerait que ton astuce ait fonctionné.

Share this post


Link to post
Share on other sites

Pour virer les +33 aux numéros, passez par le web (contacts gmail) ca va très vite

Share this post


Link to post
Share on other sites

Bonjour,

 

Forcé et contraint, je viens juste d'abandonner mon Blackberry pour un Wiko Cink Slim, mon premier téléphone Android, et j'ai découvert ce problème d'affichage des appels entrants dès le premier appel reçu...

 

La solution consistant à supprimer les +33 n'est pas viable dès lors qu'un mobile est par essence fait pour voyager...

 

Autre problème du même accabi, j'ai dans mon répertoire des numéro préfixés par #31#.

 

Si j'appelle un de ces numéros à partir du répertoire, l'appel est bien masqué mais si ensuite je rappelle ce même numéro à partir de l'appel sortant enregistré dans le journal d'appels, ce nouvel appel n'est pas masqué...

 

J'espère qu'il y aura rapidement une mise à jour corrigeant ces deux problèmes rédibitoires sinon je serais contraint d'abandonner Wiko...

Edited by didierg987

Share this post


Link to post
Share on other sites

Je n'ai jamais eu ce problème en firmware stock ICS V15. Est-ce une spécificité de JB ?

Share this post


Link to post
Share on other sites

Je n'ai jamais eu ce problème en firmware stock ICS V15. Est-ce une spécificité de JB ?

Exactement : spécifique à JB Stock

  Pendant mes quelques semaines en JB (avant de revenir à une base ICS V15) j'avais ce problème ; il me semble que j'avais trouvé une solution en changeant une .apk mais je ne me souviens plus précisément.

Share this post


Link to post
Share on other sites

Bonsoir à tous...

 

De mon coté, j'ai eu aussi mon lots de soucis avec mes contacts,

contacts en double, deux fois les numéros de phone portable et fixe par contacts ect ect...

Donc j'ai ouvert GO SMS Pro et j'ai supprimer TOUS mes contacts.

J'ai tous refais un par un (24 contacts)

 

En suite, j'ai éffectuer une sauvegarde de mes contacts avec GO SMS Pro comme ci dessous :

 

0111.jpg

 

Après cela, je les remets dans GO SMS Pro comme ci dessous, depuis que je fais ça,

je n'ai plus aucun soucis avec mes contacts !!!

 

0210.jpg

 

Bonne nuit à tous...  :lol: 

 

 

Share this post


Link to post
Share on other sites

Bonjour à tous,

   Je viens de corriger ce problème connu sous le nom de "Caller ID mismatch". Pour plus d'info, voir le lien suivant: http://forum.xda-developers.com/showthread.php?t=2268120

 

Il y a 2 solutions:

 * Passer par le framework XPosed.

 * Faire sois même les patches.

 

Je vous propose les patches smali à appliquer au code source pour résoudre ce problème.

Je viens de les tester et ça fonctionne impécable.

 

Patch pour "/system/app/Mms.apk"

--- original/smali/com/android/mms/data/Contact$ContactsCache.smali 2013-09-14 13:19:49 +0000
+++ modified/smali/com/android/mms/data/Contact$ContactsCache.smali 2013-09-14 13:40:39 +0000
@@ -75,7 +75,7 @@

 .field private static final SEPARATOR:Ljava/lang/String; = ";"

-.field static final STATIC_KEY_BUFFER_MAXIMUM_LENGTH:I = 0xa
+.field static final STATIC_KEY_BUFFER_MAXIMUM_LENGTH:I = 0x5

 .field static sStaticKeyBuffer:Ljava/nio/CharBuffer;

@@ -2758,7 +2758,7 @@
     .line 1208
     add-int/lit8 v1, v1, 0x1

-    const/16 v2, 0xa
+    const/16 v2, 0x5   #STATIC_KEY_BUFFER_MAXIMUM_LENGTH

     if-ne v1, v2, :cond_0

Patch "/system/framework/framework.jar"

--- framework.jar original/smali/android/telephony/PhoneNumberUtils.smali       2013-09-14 13:24:41 +0000
+++ framework.jar modified/smali/android/telephony/PhoneNumberUtils.smali       2013-09-14 13:33:59 +0000
@@ -1685,7 +1685,7 @@

     .line 535
     .local v7, minMatchLen:I
-    const/16 v7, 0xb
+    const/16 v7, 0x7   #MIN_MATCH

     .line 536
     if-ge v6, v7, :cond_b
@@ -7907,7 +7907,7 @@

     .line 760
     .local v0, minMatchLen:I
-    const/16 v0, 0xb
+    const/16 v0, 0x7   #MIN_MATCH

     .line 761
     invoke-static {v1, v0}, Landroid/telephony/PhoneNumberUtils;->internalGetStrippedReversed(Ljava/lang/String;I)Ljava/lang/String;

La solution à base du Framework XPosed passe par GravityBox: http://forum.xda-developers.com/showthread.php?t=2316070

 

 

Je vous propose aussi le patch suivant pour corriger la vulnérabilité 9695860 (sachant que le patch de la vulnérabilité 8219321 est déjà intégré dans la ROM JB originale)

 

Patch "/system/framework/core.jar"

--- original/ZipEntry.smali      2013-09-13 15:36:36 +0000
+++ modified/ZipEntry.smali      2013-09-14 09:12:28 +0000
@@ -309,6 +309,10 @@
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v6
+
+    const v8, 0xffff
+
+    and-int v6, v6, v8

     iput v6, p0, Ljava/util/zip/ZipEntry;->compressionMethod:I

@@ -316,6 +320,10 @@
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v6
+
+    const v8, 0xffff
+
+    and-int v6, v6, v8

     iput v6, p0, Ljava/util/zip/ZipEntry;->time:I

@@ -323,6 +331,10 @@
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v6
+
+    const v8, 0xffff
+
+    and-int v6, v6, v8

     iput v6, p0, Ljava/util/zip/ZipEntry;->modDate:I

@@ -363,6 +375,10 @@
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v6
+
+    const v8, 0xffff
+
+    and-int v6, v6, v8

     iput v6, p0, Ljava/util/zip/ZipEntry;->nameLength:I

@@ -370,12 +386,20 @@
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v2
+
+    const v8, 0xffff
+
+    and-int v2, v2, v8

     .line 374
     .local v2, extraLength:I
     invoke-virtual {v3}, Llibcore/io/BufferIterator;->readShort()S

     move-result v1
+
+    const v8, 0xffff
+
+    and-int v1, v1, v8

     .line 377
     .local v1, commentLength:I
diff -ruP original files//ZipFile.smali modified files//ZipFile.smali
--- original/ZipFile.smali       2013-09-13 15:36:36 +0000
+++ modified/ZipFile.smali       2013-09-14 09:11:45 +0000
@@ -913,6 +913,10 @@
     invoke-static {v5}, Ljava/lang/Short;->reverseBytes(S)S

     move-result v2
+
+    const v8, 0xffff
+
+    and-int v2, v2, v8

     .line 263
     .local v2, localExtraLenOrWhatever:I

Merci

Edited by new_profile

Share this post


Link to post
Share on other sites

Bonjour à tous,

   Je viens de corriger ce problème connu sous le nom de "Caller ID mismatch". Pour plus d'info, voir le lien suivant: http://forum.xda-developers.com/showthread.php?t=2268120

 

Il y a 2 solutions:

 * Passer par le framework XPosed.

 * Faire sois même les patches.

 

Je vous propose les patches smali à appliquer au code source pour résoudre ce problème.

Je viens de les tester et ça fonctionne impécable.

 

Bonjour,

 

J'ai modifié le fichier PhoneNumberUtils.smali comme proposé, mais je n'arrive pas à le copier dans le répertoire System, que ce soit avec Root Browser ou ES, le browser me dit qu'il est en train de copier mais ça reste figé.

Pire, le téléphone ne rédémarre plus après l'opération, il reste coincé sur l'animation. J'ai réinstallé ma Rom avec CWM et ça redémarre.

 

Mais, comment faire pour recompiler le fichier Framework.jar ?

 

J'ai utilisé Apktool (http://forum.xda-developers.com/showthread.php?t=2213985) :

 apktool d framework.jar

 apktool b framework.jar.out

 

Je récupère bien un fichier jar, mais je n'arrive pas à l'exploiter, est-ce qu'il faut le signer bien que ce ne soit pas un APK ?

Est-ce que tu peux partager celui que tu as généré ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...