Jump to content

custom x10 ( theme )


Recommended Posts

Bonjour,

Je possède un x10 root ( by exploid_x10mini ) et je suis en 026.

J'ai installé metamorph et il est bien install et a les superviser acces.

je télécharge un thème ( http://www.mobilecustom.fr/forum/index.php?topic=3453.0 )

je met le fichier thème dans le dossier androidTheme.

je lance l application meta, et je lance l'install ( via unzip option )

ca dezip, et arrive a 100% ,rien, un message rapide, que j ai a peine le temps de lire me dit que c'est pas bon.

quelqu'un serait me renseigner?

au pire, auriez vous d'autre logiciel ou façons de faire pour modifier theme/slide/boot

merci

Edited by p3psi
Link to comment
Share on other sites

^^ uép j ai fait un autre root que j ai trouver sur xda. mais rien, il faut un root, qui autorise +, mais j'ai beau chercher, je trouve rien. donc en gros a quoi sa sert de root si on peut rien faire de plus que quand on a pas root o_O

Link to comment
Share on other sites

il faut lancer tous les adb push depuis le DOS...

puis les adb shell depuis cette méthode :

il faut se mettre en mode shell :

adb shell (depuis le PC, sous DOS) (c'est comme si on faisait ssh/telnet sur le X10)

là on un prompt :

$

il faut taper :

su (pour entrer en mode admin)

là on a un prompt :

#

là pour commencer, mettre le répertoire system en mode écriture...

#mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system

après lancer les commande que vous voulez mais sans le "adb shell":

Link to comment
Share on other sites

@thol:

donc j'ai bien lancer cmd, puis je me suis mis dans le dossier ou se trouve mon theme.

ensuite j ai fait tout les etapes comme tu as dit jusqu'a

là pour commencer, mettre le répertoire system en mode écriture...

#mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system

premiere question le # tu le tape aussi?

ensuite,

tu dit

après lancer les commande que vous voulez mais sans le "adb shell":

la je comprend pas trop, tu veut dire que ensuite je clique sur l'auto install? expl pour mon theme "themekika" depuis le dossier, ou alors il faut aussi le lancer depuis le dos?

si c'est sur le dos je tape quoi?

merci en tout cas de ton aide.

Link to comment
Share on other sites

en fait la plupart des kit de custum ne sont qu'un fichier script *.cmd

dedans tu as des commandes adb

les commandes "adb push" tu les lancent directement depuis la fenêtre dos où se trouve le répertoire du kit de custum.

par contre les commandes "adb shell" , on doit d'abord lancer depuis ce même répertoire:

adb shell (depuis le PC, sous DOS) (c'est comme si on faisait ssh/telnet sur le X10)

là on un prompt :

$

il faut taper :

su (pour entrer en mode admin)

là on a un prompt :

#

là pour commencer, mettre le répertoire system en mode écriture...

mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system (le # c'etait juste pour illustrer le prompt que tu devais avoir)

après lancer les commande que vous voulez mais sans le "adb shell": genre :

[EDIT]

dd if=/sdcard/toto.apk of=/system/app/toto.apk

[/EDIT]

Edited by Thol
Link to comment
Share on other sites

ça a marché ! Suffit de reflache avec le liens que je t'ai passé, je viens d'installer l'interface en noir. :)

En fait les script actuel sont fait pour l'ancienne méthode de rootage (en 024), là tu peux lancer d'emblé le script tel quel et çà marche...

Je penses qu'il y aura bientot une autre méthode de rootage qui combinera la simplicité de l'un et l'autre...

Comme je suis un GEEK :) je veux toujours ce qu'il y a de plus récent... :P quitte à se prendre la tête... :P

Edited by Thol
Link to comment
Share on other sites

bon, je vais vous donner tout ce que j ai fait et vous me direz ce que j ai oublier.

alors mon dossier s'appelle theme

donc je lance:

cmd pour ouvrir mon dos

ensuite je tape

cd c:\theme ( j ai mis mon dossier en c: )

dans mon dossier theme j ai:

adb + AdbWinApi.dll et AdbWinUsbApi.dll ( ca je m'en occupe pas )

themekika le script de commande windows

framework-res.apk

phone.apk

phonebook.apk

donc pour reprendre, je suis dans le dos et j ai a l écran

c:\theme>

j'ai taper:

c:\theme>adb push framework-res.apk /sdcard/framework-res.apk
1749 KB/s (7964500 bytes in 4.446s)

c:\theme>adb push phone.apk /sdcard/phone.apk
1799 KB/s (2415098 bytes in 1.311s)

c:\theme>adb push phonebook.apk /sdcard/phonebook.apk
1824 KB/s (1582807 bytes in 0.847s)

c:\theme>adb shell
$ su
su
# mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system
mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system
# dd if=/sdcard/framework-res.apk of=/system/framework-res.apk
dd if=/sdcard/framework-res.apk of=/system/framework-res.apk
15555+1 records in
15555+1 records out
7964500 bytes transferred in 2.884 secs (2761615 bytes/sec)
# dd if=/sdcard/phone.apk of=/system/phone.apk
dd if=/sdcard/phone.apk of=/system/phone.apk
4716+1 records in
4716+1 records out
2415098 bytes transferred in 1.422 secs (1698381 bytes/sec)
# dd if=/sdcard/phonebook.apk of=/system/phonebook.apk
dd if=/sdcard/phonebook.apk of=/system/phonebook.apk
3091+1 records in
3091+1 records out
1582807 bytes transferred in 0.576 secs (2747928 bytes/sec)
#
c:\theme>adb push framework-res.apk /sdcard/framework-res.apk

j'ai reboot mais rien, le thème n'a pas changer, pouvez vous me dire, ce que j'ai oublier ou éventuellement la ou je me suis trompé?

merci

merci

Edited by p3psi
Link to comment
Share on other sites

c:\theme>adb push framework-res.apk /sdcard/framework-res.apk

il faut aussi copier le /sdcard/framework-res.apk vers le /system/app/framework-res.apk donc sous adb shell dd ...

Link to comment
Share on other sites

il faut aussi copier le /sdcard/framework-res.apk vers le /system/app/framework-res.apk donc sous adb shell dd ...

bon, perso j y comprend pu rien :) donc je laisse tomber, j attendrais fin septembre et la mise a jour 2.!!

merci en tt cas de l'aide,

++

Link to comment
Share on other sites

tu y est presque en fait !!!

rentre de nouveau en

adb shell

su

mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system

dd if=/sdcard/framework-res.apk of=/system/framework/framework-res.apk

reboot

et c'est bon...

Tu as raté la partie la plus importante :P

Edited by Thol
Link to comment
Share on other sites

lol

merci du coup j'ai fait ce que tu ma dit, ca prend forme lol quelque icone on changer :d

dd if=/sdcard/framework-res.apk of=/system/framework/framework-res.apk

je dois aussi le faire pour phone.apk et phonebook.apk ?

genre:

dd if=/sdcard/phone.apk of=/system/phone/phone.apk

thx

Link to comment
Share on other sites

heuu, en fait thol , c'est bon lol ^^ je vi[color=red][b]ent[/b][/color] de me rendre compte que j ai install un changemenb de barre de motification! et non un theme! donc en faite c'est bon, ca a marcher! donc merci beaucoup de ta patience et de ton aide!

je test avec un theme now!

autre question, je dois now faire cette methode pour tout?

je veut faire le marketfix, donc je fais pareil? je passe systématiquement par le dos?

merci

Edited by p3psi
Link to comment
Share on other sites

dans le dossier market fixe, je n'ai pas de fichier apk, donc en faite je dois donner les permissions par le dos et apres lancer le script?

WARNING: This Market fix is for X10i R2BA026 only! If you do not have an
        X10i or you do not have R2BA026, close this window immediately,
        or you will not be able to startyour phone. You may have to
        reflash your phone!

NOTE: Before you start, please install either Sony Ericsson
     Update Service or PC Companion.

If you have not done so already, follow these steps:
 1. On the phone, press the Menu button and go to Settings, Applications.
 2. Click on "Development".
 3. Place a check mark beside "USB debugging".
 4. Connect the phone to your PC with the USB cable.

IMPORTANT: Do NOT mount the phone on the PC.
          If it is mounted, unmount it NOW.

Appuyez sur une touche pour continuer...

Checking for temporary files on SD card...
Please ignore any errors in this step.

rm: can't remove '/sdcard/default.prop': No such file or directory
rm: can't remove '/sdcard/build.prop': No such file or directory

Copying files to SD card...

94 KB/s (1263 bytes in 0.013s)
212 KB/s (1737 bytes in 0.008s)

Mounting /system directory...

mount: Operation not permitted

Backing up files from /system directory to SD card...

3+1 records in
3+1 records out
1719 bytes transferred in 0.001 secs (1719000 bytes/sec)
3+1 records in
3+1 records out
1677 bytes transferred in 0.001 secs (1677000 bytes/sec)

Copying files from SD card to /system directory...

/system/default.prop: cannot open for write: Permission denied
/system/build.prop: cannot open for write: Permission denied

Removing temporary files from SD card...


THE MARKET FIX MAY TAKE UP TO 24 HOURS TO WORK.
Please leave your phone on and be patient.

Done. Rebooting the phone...

reboot: Operation not permitted
Appuyez sur une touche pour continuer...

Edited by p3psi
Link to comment
Share on other sites

DOS : oui

pareil, même principe : les "adb shell " sous dos manuel..

dis moi si ton market fix fonctionne... car moi j'en avais essayé un, çà a brické mon X10... obligé de reflasher avec SEUS...

C'est normal qu'il n'y ai pas d'APK... car c'est une modif dans les fichiers de conf d'Android...

Edited by Thol
Link to comment
Share on other sites

Ok je te dirais si ca marche.

peut tu me dire si tout est bon?

c:\Market>adb push default.prop /sdcard/default.prop
102 KB/s (1263 bytes in 0.012s)

c:\Market>adb push build.prop /sdcard/build.prop
169 KB/s (1737 bytes in 0.010s)

c:\Market>adb shell
$ su
su
# mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system
mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system
# dd if=/sdcard/default.prop of=/system/default.prop
dd if=/sdcard/default.prop of=/system/default.prop
2+1 records in
2+1 records out
1263 bytes transferred in 0.002 secs (631500 bytes/sec)
# dd if=/sdcard/build.prop of=/system/build.prop
dd if=/sdcard/build.prop of=/system/build.prop
3+1 records in
3+1 records out
1737 bytes transferred in 0.002 secs (868500 bytes/sec)
#

ensuite j'ai rebot manuellement

Edited by p3psi
Link to comment
Share on other sites

A priori c'est bon, puisque tu as pus rebooter sans encomble...

Réessaye d'aller sur le MARKET, et cherche l'appli 20Minutes par exemple... si tu le trouve c'est que c'est bon..

Link to comment
Share on other sites

oki, merci.

me reste juste a attendre maxi 24h d apres le site, pour que le fixe soit ok. donc je reviendrais au news vous dire quoi.

autre chose, je profite un peu ^^ j aimerais mettre le dossier

/system/etc/semc/startupshow/default en ecriture.

pour changer le bot screen et y mettre mes images de boots

j'ai essayé

mount -o remount,rw -t yaffs2 /system/etc/semc/startupshow/default

mais j ai une erreur qui me dit:

Usage: mount [-r] [-w] [-o options] [-t type] device directory

je pense que c'est un rapport avec les lettres, mais je vois pas la syntaxe exacte a saisir, merci

Edited by p3psi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...