Jump to content
monpseudo

[TUTO] Restaurer en pur Stock Lollipop 20H le LG G3 D855 depuis le recovery TWRP

Recommended Posts

Je regarderai ça ce soir. Sinon c'est une version eur.

Envoyé de mon LG-D855 en utilisant Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

voici le résultat

 

<model>LGD855</model>

<suffix>A6FRWH</suffix>

<esn>xxxxxxxxxxxxxxxxxx</esn>

<msn>xxxxxxxxxxxxx</msn>

<esndate>20140728</esndate>

<buyer>6FR</buyer>

<esnoutgodate>20140729</esnoutgodate>

<ULocationcode>N</ULocationcode>

<buyername>FRA</buyername>

<csn>LG0000654989428</csn>

Edited by McSpee
  • Like 1

Share this post


Link to post
Share on other sites

@McSpee

OK, version fr blanc 16Go, donc euro. Attention vire la balise <esn> de ta réponse c'est ton imei, et il n'a pas vocation a être rendu public. Il faut que tu flashes en wipant data, et les deux caches. J'ai le même en version titane et pas de souci, la calculatrice fonctionne parfaitement.

Après tu as peut-être une appli qui se réinstalle après initialisation du firmware et qui met le bins.

PS: mon quota de thank's ne s'est toujours pas réinitialisé.

Edited by 6riloo
  • Like 1

Share this post


Link to post
Share on other sites

je vais voir ça, mais c’est deja ce que j'avais fais hier.

 

wipe davik cache + system + data + internal storage + cache

 

ensuite format data et ensuite je flash la rom.

 

c’est bien ça ?


pour info la calculatrice version LG4 fonctionne


en cour d'installation :)

  • Like 1

Share this post


Link to post
Share on other sites

@McSpee

Juste le factory reset par défaut de trwrp (pas besoin d'autres choses, comme advanced wipe ou format data). Tu n'as normalement pas besoin de toucher à internal storage (qui n'est pas compris dans le factory reset ainsi que montré dans la récapitualtion affichée dans twrp sur le masque de factory reset). TWRP 2.8.7.0 pour ma part.

 

edit: Essaye de tester juste après install, avant restau titanium

Edited by 6riloo

Share this post


Link to post
Share on other sites

N'oublie pas de tester avant restauration des applis par titanium

Share this post


Link to post
Share on other sites

je reflash il y a un problème. je n'ai plus les boutons en bas ni de barre de notification


ma version TWRP 2.8.6.1

Share this post


Link to post
Share on other sites

ça va prendre du temps, je reposterai ce soir.


J'ai mis a jour TWRP.

 

J'ai réinstallé la rom mais toujours le même problème. ( je n'ai encore rien restauré via titanium, même pas mon compte google)

 

j'ai fais directement la mise a jour de la calculatrice, elle s'installe mais toujours l’icône du bonhomme vert et impossible à lancer

Edited by McSpee
  • Like 1

Share this post


Link to post
Share on other sites

Le factory reset tu l'as fait avec le dernier TWRP ?

Tu peux eraser data en plus ?

Envoyé de mon LG-D855 en utilisant Tapatalk

Dernière chose, c'est ma rom que tu flashes ou celles d'xda ?

Envoyé de mon LG-D855 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

oui le factory reset fait avec le dernier TWRP

 

c'est ta rom que je flash

  • Like 1

Share this post


Link to post
Share on other sites

C'est quand même bizarre, qu'à modele équivalent et manips identiques on n'arrive pas au même résultat.

Tu as accès à ta carte sd ?

Peut- être essayer en wipant system avant et en fixant les permissions depuis twrp après.

Envoyé de mon LG-D855 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

via le gestionnaire j'ai bien accès a ma carte SD

 

j'essaie ta manipulation pour voir

  • Like 1

Share this post


Link to post
Share on other sites

OK, tu pourras me donner la version de l'appli (calculatrice) que tu obtiens, si tu as accès au bouton désinstaller, et effacer les données, et effacer le cache (params système, application) ?

ma version: 4.40.10 et j'ai accès à tous les boutons.

 

edit: je suis de retour dans un petit 3/4 heure

Edited by 6riloo

Share this post


Link to post
Share on other sites

je sens que je n'aurai pas du poster mon problème de calculatrice. ça fou un beau foutoir sur le topic non ?

Edited by McSpee
  • Like 1

Share this post


Link to post
Share on other sites

Perso ça ne me gêne pas, je trouve très utile ta participation active à la recherche d'une solution. Mais si ça dérange, nous le dire, on poursuivra ailleurs.

Envoyé de mon LG-D855 en utilisant Tapatalk

Share this post


Link to post
Share on other sites

bon alors voila j ai la version 4.40.10 je peux désinstaller par contre les autres boutons sont grisées

8d0a6d4afa9f4fbccfa9cb57436a6bf1.jpg

Edited by McSpee
  • Like 1

Share this post


Link to post
Share on other sites

tu as un dossier /data/app/com.android.calculator2-1/ avec un fichier base.apk (droit en 644 pour l'apk et 755 pour le dossier et les sous-dossiers) dedans ?

et dans data/data/ un autre dossier com.android.calculator2

 

Si tu désinstalles et réinstalles c'est pareil ?

Share this post


Link to post
Share on other sites

Ok, moi je backup, wipe et reflash pour regarder un truc


Bon, j'ai réussi à reproduire le bug, je regarde à présent si mon hypothèse de fix est la bonne.

Share this post


Link to post
Share on other sites

C'est deja un bon début
 

tu as un dossier /data/app/com.android.calculator2-1/ avec un fichier base.apk (droit en 644 pour l'apk et 755 pour le dossier et les sous-dossiers) dedans ?
et dans data/data/ un autre dossier com.android.calculator2

Si tu désinstalles et réinstalles c'est pareil ?

Oui toujours pareil. Les droits sont corrects

tu penses que ça viens de la rom ? du téléphone ? ou de moi qui est flasher comme un pingouin ?
Envoyé de mon LG-D855 en utilisant Tapatalk

Edited by McSpee
  • Like 1

Share this post


Link to post
Share on other sites

A vrai dire je n'en ai aucune idée. J'ai reproduit le même problème en reflashant plusieurs fois, sans parvenit à comprendre. Là je restaure mon backup pour voir ce que je retrouve à présent.

J'ai l'impression qu'ils ont changé de version de fichier sur les serveurs lg et que les dernières versions merdouillent, ce qui expliquerait que tous ceux qui flashent depuis quelques jours ont le souci. Il faudrait voir avec un bon flash kdz si c'est pareil, mais là j'ai pas le temps (reroot, re recovery toussa)

Share this post


Link to post
Share on other sites

Bon ben après restauration de mon backup, tout est ok.

Je penche donc pour ma théorie sur une potentielle bouse sur les serveurs LG. Pour en être sûr, faudrait flasher un kdz, mais là, désolé, je ne m'y lance pas ;-)

En tout état de cause, pour l'instant, je crois qu'une éventuelle SExY et ses icônes légendaires devra se baser sur une 20t (discussion à venir) ;-)


ok tu me conseilles quel KDZ. j’essaierai demain

Pour que le test soit probant, il faudrait prendre le même kdz qui a servi de base à la rom:

csmgdl.lgmobile.com/dn/downloader.dev?fileKey=FW1693U13249AKP1259DUKK/D85520U_00.kdz

Bon courage ensuite pour le root, le recovery. Si tu te lances, fais le consciencieusement et calmement, pour éviter le brick. Sinon laisses tomber, ça n'en vaut peut-être pas la peine.

Edited by 6riloo
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.






×
×
  • Create New...