jyreunion

Android démarre en usb2 pas en usb3

Recommended Posts

J'utilise Android-x86 64bits version 8.1-r1 depuis sa sortie, et j'en suis satisfait.

j'ai acheté un SSD USB (pour aller plus vite…) 128 Go de marque Teyadi.

Installé Android dessus via un petit hub usb2 Logilink 4 ports relié au port usb3 de ma tablette.

Quand le disque SSD est relié via le hub, donc en mode usb2, ça marche nickel. Android est détecté sur /dev/sda2. Je précise que le grub est celui du disque de la tablette.

Si je supprime le hub usb et connecte le disque sur le port usb3, il ne trouve pas Android (No such device: /android-8.1-r1/kernel)

Je ne comprends pas…. Auriez-vous une idée?

D'avance Merci!

Share this post


Link to post
Share on other sites

Rien de très, très étonnant. L'USB 3.0 nécessite des pilotes spécifiques donc :

- des modules compilés dans le kernel Linux

- un ramdisk de boot qui les contiennent

comme il ne doit pas y avoir pléthore d'appareils disposant d'USB 3.0 tournant sous Android, ça n'est peut-être bien pas supporté, au moins dans les distributions toutes faites. Il faudrait recompiler un kernel...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.